15:01:06 <hagarth> #startmeeting
15:01:06 <zodbot> Meeting started Wed Dec  4 15:01:06 2013 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:06 <glustermeetbot> Meeting started Wed Dec  4 15:08:09 2013 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:07 <glustermeetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:35 <hagarth> #topic follow up of action items
15:02:01 <hagarth> last week's minutes and action items are here - http://meetbot.fedoraproject.org/gluster-meeting/2013-11-27/gluster-meeting.2013-11-27-14.01.html
15:02:25 <hagarth> I have updated the planning35 page to reflect the current schedule and deliverables for 3.5.0
15:02:55 <hagarth> have also added a documentation day in the schedule - this is now slotted for 13th December
15:03:19 <johnmark> howdy
15:03:22 <hagarth> also sent a note on updating feature pages with howto test instructions - haven't seen much traction from feature owners :)
15:03:35 <johnmark> hagarth: how can we get them to do more of that?
15:03:48 <hagarth> johnmark: I plan to reach out to them over today and tomorrow
15:04:07 <johnmark> hagarth: can we deny their ability to merge code until they a.) update freature pages and b.) document their stuff?
15:04:57 <hagarth> johnmark: Most of the code is in and I think owners will update test scenarios. I am hopeful about that.
15:05:21 <hagarth> #action hagarth to follow up with feature owners on test cases.
15:05:40 <hagarth> johnmark: you seem to have the most number of action items after me :), any updates there?
15:06:02 <johnmark> hagarth: one :)
15:06:25 <johnmark> hagarth: after our board meeting on Friday, we will convene a project owners/contributors meeting next week
15:06:26 <qstep> #info
15:06:39 <hagarth> johnmark: sounds good
15:06:51 <johnmark> hagarth: the other two actions are still on my plate :(
15:07:01 <johnmark> will look to get that out of the way today and tomorrow
15:07:02 <hagarth> I suggest we defer c. for the documentation agenda in today's meeting
15:07:14 <hagarth> johnmark: sounds good.
15:07:37 <hagarth> i think that covers the AIs from last week.
15:07:40 <hagarth> #topic 3.5
15:07:53 <johnmark> ok then
15:08:06 <johnmark> Technicool: /me waves
15:08:06 <hagarth> here's the latest on 3.5 - the planning page has been updated with the latest.
15:08:20 <Technicool> johnmark, hola
15:08:28 <hagarth> we have had a few early releases, more are expected over the next few days.
15:08:57 <hagarth> coming to pending patches, there are a few geo-replication bug fix patches that need to be pulled in
15:09:03 <hagarth> I am aware of that.
15:09:04 <johnmark> reminder: http://titanpad.com/gluster-community-meetings
15:09:15 <johnmark> hagarth: ok
15:09:18 <hagarth> Are there other bug fixes that folks would want to get into 3.5 before the test day?
15:09:39 <johnmark> hagarth: people are probably going to ask about RDMA/IB
15:09:57 * johnmark looks at notes from last week
15:10:01 <hagarth> johnmark: I don't think that part of the code has changed much between 3.4 and 3.5
15:10:23 <johnmark> hagarth: ok
15:10:31 <hagarth> If there is any patch that you want to be included in 3.5, please send me a note. A backport on to release-3.5 branch would also suffice.
15:11:00 <hagarth> moving on to test day for 3.5.0
15:11:13 <hagarth> we have the test day scheduled for this Friday
15:11:23 <hagarth> I have started a skeleton wiki page here - http://www.gluster.org/community/documentation/index.php/3.5_Test_Day_1
15:11:28 <johnmark> hagarth: was just about to ask for that
15:11:35 <johnmark> hagarth: how many devs need to supply test caess?
15:12:08 <hagarth> johnmark: most developers have submitted regression test cases as part of their patches
15:12:37 <johnmark> hagarth: excellent, ok
15:13:01 <hagarth> johnmark: we need more help from the devs on feature pages so that community understands how to test
15:13:18 <johnmark> hagarth: ok
15:13:37 <hagarth> if they don't update it, in all probability we are not going to get test coverage for such features.
15:13:51 <johnmark> hagarth: then we need to add some incentives, like "if you don't update teh feature pages, we're pulling it out of therelease"
15:14:13 <hagarth> johnmark: not a bad idea, we probably should include that in the planning for 3.6 :)
15:14:20 <Technicool> hagarth, separate pages, or a single monolithic page with multiple contributors?  would be helpful to consolidate if this isnt already planned
15:14:21 <johnmark> hagarth: awesome :)
15:14:41 <hagarth> Technicool: I was of the opinion that respective feature pages could be updated
15:14:58 <hagarth> and we could consolidate links to all such features from the 3.5_Test_Day_1 page
15:15:10 <Technicool> understoof
15:15:15 <hagarth> coming to the logistics for the test day
15:15:23 <Technicool> understood as well
15:15:44 <hagarth> the plan is to start around 3 AM UTC and go on for the next 24 hours
15:15:59 <johnmark> hagarth: cool
15:16:06 <hagarth> would that be sufficient or do we need a larger window for the test day?
15:16:32 <johnmark> hagarth: I think 24 hours is sufficient, but because it's friday, we could jus tutilize the whole weekend
15:16:39 <johnmark> "test dayz+++"
15:17:08 <hagarth> johnmark: yeah, we could end it on Monday noon Pacific time.
15:17:49 <hagarth> johnmark: should we recognize individual(s) who contribute the most to the test day?
15:18:07 <johnmark> hagarth: sounds good to me
15:18:10 <johnmark> hagarth: absolutely
15:18:12 <Technicool> +1 for that
15:18:25 <johnmark> hagarth: I have boxes of swag to give out for that purpose
15:18:42 <hagarth> johnmark: would it be possible for you to send out a reminder later today about the test day?
15:19:11 <johnmark> hagarth: yes. will send to both mailing lists
15:19:32 <hagarth> johnmark: great, #action johnmark to send out a reminder about test day
15:19:38 <johnmark> hang on
15:19:44 <johnmark> #action johnmark to send out a reminder about test day
15:19:56 <hagarth> ok, zodbot likes it better this way :)
15:20:09 <johnmark> I think so, just wanted to make sure
15:20:20 <hagarth> I will also update the test day page in the wiki later.
15:20:24 <johnmark> thanks
15:20:33 <hagarth> ok, moving on to documentation for 3.5
15:20:57 <hagarth> we now have a documentation hackathon scheduled for 13th December.
15:21:00 <johnmark> #topic 3.5 documentation
15:21:13 <johnmark> sweet
15:21:30 <hagarth> The aim is to make our admin-guide browseable and bring it up to date
15:22:04 <johnmark> #action johnmark to add admin guide to docs project
15:22:13 <johnmark> unless Technicool is already doing it :)
15:22:22 <hagarth> johnmark: I will update a new wiki page about what we want to do in the documentation hackathon.
15:22:36 <johnmark> hagarth: thank you - and then submit to lists for discussion
15:22:39 <Technicool> johnmark, I can do that
15:22:45 <johnmark> Technicool: thank you
15:22:59 <hagarth> johnmark: the docs project would be a mirror of the doc/admin-guide folder in glusterfs repo right?
15:23:02 <Technicool> #action Technicool to steal adding admin guide to docs project
15:23:03 <hagarth> johnmark: will do
15:23:20 <hagarth> #action hagarth to add details of documentation hackathon in wiki
15:23:51 <hagarth> ok, anything else around 3.5?
15:24:09 <hagarth> i guess not
15:24:11 <johnmark> hagarth: I'm just curious how much backporting is left
15:24:20 <johnmark> and how many patches we're waiting on - not clear on that
15:24:49 <hagarth> johnmark: this is the pending backlog - http://review.gluster.org/#/q/branch:+release-3.5,n,z
15:25:03 <johnmark> hagarth: ah, thanks
15:25:10 <hagarth> johnmark: I am also aware of a few more geo-replication and quota bug fixes that need to be backported.
15:25:14 <johnmark> #action johnmark to make a shortlink of that
15:25:23 <johnmark> hagarth: ok
15:25:34 <hagarth> johnmark: the test day will also let us know what else we need to backport to release-3.5 :)
15:26:01 <hagarth> shall we move on to 3.4.2?
15:26:09 <johnmark> hagarth: +1
15:26:13 <hagarth> #topic 3.4.2
15:26:19 <johnmark> hagarth: good poing :)
15:26:21 <johnmark> er point
15:26:32 <hagarth> we have released 3.4.2qa2 today.
15:26:58 <hagarth> we still need a few more dht patches to be able to release 3.4.2
15:27:05 <hagarth> let me take an AI for that.
15:27:09 <johnmark> hagarth: ok
15:27:17 <hagarth> #action hagarth to follow up on dht patches for 3.4.2.
15:27:22 <johnmark> hagarth: didnt' realize we were still waiting on those
15:27:36 <hagarth> johnmark: yeah, we have not had much traction from last week
15:28:15 <hagarth> if the dht patches come by, the plan is to go ahead with this release on 10th December.
15:28:45 <hagarth> if more backports are needed, please update the backport wishlist at - http://www.gluster.org/community/documentation/index.php/Backport_Wishlist
15:29:06 <johnmark> hagarth: ok
15:29:37 <hagarth> any questions/suggestions on 3.4.2?
15:30:10 <johnmark> hagarth: seems straightforward.
15:30:11 <kkeithley> goodonya for taking the gfapi handle support. I didn't expect that.
15:30:24 <kkeithley> that'll be good for nfs-ganesha
15:30:38 <johnmark> #link http://www.gluster.org/community/documentation/index.php/Backport_Wishlist
15:30:44 <hagarth> kkeithley: thanks for that backport! it looks pretty safe as none of the changes are related to exisiting apis.
15:30:46 <avati> we need to backport all the other gfapi changes (if any)
15:31:05 <hagarth> avati: are you aware of anything specific in gfapi that needs to come into 3.4.2?
15:31:09 <avati> the ABI versioning of gfapi is linear (branch independent)
15:31:32 <hagarth> yeah, that makes it easier to backport.
15:32:11 <hagarth> a slight digression on to 3.5 test day
15:32:25 <hagarth> what packages do we need for our test day to be successful?
15:32:43 <hagarth> I plan to release 3.5qa3 tomorrow and use that as the basis for testing
15:32:53 <johnmark> hagarth: that sounds good
15:32:54 <hagarth> we can certainly have RPMs - what else do we need?
15:33:06 <johnmark> hagarth: if all the feature authors have test cases written, then it "should work"
15:33:13 <johnmark> semiosis: you here?
15:33:26 <johnmark> hagarth: if we can get multiple binaries spun up in time, what would be grand
15:33:37 <semiosis> johnmark: here!
15:33:42 <johnmark> semiosis: hooray!
15:33:49 <hagarth> semiosis: great!
15:34:01 <johnmark> semiosis: can we get .debs in time for Friday?
15:34:09 <johnmark> of qa3 release coming out today?
15:35:07 <hagarth> johnmark: I guess we can follow up with semiosis on that one.
15:35:11 <johnmark> hagarth: sure
15:35:25 <johnmark> #actoin pester semiosis about .debs for test days
15:35:28 <johnmark> er
15:35:28 <semiosis> will do
15:35:35 <hagarth> semiosis: cool, thanks!
15:35:41 <semiosis> #achtung
15:35:43 <johnmark> #action semiosis to look into spinning up .debs for test day - dec 6
15:35:48 <johnmark> semiosis: thanks :)
15:36:21 <hagarth> i also noticed that the debian folks are spinning up qemu-kvm with gfapi support enabled - so we might get some qemu - libgfapi debian testing going too :)
15:36:29 <johnmark> hagarth: fantastic
15:36:36 <johnmark> hagarth: where did you see that?
15:36:46 <hagarth> johnmark: will send you out the link later
15:37:11 <hagarth> ok, anything else on 3.4 and 3.5?
15:37:40 <hagarth> ok, moving on.
15:37:49 <kkeithley> maybe that explains some of the debian folks questions about where to get the gfapi headers from (hint hint, need debian/ubuntu -devel .deb)
15:37:49 <hagarth> #topic open discussion
15:37:59 <hagarth> kkeithley: yeah
15:38:15 <hagarth> I have one suggestion for our regression tests
15:38:45 <hagarth> we need to add some samba - libgfapi tests as well, we cover only fuse and nfs accesses at the moment.
15:38:56 <johnmark> hagarth: oh, good point
15:39:01 <hagarth> anybody interested in adding those tests to our regression suite?
15:39:02 <kkeithley> btw, anyone have cycles to set up a jenkins slave on the machine I provided?
15:39:38 <hagarth> kkeithley: I am also looking to setup a netbsd slave for Emmanuel but that possibly would be a VM.
15:40:18 <hagarth> ok, I will hit the mailing lists about the samba libgfapi tests.
15:40:22 <avati> we can surely have samba/gfapi automated tests.. and more gfapi too (async I/O etc not tested by samba)
15:40:29 <hagarth> avati: right
15:40:41 <kkeithley> I bet there are cycles on the hypervisor box to run another vm. Want me to do that?
15:40:41 <semiosis> kkeithley: yes i need to work on a -dev package
15:40:53 <hagarth> kkeithley: that would be cool if you can
15:41:37 <hagarth> there was also a uint128_t failure for 32 bit machines - avati, bfoster - can you guys look into that one?
15:41:56 <hagarth> this was coming from the qemu code we imported for file snapshots.
15:42:16 <johnmark> semiosis: feel free to ask folks here for help
15:42:23 <bfoster> hagarth: got a pointer?
15:42:46 <semiosis> johnmark: thx
15:42:47 <hagarth> bfoster: referring to a mail on gluster-devel around 3.5qa1 released thread.
15:42:54 <avati> hmm, that's inside #ifdef CONFIG_UINT128
15:42:58 <kkeithley> btw, that reminds me. If the Fedora people get wind of the qemu code bundling they might throw a hissy fit.
15:43:19 <hagarth> kkeithley: why would be that?
15:43:20 <kkeithley> just fyi
15:43:23 <avati> which we have hardcoded to 1 :-)
15:43:28 <kkeithley> they don't like bundling
15:43:29 <avati> hagarth: will fix that
15:43:31 <bfoster> heh
15:43:33 <semiosis> where can I publish an apt repo for debian?  can I get access to bits.gluster.org?
15:43:42 <hagarth> #action hagarth to send out a mail on gluster-devel around libgfapi tests.
15:43:51 <semiosis> i mean, an apt repo for QA releases
15:44:03 <kkeithley> it was a major pain in the derriere to get nfs-ganesha packaged with the libntirpc bundled.
15:44:08 <hagarth> avati, bfoster: the OP reported that he still experienced failures after setting CONFIG_UINT128 to 0
15:44:16 <johnmark> semiosis: oh. I actually prefer to have those on download.gluster.org - that way, it gets included in our monthly download counts :)
15:44:28 <hagarth> avati, bfoster: I will include you folks on that thread
15:44:32 <johnmark> hagarth: ^^^^ FYI... not sure if we cna change how we publish -qa releases
15:44:32 <semiosis> johnmark: well there aren't any other QA releases there...
15:44:44 <avati> hagarth: that's very odd
15:44:47 <bfoster> I see a 1 message 3.5qa1 thread
15:45:09 <hagarth> johnmark: yeah, let us investigate that possibility. Even I would love to have all qa releases on download.gluster.org
15:45:10 <bfoster> hagarth: ok
15:45:31 <hagarth> avati: yeah
15:45:49 <semiosis> hagarth: +1 lets get all the releases (QA, beta, GA) on download.gluster.org
15:45:54 <johnmark> hagarth: if we can't, see semiosis ' request for bits.g.o access
15:45:54 <johnmark> semiosis: I know. that's somethking I've been trying ot change...
15:45:54 <johnmark> but because we don't have IT staff dedicated to this sort of thing, it's not a priority
15:45:54 <johnmark> hagarth: cool, thanks
15:46:04 <hagarth> kkeithley: do we need to have a plan b if we run into resistance with the fedora folks on bundling qemu code?
15:46:12 <kkeithley> qa != rc, right?
15:46:19 <johnmark> kkeithley: correct
15:46:21 <hagarth> kkeithley: yes, qa != rc
15:46:36 <johnmark> hagarth: they will only whine if it conflicts with an existing package
15:46:38 <semiosis> i guess rc is after beta?
15:46:42 <kkeithley> well, wrt bundling, I'm not planning on mentioning it.
15:46:48 <johnmark> so yes, if you try to bundle in something that's already part of the release, they will not like it
15:46:58 <hagarth> avati, bfoster: what is our current thinking on keeping the qemu code in sync with the latest qemu upstream?
15:47:05 <johnmark> unless you put in provisions to prevent namespace collissions
15:47:13 <kkeithley> johnmark: no that's not true. There are some dogmatic purists who will raise a stink "just because"
15:47:34 <johnmark> kkeithley: look at it from their point of view. they don't want the Windows problem of DLL hell
15:47:47 <johnmark> the recommended PoV is that devs shouls use the versions of libs already available
15:48:03 <avati> hagarth: i think it's best done on-demand
15:48:07 <johnmark> and try to integrate wiht existing packages where possible, although sometimes it's not, which brings us to edge cases like we have
15:48:15 <hagarth> johnmark: the qemu folks are probably not inclined to carve out a lib for this.
15:48:18 <avati> hagarth: if we really find a need (i.e bug)
15:48:25 <johnmark> hagarth: ok
15:48:36 <hagarth> avati: ok
15:48:57 <hagarth> we haven't classified any feature as beta in 3.5
15:49:18 <hagarth> I think it would be appropriate to do feature categorization after we have the results from test day
15:49:24 <avati> why would fedora people have an issue if we imported a few .c files from qemu?
15:49:25 <johnmark> hagarth: +1
15:49:46 <hagarth> johnmark: I am almost inclined to call a feature as beta if it does not get any coverage in the community test day ;)
15:49:48 <avati> we are not shipping it as a library.. it is embedded within one of our xlators, not exposed to others
15:49:56 <johnmark> hagarth: agreed :) great idea
15:50:06 <johnmark> avati: then it should be fine. maybe best not ot mention it, then
15:50:18 <johnmark> avati: but if it causes problems down the line, expect the riot act
15:50:32 <hagarth> do we all agree to make a feature beta if nobody provides feedback or would it be too restrictive? :)
15:50:51 <johnmark> hagarth: I think we have to do that, or else we won't get the participation we're seeking
15:50:57 <kkeithley> avati: I agree with you, but there are those people in Red Hat and Fedora who take a very dogmatic view on how open source works.
15:51:02 <johnmark> lots of other projects do things lke that, especially in the Apache space
15:51:28 <hagarth> anybody objects to this proposal? if not johnmark will be announcing this in the test day email :)
15:51:30 <johnmark> how does debian/ubuntu handle packaging issues like this?
15:51:34 <johnmark> semiosis: ^^^^
15:51:34 <semiosis> johnmark: gotta run to another meeting.  i'll work on the debs tonight.  if you need me for anything else just address me & i'll find the message in the scrollback in a little while
15:51:38 <semiosis> ha
15:51:42 <johnmark> semiosis: thanks
15:51:57 <johnmark> hagarth: awesome
15:52:02 <hagarth> johnmark: no objections, let us go ahead and announce!
15:52:17 <semiosis> johnmark: whats the question?  issues like what?
15:52:20 <johnmark> kkeithley: I'm just curious if debian packagers run int othe same issues, and how do they handle it
15:52:28 <johnmark> semiosis: see above
15:52:39 <kkeithley> johnmark: what are we packaging? We don't need Fedora and EL packages too?
15:52:45 <semiosis> unclear from above :(
15:52:48 <johnmark> fedora packaging gate-keepers can be nasty about bundling in files form other packages
15:53:04 <johnmark> in this case, .c files from qemu
15:53:08 <kkeithley> I've never stuck my head into the Debian Packaging Lion's mouth, only the Fedora one.
15:53:20 <avati> kkeithley: i'm sure a ton of open source projects import a few .c files from other open source projects? is that a problem in general w/ fedora folks?
15:53:23 <johnmark> semiosis: just wondering if Debian packaging gate-keepers will give us the same issues
15:53:34 <johnmark> avati: that's what I'm trying ot figure out
15:53:51 <semiosis> i dont understand the problem, can you give me a one line summary?
15:54:10 <johnmark> semiosis: fedora people say "no" to budnling in other packages with our RPMs
15:54:11 <avati> are we proactively trying to solve a problem we're not sure that exists? or are there signs that it might be a problem?
15:54:27 <hagarth> semiosis: if you are in a hurry, we can catch up later on this one
15:54:33 <kkeithley> Generally the Fedora folks want you to work with upstream, qemu in this case, to get your changes into their tree. Including getting them to make a library and using the their library.
15:54:36 <johnmark> avati: the previous issues had to do with swift and having another two versions of it
15:55:05 <avati> we were shipping an alternate version of swift.. we're not shipping an alternate qemu
15:55:06 <kkeithley> I don't even know, I haven't even looked. Are those qemu files license compatible with our license?
15:55:28 <johnmark> avati: exactly. so I'm not sure it will even be an issue
15:55:30 * kkeithley thinks, hey, I'm just the piano player here
15:55:31 <semiosis> hagarth: ok thanks
15:55:33 <avati> kkeithley: gplv2
15:55:44 <avati> and some lgpl
15:55:54 <johnmark> kkeithley: :)
15:56:02 <johnmark> I also have ot run to another meeting
15:56:20 <hagarth> ok, any other last minute discussions?
15:56:33 <hagarth> figure not
15:56:40 <hagarth> thanks everyone
15:56:53 <hagarth> #endmeeting