15:00:29 <hagarth> #startmeeting
15:00:29 <zodbot> Meeting started Wed Apr  2 15:00:29 2014 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:40 * kkeithley is hiere
15:00:45 * purpleidea is here
15:00:47 <hagarth> #agenda roll call
15:00:48 <johnmark> hagarth: I expect no less :)
15:00:56 <hagarth> #topic roll call
15:01:05 <ndevos> hello!
15:01:09 <jclift> Turns out I'm here atm
15:01:10 * kkeithley is here
15:01:12 <jclift> ;)
15:01:22 <hagarth> jclift: would you want to take over? ;)
15:01:24 * jclift is going to be later for something else.
15:01:27 <purpleidea> (i will have to go afk at some point as i have to catch a plane)
15:01:28 <jclift> hagarth: Nah, it's all you
15:01:39 <hagarth> jclift: haha, ok
15:01:45 * kshlm is here
15:01:52 <hagarth> #topic Action items from last meeting(s)
15:02:07 <hagarth> 1. hagarth to send note to gluster-devel, that patches older than 1 year will be abandoned
15:02:18 * msvbhat is late but here :)
15:02:20 <atinm> hey guys, this is Atin, first time attending this meet
15:02:24 <hagarth> I have not been able to do this, probably need some advise on this one.
15:02:28 <hagarth> atinm: welcome!
15:02:29 * lalatenduM is here
15:02:30 <purpleidea> atinm: hi there
15:02:40 <jclift> Etherpad URL: http://titanpad.com/gluster-community-meetings
15:02:41 <glusterbot> Title: TitanPad: gluster-community-meetings (at titanpad.com)
15:02:53 <hagarth> I am planning to fire a gsql query to figure out all patches > 1 year and publish it somewhere
15:02:55 <jclift> hagarth: What advice do you need?
15:03:04 <hagarth> I will then send a mail to gluster-devel
15:03:18 <jclift> Into Etherpad or Google docs maybe?
15:03:40 <hagarth> jclift: the question I have is should we bring in ageing for patches on an ongoing basis? maybe abandon patches that have more than 1 month of inactivity?
15:04:05 <hagarth> jclift: yeah, will publish it in google docs in all probability
15:04:12 <jclift> hagarth: Interesting question.  Bring it up on list?
15:04:27 <hagarth> jclift: sounds good, will send it over on -devel
15:04:42 <hagarth> #action hagarth to send out an email on abandon policy for gerrit patches.
15:04:45 <jclift> For the current item, does there really need to be the gsql fired off?
15:04:57 <jclift> hagarth: Thinking that might just be complicating things too much?
15:05:08 <hagarth> jclift: just to set the right context for everybody
15:05:15 <hagarth> 2. semiosis will add java projects to jenkins
15:05:27 <jclift> Saying "Hey dude, everything over 1 yr is giong to be nuked.  If you have a patch there, finish/submit it or pls abandon it?"
15:05:36 <jclift> s/dude/dudes/ :)
15:05:39 <hagarth> semiosis: if you are around, any updates on this?
15:05:48 <jdarcy> http://review.gluster.org/#/q/status:open+project:glusterfs+age:1y,n,z
15:05:49 <glusterbot> Title: Gerrit Code Review (at review.gluster.org)
15:05:51 <atinm> guys, one question...apart from the patches, are we gonna take any actions on the BZs which are quite old?
15:05:57 <hagarth> jdarcy: thanks!
15:06:05 <jclift> jdarcy: Excellent. :)
15:06:17 <hagarth> atinm: yes, we need to evolve a policy for that.
15:06:30 <jdarcy> I was the owner of the oldest patch (almost 2y) not too long ago.
15:06:51 <hagarth> jdarcy: interesting :)
15:06:53 <hagarth> 3. jclift to do a live webcast with johnmark talking about glusterflow!
15:07:09 <hagarth> jclift: should we carry forward this AI?
15:07:25 <jclift> hagarth: Anohter action item, or starting the upstream discussion on what to do with old bugs?
15:07:35 <hagarth> jclift: please add it on me
15:07:57 <jclift> hagarth: For this action item re glusterflow, might as well.  It'll get done.  Just not right away.
15:08:04 <hagarth> jclift: okay
15:08:09 <jclift> #action hagart to start upstream discussion on what to do with old bugs
15:08:17 <jclift> Gah
15:08:23 <hagarth> 4. jclift_ and johnmark to update guidelines on community standards
15:08:25 <jclift> tream discussion on what to do with old bugs
15:08:25 <jclift> 15:08 < jclift> Gah
15:08:47 <jclift> My cut-n-pasting is sucking atm
15:08:55 <atinm> :)
15:08:59 <jclift> hagarth: We haven't done this action item.
15:09:08 <jclift> It's been hanging around for weeks, without getting done
15:09:10 <hagarth> jclift: intend doing it over the next week or so?
15:09:15 <jclift> hagarth: We can probably just drop it
15:09:23 <hagarth> jclift: ok
15:09:30 <hagarth> 5. msvbhat to send draft of new geo-rep docs to interested ppl.
15:09:34 <hagarth> msvbhat: was this done?
15:09:57 <msvbhat> hagarth: I did not send the draft. But it is ready
15:10:06 <hagarth> and one more 6. msvbhat to create screencast of geo-rep.
15:10:22 <hagarth> msvbhat: please send out to purpleidea and whoever else might be interested in that.
15:10:24 <msvbhat> hagarth: I just wanted to add screencast. But couldn't do so far
15:10:37 <msvbhat> hagarth: Sure...
15:10:40 <hagarth> msvbhat: ok
15:10:50 <hagarth> msvbhat: do you need any help for the screencast?
15:10:56 <lalatenduM> msvbhat, with out screencast we should be ok
15:11:11 <lalatenduM> msvbhat, you can add the screencast laster
15:11:16 <jclift> Yeah
15:11:17 <hagarth> lalatenduM: +1
15:11:19 <lalatenduM> I meant later
15:11:42 <msvbhat> hagarth: I have a tool asciinema, which looks cool and I can embed that anywhere like text
15:11:57 <msvbhat> lalatenduM: hagarth: ^^ So I was planning to use that
15:12:06 <hagarth> msvbhat: cool.
15:12:09 <hagarth> 7. dlambrig  to investigate Google Docs as a replacement for Etherpad. Can people  collaborate without signing in is an important point.
15:12:19 <hagarth> dlambrig_: any updates on 7.?
15:12:26 <lalatenduM> msvbhat, I would say "something is better than nothing" :)
15:12:26 <dlambrig_> works fine, as far as a screen people can edit
15:12:42 <dlambrig_> no need for a google login id
15:12:52 <dlambrig_> however, no chat, as we see in etherpad
15:13:09 <jclift> We don't really need chat tho do we?
15:13:10 <lalatenduM> we dont use chat in etherpad either
15:13:16 <lalatenduM> jclift, yup
15:13:17 <jclift> We have mailing lists and IRC
15:13:20 <dlambrig_> I think the main point with it is reliability, google has quality stuff
15:13:36 <jclift> Yeah.  Better than TitanPad will likely be
15:13:38 <hagarth> ok, should we move over to google docs for all our online meetings?
15:13:41 <dlambrig_> downside- they are a huge evil company
15:13:43 <jclift> +1
15:13:48 <jdarcy> The Etherpad chat is a bit of a trap, since it encourages people to ask questions where nobody who might answer is looking.
15:13:49 <lalatenduM> dlambrig_, +1
15:13:49 <dlambrig_> :)
15:14:19 * lalatenduM given a choice I would like to stay away from Google :)
15:14:22 <hagarth> or should we host an etherpad on gluster.org?
15:14:31 * jclift reckons we should try Google Docs approach next week, and see how it goes
15:14:40 <jclift> lalatenduM: For sensitive docs, completely agree
15:14:50 <lalatenduM> jclift, yeah, so I am ok
15:14:55 <jclift> hagarth: I brought that up last week.  Strong no from JM. ;)
15:15:01 <jdarcy> We have all sorts of internal places for anything company-confidential.
15:15:03 <hagarth> jclift: ok :)
15:15:18 <hagarth> alright, let us use google docs for next week's meeting
15:15:23 <lpabon> I suggest to use WorkFlowy
15:15:38 <lpabon> https://workflowy.com/
15:15:39 <glusterbot> Title: WorkFlowy - Organize your brain. (at workflowy.com)
15:15:45 <jclift> lpabon: Does it require SignIn?
15:15:45 <hagarth> lpabon: we can try that out 2 weeks from now :)
15:16:07 <lpabon> yes, it requires signin, but it is an easy one
15:16:12 <jclift> Non-starter
15:16:30 * jdarcy whispers "wiki"
15:16:43 <jclift> lpabon: Unnecessary barrier to participation, where we have better alternatives already
15:16:52 * jclift quiets down
15:17:06 <lpabon> jclift: no biggie, just suggesting... its a pretty cool tool
15:17:09 <hagarth> let us use google docs for next week and then take it from there
15:17:12 <jclift> :)
15:17:14 <hagarth> 9. jclift to put the code for spinning up new Rackspace vms on the Forge
15:17:19 <jclift> Done
15:17:25 <hagarth> jclift: cool, thanks!
15:17:27 <jclift> It's not in feature complete state
15:17:29 <lalatenduM> agrees with jdarcy , why not wiki?
15:17:47 <hagarth> jclift: any further help needed?
15:17:58 <lalatenduM> we can just use gluster wiki , jclift hagarth ^^
15:18:01 <jclift> lala: No real-time collaborative editing in wiki's
15:18:01 <hagarth> lalatenduM: real time collaboration might be hard on wiki
15:18:02 <kshlm> wiki is not realtime
15:18:10 <jdarcy> Do we need realtime?
15:18:18 <jclift> hagarth: I'm having troubles with the regression tests themselves in the Rackspace environment
15:18:29 <jclift> jdarcy: For meetings, yeah
15:18:31 <hagarth> jdarcy: for meetings like this, I prefer realtime updates.
15:18:32 <lalatenduM> yeah
15:18:38 <atinm> yeah, thats the main purpose of using this kind of editor I believe?
15:18:43 <jclift> yeah
15:18:45 <hagarth> jclift: can we continue that discussion on gluster-devel?
15:18:45 * jdarcy shuts up about editing tools, then.  ;)
15:18:49 <jclift> Of course :)
15:18:55 <jclift> hagarth: ^^^
15:19:01 <hagarth> jclift: ok
15:19:04 <hagarth> 10. johnmark to start the conversation with the docs team about getting docs ready for 3.5 release
15:19:14 <hagarth> I don't think this has happened
15:19:18 <jclift> Dammit
15:19:21 <lpabon> what is the link to the etherpad we use for this meeting? i forget
15:19:26 <lalatenduM> jclift, +1
15:19:28 <lalatenduM> :(
15:19:28 <jclift> http://titanpad.com/gluster-community-meetings
15:19:29 <glusterbot> Title: TitanPad: gluster-community-meetings (at titanpad.com)
15:19:31 <hagarth> so let us continue this AI for johnmark
15:19:34 <hagarth> #action johnmark to start the conversation with the docs team about getting docs ready for 3.5 release
15:19:38 <jdarcy> jclift: Are there separate "our regression tests suck" and "Rackspace config isn't quite right" problems, or do they still seem to be one problem?
15:19:51 <hagarth> 11. johnmark  to email gluster-devel reminding feature owners that 3.5 will not be  released until the 3.4 & 3.5 feature pages have at least basic user  level docs
15:20:12 <hagarth> I think we have docs for few features at least
15:20:17 <johnmark> hagarth: aha
15:20:20 <jclift> jdarcy: I seem to have gotten through the Rackspace config problems, and now I'm thinking it's mostly the "regression tests suck" ones left
15:20:27 <johnmark> hagarth: I can still send that, if still needed
15:20:34 <hagarth> johnmark: please do
15:20:38 <johnmark> hagarth: ok.
15:20:45 <jdarcy> jclift: OK, then we can continue that on -devel.  Thanks.
15:20:51 <hagarth> more on 3.5.0 in the topic for that.
15:20:52 <jclift> jdarcy: But, I'm still trying stuff out in the Rackspace env, to see if some of those are just still env problems
15:20:56 <jclift> jdarcy: np
15:20:57 <johnmark> #action johnmark to send note to gluster-devel reminding devs about feature docs and tests
15:21:21 <hagarth> 12. and 13. are about semiosis, since he doesn't seem to be around will be skipping them
15:21:29 <jclift> hagarth: "few features" != 100% of features
15:21:35 <hagarth> 14. kshlm to investigate Gluster Forge replacement options
15:21:43 <jclift> But it's progress.  /me is grumpy abt this ;)
15:21:49 <kshlm> doing it.
15:21:50 <hagarth> jclift: deferring that for 3.5.0 topic
15:22:05 <hagarth> kshlm: would you be sending the possibilities on gluster-devel?
15:22:08 <kshlm> building a list @ https://gist.github.com/kshlm/fd884ae1df1e9b982252
15:22:09 <glusterbot> Title: What should be done for GlusterForge? (at gist.github.com)
15:22:16 <kshlm> will announce publicly once done.
15:22:24 <kshlm> taking more time than I expected.
15:22:28 <hagarth> kshlm: cool, thanks
15:22:47 <hagarth> 15. and 16. are done, so skipping them for now.
15:22:50 <hagarth> #topic 3.5.0
15:23:08 <hagarth> 3.5.0 is blocked by two issues primarily:
15:23:21 <hagarth> 1. memory leak reported by Emmanuel on gluster-devel.
15:23:39 <hagarth> 2. quota bug that jclift reported, don't seem to have bz handy.
15:23:45 <jclift> ahh, 1 sec
15:23:47 <jdarcy> kshlm: I'd be interested specifically in Gitlab vs. Phabricator, not only for this project.  ;)
15:24:09 <hagarth> 1. is not reproducible on Linux. I am inclined to believe that it could be a NetBSD FUSE problem.
15:24:10 <jclift> https://bugzilla.redhat.com/show_bug.cgi?id=1077159
15:24:11 <glusterbot> Bug 1077159: high, unspecified, ---, vshastry, POST , Quota hard limit not being enforced consistently
15:24:15 <hagarth> jclift: thanks
15:24:28 <hagarth> 2. we have a patch for bug 1077159
15:24:30 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1077159 high, unspecified, ---, vshastry, POST , Quota hard limit not being enforced consistently
15:24:41 <jclift> Yep, just needs backporting now
15:24:47 <hagarth> so, we need a backport and that might be one of the last patches for 3.5.0.
15:24:59 <hagarth> from a code perspective, we would be mostly ready by tomorrow.
15:25:16 <hagarth> we need some doc effort to push 3.5.0 out
15:25:26 <jclift> Yep
15:25:29 <hagarth> sas and lalatenduM are working on release notes for 3.5.0
15:25:45 <hagarth> sas mentioned that he would be able to send out a draft for review tomorrow on ML
15:25:51 <jclift> Sweet
15:26:11 <hagarth> coming to user documentation, I think we need to identify areas that need attention in 3.5.0
15:26:40 <hagarth> and work on them. anybody willing to help identify features in 3.5.0 that need more user documentation?
15:27:16 <jclift> We can ask on the mailing list
15:27:19 <jclift> lists
15:27:30 <jclift> That should be a pretty comprehensive list happening...
15:27:32 <hagarth> jclift: sounds good, we can improve such documentation after the release too.
15:27:55 <hagarth> if nothing late breaking happens, we should release 3.5.0 over the weekend.
15:28:02 <kshlm> I have a patch that I want in 3.5, atinms http://review.gluster.org/7302 (deprecation message for remove-brick)
15:28:03 <glusterbot> Title: Gerrit Code Review (at review.gluster.org)
15:28:20 <kshlm> hagarth, can you take a look at it?
15:28:21 <hagarth> kshlm: sure, will merge that. It is on my todo.
15:28:25 <lalatenduM> as a whole we need docs for gluster with openstack (with libgfapi), qemu and libvirt (with libgfapi)
15:28:25 <kshlm> cool.
15:28:40 <hagarth> lalatenduM: there is a topic for that later :)
15:28:46 <lalatenduM> hagarth, cool
15:28:51 <kshlm> or atleast for qemu and libvirt, lots of queries on that.
15:29:13 <hagarth> jclift: would you be able to send out email on the mailing lists around documentation?
15:29:32 <jclift> I need to get some Libgfapi docs happening extremely soon.  Am overdue on it, but wanted to have this regression stuff finished before starting it.  Might have to drop the regression-tests-on-rackspace stuff if I can't get it finished quickly. :/
15:29:41 <jclift> hagarth: Yeah, AI me
15:29:45 <hagarth> #action jclift to send out email on mailing lists around 3.5 documentation.
15:29:48 <lalatenduM> jclift,  I have added a section in wiki abt how to get started with docs
15:30:00 <hagarth> any questions on 3.5.0?
15:30:03 <jclift> lalatenduM: Cool.  :)
15:30:19 * msvbhat brb
15:30:29 <lalatenduM> jclift, check http://www.gluster.org/community/documentation/index.php/Main_Page#Documentation_for_GlusterFS
15:30:31 <hagarth> guess not, let us move on.
15:30:32 <glusterbot> Title: GlusterDocumentation (at www.gluster.org)
15:30:36 <hagarth> #topic 3.4.3
15:31:02 <hagarth> kkeithley: any updates on 3.4.3?
15:31:12 <kkeithley> I'm ready to push the button for GA
15:31:45 <kkeithley> everything I intend to do is done. 3.4.3beta2 was released last week. Nobody has said anything one way or the other about it.
15:32:01 <kkeithley> And it's been dragging on way too long
15:32:07 <hagarth> kkeithley: cool, we might need a lightweight release notes to accompany 3.4.3 GA
15:32:08 <jclift> kkeithley: One thing that came up during the week as a prob with 3.4.2 is this: http://review.gluster.org/#/c/7360/
15:32:09 <glusterbot> Title: Gerrit Code Review (at review.gluster.org)
15:32:32 <kkeithley> That's a problem with everything, not just 3.4.2.
15:32:40 <jdarcy> There are at least three fixes/workarounds for that.
15:32:45 <hagarth> jclift: we can defer it to 3.4.4
15:33:17 <jclift> Cool, np :)
15:33:37 <jdarcy> I don't think it should be a blocker, but we should pick one for master.
15:33:47 <kkeithley> death by beta is the alternative
15:33:49 <hagarth> kkeithley: shall we target a double whammy - 3.4.3 and 3.5.0 over the weekend?
15:34:00 <hagarth> jdarcy: yeah, will merge that in.
15:34:12 <johnmark> hagarth: woohoo! two for the price of one
15:34:32 <hagarth> not a whammy per se :D
15:34:39 <kkeithley> do I need to wait for the weekend or can I push the button now (or after the meeting)?
15:34:46 <jdarcy> I hope our users don't see it as a whammy.  ;)
15:35:08 <hagarth> jdarcy: I hope not! maybe a whammy for us ;)
15:35:19 <jclift> kkeithley: Lightweight release notes for it?
15:35:19 <hagarth> kkeithley: I think we can go ahead with 3.4.4
15:35:24 <hagarth> s/4.4/4.3/
15:35:36 <johnmark> kkeithley: do it - but please write up a quick description
15:35:40 <johnmark> which I'll then rewrite :)
15:36:05 <kkeithley> git log is my friend
15:36:43 <hagarth> cool, sounds like we are in good shape wrt our releases.
15:36:49 <hagarth> let us move on.
15:36:52 <hagarth> #topic Documentation update
15:37:07 <hagarth> lalatenduM: would you want to talk about your plans on GlusterFS & OpenStack documentation?
15:37:19 <lalatenduM> hagarth, sure
15:37:41 <lalatenduM> sas, shilpa are putting together docs, wiki pages for these
15:37:51 * jdarcy liked the ClosedStack April Fools' Joke BTW.
15:37:52 <lalatenduM> for openstack we have some wiki pages
15:38:02 <lalatenduM> but not updated
15:38:09 <lalatenduM> so will be working on these
15:38:37 <lalatenduM> sas is writing http://www.gluster.org/community/documentation/index.php/Libgfapi_with_qemu_libvirt
15:38:38 <glusterbot> Title: Libgfapi with qemu libvirt - GlusterDocumentation (at www.gluster.org)
15:38:46 <johnmark> lalatenduM: nice
15:38:53 <lalatenduM> I hope this will solve some issues
15:39:08 <hagarth> jdarcy: +1
15:39:14 <lalatenduM> thats all
15:39:37 <hagarth> lalatenduM: cool, we might want to link from the OpenStack wiki as well.
15:39:38 <jdarcy> lalatenduM: Looking good.
15:39:43 <lalatenduM> Once done will send it to users mailing list
15:39:59 <lalatenduM> hagarth, yeah I will do that
15:40:10 <lalatenduM> Also from RDO docs
15:40:13 <hagarth> lalatenduM: thanks for your effort on this one, much appreciate that!
15:40:22 <hagarth> lalatenduM: yeah
15:40:43 <hagarth> #topic open discussion
15:40:56 <hagarth> I am contemplating doing a 3.7 after 3.6
15:40:57 <lalatenduM> I wanted to talk about http://wiki.qemu.org/ChangeLog/Next
15:40:58 <glusterbot> Title: ChangeLog/2.0 - QEMU (at wiki.qemu.org)
15:41:06 <hagarth> lalatenduM: go ahead with your topic
15:41:28 <lalatenduM> I can see snapshot in the above change log support for snapshot with glusterfs is there
15:41:53 <lalatenduM> so do we need latest qemu for CentOS?
15:42:07 <lalatenduM> kkeithley, ^^
15:42:49 <hagarth> lalatenduM: snapshot is already supported with qemu
15:42:57 <hagarth> lalatenduM: I think this is the snapshot merge feature
15:43:07 <lalatenduM> hagarth, ohh
15:43:18 <hagarth> which is basically the ability to merge multiple snapshots into one IIUC
15:43:55 <lalatenduM> hagarth, ok, may be this is something CentOS Storage SIG can provide
15:44:15 <purpleidea> hagarth, et al. so RedHat hired me. I had orientation yesterday and monday. Full disclosure, although I don't know if I'll be working on puppet-gluster or what.
15:44:16 <hagarth> lalatenduM: right, we might want to include this updated version of qemu in CentOS SIG
15:44:28 <lalatenduM> hagarth, yeah
15:44:30 <hagarth> purpleidea: woohoo, congratulations!
15:44:32 <kshlm> purpleidea, congrats!
15:44:44 <purpleidea> thanks!
15:44:48 <hagarth> lalatenduM: btw libvirt 1.2.3 has nice features for glusterfs, we should consider that for SIG
15:44:53 <lalatenduM> purpleidea, congrats :)
15:44:58 <atinm> purpleidea, congrats
15:45:09 <purpleidea> i'll be purpleidea@redhat.com once i get my email working!
15:45:10 <lalatenduM> hagarth, what is that feature, good to know
15:45:13 <tdasilva> purpleidea: congratulations!
15:45:25 <purpleidea> not to derail, but i figured i'd disclose in open discussion.
15:45:42 <hagarth> lalatenduM: ability to take snapshots with libgfapi primarily
15:45:43 <jdarcy> purpleidea: Yay!
15:45:52 <kkeithley> I happen to know you'll be responsible for maintaining puppet-gluster, in addition to whatever else you get to do
15:46:02 <hagarth> purpleidea: always nice to have a community member joining us!
15:46:08 <lpabon> purpleidea: awesome!
15:46:12 <lalatenduM> hagarth, cool then we need to libvirt as well, which I already built :)
15:46:18 <lalatenduM> kkeithley, ^^
15:46:21 <purpleidea> kkeithley: oh cool, good to know!
15:46:27 <hagarth> lalatenduM: great :)
15:46:43 <lalatenduM> I meant in storage SIG
15:46:57 <jclift> purpleidea: Just read back, that's cool. :)
15:47:01 <purpleidea> a small side note, i added a bunch of new features to puppet-gluster at RedHat in westford which I haven't blogged about yet.
15:47:10 <purpleidea> but jdarcy puppet-gluster can now build chained volumes for example.
15:47:22 <lalatenduM> hagarth, may be I should check change log of libvirt and qemu thoroughly
15:47:34 <hagarth> lalatenduM: yeah, lot of good stuff happening for us there
15:47:52 <lalatenduM> hagarth, cool, my need your help little bit
15:47:58 <lalatenduM> s/my/may
15:48:14 <hagarth> lalatenduM: sure, feel free to reach out
15:48:41 <hagarth> btw I am inclined to have schedule 3.7 after 3.6
15:48:42 <jclift> purpleidea: If you don't have tasks assigned to you yet, I'd like to hand you the "spinning up our regression testing infrastructure in Rackspace" thing I'm working on.  I'd wanting to change it to use puppet-gluster later anyway.
15:48:58 <purpleidea> jclift: you'll have to ask my manager :P (sorry)
15:49:19 <hagarth> this can serve as a bridge release for migration to 4.0 or Quattro
15:49:24 <jclift> purpleidea: No problem there at all.  Will discuss with you later. ;D
15:50:07 <hagarth> any thoughts on 3.7?
15:50:10 <purpleidea> jclift: cool! i'm obviously happy to work on whatever, but i just want to make sure i do things right through the proper channels
15:50:16 <jdarcy> 3.7?
15:50:29 <purpleidea> hagarth: small potatoes, but i have at least on bz or two that i'd like to see in 3.7 :)
15:50:57 <johnmark> purpleidea: congrats :)
15:51:13 <jclift> hagarth: What's the general concept for 3.7?
15:51:13 <purpleidea> johnmark: :) thank you!
15:51:28 <jclift> hagarth: Continuation of Gluster 3.x series items, before major changes for 4.x?
15:51:31 <hagarth> jdarcy, jclift: basically the idea is to do 4.0 in phases
15:51:32 <johnmark> jclift: has that even been discussed yet?
15:52:11 <hagarth> so that we can do improved striping etc. in 3.7, continue some more features for 3.x
15:52:20 <hagarth> and then cut over to 4.0
15:52:58 <hagarth> I am also wondering if we should pull in glusterd scalability for 3.7 - considering the problems that we are seeing in mid size clusters
15:53:27 <johnmark> hagarth: I hear enough complaints about it that I would agree
15:53:35 <hagarth> if we just work on 4.0, it will be a massive effort and will take time for us to reach there
15:53:38 <jdarcy> hagarth: We should pull in *something* for glusterd scalability.  Let's schedule something to talk about what that should be.
15:53:49 <lalatenduM> hagarth, yeah scalability +1
15:54:05 <hagarth> so, we can knock off things in 3.x and gradually transition to 4.0
15:54:10 <jdarcy> 100 nodes reliably for 3.7, 1000+ for 4.x
15:54:51 <hagarth> jdarcy: sure, sounds like a plan. We can discuss more around our community booth in RH Summit.
15:54:53 <kshlm> hagarth, what i understand is that the scalability changes (from what has been discussed till now) would break backward compatability
15:55:01 <jclift> jdarcy: Saw your etd-api repo the other day.  Is that part of trying things out for potential 4.x?
15:55:14 <kshlm> so there is no point in calling it 3.x anymore.
15:55:14 <hagarth> kshlm: let us try to make it non-disruptive or at least provide an upgrade path
15:55:46 <jdarcy> jclift: It's already being used by NSR, but the eventual plan is to use it for glusterd as well.
15:55:46 <hagarth> kshlm: 3.7 can possibly operate in both modes
15:55:50 <jclift> If people can upgrade easily - preferably on the fly - that would be excellent
15:56:15 <hagarth> kshlm: backward compatible non-scalable way or forward compatible super-scalable way :)
15:56:54 <jdarcy> Gossip-based membership could be done in a relatively non-disruptive way.
15:57:20 <hagarth> jdarcy: yeah, let us discuss this over.
15:57:56 <hagarth> we seem to have 3 more minutes left. In all probability, I will not be able to attend the next 2 community meetings.
15:58:05 * kkeithley is looking for release notes from 3.4.2 or 3.4.1 for "style", but only sees the jenkins automatic release emails.
15:58:10 <kshlm> I have an open question regarding the forge replacement. What do people really want from forge? This would help me in tuning my search better.
15:58:15 <jdarcy> Next week is probably OK for me, but after that is Summit.
15:58:15 <kkeithley> or should I be looking elsewhere
15:58:27 <hagarth> anybody willing to host next week's meeting?
15:58:35 <kkeithley> I'll be at summit too.
15:58:52 <hagarth> we can probably cancel the meeting slotted for RH summit week.
15:59:15 <hagarth> kkeithley: you can check in release-3.4's doc/release-notes/
15:59:16 <kkeithley> and FYI, Ric is exploring the idea of some of the senior devs here (me included) coming to BLR for 3-4 weeks.
15:59:21 <kkeithley> ah
15:59:22 <kkeithley> okay
15:59:43 <hagarth> kshlm: a replacement for sourceforge
15:59:47 <kshlm> Is it just git hosting with some extras thrown in, or a full blown project management?
16:00:13 <purpleidea> i too will be at summit and looking forward to meeting some of you awesome gluster hackers irl (eg: hagarth !)
16:00:19 <kshlm> i meant glusterforge
16:00:29 <hagarth> kshlm: what are git + extras?
16:00:47 <kshlm> lightweught doc, issues etc.
16:00:50 <purpleidea> kshlm: sad to say it, but i think a github project would be a fine replacement for the forge
16:00:59 <hagarth> kshlm: any way to manage patches?
16:01:01 <jclift> kshlm: Issue tracking, code review (we don't need this bit), software releases
16:01:07 <jdarcy> Does anybody actually do bug tracking on the forge?
16:01:16 <hagarth> jdarcy: I figure not
16:01:29 <jclift> jdarcy: The Forge doesn't have bug tracking capability at present, that's why "no, they don't"
16:01:38 <jdarcy> Actually, having code review built in is nice, so we don't keep interfering with review.gluster.org
16:01:42 <jclift> It's one of the suck points with it
16:02:03 <jclift> (the lack of issue tracking capabilities I mean)
16:02:13 <hagarth> kshlm: code review + issue tracking would be bare minimum I think
16:02:34 <jdarcy> Personally I'd like a more fully-featured and integrated alternative, vs. just git hosting.
16:02:41 <hagarth> purpleidea: likewise, look forward to meet you all in 2 weeks!
16:02:45 <jclift> Automatic email notification on issue changes, etc
16:02:51 <kshlm> jdarcy, me too.
16:03:04 <jclift> jdarcy: Agreed.  Something like say... GitHub or GitLab
16:03:11 <jclift> Good UX workflow helps too
16:03:25 * purpleidea has to go. bye!
16:03:26 <hagarth> anything more for now?
16:03:28 <kshlm> Thanks for the points guys, I'll search with them in mind.
16:03:28 <jclift> Preferably a large existing Community,
16:03:31 <jclift> Nah...
16:03:44 <hagarth> alrite, talk to you all in a bit.
16:03:44 <jdarcy> I'm not wild about Gitflub for many of the same reasons people have expressed re: Google.
16:04:01 <hagarth> #endmeeting