15:01:15 <JustinCl1ft> #startmeeting Weekly GlusterFS Community Meeting
15:01:15 <zodbot> Meeting started Wed Jul 30 15:01:15 2014 UTC.  The chair is JustinCl1ft. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:28 <JustinCl1ft> Roll call.  Who's here? :)
15:01:29 * kkeithley is here
15:01:37 * bennyturns is here
15:01:37 * lpabon here
15:01:38 * xavih is here
15:01:53 * lpabon wondering if #halp is supposed to be #help
15:02:21 <JustinCl1ft> Probably.  My name seems to be wonky too
15:02:33 <JustinCl1ft> Meh.  Not caring. ;)
15:02:39 <lpabon> :-D
15:02:46 * kkeithley thought you were trying to be l33t
15:02:46 <JustinCl1ft> So, agenda URL: https://public.pad.fsfe.org/p/gluster-community-meetings
15:02:49 <JustinCl1ft> Nope
15:03:01 <JustinCl1ft> It's also messed around with purpleid1a
15:03:29 <JustinCl1ft> #topic Action items from last meetings
15:03:33 <JustinCl1ft> "hagarth to branch release-3.6 tomorrow (17th of July) and start the qa-release process"
15:03:37 <JustinCl1ft> Done, a while ago
15:03:45 <JustinCl1ft> "pranithk discuss with vijay about community test days for 3.6 and its potential conflict with a 3.5.2 beta"
15:03:54 <JustinCl1ft> Neither of them seem to be here atm, so moving on
15:04:07 <JustinCl1ft> Same for the next Pranith items (skipping for now)
15:04:31 <JustinCl1ft> Same for Lala's item about bug triage email
15:04:42 <JustinCl1ft> "xavih email Humble with the request to add a 'ec' component"
15:04:51 <JustinCl1ft> Complete.  Thanks xavih :)
15:04:52 <hchiramm> yep.. its added
15:04:57 <xavih> it's done
15:05:02 <JustinCl1ft> "JustinClift to add freebsd slave node to Jenkins"
15:05:24 <JustinCl1ft> Done.  It's all hooked up, and I think we're still waiting for a CR to be merged which will let it work.
15:05:38 <JustinCl1ft> Once that's done, it'll be enabled and should be ok from there
15:05:52 <JustinCl1ft> Same for the NetBSD one too.  Waiting for a CR, etc)
15:06:03 <JustinCl1ft> "JustinClift to get initial GlusterFS Consultants and Support Companies page online"
15:06:18 <JustinCl1ft> Meh, I haven't put much time into it.  I need to get Middleman working.
15:06:21 <JustinCl1ft> Next week. :)
15:06:35 <JustinCl1ft> "pranithk & Nithya to write documentation for dht"
15:06:41 <JustinCl1ft> Anyone around which knows about this?
15:06:57 <JustinCl1ft> Seems to be some disagreement in the CR, so I'm not sure it'll get it.
15:07:18 <JustinCl1ft> Meh, we can figure it out later. ;)
15:07:26 <JustinCl1ft> "JustinClift to set up OSX VM's, for hooking into Jenkins"
15:08:04 <JustinCl1ft> Working on it.  We have OSX 10.7.5 in a VM, but it's hogging up 30% of a cpu core on the host just idling.  Going to try out VMware Fusion instead and see if that's better.
15:08:20 <JustinCl1ft> (the host only has 2 cores, so 30% is a lot)
15:08:32 <JustinCl1ft> Moving on...
15:08:37 <JustinCl1ft> #topic 3.4
15:08:44 <JustinCl1ft> How's this going?
15:09:24 <JustinCl1ft> kkeithley: ?
15:09:58 <kkeithley> 3.4.5 is out
15:10:09 <kkeithley> was reported as such last week, IIRC
15:10:29 <JustinCl1ft> k.  Pranith mentioned a mem leak patch he'd like in 3.4 I think
15:10:29 <kkeithley> I haven't heard anything about needing 3.4.6 yet
15:10:32 <hchiramm> JustinCl1ft, on "DHT" documentation, Jeff has a patch http://review.gluster.org/#/c/8240/
15:10:49 <JustinCl1ft> hchiramm: Yeah, but there seems disagreement on the patch, with a -1 in there
15:11:26 <JustinCl1ft> kkeithley: We should probably ask pranith how bad the mem leak is, and if it's worth doing a 3.4.5-2 or something
15:11:32 <hchiramm> JustinCl1ft, yep, but the action is taken, thats what I meant
15:11:43 <JustinCl1ft> hchiramm: Good point.
15:12:01 <JustinCl1ft> hchiramm: Actually no.  It's not "done" until it's "done". ;)
15:12:22 <JustinCl1ft> Some action without a result isn't Done. ;)
15:12:50 <JustinCl1ft> #action JustinCl1ft to ask Pranith how bad the mem leak in 3.4 is that his patch fixes
15:13:02 <kkeithley> is the leak in any other branches?
15:13:11 <JustinCl1ft> No idea
15:13:13 <kkeithley> E.g. master?
15:13:19 * JustinCl1ft looks for the email
15:13:43 <hchiramm> JustinCl1ft, well, no objection.. but , we can avoid pinging others on the same action item :)
15:14:31 <JustinCl1ft> k, I can't see Pranith's email about it atm.  We can follow up with him outside of the meeting
15:14:56 <JustinCl1ft> #action JustinClift to ping Pranith about his mem leak patch for 3.4, and find out if it's in other branches as well
15:15:17 <JustinCl1ft> #topic 3.5.2
15:16:31 <JustinCl1ft> We have 3.5.2 beta1 RPMs out: https://download.gluster.org/pub/gluster/glusterfs/qa-releases/3.5.2beta1/
15:16:43 * JustinCl1ft wishes Niels was here
15:16:57 <hchiramm> ndevos, ping ^^^ :)
15:17:01 <JustinCl1ft> Let's put this off until next week, when he's hopefully recovered and we can ask him questions?
15:17:07 <kkeithley> he's on pto, recovering from surgury
15:17:10 <kkeithley> surgery
15:17:18 <JustinCl1ft> Yeah
15:17:47 <JustinCl1ft> #topic 3.6
15:17:52 <JustinCl1ft> http://www.gluster.org/community/documentation/index.php/Planning36
15:18:08 <JustinCl1ft> According to the Planning 3.6 doc we have a test day coming up
15:18:27 <JustinCl1ft> I thought we were going to change the date of that, due to conflict with other items
15:18:46 <JustinCl1ft> Anyone have further knowledge, or should we discuss on gluster-devel or something?
15:19:22 <JustinCl1ft> k, guessing that's a "lets find out via gluster-devel"
15:19:35 <JustinCl1ft> #action JustinClift to ask on gluster-devel about our Planning3.6 schedule
15:19:41 <JustinCl1ft> Moving on...
15:19:47 <JustinCl1ft> #topic Other Agenda Items
15:20:03 <JustinCl1ft> So, I haven't heard the results back for the poll about changing meeting times
15:20:29 <JustinCl1ft> I emailed Prashanth Pai about an hour ago, so hopefully we'll have the results known in the next day or two
15:20:41 <JustinCl1ft> We can figure it out from there, depending on the info we get :)
15:20:46 <JustinCl1ft> Moving on...
15:21:06 <JustinCl1ft> Does anyone have other agenda items they'd like to bring up?
15:22:19 <JustinCl1ft> andersb: We're about to end the meeting.  Is there anything you want to add to the agenda before that?
15:22:48 <JustinCl1ft> k, guess not
15:22:53 <JustinCl1ft> Thanks for attending everyone. :)
15:22:57 <JustinCl1ft> #endmeeting