12:00:16 <JustinClift> #startmeeting Weekly GlusterFS Community Meeting
12:00:16 <zodbot> Meeting started Wed Aug 20 12:00:16 2014 UTC.  The chair is JustinClift. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:32 <JustinClift> #topic roll call
12:00:36 <JustinClift> Who've we got? :)
12:00:37 * kkeithley is here
12:01:30 * JustinClift guesses lalatenduM as well
12:01:36 * lalatenduM is here
12:01:51 <lalatenduM> JustinClift, :)
12:02:29 <JustinClift> I'm becoming prety sure that someone did actually cheat with the voting for new meeting times. :/
12:02:44 <JustinClift> #topic Action items from last meeting
12:02:45 <lalatenduM> JustinClift, yeah I agree :)
12:03:21 <JustinClift> Hmmm, pranithk isn't here.  Can't ask him about his items.  Will need to do that via email.
12:03:31 <JustinClift> "lalatenduM send a bug triage email announcing the process, and call for volunteers"
12:03:41 <JustinClift> lalatenduM: So, this week to be finished?
12:03:49 <lalatenduM> JustinClift, I have updated the wiki pages
12:04:04 * ndevos just arrived _o>
12:04:13 <JustinClift> lalatenduM: What's the next bit?  Announce via email
12:04:14 <JustinClift> ?
12:04:18 <lalatenduM> JustinClift, the mail is in draft, I dont think it is is ready
12:04:23 <lalatenduM> so plz move it to next week
12:04:28 <JustinClift> Sure
12:04:37 <lalatenduM> ndevos, I need ur help for this
12:04:38 <JustinClift> #action lalatenduM send a bug triage email announcing the process, and call for volunteers
12:04:55 <JustinClift> "JustinClift to get initial GlusterFS Consultants and Support Companies page online"
12:04:56 <lalatenduM> ndevos, will send you the draft
12:05:05 <ndevos> lalatenduM: sure!
12:05:07 <JustinClift> That's mine dragging out more.  Now we have the build instructions from Eco it's closer
12:05:28 <JustinClift> "kkeithley to email gluster-devel about the reviews needed for cppcheck stuff on master"
12:05:42 <JustinClift> Email done yeah?
12:05:54 <kkeithley> yes, sort of
12:05:57 <JustinClift> ?
12:06:13 <kkeithley> I'll send an email today.
12:06:27 <kkeithley> nagging, guilt, threats, bribes, nothing works. ;-(
12:06:45 <JustinClift> Hmmm, what kind of bribery have you tried? :)
12:06:58 <kkeithley> beer, chocolate, ice cream. ;-)
12:07:04 <JustinClift> Heh Heh Heh
12:07:07 <hchiramm_> :)
12:07:08 <lalatenduM> LOL
12:07:41 <JustinClift> k.  hagarth's new review stats thing is meant to help with this, when it's tied in with actual rewards
12:08:04 <JustinClift> eg when we're sure it's accurate and good, we can start giving some form of real world rewards to the most active reviewers
12:08:33 <JustinClift> I'm not sure what the reward/encouragement system will be.  But whatever it is we need to ensure it's effective
12:08:45 <JustinClift> kkeithley: I guess until then just keep with the emailing/asking
12:08:55 <lalatenduM> JustinClift, I think it should just motivation to make Gluster better :)
12:09:02 <JustinClift> kkeithley: Hopefully it won't take more than a few weeks to get this reward system to work
12:09:17 <JustinClift> lalatenduM: Sure, but people have to choose between several priorities, all of which do that
12:09:28 <JustinClift> lalatenduM: This is trying to encourage them to prioritise reviewing :)
12:09:33 <hchiramm_> yeah, I am sure it will invite more people to the review process..
12:09:48 <JustinClift> Anyway, moving on...
12:09:54 <JustinClift> "JustinClift to create blog post of latest leaderboard stats, after receiving from hagarth"
12:09:58 <lalatenduM> JustinClift, excessive enumeration might be bad too :)
12:10:04 <JustinClift> lalatenduM: Agreed
12:10:10 <JustinClift> All reviews, no patches ;)
12:10:19 <lalatenduM> thats my personal opinion :)
12:10:28 <hchiramm_> JustinClift, apply the same for patches :)
12:10:33 <JustinClift> I've received the latest leaderboard stats from hagarth.  Need to make a blog post next :)
12:10:46 <JustinClift> Yeah, we'll figure things out over time and adjust as needed I guess.
12:10:55 <JustinClift> "JustinClift to encourage Tamas Papp to log a bug bout   http://supercolony.gluster.org/pipermail/gluster-users/2014-July/018219.html"
12:10:58 <JustinClift> Today
12:11:06 <JustinClift> "ndevos will verify status of patches proposed for 3.5.3 and request reviews for those patches in master?"
12:11:10 <JustinClift> ndevos?
12:11:30 <ndevos> mostly done, where there were patches - which is few
12:11:56 <JustinClift> ndevos: When do you reckon it'll be done?
12:12:04 <JustinClift> eg the verify status of patches for 3.5.3
12:12:11 <ndevos> after kkeithley's nagging :)
12:12:27 <JustinClift> Due today then. :)
12:12:34 <ndevos> well, status check is easy, getting the reviews done is harder
12:12:57 <JustinClift> k.  When kkeithley sends nag email, can you follow that up with extra encouragement? :)
12:13:23 <JustinClift> "JustinClift to test out Gitorious 3.x, to see if it's better than GitLab"
12:13:29 <ndevos> sure, I'll point out *again* that 3.5.3 needs the reviews in master first
12:13:33 <JustinClift> Haven't yet done it.  Got caught up with other stuff.
12:13:54 <JustinClift> ndevos: Repeating things is a good idea.  Reinforcement style. :)
12:14:10 <JustinClift> "kkeithley will nag pranithk about fixes for 3.4.6"
12:14:33 <kkeithley> not done
12:14:39 <JustinClift> Next week?
12:14:44 <kkeithley> yes
12:14:57 <kkeithley> dht backport too
12:14:59 <pranithk> JustinClift: COnsidering I am here, not needed I guess
12:15:12 <pranithk> kkeithley: I will send the patch this week
12:15:15 <JustinClift> So, consider it done. :)
12:15:40 <JustinClift> "pranithk to send a list with components and their assignees - soliciting others to contribute too"
12:15:45 <kkeithley> <montgomery burns>excellent</montgomery burns>
12:15:58 <JustinClift> pranithk: Did that get done?
12:15:59 <pranithk> JustinClift: huh? I don't remember it
12:16:12 <JustinClift> It's from a few weeks ago meeting
12:16:16 <hagarth> pranithk: possibly the design documentation?
12:16:22 <pranithk> JustinClift: ah! okay will do
12:16:31 <pranithk> JustinClift: or is it the QA list thing?
12:16:37 <JustinClift> Heh Heh Heh
12:16:55 <pranithk> JustinClift: I am confused. I don't remember :-(
12:16:59 <hagarth> pranithk: probably worth a check in the meeting log archive
12:17:06 <ndevos> pranithk: and please file bugs for the single documentation parts :)
12:17:07 <JustinClift> Yeah
12:17:15 <pranithk> hagarth: yeah
12:17:18 <pranithk> ndevos: yeah
12:17:33 <JustinClift> pranithk: Go look through the meeting log archives now?  We'll move onto the other items meanwhile and come back to this
12:17:43 <pranithk> JustinClift: yes
12:18:01 <JustinClift> #action kkeithley DHT backport 3.5.3->3.4.6  https://bugzilla.redhat.com:443/show_bug.cgi?id=1116150,  https://bugzilla.redhat.com:443/show_bug.cgi?id=1117851
12:18:03 <glusterbot> Bug 1116150: high, unspecified, ---, nsathyan, POST , [DHT:REBALANCE]: Rebalance failures are seen with error message  " remote operation failed: File exists"
12:18:04 <glusterbot> Bug 1117851: high, unspecified, ---, jdarcy, POST , DHT :- data loss - file is missing on renaming same file from multiple client at same time
12:18:15 <JustinClift> "ndevos to add branch checking to rh-bugs"
12:18:24 <JustinClift> So, still being worked on then yeah?
12:18:28 <kkeithley> yes
12:18:32 <JustinClift> eg making sure it's ok before enforcing
12:18:33 <JustinClift> Cool
12:18:53 <ndevos> just checked http://build.gluster.org/view/Bugzilla%20Checks/job/compare-bug-version-and-git-branch/ and there are some failures
12:18:57 <JustinClift> #action ndevos to add branch checking to rh-bugs
12:19:04 <JustinClift> ndevos: I'm sure you'll get then sorted :)
12:19:06 <ndevos> I'll have to check what those failures are, and if they are valid
12:19:35 <JustinClift> Is "ndevos to update the rh-bugs script in Jenkins to check git/branch and bug/version" a different thing?
12:20:03 <JustinClift> Or is that a subsequent task, after you've got it working well?
12:20:03 <hagarth> JustinClift: I think they are the same
12:20:10 * JustinClift nukes that item
12:20:16 <ndevos> JustinClift: yeah, should be the same
12:20:30 <JustinClift> "hagarth to evolve plan for the test weekend and update schedule for 3.6"
12:20:43 <JustinClift> We'll do this as part of 3.6 topic
12:20:53 <JustinClift> "kkeithley to discuss -dev and -geo-rep  subpackages for Debian with pmatthai"
12:20:56 <JustinClift> Done
12:21:15 <JustinClift> Sounds like we're just going to have everything in one package
12:21:37 <JustinClift> kkeithley: Would you be ok to email gluster-devel to let everyone know how that went?
12:21:55 <JustinClift> eg so ppl know everything will be in one package (or whatever)
12:22:17 <kkeithley> there are four .debs in the Debian/Ubuntu packaging.  semiosis put the "source" on github.  Maybe we should put in in our source too, a la .../extras/Linux{RPM,dpkg)?
12:22:18 <ndevos> an email with the results of the discussion would be good, yes
12:22:39 <hagarth> +1
12:22:43 <kkeithley> fwiw it was all discussed on #gluster-dev IIRC
12:22:48 <kkeithley> but I'll send an email
12:22:51 <JustinClift> Thx
12:23:02 <lalatenduM> kkeithley++ :)
12:23:14 <lalatenduM> We need a bot here
12:23:29 <kkeithley> thoughts about .../extras/LinuxDPKG/ ?
12:23:32 <JustinClift> #action kkeithley to email gluster-devel with info on how the Debian packaging will be done
12:23:40 <JustinClift> kkeithley: No objections here
12:23:58 <ndevos> kkeithley: whatever makes it easy for people that need to build .debs
12:24:00 <JustinClift> kkeithley: Will it be useful in some way, or is it a way to just not lose it?
12:24:05 <pranithk> glusterbot: kkeithley's karma is now 1
12:24:06 <kkeithley> I'll bring it up on #gluster-dev
12:24:12 <JustinClift> pranithk: Heh
12:24:23 <JustinClift> kkeithley: Sure
12:24:29 <hagarth> JustinClift: do we need an action item to get a bot here? ;)
12:24:38 <kkeithley> a way not to lose it. Certainly I'll use it (and others) to build for wheezy and jessie
12:24:42 <lalatenduM> kkeithley, no objections, should be fine
12:25:04 <JustinClift> #action kkeithley to figure out if the .deb packaging info should be carried in main GlusterFS git repo
12:25:17 <kkeithley> I believe semiosis is still the preferred packager for Ubuntu Launchpad PPAs
12:25:36 <JustinClift> Anyone remember who set up the Karmba bots for the other channels?
12:25:41 <ndevos> kkeithley: I think he started a launchpad group for packaging?
12:25:42 * JustinClift can feel an action item coming on
12:25:49 <hchiramm_> JustinClift, JoeJulian ?
12:25:55 <lalatenduM> I think it is JoeJulian
12:26:25 <JustinClift> #action hchiramm_ to ask JoeJulian to set up a karma bot for #gluster-meeting channel :)
12:26:36 <hchiramm_> sure :) JustinClift
12:26:41 <JustinClift> :)
12:26:42 <hagarth> sounds good!
12:26:46 <JustinClift> "hagarth, JustinClift and misc to evolve a proposal for web site maintenance"
12:26:52 <JustinClift> In progress
12:27:03 <JustinClift> "ndevos when we know how to update the webpage, add a pointer to proposed features for new contriburos"
12:27:13 <JustinClift> In progress
12:27:15 <JustinClift> :)
12:27:24 <hchiramm_> JustinClift, I propose "Who is who" page as well :)
12:27:25 <JustinClift> Eco's email yesterday should get us going
12:27:32 <JustinClift> Good idea
12:27:43 <JustinClift> #action hchiramm_ to create a "Who is Who" page for GlusterFS
12:27:48 <hchiramm_> thanks :)
12:27:52 <JustinClift> :)
12:27:56 <ndevos> haha :D
12:28:04 <hchiramm_> ndevos, :(
12:28:16 <JustinClift> "kkeithley will talk to Ira and Jose about samba packaging."
12:28:29 <JustinClift> "TBD"
12:28:31 <kkeithley> I just sent them an email
12:28:53 <JustinClift> "In progress.  Initial email sent."
12:28:58 <JustinClift> #topic 3.4
12:29:10 <JustinClift> kkeithley: Go for it
12:29:32 <kkeithley> nothing to report. Just waiting on critical mass of fixes for 3.4.6
12:29:37 <pranithk> #action pranithk to send backport for self-heald memory leak
12:30:22 <JustinClift> :)
12:30:38 <JustinClift> How's this item go? "Should the patch/fix backport request page just point to the respective tracker BZs?"
12:30:45 <kkeithley> yes
12:30:53 <JustinClift> Did we get any written instructions updated?
12:31:18 <ndevos> kkeithley: Manu found a NFS bug that can cause hangs on certain (NetBSD) NFS clients, want a backport for that?
12:31:33 <kkeithley> sure
12:31:42 <JustinClift> AI it
12:31:54 <ndevos> okay, I'll clone, "backport" and post it later
12:32:00 <kkeithley> thanks
12:32:10 <hagarth> I think we need to update the backport request page
12:32:17 <JustinClift> #action ndevos to clone, backport, and post the NFS bug that can cause hangs on certain (NetBSD) NFS clients
12:32:43 <hagarth> We need sections for 3.4.6 and also possibly for 3.6.0
12:32:49 <JustinClift> hagarth: Who should do that?
12:32:55 <JustinClift> lalatenduM: Do you have time to?
12:33:04 <ndevos> hagarth: I prefer to get backports requests as bug against the tracker...
12:33:18 <hagarth> ndevos: yes, we can add a link to the tracker bz from that page
12:33:20 <JustinClift> Yeah.  We can update the backport request page to instruct people to do that
12:33:38 <JustinClift> eg link to each of the tracking BZ's and such
12:33:55 <JustinClift> We just need a volunteer....
12:33:59 <ndevos> hagarth: right, thats what I've done for 3.5.x
12:34:16 <hagarth> hchiramm_: can you help here?
12:34:21 <hchiramm_> hagarth, sure
12:34:33 <Thilam|work> hi, sorry to be late
12:34:53 <hagarth> hchiramm_: thanks, JustinClift - one more AI for hchiramm_ ;)
12:34:58 * kshlm says pranithk hi!
12:35:01 <JustinClift> #action hchiramm_ to update the backport request page, adding the tracker BZ's for each release and instruction people to add proposed patches to the appropriate tracker BZ's
12:35:08 <hchiramm_> hagarth, thanks :)
12:35:40 <JustinClift> #topic 3.5
12:35:47 <JustinClift> Is there anything for this?
12:36:11 <lalatenduM> JustinClift, missed ur question , are u waiting for me
12:36:15 <lalatenduM> on me*
12:36:22 <JustinClift> lalatenduM: Nah, we got it sorted :)
12:36:32 <lalatenduM> sorry abt it
12:36:34 <JustinClift> k, sounds like nothing new for 3.5 this week.
12:36:36 <ndevos> 3.5 -> dht fixes coming this or next week
12:36:37 <JustinClift> lalatenduM: Not a killer
12:36:37 <hagarth> we still need dht fixes for 3.5.3
12:36:57 <ndevos> when they land, I'll get a beta out, so maybe next week friday
12:37:03 <JustinClift> Cool
12:37:18 <lalatenduM> okies
12:37:40 <JustinClift> k, updated etherpad with that eta.  29th Aug
12:37:47 <JustinClift> #topic 3.6
12:37:56 <JustinClift> hagarth: Yours?
12:38:01 <hagarth> we had planned a test day this week
12:38:21 <hagarth> however there are issues in dht and afrv2 that need to be addressed
12:38:32 <JustinClift> k, so we'll get it organised after they're done
12:38:40 <hagarth> I don't think our test day will be effective without those fixes
12:38:44 <JustinClift> "put our best foot forward"
12:38:51 <JustinClift> It's all good.
12:38:51 <ndevos> we could test one-brick configs? but well, uhm...
12:38:56 <JustinClift> Heh
12:39:09 <JustinClift> We have the regression test stuff for that ;)
12:39:12 <JustinClift> (kinda)
12:39:23 <JustinClift> hagarth: Sounds workable
12:39:33 <hagarth> I will push out the test day by a week
12:39:42 <JustinClift> hagarth: Update the schedule page?
12:39:43 <hagarth> pranithk: do you want to provide an update on afrv2 fixes?
12:39:47 <hagarth> JustinClift: will do
12:39:50 <JustinClift> :)
12:39:57 <ndevos> did you announce the test day already? I might have missed the emails
12:40:11 <hagarth> ndevos: no, I had just updated the Planning36 page
12:40:23 <hagarth> was waiting for this decision to send out a note on the MLs.
12:40:27 <ndevos> hagarth: ah, okay
12:40:52 <JustinClift> Anything else for 3.6?
12:41:04 <hagarth> nothing else from me
12:41:07 <lalatenduM> I am started working on the specfile
12:41:08 <pranithk> hagarth: I found 2 issues in data-self-heal. 3 in entry-self-heal and testing metadata self-heal today.
12:41:10 <lalatenduM> for 3.6
12:41:18 <hagarth> one more thing around 3.6 planning
12:41:27 <JustinClift> pranithk: Applicable to 3.6?
12:41:44 <pranithk> JustinClift: yes they are afrv2 problems the ones hagarth mentioned a while earlier...
12:41:46 <hagarth> would it be good to start community hangouts that talk about the features?
12:41:50 <JustinClift> Cool
12:42:02 <ndevos> lalatenduM: hmm, what needs to be done for 3.6? the nightly builds at least build :)
12:42:03 <hagarth> s/features/new features in 3.6/
12:42:24 <ndevos> oh, I'd love to see a hangout with pranithk!
12:42:25 <lalatenduM> ndevos, the fedora spec file is diff than source
12:42:31 <JustinClift> hagarth: Hangouts is one way.  We could do that.  There's also web instructional video type stuff.
12:42:34 <ndevos> lalatenduM: ah, yes, sure
12:42:37 <JustinClift> I'm all for whatever works. :)
12:43:00 <hagarth> right, let us have this planned and start these sessions as a build up to 3.6 GA
12:43:05 <pranithk> ndevos: sure why not ;-)
12:43:16 <JustinClift> hagarth: We should probably try it out, and see how well it goes.
12:43:24 <hagarth> JustinClift: yeah
12:43:27 <pranithk> ndevos: English could be terrible, don't say I didn't warn you folks :-)
12:43:34 <JustinClift> Might take a few to knock off any "rough edges" our people have
12:43:43 <JustinClift> pranithk: That's what subtitles are for. :D
12:43:43 <ndevos> pranithk++
12:43:50 <lalatenduM> pranithk++
12:43:56 <hagarth> pranithk: most of us could use that disclaimer before we start :D
12:44:06 <pranithk> JustinClift: spoke like a hollywood producer :-D
12:44:14 <JustinClift> Heh Heh Heh
12:44:30 <hagarth> cool, I will start a thread for doing this planning
12:44:42 <JustinClift> Cool, sounds like pranithk has been volunteered for the first one too
12:44:49 <JustinClift> hagarth: AI it :)
12:44:54 <lalatenduM> we some VFX studios using Gluster :)
12:45:06 <hagarth> #action hagarth to evolve a plan for 3.6 feature sessions
12:45:18 <ndevos> #action pranithk to write a script for his afrv2 hangout
12:45:27 <hagarth> that's it from me around 3.6
12:45:29 <pranithk> ndevos: script?
12:45:31 <JustinClift> Scripts even :)
12:45:44 <ndevos> pranithk: hehe, yes, or at least something :D
12:45:50 <pranithk> ndevos: I thought it is a video of me explaining afrv2
12:45:58 <JustinClift> pranithk: script -> what happens in the scene / act / hangout
12:46:06 <pranithk> JustinClift: ah!
12:46:07 <JustinClift> eg words, actions, etc
12:46:28 <JustinClift> Gah, ksmlm got away without an AI
12:46:33 * JustinClift will do better next time
12:46:33 <hagarth> pranithk: be prepared, as in the scout motto!
12:46:36 <JustinClift> Moving on... :)
12:46:41 <JustinClift> Aha
12:46:43 <lalatenduM> JustinClift, lol :)
12:46:48 <hagarth> #action kshlm to do a hangout on glusterd
12:46:53 <lalatenduM> haha
12:46:55 <JustinClift> Awesome :)
12:46:58 <lalatenduM> hagarth++
12:47:07 <kshlm> What!
12:47:15 <JustinClift> You been volunteered :)
12:47:17 <hchiramm_> ++
12:47:25 <hagarth> kshlm: yes, you have been volunteered for better peer identification
12:47:25 <hchiramm_> :)
12:47:31 <JustinClift> Moving on
12:47:36 <JustinClift> "Other agenda items"
12:47:51 <JustinClift> #topic cppcheck fixes nag
12:47:56 <pranithk> JustinClift: 6th August meeting minutes didn't contain any action item on me related to this 'list' 13th contains it, but kkeithley says he is picking it up from previous meeting. So not sure. Ah! I think it is from bug-triage meeting?
12:48:27 <JustinClift> Is it present in the weeks before meeting summary action items?
12:48:37 <pranithk> JustinClift: not in the mails you sent
12:48:55 <JustinClift> pranithk: Yeah, maybe from the bug-triage meeting
12:48:56 <hchiramm_> pranithk, https://public.pad.fsfe.org/p/gluster-community-meetings :) grep there
12:49:05 <JustinClift> If you can't find it, we can drop it I guess
12:49:10 <JustinClift> hchiramm_: Good idea
12:49:21 <hchiramm_> :)
12:49:29 <JustinClift> We need to get this cppcheck stuff done
12:49:41 <JustinClift> kkeithley's nag emails don't seem to work effectively for it
12:49:58 <kkeithley> I just sent email to #gluster-dev
12:50:06 <hagarth> JustinClift: I will get to it this week
12:50:10 <JustinClift> kkeithley: Do you have known people for each branch that can be assigned to them, instead of requesting?
12:50:25 <JustinClift> hagarth: AI it :)
12:50:32 <ndevos> JustinClift: not branch, sub-system
12:50:47 <JustinClift> Good piont
12:50:49 <JustinClift> point
12:50:50 <hagarth> #action hagarth to review cppcheck fixes  this week
12:50:58 <pranithk> hchiramm_: I think we should drop it. It doesn't have what we are talking about either :-(
12:51:02 <JustinClift> QUESTION from ndevos: is there a deadline/planning/date we need to meet to get 3.5.x or 3.6.x in Ubuntu?
12:51:10 <ndevos> I guess that smaller patches, one per subsystem is quicker to review/merge
12:51:39 <JustinClift> ndevos: Yeah.  That way has an easier defined list of ppl to review stuff
12:51:53 <JustinClift> But, hagarth said he'd get this done, so it's probably moot point for now
12:51:59 <pranithk> ndevos: +1
12:52:10 <ndevos> JustinClift: it would help for next patches :)
12:52:15 <JustinClift> Yep
12:52:16 <pranithk> JustinClift: future
12:52:23 <ndevos> pranithk: +1
12:52:26 <JustinClift> Oh, we should remove me from the Glupy maintainers list
12:52:30 * JustinClift will sent patch
12:52:33 <JustinClift> send
12:52:40 * ndevos wont review that one :P
12:52:50 <JustinClift> #action JustinClift to remove himself/Glupy from maintainers list
12:53:03 * pranithk -2 Do not submit :-)
12:53:06 <JustinClift> I haven't touched the code in ages, so useless to help ppl with it :(
12:53:25 <JustinClift> #topic Backups for GlusterFS Infrastructure
12:53:30 <pranithk> JustinClift: it will become orphan Justing
12:53:36 <JustinClift> Yeah, I know
12:53:54 <JustinClift> No-one else seems to have any interest in it at all.  Non-optimal, but it is what it is.
12:54:02 <pranithk> JustinClift: that backup stuff, some interns did it I thought... hagarth?
12:54:14 <hagarth> pranithk: this is different from NDMP
12:54:19 <JustinClift> With the backup stuff, it's being actively worked out on #gluster-infra
12:54:33 <pranithk> hagarth: ah! got t
12:54:38 <JustinClift> pranithk: There's currently no backups being done of any of the GlusterFS infrastructure
12:54:39 <hagarth> JustinClift: we need to collate all our infra details as hchiramm_ mentions
12:54:44 <JustinClift> Which is scaery in all kinds of ways :)
12:54:49 <ndevos> JustinClift: oh, there is a #gluster-infra channel?
12:54:52 <JustinClift> So, we're getting that fixed
12:55:01 <pranithk> JustinClift: got it
12:55:08 <JustinClift> ndevos: Oops, I meant gluster-infra mailing list
12:55:14 <ndevos> ah, okay
12:55:26 <JustinClift> #topic Website maintenance strategy - Eco's post on gluster-infra
12:55:31 <JustinClift> http://www.gluster.org/pipermail/gluster-infra/2014-August/000299.html
12:55:37 * JustinClift is going to try the steps out today
12:55:44 <hagarth> please let us know your comments on this workflow
12:55:50 <JustinClift> Definitely
12:55:53 <ndevos> "only 23 steps"
12:56:08 <JustinClift> From memory there's some kind of warning/error that happens with Middleman
12:56:17 <JustinClift> But it still builds the site ok I'm told
12:56:31 <hagarth> we still need to evovle more details there
12:56:33 <JustinClift> When we get that error fixed, then we should (hopefully) be able to automate the whole thing
12:56:36 <JustinClift> Yeah
12:56:40 <hagarth> and reduce the overall number of steps
12:56:45 <JustinClift> That's what I'm going through it today for.
12:56:49 <hagarth> JustinClift: cool
12:56:54 * JustinClift *really* wants it fully automated
12:56:57 <ndevos> and remove the needed ssh access to servers :)
12:57:04 <JustinClift> ;)
12:57:42 <JustinClift> #topic owncloud/GlusterFS talk on Friday in Linuxcon - http://lccona14.sched.org/event/d74123964f922f5fe84a28066ca11633#.U_SMIGeeHQZ
12:57:59 <JustinClift> We should probably send details of that out via mailing lists / blog
12:58:00 <hagarth> nvm, there's a talk on glusterfs & owncloud in LinuxCon NA this friday
12:58:12 <JustinClift> ... or not then?
12:58:35 <hagarth> please spread the word around this in all your favorite social networking sites :)
12:58:39 <JustinClift> :)
12:59:05 <hagarth> a mail on gluster-users could help too
12:59:07 <JustinClift> #action JustinClift to blog about upcoming owncloud/GlusterFS talk happening on Friday.  And email gluster-* abt it too
12:59:20 <JustinClift> #topic Bug triage meetings - do we need bi-weekly bug triage meetings in #gluster-meeting ?
12:59:37 <JustinClift> Who's item is that?
12:59:50 <hagarth> mine
13:00:08 <hagarth> we started off with a bug triage meeting earlier to define the process
13:00:14 <ndevos> I guess it would be good to do that bi-weekly
13:00:39 <hagarth> right
13:00:43 <JustinClift> Note - We've just hit meeting end time.  But we're nearly through the items so lets get them finished
13:01:01 <lalatenduM> plz review http://www.gluster.org/community/documentation/index.php/Bug_triage
13:01:03 <hagarth> ndevos: would you want to setup those meetings?
13:01:05 <JustinClift> hagarth: Discuss on gluster-devel and +1/-1 there?
13:01:20 <lalatenduM> if you have not reviewed it before
13:01:22 <ndevos> hagarth: yeah, I think I can - any idea who would want to join?
13:01:41 <hagarth> ndevos: we need the sub-maintainers and anybody else who's interested
13:01:58 <hagarth> ndevos: we can just drop a note to gluster-devel about the meeting series
13:01:58 <ndevos> hagarth: okay, sounds good to me
13:02:19 <JustinClift> AI it
13:02:25 <hagarth> #action ndevos to work on setting up periodic bug triage meetings
13:02:26 <hagarth> done
13:02:34 <JustinClift> #topic Gluster related talk at the File and Storage Systems track / Linux Plumbers Conference?
13:02:49 <ndevos> yes, I just added that
13:03:02 <hagarth> fs-cache for fuse sounds like a good proposal
13:03:19 <ndevos> any other ideas?
13:03:27 <JustinClift> This is a "we need ideas" for the talk?
13:03:32 <ndevos> yes
13:03:50 <ndevos> or, rather, "what talk would you like to see?"
13:03:53 <JustinClift> Something to do with clustering and striping?
13:03:55 <hagarth> LPC is for slightly futuristic stuff - we don't need a lot of involved implementation details
13:04:32 <JustinClift> Our striping implementation isn't great speed wise.  Maybe discussion of ways to address that, if appropriate to LPC
13:04:45 <lalatenduM> what abt replication vs EC in gluster?
13:04:51 <hagarth> s/striping/sharding/ is going to be our answer :)
13:05:20 * JustinClift would argue with that
13:05:38 <hagarth> lalatenduM: possible, if we can have a novel idea around replication or EC
13:05:44 <JustinClift> Yeah
13:05:59 <JustinClift> ndevos: Also ask on gluster-users?
13:06:02 <lalatenduM> hagarth, also the performance implications
13:06:19 <hagarth> ndevos: you can probably reply to Ric's email on gluster-users and see if we get more ideas
13:06:29 <ndevos> JustinClift: yes, I plan to send an email about it after Vimal confirmed he'll be working on it :)
13:06:29 <JustinClift> k, that's the last item for today's agenda
13:06:35 <kkeithley> <late update>Re: latest samba, Jose is building samba-4.1.11 for download.gluster.org now. you can mark that as done</late update>
13:06:38 <JustinClift> ndevos: Cool :)
13:06:49 <ndevos> hagarth: thats the thought, yes
13:07:05 <JustinClift> kkeithley: Done
13:07:11 <JustinClift> Anything else ?
13:07:14 <hagarth> kkeithley: cool
13:07:15 * JustinClift is going to endmeeting...
13:07:22 <kkeithley> and if you haven't notice, I've added dynamic analysis runs in addition to static analysis on d.g.o
13:07:31 <ndevos> happy birthday msvbhat!
13:07:32 <JustinClift> Cool :)
13:07:32 <kkeithley> valgrind now, more coming.
13:07:40 <JustinClift> kkeithley: email gluster-devel abt that?
13:07:40 <msvbhat> Thanks ndevos
13:07:43 <kkeithley> chat on #gluster-dev for me
13:07:44 <raghug> happy b'day msvbhat
13:07:45 <JustinClift> #endmeeting