12:02:42 <davemc> #startmeeting
12:02:42 <zodbot> Meeting started Wed Oct 29 12:02:42 2014 UTC.  The chair is davemc. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:03:00 <davemc> etherpad is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:03:11 <davemc> #topic roll call
12:03:16 <davemc> whos here?
12:03:16 * overclk is here
12:03:19 * ndevos is here _o/
12:03:19 * lalatenduM is here
12:03:22 * davemc is almost here
12:03:22 * purpleidea is here
12:03:39 * Humble is here
12:03:40 * hagarth is here
12:04:05 <davemc> I rearranged the agenda a bit
12:04:36 <davemc> #topic FreeBSD maintainer
12:04:44 <davemc> seems to be under control
12:05:12 <hagarth> davemc: yes, we need to reach out to involve the maintainer actively
12:05:46 <davemc> #action davemc to contact Craig Butler
12:05:49 <ndevos> someone should update the MAINTAINERS file
12:05:59 <hagarth> ndevos: will do
12:06:14 <davemc> #action hagarth to update maintainers file
12:06:14 <ndevos> hagarth: thanks :)
12:06:26 <davemc> next up
12:06:30 <davemc> #topic rackspace for brtfs testing
12:06:40 * xavih is here
12:06:43 <davemc> JustinClift doesn't appear to be on
12:06:55 <hagarth> overclk: did you get any VMs from RAX for this?
12:07:19 <overclk> davemc: nope. I thought of getting in touch with Justin, but got busy elsewhere.
12:07:24 <purpleidea> davemc: as a side note to btrfs, this is in puppet-gluster, needs testing, and might help automate your testing: https://github.com/purpleidea/puppet-gluster/commit/6c962083d8b100dcaeb6f11dbe61e6071f3d13f0
12:07:43 <purpleidea> </shameless plug>
12:07:54 <hagarth> davemc: we can probably ping JustinClift again on this.
12:08:08 <davemc> anything that helps testing can't be all bad. so just a plug
12:08:09 <overclk> davemc: I'll get in touch with Justin
12:08:17 <davemc> tks overclk
12:08:18 <hagarth> purpleidea: might be interesting to see if we can drive a jenkins job for puppet-gluster
12:08:45 <davemc> I've got a couple of emails out to him but haven't heard back
12:08:57 <purpleidea> hagarth: i was thinking about this the other day actually, but shamefully looking at travis
12:09:17 <hagarth> purpleidea: let us discuss this on gluster-infra
12:09:34 <davemc> next up
12:09:40 <davemc> #topic davemc to get the GlusterFS Consultants and Support Company's page online
12:09:48 <davemc> the etherpad is updated
12:09:59 <davemc> the changes are done
12:10:22 <davemc> however, we have several people now trying to recreate all the steps to build the site
12:10:47 <davemc> it is also clear that some parts weren't converted correctly
12:11:01 <davemc> I have one page with 24 broken links for example
12:11:24 <davemc> we will need to revisit the site issue
12:11:41 * kshlm is here and is sorry he is late.
12:11:42 <hagarth> davemc: should we continue more discussions on this on gluster-infra ML?
12:11:45 <davemc> there is also been discussion on the site in int -infra mailing list
12:11:48 <davemc> yes
12:12:07 <ndevos> wow, sounds we need something like a link-checker for the site
12:12:10 <hagarth> let us do that, I am tired of having a dysfunctional site :)
12:12:22 <davemc> hagarth++
12:12:23 <ndevos> a jenkins job for the site repository?
12:12:39 <purpleidea> hagarth / ndevos : how about having the site in git
12:12:42 * krishnan_p is here
12:12:45 <hagarth> ndevos: that would be cool
12:12:46 <davemc> can we consider a modern CMS? (I know, not allowed)
12:12:57 <ndevos> purpleidea: I think the site is in git?
12:13:02 <hagarth> purpleidea: the site is in git, but the process of updating + publishing is laborious at best
12:13:24 * ndevos looked at the process, and it was 20(?) steps?
12:13:40 <davemc> 2 separate gits, one wiki, one forge connect, a tie to bitgeria
12:13:45 <hagarth> ndevos: 24 IIRC
12:13:54 <davemc> ndevos, and we know that was incomplete
12:14:11 <davemc> the current list is closer to 35
12:14:12 <ndevos> I'm glad I did not try them out
12:14:18 <davemc> aanyway, discussion continues on -infra
12:14:28 <davemc> s/aa/a/
12:14:38 <davemc> #topic 3.6.0
12:14:40 <kshlm> There is a tool called gollum, which is a git+markdown wiki. It's use by github for their project wiki pages.
12:14:47 <kshlm> We could look at that.
12:14:55 <hagarth> kshlm: interesting
12:15:10 <davemc> #idea look into gollum, git+markdown
12:15:28 <davemc> #topic 3.6.readiness check
12:15:34 <davemc> hagarth, ?
12:15:42 <lalatenduM> davemc, we should have a action item for this
12:15:43 <hagarth> here's the current state:
12:15:53 <lalatenduM> I mean for idea look into gollum, git+markdown
12:16:07 <davemc> so marked lalatenduM
12:16:08 <hagarth> 1. Expecting 2 patches for afrv2 to make 3.6 complete content wise
12:16:28 <hagarth> 2. Release Notes draft is available, I will be refreshing it later today
12:16:44 <davemc> read the release notes draft, nice job
12:16:52 <hagarth> 3. Upgrade instructions are getting ready, awaiting more info from afrv2
12:17:18 <hagarth> Once these 3 are complete, a +1 from me for 3.6.0
12:17:33 <hagarth> I am hoping to make it happen over the next day or two
12:17:33 <davemc> other comments form anyone?
12:17:43 <davemc> s/form/from
12:17:58 <davemc> (my fngers are still asleep)
12:17:59 <hagarth> go or no-go please :)
12:18:04 <davemc> go
12:18:05 <ndevos> I think it looks good :)
12:18:32 <ndevos> lalatenduM: did you backport the logrotate fix to 3.6 already?
12:18:36 <hagarth> yay! no no-go votes.. we seem to be good ;)
12:18:45 <lalatenduM> ndevos, nope
12:18:46 <kshlm> GO
12:18:58 <purpleidea> someone have a #link to the draf ?
12:19:12 <lalatenduM> ndevos, waiting for the patch to get merged in master
12:19:16 <davemc> do we have consensus?
12:19:33 <davemc> purpleidea, the release notes?
12:19:37 <purpleidea> davemc: ya
12:19:44 <hagarth> purpleidea: https://draftin.com/documents/514537/ has the latest draft
12:19:48 <ndevos> hagarth: I'd like to see the logrotate one included, that is what holds up the 3.5 one for now
12:19:57 <hagarth> ndevos: sure
12:19:57 <lalatenduM> hagarth, ndevos I think we should have the logrotate stuff, what do u think?
12:20:06 <davemc> Hagarth beat me to it.
12:20:16 <ndevos> hagarth: that would be a backport of http://review.gluster.org/#/c/8994/
12:20:21 <purpleidea> hagarth: The page you were looking for doesn't exist.
12:20:22 <kshlm> the link doesn't open.
12:20:23 <hagarth> xavih: would you mind marking the quota + ec incompatibility in known issues of release notes?
12:20:27 <hagarth> hang on
12:20:31 <kshlm> http://goo.gl/zY6fve but this does.
12:20:39 <hagarth> http://goo.gl/zY6fve
12:20:45 <hagarth> yes, that's the one
12:21:01 <lalatenduM> ndevos, not sure if kkeithley1's related to logrotate changes in spec file got in to 3.6
12:21:19 <xavih> hagarth: I'll do. Do I modify the patch and resubmit it ?
12:21:43 <ndevos> lalatenduM: that does not matter, as long as that change is in the fedora .spec
12:21:46 <hagarth> xavih: you can update it in draftin (link above)
12:21:50 <lalatenduM> ndevos, yeah
12:21:57 <xavih> hagarth: ok
12:21:59 <hagarth> I will take care of sending it to gerrit
12:22:17 <purpleidea> hagarth: looks great!
12:22:30 * lpabon a little late, but here
12:22:36 <hagarth> purpleidea: thanks! it is a collaborative effort :)
12:22:54 <davemc> If we add anything major, please let me know directly by email davemc@gluster.org
12:23:09 <hagarth> davemc: sure
12:23:15 <davemc> I'm working on a blog and an intro presentation
12:23:43 <hagarth> davemc: awesome!
12:23:50 <davemc> more on 3.6 readiness?
12:24:05 <davemc> otherwise
12:24:18 <davemc> #topic RHEL-6.6 issue
12:24:30 <hagarth> i will move all open dependent bugs of 3.6.0 to 3.6.1
12:24:43 <davemc> ndevos, kkeithley_ ?
12:24:52 <kkeithley_> ?
12:25:24 <kkeithley_> oh shoot, let me get on the etherpad
12:25:38 <ndevos> is that about the conflicts in rhel-6.1 and the community 3.6 packages?
12:25:47 <davemc> last meeting was a discussion on whether approach was right
12:25:55 <davemc> for yum updates
12:26:00 <kkeithley_> oh, that. yeah
12:26:07 <ndevos> I think we settled on an approach
12:26:07 <lalatenduM> ndevos, yeah rhel 6.6. has a higher versionpkg than upstream
12:26:13 <lalatenduM> yeh
12:26:22 <Humble> its not correct afaict.. :)
12:26:22 <ndevos> ah, not rhel-6.1, but rhel-6.6
12:26:48 <ndevos> Humble: I agree that it is not correct, but we cant change rhel :)
12:26:50 <kshlm> Would'nt release glusterfs-3.6 fix that?
12:26:53 <davemc> whew, I did type the topic right
12:26:59 <lalatenduM> kshlm, nope
12:27:21 <lalatenduM> kshlm, we will release 3.6.0 but 6.6 has 3.6.29-2
12:27:38 <ndevos> lalatenduM: 3.6.0.*, I hope?
12:27:42 <lalatenduM> still RHEL has higher version RPM
12:27:45 <lalatenduM> ndevos, yes
12:27:54 <ndevos> phew :)
12:28:03 <kkeithley_> yes, we have an approach
12:28:07 <hagarth> to make it worse, the op-versions would be different between 3.6.0.29 and GlusterFS 3.6.0
12:28:19 <lalatenduM> hagarth, yeah :)
12:28:43 <lalatenduM> awesome isn't it :)
12:28:55 <Humble> ndevos, the downstream major version should be < upstream major version .. :)
12:29:12 <ndevos> so, the issue is that 3.6.0-1 (community release) has a lower rpm-version than 3.6.0.29-1 -> users that want to install glusterfs-server from the community repo will get errors
12:29:25 <ndevos> Humble: yes, I fully agree
12:29:35 <krishnan_p> Humble, the downstream op-version is less than the upstream op-version, at the moment.
12:30:06 <Humble> krishnan_p, op-version ?
12:30:39 * ndevos suggests to skip the op-version topic for now
12:30:52 <hagarth> ndevos: ok, move it to -devel ML?
12:30:53 <krishnan_p> ndevos, OK.
12:31:25 <ndevos> kkeithley_: was there a final email about the solution sent out?
12:31:28 <davemc> so, is there a plan, a plan for a plan?
12:31:51 <Humble> krishnan_p, I was talking abt package major version.
12:32:17 <ndevos> davemc: we have a plan, and we can post it if it was not done yet
12:32:25 <davemc> tks
12:32:58 <krishnan_p> Humble, I know. I was saying op-version has the property you were looking for. You are right that installation/upgrade problems have nothing to do with op-version.
12:32:58 * ndevos wonders if he was assigned to send the email out, and forgot about it
12:33:06 <kkeithley_> plan was posted to gluster-devel last week. There were a few comments
12:33:14 <kkeithley_> I sent it
12:33:41 <hagarth> however if we have an op-version compatibility problem, there are bound to be some heartaches. krishnan_p, i think it is worth some more thought..
12:33:43 <kkeithley_> comments were all related to not setting priority=1 and not blindly installing yum-plugin-priorities
12:33:45 <lalatenduM> #action ndevos to send email about the solution for rhel6.6 glusterfs version issue with upstream
12:34:04 <ndevos> ah, yes, http://supercolony.gluster.org/pipermail/gluster-devel/2014-October/042579.html
12:34:39 <lalatenduM> ndevos, but tehre was no final conclusion
12:34:47 <ndevos> lalatenduM: no, indeed
12:35:04 <ndevos> lalatenduM: I think we agreed on IRC about it
12:35:20 <lalatenduM> ndevos, yeah I think so
12:35:41 <davemc> can someone pull together the agreed solution and get it out?
12:35:43 * Humble : can we move to 3.6.1 in upstream as soon as 3.6 GA is released ? just a thought .?? :)
12:35:47 <krishnan_p> hagarth, true.
12:35:49 <ndevos> anyway, we know how we like to address it - I'll send the email
12:36:18 <lalatenduM> Humble, awesome idea . that would save us lot of trouble
12:36:22 <davemc> #action ndevos to send out email detailing solution to the RHEL-6.6 issue
12:36:25 <lalatenduM> ndevos, ^^
12:36:38 <ndevos> Humble: we can, just wait with getting a most urgent fix in ;)
12:36:44 <hagarth> Humble: not a bad idea
12:37:01 <davemc> that does seem to solve many things
12:37:33 <davemc> I'll go break something in the code so we can force it <GRIN>
12:37:36 <Humble> \0/
12:37:40 <kkeithley_> finesse
12:37:42 <ndevos> most people prefer to installa .1 release as they hope it has less bugs than a .0 one :D
12:37:45 <lalatenduM> looks like most of us like the idea :)
12:37:58 <lalatenduM> Humble++
12:38:52 <davemc> #action review Humbles suggestion for moving to 3.6.1 quickly
12:39:22 <davemc> ready to move on? 20 minutes left
12:39:48 <davemc> #topic POODLE advisory
12:40:30 <davemc> I did some minor tweaks to the PODLE advisory. IF and when we can get it to the website, I want to make sure its visible
12:40:48 <davemc> please review the text in the pad and edit if necessary
12:40:48 <jdarcy> Looks like the patch has been merged on master and at least one other branch, at least one other still pending.
12:40:55 <hagarth> davemc: cool
12:41:07 <kkeithley_> http://review.gluster.org/8967   Needs a +2
12:41:20 <hagarth> jdarcy: I merged it on release-3.6 some time back. Niels has it in release-3.5 too.
12:41:29 <kkeithley_> pretty please with sugar on top
12:42:19 <ndevos> it's backported and included in 3.5, without the manual override of selecting ciphers
12:43:36 <davemc> can we get another review so to get to a +2 per kkeithley_
12:44:26 <hagarth> xavih++ thanks, have merged your update to release notes
12:44:39 <davemc> okay, moving on?
12:44:45 <hagarth> davemc: yeah
12:44:45 <kkeithley_> If I hadn't posted the patch myself I'd just merge it.
12:45:03 <xavih> hagarth: np :)
12:45:30 <davemc> #topic other 3.6
12:45:51 <davemc> I'm working on various outreach for release of 3.6
12:46:03 <hagarth> davemc: cool
12:46:28 <davemc> blog(s), vlog, twitter, email IRC
12:46:48 <davemc> we will have a Gluste revening in PAris 4-Nov
12:47:02 <hagarth> davemc: great!
12:47:05 <ws2k3> i was wondering will 3.6 contain support fur multi datacenter glusterfs volume? so i dont need the geo replication?
12:47:11 <davemc> which I'm now flying over and back within a 2 day period
12:47:14 <hagarth> davemc: do we have speakers lined up for the event?
12:47:15 <ndevos> 4 November?
12:47:25 <hagarth> ws2k3: not yet
12:47:35 <davemc> ndarshan, that's what the event thingee says
12:47:48 <davemc> https://www.eventbrite.com/myevent?eid=10413255327
12:48:27 <ndevos> davemc: wasnt it on the 3rd earlier?
12:48:37 <davemc> would be good to promote the eventbrite link
12:49:10 <hagarth> davemc: need a proper eventbrite link - this asks for a login
12:49:12 <hagarth> ndevos: http://paris.eventful.com/events/gluster-night-paris-/E0-001-066265345-8
12:49:21 <davemc> ndevos, I can't recall.
12:49:25 <davemc> hagarth, one sec
12:49:33 <ndevos> hagarth: yeah, got it
12:49:43 <ndevos> davemc: I'm pretty sure it did... oh well
12:50:02 <hagarth> I think this is the one - http://www.eventbrite.com/e/inscription-gluster-night-paris-10413255327
12:50:46 <davemc> that's it. forgot I was still in the edit site
12:51:15 <hagarth> sure, we can promote it in various forums.
12:51:48 <davemc> ndevos, I think the problem may have been finding space since openstack EU is tha week
12:51:51 <hagarth> coming back to 3.6.0, I think it would be nice to have more howtos/blogs on 3.6.0.
12:52:14 <hagarth> ndevos has volunteered to write up about nfs-ganesha 2.1 and glusterfs 3.6.0
12:52:31 <ndevos> wait, *I* did?
12:52:47 <hagarth> ndevos: yes,  you did ;)
12:52:51 <davemc> think of the karma points, ndevos
12:53:13 <hagarth> more such posts on  components that we work with would be useful
12:53:21 <ndevos> hagarth: uhm, right, but I was thinking to volunteer someone else to do the work :D
12:53:31 <davemc> would certaainly he /me
12:53:39 <davemc> would certainly help me
12:53:51 <lalatenduM> ndevos, I think soumya would be interested too :)
12:53:51 <kkeithley_> thanks jdarcy
12:54:00 <ndevos> but, yes, we'll get that done this week
12:54:02 <davemc> 7 mintes
12:54:08 <jdarcy> kkeithley_: Thanks for the backport.  :)
12:54:12 <ndevos> no, not within 7 minutes!
12:54:15 <hagarth> ndevos: you are the AI owner for that .. how you get it done is immaterial :D
12:54:30 <ndevos> hagarth: sounds good to me :)
12:54:53 <davemc> Moving on
12:55:04 <davemc> #topic 3.5
12:55:11 <davemc> any updates?
12:55:22 <davemc> any targeted releases?
12:55:39 <ws2k3> and how is the progress going with freebsd 3.6 will have officaly freebsd support right?
12:56:17 <ndevos> only waiting for one patch from lalatenduM
12:56:36 <ndevos> once the logrotate fix is in, we'll do a 2nd beta for 3.5
12:56:37 <lalatenduM> ndevos, the logrotate one ?
12:56:39 <hagarth> ws2k3: we are still expecting some testing to make freebsd support official
12:57:25 <davemc> k
12:57:27 <ndevos> after the beta, some testing is needed, and the release-notes need to get merged before we make 3.5.3 GA
12:58:02 <davemc> sounds good.  I want to start promoting the beta releases a bit more actively as well
12:58:09 * ndevos has finished on 3.5
12:58:15 <davemc> #topic 3.4
12:58:31 <davemc> any updates on 3.4.6 release?
12:58:34 <kkeithley_> just waiting on the AFR fix/backport
12:58:40 <kkeithley_> from Pranith
12:58:49 <kkeithley_> maybe we want the logrotate fix too?
12:59:29 <hagarth> kkeithley_: +1 to have the logrotate fix
13:00:16 <kkeithley_> that's it for me
13:00:31 <davemc> #topic Gluster next
13:00:55 <davemc> small file performance is the top called out item in the current survey
13:01:11 <davemc> also the only listed reason people have stopped using Gluster
13:01:23 <purpleidea> davemc: did nsr or btrfs get results?
13:01:26 <davemc> still need to do feature pages
13:01:39 <hagarth> davemc: me, jdarcy and krishnan_p have some plans on 4.0. will reach out to you soon.
13:02:02 <davemc> don't recall nsr, 2 mentions of brtfs, neither big deals
13:02:36 <hagarth> davemc: when do we expect the survey results to be out?
13:02:36 <jdarcy> We need to figure out which of the many small-file-related fixes will/should be part of 4.x.
13:02:41 <davemc> will share results when survey closes
13:03:11 <hagarth> jdarcy: yes
13:03:39 <davemc> I'll need to wrap this soon-ish
13:03:51 <davemc> my next meeting has already started
13:03:55 <jdarcy> Some of them can/should go in sooner, especially in light of the survey results.
13:04:28 <ws2k3> hagarth but will 3.6 official support freebsd?
13:04:30 <hagarth> jdarcy: yeah
13:04:39 <davemc> I want to discuss -next in more detail, particularly around community involvement and Board
13:04:48 <hagarth> ws2k3: a minor release of 3.6.x will have
13:04:58 <hagarth> davemc: have a separate meeting for that?
13:06:00 <davemc> hagarth, yes
13:07:30 <hagarth> davemc: #endmeeting for now?
13:07:35 <davemc> sorry, cat distraction
13:07:35 <purpleidea> quick question to stick in before meeting's over--
13:07:42 <davemc> yeah, would like to end
13:07:52 <purpleidea> anyone have any ACK/NACK preferences to:     https://github.com/purpleidea/puppet-gluster/commit/198d616747ccff61b996e9523fe3d08bd783efb8
13:08:06 <purpleidea> ^^ will causes occasional bot irc messages in gluster-devel
13:08:17 <davemc> and table till next time
13:08:36 <davemc> please get back to purpleidea  on his request
13:08:36 <hagarth> purpleidea: ACK
13:08:45 <davemc> ending meeting
13:08:51 <davemc> #endmeeting