12:02:24 <hagarth> #startmeeting
12:02:24 <zodbot> Meeting started Wed Jan 28 12:02:24 2015 UTC.  The chair is hagarth. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:28 <hagarth> purpleidea: hello!
12:02:53 <hagarth> Agenda is at the usual place on fsfe: https://public.pad.fsfe.org/p/gluster-community-meetings
12:02:54 * purpleidea is finally awake at this time (by being in a europe tz)
12:03:08 <hagarth> #topic Roll Call
12:03:13 * lalatenduM is lurking
12:03:14 <hagarth> who do we have here today?
12:03:19 * purpleidea is here
12:03:37 * ndevos _o/ (but on a meeting)
12:03:39 * krishnan_p is here
12:03:42 * xavih is here
12:03:45 * partner busy emptying datacenter
12:03:48 * jdarcy is.
12:03:56 <hagarth> cool, we seem to have quorum.
12:04:26 <hagarth> #topic AI review from last week
12:04:37 <hagarth> hchiramm will try to fix the duplicate syndication of posts from blog.nixpanic.net
12:04:45 <hagarth> I guess we did not make much progress on this one
12:05:14 * ndevos did not try to blog, so no tests
12:05:15 * kshlm is here
12:05:23 * atinmu is here
12:05:55 <hagarth> ndevos: ok, but I did see a bunch of repetitive facebook and twitter posts :-/
12:06:25 <ndevos> :-/
12:06:29 <hagarth> I think we should probably stop auto syncing between twitter, blog and facebook for a while
12:06:59 <hagarth> and start enabling syncing one by one
12:07:10 <hagarth> anyway, we have an AI to be reviewed on this
12:07:23 <hagarth> next AI - hagarth to open a feature page for (k)vm hyperconvergence
12:07:36 <hagarth> not yet done, but the ovirt folks have opened a page already
12:07:53 <hagarth> #link - http://www.ovirt.org/Features/GlusterFS-Hyperconvergence
12:08:12 <hagarth> This also contains links and details of some RFEs in GlusterFS for supporting hyperconvergence
12:08:38 <hagarth> I will include this link in the feature page on gluster.org
12:08:47 <hagarth> #action hagarth to open a feature page for (k)vm hyperconvergence
12:09:01 <hagarth> next AI - hagarth to share results of community survey and solicit feature proposals from the community
12:09:13 <hagarth> got this done just before the meeting :)
12:09:20 <hagarth> please share your ideas on the thread
12:09:52 <hagarth> next AI - spot to investigate repetitive posts on social networking sites
12:09:57 <hagarth> do we have spot here today?
12:10:27 <hagarth> figure not, so let's carry forward this AI
12:10:32 <hagarth> #action spot to investigate repetitive posts on social networking sites
12:10:53 <hagarth> more AIs on spot, they all carry forward :)
12:10:57 <hagarth> #action spot will send out an email with upcoming Gluster events and meetups
12:11:13 <hagarth> #action spot to reach out to community about website messaging
12:11:23 <hagarth> next AI - JustinClift to help spot and jdarcy with wp-admin
12:11:40 <hagarth> JustinCl1ft, jdarcy: any luck with this one?
12:11:58 <jdarcy> Nothing here.
12:12:08 <hagarth> jdarcy: ok
12:12:17 * shyam just joined
12:12:19 <hagarth> #action JustinClift to help spot and jdarcy with wp-admin
12:12:52 <hagarth> next AI - raghu to open a 3.6.3 tracker and move dependent bugs from the 3.6.2 tracker to that.
12:13:10 <hagarth> don't think this has happened as yet, ndevos - any ideas on this one?
12:13:24 <ndevos> I did not see one yet
12:13:32 <hagarth> right, so #action raghu to open a 3.6.3 tracker and move dependent bugs from the 3.6.2 tracker to that.
12:13:47 <hagarth> #action hagarth to carry forward discussion on automated builds for various platforms in gluster-infra ML.
12:14:00 <hagarth> I haven't been able to do this, any volunteers to snatch this from me? :)
12:14:46 <hagarth> none I guess, will attempt getting this done over the week or so
12:15:05 <hagarth> last AI - hagarth to do a sanity check on status of features for 3.7 in gluster-devel
12:15:11 <hagarth> this is complete
12:15:16 <hagarth> ok, moving on
12:15:20 <hagarth> #topic GlusterFS 3.6
12:15:39 <hagarth> 3.6.2 got released this week. Kudos to all those who contributed to 3.6.2
12:15:41 <xavih> Could be this the tracker for 3.6.3 ? https://bugzilla.redhat.com/show_bug.cgi?id=1184460
12:16:19 <hagarth> we now have fully supported RDMA in 3.6.2. Testing feedback would be welcome.
12:16:33 <ndevos> xavih: yes, thats it!
12:16:37 <hagarth> xavih: looks like that, thanks for pointing!
12:16:58 <hagarth> so one AI less for Raghu!
12:17:38 <hagarth> the next release is 3.6.3, we have a tracker - please add bugs that you would like to see in 3.6.3 to the tracker.
12:17:50 <hagarth> any questions, comments on 3.6?
12:18:29 <hagarth> guess not, moving on
12:18:36 <hagarth> #topic GlusterFS 3.5
12:18:42 <hagarth> ndevos: any updates here?
12:18:59 <ndevos> merged some changes recently, others still need some review
12:19:17 <ndevos> nothing planned to get released in the next 2 weeks :)
12:19:40 <hagarth> ndevos: ok
12:20:07 <hagarth> ndevos: should we publish a schedule and move out things that don't get reviewed beyond that date to 3.5.4?
12:20:15 <hagarth> s/beyond/by/
12:20:26 <hagarth> rather 3.5.5
12:20:28 <ndevos> hagarth: we could, sure
12:20:56 <hagarth> ndevos: this is one of the reasons I was thinking of a merge window for minor releases.
12:21:21 <hagarth> that way we might get more momentum for minor releases but this is probably a separate discussion.
12:21:44 * krishnan_p likes the merge window concept too!
12:21:48 <ndevos> hagarth: right, that might work, but I'm sceptic about it :)
12:22:11 <ndevos> maybe call it 'review window' instead?
12:22:28 <hagarth> ndevos: yeah, let us discuss more on the thread that we have on gluster-devel
12:22:34 <ndevos> but yes, it gets off topic
12:22:56 <hagarth> any questions on 3.5?
12:23:06 * ndevos doesnt have any
12:23:10 <hagarth> ok
12:23:15 <hagarth> #topic Gluster 3.4
12:23:24 <hagarth> kkeithley_: any updates here?
12:24:20 <kkeithley_> no
12:24:26 <hagarth> kkeithley_: ok
12:24:32 <kkeithley_> still working to narrow down the memleak
12:24:53 <hagarth> kkeithley_: ok
12:25:02 <hagarth> moving on
12:25:07 <kkeithley_> some small leaks (or nonleaks) with single performance xlators enabled
12:25:17 <kkeithley_> now working through combinations of two perf xlators
12:25:19 <jdarcy> Nonleaks?
12:25:52 <kkeithley_> RSZ, VSZ grow slowly. Maybe just an artefact of caching
12:26:28 <kkeithley_> grow slowly, nothing on the scale when all perf xlators are enabled
12:26:48 <hagarth> kkeithley_: which has been the worst offender amongst the perf xlators in your observation?
12:27:04 <JustinCl1ft> Oops, nearly missed this
12:27:40 <JustinCl1ft> hagarth: I didn't give wp admin to jdarcy or spot.  I can easily though, if I can find their users
12:27:44 * JustinCl1ft will look now
12:27:54 <hagarth> JustinCl1ft: thanks!
12:28:29 <hagarth> kkeithley_: will await your results later, maybe Raghavendra G can offer some help if we need to corner known leaks
12:28:33 <hagarth> moving on
12:28:43 <hagarth> #topic Gluster.next
12:28:47 <hagarth> #topic 3.7
12:28:51 <kkeithley_> hagarth: quick-read, stat-prefetch, and open-behind all leak a little.   Summary here http://download.gluster.org/pub/gluster/glusterfs/dynamic-analysis/longevity/README
12:28:59 <hagarth> kkeithley_: great, thanks!
12:29:13 <JustinCl1ft> jdarcy: You're now an admin for our WordPress setup
12:29:35 <jdarcy> JustinCl1ft: OK, I'll take a look and see if anything jumps out at me.
12:29:36 <hagarth> I sent a note about updating status for 3.7 feature pages yesterday.
12:29:53 <hagarth> A few of us have already updated the pages, thanks to all who did!
12:30:16 <hagarth> as a reminder, we are looking at Feb 10th as the deadline for opening new feature pages for 3.7
12:30:38 <hagarth> so please try to have your feature pages ready by then if your code has to be part of 3.7 :)
12:30:55 <hagarth> any questions, comments on 3.7?
12:31:25 <hagarth> figure not, let's move on to 4.0
12:31:31 <hagarth> #topic GlusterFS 4.0
12:31:39 <hagarth> jdarcy: the floor's yours
12:32:11 <jdarcy> I collected status on the various subprojects, reflected in http://www.gluster.org/community/documentation/index.php/Planning40
12:32:21 <jdarcy> Thanks to KP, Xavier, Dan.
12:32:48 <jdarcy> There are a few subprojects that I would consider "at risk" - notably sharding, multi-network, and everything in the management space.
12:33:22 <jdarcy> By that I mean there has been *no* activity, and therefore no expectation of progress would be rational.
12:33:53 <hagarth> jdarcy: yeah, I know that there are some ongoing efforts in that space. Probably need to ping the individual developers working on them to provide an udpate, will try doing that.
12:33:54 <jdarcy> I'd like to have an IRC/Hangout "summit" next week(ish) so we can figure out how to move forward.
12:34:20 <hagarth> is this the virtual design summit?
12:34:33 <purpleidea> jdarcy: fyi next week there are a lot of conferences going on... this week too... devconf.cz is coming, etc...
12:34:37 <jdarcy> Also need to meet with the guy who controls most of the people's time, find out if we can get up to more than one FTE.
12:35:12 <jdarcy> hagarth: Yes, though I think it will be as much logistics as design.
12:35:29 <hagarth> jdarcy: ah ok, I expect more of the former too.
12:35:42 <hagarth> jdarcy: I think we probably need to do several design summits for 4.0
12:36:07 <hagarth> I expect more folks to be pick up features for 4.0 once 3.7 happens
12:36:18 <jdarcy> Right now Dan/Joseph are working on cache tiering (which is semi-related to data classification) and I'm working on NSR.  Others seem to get a couple of hours at a time (at most) to think about 4.0 stuff, hardly any to code.
12:36:32 <hagarth> so we may see a flurry of activity as 3.7 tapers down
12:36:42 <jdarcy> That would be epic.
12:36:49 <hagarth> jdarcy: agree
12:37:04 <krishnan_p> Look forward to working on 4.0 stuff!
12:37:24 <hagarth> maybe once we get more feature requests from the community, we can possibly reach out to the broader community to see if we can get help on the (more) requested features.
12:37:44 <jdarcy> We should get the Hadoopoids to help with sharding, since they seem to want it.
12:37:56 <hagarth> jdarcy: +10 :)
12:38:35 <bene2> sorry I'm late, have you discussed small-file-related stuff already?
12:38:38 <hagarth> right, maybe next week or so we can announce the first design summit for 4.0 after we sort out the logistics
12:38:41 <hagarth> bene2: not yet
12:39:00 <jdarcy> bene2: Not really, though I noticed that small-file stuff features prominently in the user survey results.
12:39:18 <shyam> Are the design summits to be on IRC or something like Bluejeans?
12:39:37 <hagarth> shyam: that is an excellent logistics question for which we need to find an answer :)
12:39:41 <bene2> you can record meetings on bluejeans too.
12:39:54 <jdarcy> shyam: Once we get to actual design, I think something like Bluejeans/Hangouts.  Until then, IRC is probably sufficient.
12:40:08 <shyam> I would assume at some point we need to present ideas/designs/smaller stuff, IRC may not cut it then
12:40:11 <shyam> agreed jdarcy
12:40:12 <hagarth> I guess bluejeans limits to 50 or (is it 100) concurrent attendees.
12:40:24 <jdarcy> Shouldn't be a problem then.  ;)
12:40:49 <hagarth> jdarcy: I hope that it will be a bottleneck ;)
12:41:35 <hagarth> jdarcy: should we look forward to an IRC meeting on logistics next week?
12:41:47 <jdarcy> Yes.
12:42:02 <hagarth> jdarcy: cool, thanks.
12:42:10 <hagarth> any more questions, comments, thoughts on 4.0?
12:42:51 <hagarth> guess not, let us move on
12:43:07 <hagarth> #topic GSOC 2015
12:43:14 <hagarth> kshlm: did you add this topic?
12:43:18 <kshlm> Yeah.
12:43:43 <kshlm> So, as I said in the mail that I sent out, GSOC 2015 is starting soon.
12:44:08 <hagarth> right..
12:44:26 <kshlm> And this time I hope to have Gluster itself as a participating org.
12:44:35 <kkeithley_> have there been any proposals?
12:44:41 <kshlm> This requires a lot of planning from our sides.
12:44:52 <hagarth> kshlm: like?
12:45:22 <kshlm> kkeithly, The proposal period hasn't started yet. The org registration is yet to start.
12:45:58 <kshlm> hagarth, From what I observed with the Fedora community last year, there are several things to be done.
12:46:40 <krishnan_p> We could use GSOC to kick start a few 'short-staffed' 4.0 features.
12:46:42 <kshlm> Things like setting up proposal guidelines, getting mentors registered, acceptance criteria etc etc
12:47:14 <hagarth> kshlm: ok, I think we can start an email thread with spot and JustinCl1ft. The GlusterFS board might also be able to offer some help as far as logistics is concerned.
12:47:28 <kshlm> We can use the Fedora community as a guide for what needs to be done.
12:47:54 <hagarth> kshlm: right, let us start a thread. it would be great to have gluster.org as an organization in GSOC.
12:48:16 <hagarth> kshlm: a more specific thread with spot et al rather.
12:48:32 <kshlm> Okay. I'll do that.
12:48:39 <hagarth> kshlm: thanks!
12:48:47 <hagarth> moving on
12:48:53 <hagarth> #topic Small File Performance
12:49:02 <hagarth> too bad bene2 dropped out
12:49:14 <hagarth> I believe we have some action around multi-threaded epoll
12:49:22 <shyam> yes
12:49:37 <hagarth> I am working on having md-cache loaded in the brick stack by default .. along with a possible re-ordering of xlator positions
12:49:51 <shyam> We are at a phase where on Linux we have almost all regression tests passing, (epoll multi-thread)
12:50:03 <hagarth> xlator positions in the brick graph .. more along the lines of what was discussed on gluster-devel a few days back
12:50:16 <shyam> NetBSD has some issues in poll changes with the same, I have the same reproduced and am looking at it in terms of a fix.
12:50:30 <hagarth> shyam: cool, what testing would we like to see on Linux?
12:51:07 <shyam> Well, we would need the regression suite passing, other than that, we really need to excercise this with other code paths, or in general open it up for wider testing
12:51:46 <hagarth> shyam: right, I would like to sign up to run some tests for this. Can we prepare a list of tests (not detailed, but at a high level?)
12:51:54 <shyam> We can only test so much here, considering the change itself should be well tested with the regression suite, but other code areas would need to be tested.
12:52:04 <shyam> hagarth: Hmmm... ok let me see what I can drum up
12:52:16 <hagarth> more volunteers to run tests can also help in expediting the inclusion of this patchset.
12:52:57 <hagarth> I am also considering enabling optimize-readdir in dht by default
12:53:07 <shyam> I am looking at runtime change to the number of threads as a fail safe to its adoption in the real world as well, jFYI
12:53:23 <hagarth> shyam: ok
12:53:42 <hagarth> maybe I'll post about optimize-readdir on -devel.
12:54:08 <shyam> hagarth: ok, need to check the code once more, there were some corners that were hairy in that part of the code
12:54:15 <hagarth> any other small file improvements that we need to consider for inclusion in 3.7?
12:54:24 <shyam> auto-unhashed in DHT
12:55:02 <hagarth> shyam: yes, the readdir performance just sucks when we scale out. I also wonder if we should enable readdir-ahead by default in 3.7.
12:55:07 <shyam> I would say this is WIP, we need some stability fixes in DHT before adopting this patch, as otherwise FOPs from multiple clients etc. have a tendency to derail DHT at times
12:55:33 <shyam> ^^^ for auto-unhashed
12:55:42 <hagarth> shyam: ok, maybe we should keep updating about small file performance in this meeting or on -devel so as to foster more eyes/help.
12:56:09 <shyam> readdir-ahead, no comments as yet, need to understand the code/benefits
12:56:13 <shyam> hagarth: ok will do...
12:56:34 <hagarth> shyam: cool, thanks. let us begin a crusade to optimize small file performance :).
12:56:51 <hagarth> #topic upcoming talks in conferences
12:56:59 <hagarth> who all do we have talking in the next two weeks?
12:57:25 <hagarth> I will be talking about GlusterFS - overview and future directions in devconf.cz on Feb 6th
12:57:44 <hagarth> ndevos, lalatenduM, kkeithley_ have speaking engagements too over the next two weeks
12:57:56 <dlambrig_> gluster tiering at devconf.cz
12:57:59 <purpleidea> i'll be giving at least two glusterfs talks...
12:58:04 <hagarth> atinmu et al are talking in Pune as part of a Gluster Community Meetup
12:58:09 <purpleidea> (puppet-gluster, most specifically...)
12:58:19 <hagarth> dlambrig_, purpleidea: fantastic!
12:58:21 <kkeithley_> hagarth too, right?
12:58:26 <purpleidea> 1 at CentOS dojo (short, to help out lalatenduM)
12:58:36 <hagarth> looks like it is going to be a busy two weeks for the community :)
12:58:48 <hagarth> kkeithley_: right, on 6th as I mentioned above
12:59:02 <kkeithley_> haha, yes.. I'm blinkd
12:59:04 <kkeithley_> blind
12:59:06 <purpleidea> 1 at devconf.cz with some vagrant thrown in too: http://developerconference2015.sched.org/speaker/jamesjustjames
12:59:20 <purpleidea> sorry, this one: http://developerconference2015.sched.org/event/bb36bcd5e0d97cdab69d014b77c3edad
12:59:37 <hagarth> I will try posting a consolidated list of talks tomorrow on gluster.org/bloig
12:59:54 <hagarth> alright, any last minute topics for today?
13:00:08 <ndevos> hagarth: and include the Gluster Office Hours in your blog post too
13:00:14 <hagarth> ndevos: will do!
13:00:33 <kkeithley_> I already blogged about Office Hours, but more press is never bad
13:00:44 <purpleidea> kkeithley_: link ?
13:00:52 <hagarth> thanks everyone for being here today! Let us meet next week same time.
13:00:57 <hagarth> #endmeeting