12:02:12 <overclk> #startmeeting
12:02:12 <zodbot> Meeting started Wed Jun 24 12:02:12 2015 UTC.  The chair is overclk. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:43 <overclk> #info https://public.pad.fsfe.org/p/gluster-community-meetings
12:02:47 <overclk> #topic RollCall
12:02:52 * tigert is in
12:02:55 * raghu is here
12:02:59 <overclk> who do we have here today..
12:03:15 * RaSTar is here
12:03:32 * rjoseph is here
12:03:33 * ira is in attendance.
12:03:39 * poornimag is here
12:03:47 * soumya_ is here
12:03:51 <overclk> okies.
12:04:12 <overclk> #topic Actions from last week.
12:04:22 <overclk> #topic JustinClift will demo the new Forge next week (week of 22 June)
12:04:31 <overclk> JustinCl1ft?
12:05:25 <overclk> nothing I guess..
12:05:38 <overclk> #action JustinClift to demo the new Forge next week
12:05:40 <overclk> moving on.
12:05:59 <overclk> #topic hchiramm will send out a call (email and blog?) for volunteers for helping with the packaging
12:06:08 <overclk> hchiramm, anything?
12:06:59 <RaSTar> hchiramm did send the mail
12:07:42 <overclk> RaSTar, OK. Still keeping it op action till we get replies on the email.
12:08:01 <rjoseph> I think MS voluntered
12:08:19 <overclk> #action hchiramm to udpate about packaging emails
12:08:51 <overclk> rjoseph, yes. thanks!
12:09:08 <overclk> moving on..
12:09:16 <overclk> #topic tigert summarize options for integrating a calendar on the website, call for feedback.
12:09:24 <tigert> sorry, this has been hanging for too long
12:09:43 <tigert> again was busy with RH summit tasks :/ but there is the http://community.redhat.com/events/ which is something we could use
12:09:56 <tigert> but havent had time to look into it yet
12:10:25 <overclk> tigert, probably move it to next meeting?
12:10:34 <tigert> yeah, except that I will be on pto
12:10:53 <overclk> anyone else who can take this up (or interested to)?
12:11:08 <tigert> so it would need to skip a few. we also have some thoughts about making one common events calendar for all Red Hat community projects
12:11:12 <tigert> that could serve feeds
12:11:19 <tigert> but this is preliminary, but likely could use this thing
12:11:45 <tigert> so looking into this thing would be something that might be useful. it is ruby and based on the same framework as the www.gluster.org site too
12:12:00 <overclk> OK.
12:12:16 <overclk> let's keep it for next week then anyway.
12:12:31 <overclk> #action tigert summarize options for integrating a calendar on the website, call for feedback.
12:12:41 <overclk> #topic hagarth will start with planned roadmaps for all gluster.next releases
12:12:53 <overclk> hagarth isn't there I guess
12:13:01 <overclk> anyone else?
12:13:20 <overclk> guess not..
12:13:25 <overclk> #action hagarth will start with planned roadmaps for all gluster.next releases
12:13:26 <overclk> moving on
12:13:44 <overclk> #topic csim/misc to pickup the requesting of public IPs and those kind of things for our new servers
12:14:11 <overclk> csim, misc ?
12:15:00 <overclk> guess not..
12:15:03 <overclk> #action csim/misc to pickup the requesting of public IPs and those kind of things for our new servers
12:15:05 <overclk> moving on.
12:15:26 <overclk> #topic EVERYONE Announce participation and times of Gluster related presentations on the community lists
12:16:32 <overclk> anyone initiated (or planning to initiate) anything?
12:16:46 <hagarth> overclk: I did one about Gluster BoF
12:17:19 <overclk> hagarth, yeh. I did see that.
12:17:30 <overclk> hagarth, I see you missed BitRot from the list.
12:17:48 <overclk> hagarth, I guess you could use the hangout sessions that I did on bitrot :)
12:18:13 <hagarth> overclk: will do, if possible I will demo it there :)
12:18:21 <overclk> hagarth, cool! thanks.
12:19:10 <overclk> anyone else?
12:19:32 <rjoseph> I guess this include all external conferences as well
12:19:48 <overclk> rjoseph, it should.
12:20:22 <overclk> rjoseph, anything that's up your sleeve?
12:20:29 <rjoseph> I am planning a tutorial on GlusterFS and access protocols (specifically SMB) at LISA 2015
12:20:42 <rjoseph> Will send details about that on the mailing list soon
12:20:49 <overclk> cool!
12:21:11 <overclk> I guess atinm and deepakcs have a session in FUDCON
12:21:51 <obnox> rjoseph: any of you heard of SDC yet?
12:22:06 <rjoseph> obnox: No reply from SDC yet
12:22:29 <ira> obnox: Not here.  I don't think they set the schedule yet.
12:22:52 <obnox> right.
12:24:41 <overclk> OK. probably this is ongoing. Anyone planning to showcase Gluster related work please drop a note to community list.
12:25:28 <overclk> Anyone else wants to chip in? Else we can move on.
12:25:46 <overclk> moving on.
12:25:49 <overclk> #topic hagarth should remove the meeting invite request
12:26:03 <overclk> hagarth?
12:26:23 <hagarth> overclk: will do so this week
12:26:29 <overclk> hagarth, ok
12:26:46 <overclk> #action hagarth should remove the meeting invite request
12:27:05 <overclk> #topic GlusterFS 3.7
12:27:37 <overclk> atinm released and announced glusterfs-3.7.2
12:28:14 <hagarth> patches are piling up in release-3.7, so we might have a 3.7.3 soon
12:28:21 <overclk> 3.7.3 tracker is here: https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.7.3
12:28:46 <overclk> hagarth, yeh! I need to get my patches in too. Now that the regression failure on upstream master has been fixed.
12:29:05 <hagarth> overclk: yes, 3.7.3 is already looking very promising :)
12:29:06 <overclk> and I see logging patches too getting merged :)
12:29:09 <rjoseph> Do we have timeline for glusterfs-3.7.3?
12:29:31 <overclk> hagarth, ^^^
12:29:33 <hagarth> rjoseph: next two weeks in all probability
12:30:04 <rjoseph> thanks
12:30:20 <overclk> hagarth, somewhere in the week on 6th July?
12:30:30 <hagarth> overclk: tentatively yes
12:30:41 <overclk> hagarth, ok, cool!
12:31:07 <overclk> this is the link of open BZs: https://bugzilla.redhat.com/showdependencytree.cgi?maxdepth=2&id=glusterfs-3.7.3&hide_resolved=1
12:32:05 <overclk> raghu, isn't bz 1207134 fixed in 3.7.2?
12:32:38 * raghu is checking
12:33:43 <raghu> overclk: I think that patch has made into 3.7 branch already
12:34:16 <overclk> hmmm. I see a bunch of patches that have made it to 3.7.2 (bz as MODIFIED) but still showing up in the above list.
12:35:00 <overclk> raghu, mind doing the needful?
12:35:35 <raghu> overclk: sure. But 1207134 says that, the fix did not make it to 3.7.2 and is targeted for 3.7.3
12:35:46 <overclk> anything else on 3.7 anyone?
12:35:52 <overclk> raghu, yeh. I see that.
12:36:34 <overclk> raghu, that's incorrect by all means :) I know the fix is there and the BZ too has been moved to MODIFIED.
12:36:53 <overclk> anyway, let's take that up.
12:37:07 <overclk> #topic GlusterFS 3.6
12:37:16 <raghu> overclk: yes, thats right. Both the git log and the bugzilla says the fix is already present
12:38:12 <raghu> infact the bug 1226146 (release-3.7 clone of 1207134) has been closed as well.
12:38:25 <overclk> raghu, yeh. let
12:38:30 <raghu> overclk: anyway we can take it offline since the patch is already present.
12:38:46 <overclk> raghu, let's park it for now and deal with it after the meeting.
12:39:01 <overclk> ok.. GlusterFS 3.6
12:39:05 <overclk> raghu, ^^^
12:39:46 <raghu> overclk: sure.
12:40:08 <raghu> overclk: regarding release-3.6, I have made 3.6.4beta2 last week itself. I am waiting for RPMs to be built
12:40:25 <raghu> once the RPMs are ready I will make an announcement in the mailing list
12:40:44 <overclk> raghu, ok, cool! action for you then..
12:41:05 <raghu> apart from that I dont have much update on release-3.6 except the fact that I have pushed couple of more patches in release-3.6 branch
12:41:36 <overclk> #action raghu to announce 3.6.4beta2 in the mailing list (post RPM build)
12:41:52 <overclk> raghu, OK. awaiting anymore patches?
12:42:17 <raghu> overclk: no. Not waiting for anymore patches. Atleast not for 3.6.4
12:42:32 <overclk> heres the tracker: https://bugzilla.redhat.com/showdependencytree.cgi?maxdepth=2&id=glusterfs-3.6.4&hide_resolved=1
12:42:55 <overclk> raghu, cool! things look good then.
12:43:07 <raghu> overclk: yes
12:43:09 <overclk> moving on.
12:43:15 <overclk> #topic GlusterFS 3.5
12:44:25 <overclk> 3.5.5 tracker: https://bugzilla.redhat.com/showdependencytree.cgi?maxdepth=2&hide_resolved=1&id=glusterfs-3.5.5
12:44:55 <overclk> There are some bugs assigned to ndevos
12:45:46 <overclk> from last weeks meeting ndevos was planning to release 3.5 later this month
12:45:53 <overclk> let's keep the action as it is
12:46:31 <overclk> #action ndevos to release 3.5.5 before end of June
12:46:45 <overclk> #topic GlusterFS 4.0
12:47:17 <overclk> I guess jdarcy is busy with Summit.
12:47:42 <overclk> Anyone else? krishnan_p, raghu, hagarth?
12:48:36 <hagarth> overclk: we are looking at phasing out deliverables for 4.0
12:48:42 <krishnan_p> overclk, I have no updates at the moment.
12:48:57 <hagarth> glusterd would be the first, others will come by later etc.
12:49:16 <hagarth> when I push the roadmap on the site, I will have some of these details available.
12:49:23 <overclk> OK. keeping this as it is then.
12:49:25 <overclk> sure hagarth
12:49:29 <krishnan_p> hagarth, look forward to it.
12:49:47 <rjoseph> Did we finalized what all changes are we planning in the first phase for glusterd?
12:50:05 <rjoseph> or that is also under-planning?
12:50:15 <overclk> #action hagarth to push 4.0 roadmap on the site.
12:50:25 <hagarth> rjoseph: kshlm is evolving details .. do refer to the glusterd-2.0 discussion on ML
12:51:03 <krishnan_p> rjoseph, kshlm is gathering requirements that Manila team has now and trying to fit them into glusterd-2.0's broader goals.
12:51:42 <rjoseph> OK I was only part of the discussion we had in Gluster summit
12:51:52 <rjoseph> thanks for the update
12:52:14 <overclk> #topic Open Floor
12:52:31 <overclk> anyone?
12:52:43 <overclk> who wants to go first?
12:53:05 <overclk> I'll go first then :)
12:53:33 <overclk> I was planning to write lockdep (runtime lock validator) for GlusterFS.
12:53:47 <hagarth> overclk: sounds cool!
12:53:49 <overclk> This is in the similar lines of lockdep in linux kernel.
12:53:56 <overclk> anyone interested?
12:54:24 <overclk> I've done basic ground work (no code atm :))
12:54:34 <krishnan_p> overclk, I am
12:54:49 <overclk> but looks like this would be something that would be of great use
12:54:56 <raghu> overclk: I am interested
12:54:58 <krishnan_p> overclk, completely agree.
12:55:01 <overclk> catch deadlocks before you can even hit them in real life.
12:55:13 <overclk> ok, krishnan_p is interested.. anyone else?
12:55:18 <krishnan_p> overclk, any pointers for interested folks.
12:55:23 <overclk> raghu, too.
12:55:38 <rjoseph> Can you have a feature page for this?
12:55:59 <overclk> krishnan_p, raghu : sure <kernel source>/Documentation/locking/lockdep-design.txt :)
12:56:07 <overclk> rjoseph, sure
12:56:09 <krishnan_p> overclk, damn! Will read.
12:56:24 <overclk> krishnan_p, :)
12:56:46 <overclk> #action overclk to put up feature page for lockdep
12:57:45 <overclk> ok. anyone else with anything?
12:59:14 <overclk> krishnan_p, epoll related?
12:59:44 <krishnan_p> Nothing new.
13:00:02 <overclk> ok.
13:00:02 <krishnan_p> still learning how epoll Linux subsystem works when there are multiple threads waiting on a single epoll fd
13:00:18 <krishnan_p> will post updates on ML
13:00:32 <overclk> ok
13:01:03 <overclk> #action krishnan_p to send out email on devel list about improving our epoll solution
13:01:13 <overclk> #topic More Open Floor
13:01:55 <overclk> guess not.
13:02:04 <overclk> Ok, looks like we're done here.
13:02:09 <overclk> Thanks evryone.
13:02:12 <overclk> #endmeeting