12:01:08 <kshlm> #startmeeting
12:01:08 <zodbot> Meeting started Wed Jul 15 12:01:08 2015 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:19 <kshlm> Roll-Call
12:01:57 * obnox here
12:02:00 * kkeithley is here
12:02:10 * raghu is here
12:02:11 * poornimag is here
12:02:13 * overclk is here
12:02:14 * msvbhat is here
12:02:38 * kshlm is here chairing for the first time.
12:02:52 <kshlm> Okay looks like enough people.
12:02:53 <atinm> kshlm, a big thank you
12:02:57 * spot is here
12:02:59 <atinm> kshlm++
12:02:59 <kshlm> Let's start the meeting.
12:03:11 <kshlm> #topic Last week's action items
12:03:27 <kshlm> #topic spot will ask about a potential Justin replacement
12:03:31 <kshlm> spot?
12:04:42 <spot> In the short term, there is going to be a team out of Bangalore that is going to take over the most important infrastructure tasks.
12:05:04 <spot> OSAS infrastructure team is also going to help out
12:05:15 * hchiramm is here
12:05:20 * jiffin1 is here
12:05:24 * anoopcs is here
12:05:32 * RaSTar is here
12:05:44 * jdarcy is
12:05:48 <spot> We should have more specific details on that in the next few weeks.
12:06:23 <kshlm> #note Short term infra maintainence to be done by a team from Bangalore. OSAS to help. More details in coming weeks.
12:06:27 <kshlm> Thanks spot.
12:06:45 <kshlm> #topic hchiramm to update about packaging emails
12:06:55 <kshlm> hchiramm, has already updated it as TBD
12:07:00 <hchiramm> kshlm, yep :)
12:07:04 <kshlm> #action hchiramm to update about packaging emails
12:07:27 <kshlm> Oops forgot this. The agenda as always is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:07:40 <kshlm> #topic tigert summarize options for integrating a calendar on the website, call for feedback
12:07:50 <kshlm> Is tigert here?
12:08:30 <kshlm> Doesn't seem so.
12:08:32 <spot> No, he's not.
12:08:34 <csim> in vacation
12:08:37 <kshlm> #action tigert summarize options for integrating a calendar on the website, call for feedback
12:09:03 <kshlm> #topic hagarth shoudl have completed the roadmap planning for the next gluster releases
12:09:26 <kshlm> hagarth isn't here, but he informed me of his update.
12:09:53 <kshlm> hagarth sent out a note on 3.8 plans to the mailing list.
12:10:04 <kshlm> So this item is completed.
12:10:17 <kshlm> #topic hagarth should have published the 4.0 roadmap to gluster.org last week
12:10:36 <kshlm> hagarth said he'd be doing this, this week.
12:10:44 <kshlm> #action hagarth should have published the 4.0 roadmap to gluster.org last week
12:11:02 <kshlm> #topic csim/misc to pickup the requesting of public IPs and those kind of things for our new servers (or VPN)
12:11:14 <kshlm> csim you're up.
12:11:35 <csim> well, VPN is up, I am now setting firewall and routing so it doesn't break after reboot
12:11:39 <csim> (as i found out à
12:11:56 <csim> so far, I have 1 fedora builder, but adding a few more should be easy once the fireone is going
12:12:09 * rjoseph arrived late
12:12:11 <kshlm> Cool.
12:12:44 <kshlm> So when can we expect to get jenkins slaves from this new setup?
12:12:56 <csim> I would say end of the week
12:13:06 <kshlm> Awesome!
12:13:19 <csim> but after, I am in europython for 1 week, so if I cannot finish in time, it will be in 2 weeks
12:13:50 <kshlm> Please keep us updated on your progress.
12:14:09 <csim> kshlm: when there is, yes, but this month, it was mostly PTO :)
12:14:10 <kkeithley> csim: what about using CentOS's jenkins?
12:15:01 <csim> kkeithley: did look yet, I was focusing on getting our infra ready, in the end, that's jenkins slaves no matter the underlying hardware
12:15:50 <kkeithley> did _not_ look??  But yes, a jenkins slave is a jenkins slave. ;-)
12:15:59 <csim> yeah, did not look
12:16:10 <csim> yup, but the amount of setup would be the same in both case
12:16:17 <csim> so I rather finish the one I started :)
12:16:21 <kkeithley> yup
12:16:26 <kshlm> csim, any plans on when/if you're planning to look at the CentOS infra?
12:17:01 <csim> kshlm: I plan to do, but nope, do not have a planning
12:17:11 <kshlm> Cool.
12:17:14 <csim> likely once the ci.gluster;org is in use
12:18:07 <kshlm> #note csim will look at the CentOS Jenkins infra once ci.gluster.org is up and running.
12:18:23 <kshlm> Thanks csim.
12:18:44 <kshlm> #topic overclk should have created a feature page about lockdep
12:18:52 <kshlm> overclk, you here?
12:18:58 <overclk> kshlm: that's what I'm doing at the moment.
12:18:59 * surabhi is here
12:19:12 * ira is here.
12:19:16 <csim> kshlm: but the team in bangalore that should help can also look, i do not have magic access to the ci.centos infra :)
12:19:23 <overclk> kshlm: should be done by the time meeting ends :)
12:19:42 <kshlm> overclk, okay. I'll get back to this towards the end.
12:19:49 <overclk> kshlm: sure.
12:20:02 <kshlm> #topic hchiramm should have come up with suggestions on how/where to post work-in-progress documentation
12:20:25 <kshlm> hchiramm, ?
12:20:39 <hchiramm> we have enough inputs now :)
12:20:50 <hchiramm> me or anjana will send a mail
12:20:56 <hchiramm> tomorrow about the same
12:20:58 <kshlm> Awesome.
12:21:06 <RaSTar> cool
12:21:22 <kshlm> #action hchiramm will send an update on WIP documentation issue
12:21:33 <kshlm> Thanks hchiramm
12:21:43 <hchiramm> yw !
12:21:47 <kshlm> #topic atinm will start a schedule for office hours in #gluster
12:22:21 <kshlm> atinm sent out a mail with a link to an etherpad with the schedules.
12:23:08 <kshlm> #link https://public.pad.fsfe.org/p/gluster-office-hours
12:23:39 <kshlm> Several community members have already penned themselves in.
12:23:57 <kshlm> There a lot more who haven't (me included).
12:24:05 * msvbhat is updating now
12:24:47 <kshlm> #action kshlm to add himself to the gluster-office-hours schedule.
12:25:04 <RaSTar> does anyone mind if I restructure the etherpad to be sorted as per time?
12:25:05 <obnox> so what is that really about: guaranteed presence and responsiveness on #gluster
12:25:08 <obnox> ?
12:25:18 <msvbhat> But what if sometime I am not available on the time I mentioned?
12:25:44 <kshlm> obnox, I think so.
12:25:52 <obnox> ok, wow
12:26:06 <kshlm> But I wasn't in last weeks meeting, so could anyone confirm?
12:26:18 <obnox> RaSTar: I think the sorting makes sense
12:26:27 <rjoseph> RaSTar: I think that's a good proposal to sort it by time
12:26:41 <kshlm> Does etherpad have tables? Tables would be good for this.
12:27:23 <RaSTar> etherpad does not have tables..
12:27:26 <msvbhat> But I can not commit to the same time always. Sometimes I can't be online for many reasons
12:28:10 <rjoseph> I agree with msvbhat I also want to be there but sometimes I may not.
12:28:32 <msvbhat> But I *try* to be online most the time which I mentioned. Sometimes I may not be though
12:28:41 <kshlm> I don't think this is meant to be a rigid schedule.
12:29:17 <obnox> kshlm: reading from last week's log, the idea is as reliable presence and coverage in #gluster and #gluster-devel. term office-hours was not strictly definde
12:29:21 <obnox> defined
12:29:39 <obnox> (#gluster-dev that is)
12:31:13 <kshlm> thanks obnox.
12:32:02 <msvbhat> Cool, Having people spread across different time zones will be helpful here :) To have more presence coverage
12:33:14 <kshlm> Anyways, let's move on.
12:33:20 <kshlm> #topic HELP: maintainers can volunteer to become release manager for 3.7.3
12:33:50 <kshlm> What's the difference between a release-maintainer and a release-manager?
12:33:56 <kshlm> I don't get this.
12:34:47 <RaSTar> kshlm: it mostly refers to module mainatainers
12:34:56 <kshlm> I don't remember seeing any request for volunteers being sent out on the lists this week.
12:35:51 <kshlm> So this doesn't seem like it's been done. Carrying it forward to next week.
12:36:33 <obnox> kshlm: there i no mention of *release-*maintainers, just maintainers. (gluster component maintainers?) It seems they are eligible for being release-manager for a given release?
12:36:53 * obnox is just learning gluster communit and trying to understand... :)
12:37:05 <kshlm> #action <someone> to Send a request to mailing list requesting for volunteers to be release-manager for 3.7.3
12:37:15 <kshlm> obnox, I don't understand that either.
12:37:34 <RaSTar> kshlm: hagarth is currently assigned with 3.7.3 release..
12:37:53 <kshlm> #note hagarth is release manager for 3.7.3
12:37:54 <RaSTar> he said he would be happy if any of the maintainers take it up
12:37:56 <obnox> kshlm: it seems gluster has varying release managers for different releases. so one needs volunteers for a release, no?
12:38:17 * obnox thinks this is a very interesting concept
12:38:58 <kshlm> obnox, All I know is hagarth handles the master branch. The release branches upto release-3.6 have release maintainers who maintain that branch and do releases.
12:39:13 <kshlm> release-3.7 seems to be in a unique position currently.
12:39:32 <kshlm> It doesn't have a release-maintiner (AFAIK)
12:40:04 <kshlm> hagarth could probably answer better about this if he were here.
12:40:21 <obnox> kshlm: ah, so hagarth is in charge but looking for someone to help out because he is overloaded (or so)
12:40:31 <kshlm> obnox, seeems like it.
12:40:43 * obnox shuts up now with speculations ;)
12:41:10 <kshlm> #action Get hagarth to clear up the speculations about "release-manager'
12:41:20 <kshlm> Onto the next topic.
12:41:33 <kshlm> #topic HELP: <someone> propose a roster/schedule for hosting the weekly meeting (all     maintainers should participate)
12:41:45 <kshlm> atinm did it. So this is done.
12:42:53 <kshlm> #topic GlusterFS 3.7
12:43:21 <kshlm> hagarth, just in time.
12:43:31 <hagarth> kshlm: for ?
12:43:37 <kshlm> The current topic is GlusterFS 3.7
12:44:04 <obnox> kshlm: hagarth can also clarify ... ;)
12:44:06 <kshlm> Do you have an update on 3.7.3 plans
12:44:44 <kshlm> obnox, Yes. But I don't think we'll have time.
12:44:56 <obnox> right. sorry
12:44:59 * kshlm is running the meeting really slowly.
12:45:17 <hagarth> kshlm: yes
12:45:30 <hagarth> the plan is to release 3.7.3 later this week or in a week from now
12:45:57 <kshlm> hagarth, Who is doing the release?
12:46:11 <hagarth> kshlm: in all probability I will release 3.7.3
12:46:33 <kshlm> There was an earlier action item on calling for volunteer to be release-manager for 3.7.3. We were speculating on what release-manager means.
12:46:42 <kshlm> Cool. Thanks hagarth.
12:46:45 <hagarth> kshlm: basically how we did 3.7.x releases
12:47:03 <kshlm> #note hagarth will be releasing 3.7.3 in 1 or 2 weeks time.
12:47:18 <hagarth> if there is somebody interested to push 3.7.3 out as KP did it for 3.7.1 and atinm for 3.7.2, I am happy to let them take over
12:47:33 <kshlm> I'll volunteer.
12:48:03 <hagarth> kshlm: ok, 3.7.3 is yours then :)
12:48:19 <kshlm> #note kshlm will be releasing 3.7.3 in 1 or 2 weeks time.
12:48:30 <kshlm> Anything else on 3.7?
12:49:06 <kshlm> Doesn't seem to be. Onto the next topic.
12:49:13 <kshlm> #topic GlusterFS 3.6
12:49:19 <kshlm> raghu, You're up.
12:49:30 <raghu> I have made 3.6.4 and announced it in the mailing list also.
12:49:39 <raghu> There are some patches sent for 3.6 branch. I will be considering them for 3.6.5
12:50:10 <raghu> For 3.6.5 I am planning not to make any beta releases and directly go ahead with GA
12:50:25 <kshlm> Any timeline for 3.6.5?
12:50:43 <raghu> Since no beta, 2-3 weeks.
12:51:05 <kshlm> Thanks raghu
12:51:06 <raghu> If suffecient amount of patches are merged, then 2 weeks. Otherwise I will wait for 1 more week
12:51:40 <kshlm> #note raghu will do the 3.6.5 release directly in 2-3 weeks depending on patch merge rates.
12:51:52 <kshlm> Anything else on 3.6?
12:52:12 <raghu> nope.
12:52:16 <kshlm> Ok.
12:52:20 <kshlm> #topic GlusterFS 3.5
12:52:32 <kshlm> kkeithley, anything to say?
12:52:42 <hagarth> 3.5.5 was released last week
12:52:56 <kshlm> Oh sorry, ndevos is the maintainer for 3.5 right?
12:53:36 <kshlm> Thanks hagarth
12:53:46 <kshlm> Anything else w.r.t 3.5?
12:54:02 <kshlm> #topic Gluster 4.0
12:54:15 <kshlm> jdarcy, hagarth Anything you want to add.
12:54:42 <jdarcy> Did some experiments to validate the brick-multiplexing infrastructure idea.
12:55:01 <hagarth> kshlm: nothing new from me, I have an AI to publish the roadmap for 4.0 this week. Will do so in consultation with jdarcy and others.
12:55:03 <jdarcy> Experiment was successful, but in the process I uncovered a few minor issues in glusterd-land.
12:55:04 <kkeithley> correct, ndevos has 3.5
12:55:40 <kshlm> jdarcy, That's good news.
12:56:00 <jdarcy> Next week I'll be trying to revive NSR.
12:56:03 <kshlm> #note jdarcy experimented with brick multiplexing. The experiment was a success.
12:56:38 <kshlm> #note jdarcy will experiment with NSR next.
12:57:08 <kshlm> #action hagarth will publish 4.0 roadmap this week
12:57:14 <kshlm> Thanks hagarth and jdarcy.
12:57:22 <kshlm> Anything else to add?
12:58:11 <kshlm> #topic overclk should have created a feature page about lockdep
12:58:30 <overclk> kshlm: nope not yet.
12:58:32 <kshlm> overclk, We're back to you. Are you done? Or should we move this to next week?
12:58:42 <kshlm> Okay. moving to next week.
12:58:43 <overclk> kshlm: still slow on it, move it to next week.
12:58:50 <kshlm> #action overclk should have created a feature page about lockdep
12:58:56 <overclk> kshlm: and perhaps feature pages should be in readthedocs now?
12:58:57 <kshlm> #topic Open Floor
12:59:30 * RaSTar just managed to get a text table for etherpad
12:59:34 <hagarth> overclk: possibly so, I don't think we converged on a decision on that one
13:00:02 <overclk> kshlm: OK, because the feature page template in gluster.org says that it locked.
13:00:02 <kshlm> Weekly reminder on community members attending events.
13:00:26 <kshlm> Please keep https://public.pad.fsfe.org/p/gluster-events updated with events you are attending.
13:00:42 <kshlm> overclk, Yes. The wiki is in RO mode now.
13:00:57 <kshlm> And as hagarth said we haven't converged on any decision yet.
13:01:28 <kshlm> Anyone have a topic they'd like to discuss now?
13:01:33 <overclk> kshlm: yeh, so where can I put up the feature page now? anyone has a link from readthedocs (I couldn't find it there).
13:01:50 <hagarth> hchiramm: ^^ ?
13:02:06 <kshlm> overclk, hchiramm should be able to help you.
13:02:28 <overclk> kshlm: ok, thanks! I'll disturb him :)
13:02:30 <hchiramm> kshlm, https://github.com/gluster/glusterdocs/tree/master/Features
13:02:50 <hchiramm> https://github.com/gluster/glusterdocs/tree/master/Feature%20Planning overclk
13:03:12 <overclk> hchiramm: thanks. and send the pull request perhaps...
13:03:20 <kshlm> Thanks hchiramm
13:03:23 <hchiramm> overclk, yep
13:03:31 <overclk> hchiramm: okies.
13:03:38 <kshlm> There don't seem to be anymore topics left to discuss.
13:03:51 <kshlm> Thanks for attending the meeting everyone.
13:04:03 <hagarth> kshlm: thanks for hosting today!
13:04:04 <kshlm> #endmeeting