12:02:44 <rafi> #startmeeting
12:02:44 <zodbot> Meeting started Tue Sep 15 12:02:44 2015 UTC.  The chair is rafi. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:03:07 * skoduri is here
12:03:44 <rafi> #topic roll call
12:04:01 * ndevos is here \o_
12:04:17 <rafi> #info Agenda for today: https://public.pad.fsfe.org/p/gluster-bug-triage
12:05:07 * kkeithley_ is here
12:05:32 <rafi> I would love to see jiffin also
12:06:49 <rafi> moving to next topic
12:07:02 <rafi> #topic Status of last weeks action items
12:08:09 <rafi> I will be skipping the some action items, if they are not available for today
12:08:28 <rafi> #topic soumya to send send a reminder to the users- and devel- ML about (and how to find and  fix ) Coverity defects
12:08:39 <rafi> skoduri: i think you did it
12:08:41 <skoduri> yes
12:08:43 <ndevos> yeah, thats the only one we need to mention today :)
12:09:07 <rafi> ndevos: you are trying to escape from some of the action item :D
12:09:24 * rafi just kidding
12:09:43 <ndevos> heh, nope, just dont have anything to report :)
12:09:57 <rafi> thanks skoduri for sending the mail
12:10:27 <rafi> let's wait for the fruits from your handwork
12:11:04 <skoduri> :) I see many registering and some even sending fixes :)
12:11:31 <rafi> great, We already got some nice fruits
12:11:32 <rafi> :D
12:11:46 <kkeithley_> I keep getting requests to give people access to the Coverity results, but I don't know the password for granting those requests. :-/
12:12:08 * kkeithley_ presumes someone else is granting the requests
12:12:08 <ndevos> kkeithley_: login with your github account :)
12:12:18 <kkeithley_> oh, my github account. haha
12:12:23 * ndevos grants permissions sometimes, but is often too late
12:13:02 <skoduri> I do that too sometimes
12:13:06 <skoduri> :)
12:13:14 <ndevos> kkeithley_: ah, no, maybe not github account, kkeithle@redhat.com is your login name
12:14:17 <rafi> Cool, looks like , nothing much to discuss for this topic
12:14:33 <rafi> Moving into the more bigger one
12:14:45 <rafi> #topic Group triage
12:14:54 <rafi> #info https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:14:57 <kkeithley_> ndevos: yeah, it looks strange. All I can do is give coverity access to my account?
12:15:32 <rafi> #info we got 23 new interesting bugs to triage
12:16:00 <ndevos> kkeithley_: not sure, try to go to https://scan.coverity.com/projects/gluster-glusterfs?tab=members ?
12:16:36 <ndevos> rafi: oh, did you get the bugzilla command output? I did that too :)
12:17:03 <rafi> Ooops, I thought it could be an older one
12:17:15 <rafi> ndevos: sorry, thanks for doing it
12:17:19 <rafi> :)
12:25:29 <ndevos> quote some awesomeness: I had about 1Lakh files ...
12:25:54 <ndevos> if you never been to India, you would have no clue what bug would be about :)
12:26:21 <kkeithley_> better or worse than a Crore?
12:30:11 <ndevos> equal
12:30:54 <ndevos> rafi: I think all have been triaged?
12:31:23 <rafi> ndevos: two more left on me , still doing it
12:34:00 * rafi looking into bug list to double check
12:34:13 <skoduri> I had put one on NEED_INFO
12:34:22 <skoduri> 1263056
12:34:48 <ndevos> I did that 2x too
12:35:14 <rafi> we are clean then
12:35:22 <rafi> let's move to the next
12:35:32 <rafi> #topic open floor
12:35:40 <ndevos> kkeithley_, hchiramm_home: we should remove the 3.4.x versions from bugzilla...
12:36:23 <rafi> ndevos: we are not supporting 3.4.
12:36:32 <rafi> ndevos: right ?
12:36:47 <ndevos> rafi: yeah, but those versions are still selectable by users when reporting a bug
12:37:45 <kkeithley_> IIRC you can't remove a version while there are still bugs open against it. We have many versions in BZ simply for that reason.
12:38:10 <kkeithley_> so we should close any remaining open BZs (as WONTFIX?) and then get rid of the unsupported versions.
12:38:28 <ndevos> yes, I guess so
12:38:30 * rafi love to see bugs irrespective of the versions, it might also be there in master ;)
12:38:55 <kkeithley_> OTOH, maybe someone wants to report a bug against 3.4.7, and it's still a bug in later versions. What should we do?
12:39:25 <ndevos> if its still a bug in later versions, report is against an actively maintained version?
12:39:25 <kkeithley_> let them file it against 3.4.7, because that's what they're using?
12:39:56 <ndevos> leaving the old versions in there for users to select them give them wrong expectations, I think
12:40:18 <kkeithley_> how do you document that?  Or for someone who is still running 3.4.7 in production and can't easily tell if it's still a bug in later versions
12:40:49 <kkeithley_> yes, it can give the wrong expectation
12:41:21 <ndevos> we need to make it clear that 3.4.x (or even older) is not supported anymore, maybe we should have a End-Of-Life version?
12:42:03 <ndevos> if we have an End-Of-Life version, we can move all 3.4.x and older bugs to that, leave a note for the reporter to re-check on a newer version?
12:42:04 <rafi> ndevos: kkeithley_ : how about bringing this topic on gluster-meeting, for a broader audience and suggestions
12:42:09 <kkeithley_> what does, e.g. the kernel do?
12:42:39 <ndevos> many kernel devs may laugh at you when you use an old kernel :P
12:42:39 <kkeithley_> yes, make it a topic for tomorrow's meeting
12:43:09 <kkeithley_> well, we're nicer (friendlier) than the kernel.  At least I like to think so.
12:43:34 <ndevos> fedora just closes bugs for releases that are not supported anymore
12:44:24 <rafi> #action ndevos to add a agenda for gluster-meeting to discuss about cleaning up of older (which we are not supporting )version tag and bugs from bugzilla
12:44:28 <kkeithley_> Yeah, I guess I knew that.  I keep having my xserver bug closed, then I have to go reopen it and assign it to the current version of Fedora.
12:44:46 <ndevos> kkeithley_: arrign it to rawhide ;-)
12:44:52 <ndevos> *assign
12:44:55 <rafi> ndevos: i added an action item
12:45:24 <kkeithley_> I don't know if it's actually a bug in rawhide, so that'd be lieing.
12:45:26 <rafi> any other topics
12:45:29 <ndevos> rafi: I'm looking at the meeting agenda for tomorrow, but hchiramm_home/kshlm did not prepare it yet :-/
12:45:30 <kkeithley_> that'd be a lie.
12:46:04 <rafi> ndevos: :( , some times people may forget it,
12:46:19 <rafi> ndevos: by the way , we can remind them
12:46:33 <ndevos> rafi: it seems they need reminders, yeah :-/
12:46:51 <kkeithley_> maybe put a big bold "reminder" in the e'pad?
12:47:09 <ndevos> well, its listed in the "Instructions"
12:47:18 <ndevos> hmm, I could make that *bold*
12:47:45 <rafi> I love to see more people participating and hosting the community meeting
12:48:01 <ndevos> rafi: you're not alone :)
12:49:01 <rafi> ndevos: kkeithley_ : how about bringing this in community meeting, especially for bug triage
12:49:24 <kkeithley_> bringing what?
12:49:34 <rafi> ndevos: kkeithley_ : at least we can remind some of them , that bug triage meeting is still happening
12:49:59 <kkeithley_> indeed. agreed
12:50:15 <ndevos> rafi: everyone should have it in their calendar, maybe we need to send them all an invite ;-)
12:51:02 <ndevos> if only our #$%^#*&#*@#!@ calendar would accept invites sent to a mailinglist
12:51:18 <rafi> ndevos: that will help to some extend, but the ultimate one is our mind set
12:52:21 * rafi thinks bug triage meeting is more or less like nfs team meeting :D
12:52:29 <kkeithley_> what? It's google. Isn't it perfect? ;-)
12:52:43 <rafi> i love nfs team
12:53:08 <ndevos> rafi: oh, we are looking for a meghanam replacement :D
12:54:03 <ndevos> rafi: also, we need something very loud and obvious that you can wear (maybe a huge Ant suit?) just before the community meetings start
12:54:13 <skoduri> :D
12:54:22 <ndevos> rafi: that would remind everyone in your office that they need to join :P
12:55:23 <rafi> ndevos: I love fancy dressing, :D
12:55:38 <rafi> ndevos: I got prizes in school level ;)
12:55:54 <kkeithley_> sounds like you'd be perfect then.
12:56:13 <ndevos> rafi: oh, you were like a model?
12:56:20 <rafi> ndevos: Ooops but in college level i got defeated by jiffin
12:56:37 <jiffin> rafi: in dreams
12:56:38 <rafi> ndevos: so jiffin goes here first
12:57:07 <jiffin> rafi: or do u meet someone other jiffin in college
12:57:19 <jiffin> rafi: its not me
12:57:37 <ndevos> rafi, jiffin: there are those 2-person suits too, maybe there is an Ant one :D
12:58:39 <hagarth> do we need a salmon jacket too? ;)
12:58:40 <rafi> cool, though it is a nice idea
12:59:00 <amye> hagarth: we could make a shrine to a salmon jacket
12:59:23 <hagarth> amye: lol
12:59:24 <csim> +1
12:59:33 <amye> hagarth: happy to help. :)
12:59:43 <hagarth> :)
13:00:31 <ndevos> rafi, jiffin: or you should both wear http://i00.i.aliimg.com/photo/v0/778916876/Adult_ant_Costume_Mascot_party_clothes_moving.jpg
13:01:00 <jiffin> ndevos: its not gluster ant
13:01:19 <jiffin> ndevos: gluster ant is more handsome
13:01:19 <ndevos> jiffin: I could not find a green suit that quickly
13:01:20 <rafi> I don't like pink
13:01:31 <jiffin> me too
13:01:32 <rafi> i guess skoduri will be
13:01:41 <ndevos> and hagarth said salmon, this is close
13:01:48 <rafi> skoduri: how about it ,
13:02:48 <rafi> by the way, I haven;t seen an Ant standing like
13:03:28 <rafi> alright any thing else to discuss for today
13:03:46 <skoduri> rafi, I am not much into fancy dressing ... but would love to get a soft toy of it :P
13:03:46 <ndevos> nope, I think we're done?
13:04:19 <skoduri> yupp done I guess..
13:04:27 <rafi> skoduri: you have to do something nice to get it
13:04:46 <rafi> skoduri: like hosting the meeting for next week :D
13:05:12 <rafi> let's discuss it next week
13:05:22 <skoduri> sure :)
13:05:30 <rafi> I guess we are done
13:05:49 <rafi> guys let's meet tomorrow for community meeting
13:06:00 <rafi> until then good by
13:06:11 <rafi> and thanks every one for joining the meeting
13:06:15 <kkeithley_> <americanism>same bat time, same bat channel</americanism>
13:06:16 <ndevos> thanks rafi!
13:06:24 <rafi> #endmeeting