12:01:05 <ndevos> #startmeeting Weekly Gluster Community Meeting
12:01:05 <zodbot> Meeting started Wed Dec 16 12:01:05 2015 UTC.  The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:05 <zodbot> The meeting name has been set to 'weekly_gluster_community_meeting'
12:01:20 <ndevos> #info Agenda: https://public.pad.fsfe.org/p/gluster-community-meetings
12:01:25 <ndevos> #topic Roll Call
12:01:32 <ndevos> Hi all, who do we have here today?
12:01:37 * anoopcs is here
12:01:39 * skoduri is here
12:01:40 * amye is here
12:01:43 * msvbhat is here
12:01:49 <ndevos> kshlm mentioned he might not make it, or maybe later
12:01:51 * jiffin is here
12:02:24 * Manikandan is here
12:02:45 <ndevos> so, about 8 attendees, and 51 people in this channel, hmm
12:02:46 * obnox is only somewhat here
12:03:30 <ndevos> I guess we'll just get started then
12:03:37 <ndevos> #topic Action Items from last week
12:03:41 <ndevos> #topic ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:03:58 <ndevos> I was enjoying holidays last week, and didnt do the emails for this
12:04:06 <ndevos> will try to do it before next meeting
12:04:19 <ndevos> #topic raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.8
12:04:49 <ndevos> raghu isnt here, did anyone see his call for help?
12:05:18 <jiffin> ndevos: I don't recollect any
12:05:47 <jiffin> from last week
12:06:00 <ndevos> ok, thanks, I've still not managed to read all emails from last week
12:06:14 <ndevos> #topic rastar and msvbhat to publish a test exit criterion for major/minor releases on gluster.org
12:06:27 <Manikandan> ndevos, I will ask an update on this from raghu
12:06:30 <ndevos> msvbhat: do you have an update on this?
12:06:41 * sac is here.
12:06:43 <msvbhat> ndevos: Sent a mail to ML few hours ago
12:06:47 <ndevos> Manikandan: oh, just remind him, we'll check next week again
12:06:58 <Manikandan> ndevos, sure, I will remind him :)
12:07:05 <ndevos> msvbhat: to the devel list?
12:07:24 <msvbhat> Depending on the suggestions we receive, will publish it in glusterweb
12:07:32 <msvbhat> ndevos: Yes,
12:08:02 <msvbhat> ndevos: @gluster-devel list
12:08:24 <ndevos> msvbhat: hmm, I do not see it in the archives yet
12:08:38 <msvbhat> ndevos: I sent an hour back
12:09:09 <ndevos> msvbhat: ah, found it!
12:09:13 <ndevos> #link http://www.gluster.org/pipermail/gluster-devel/2015-December/047423.html
12:09:44 <msvbhat> Yes, That's the one
12:09:54 <ndevos> #info feedback on the "Gluster testing matrix" requested, results will be included in glusterweb
12:10:22 * hgowtham is a bit late
12:10:27 <ndevos> #action msvbhat and rastar to follow up on the results of the "Gluster testing matrix" email
12:10:44 <ndevos> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:11:09 <ndevos> csim: if you're there, maybe an update from you?
12:11:34 <ndevos> ok, then next week maybe
12:11:38 <ndevos> #topic hagarth to decide on 3.7.7 release manager
12:11:57 <ndevos> hagarth: did your bottle swinging pick someone?
12:12:19 <ndevos> or, does anyone know if hagarth found someone to release 3.7.7?
12:13:07 <jiffin> ndevos: In last meeting ,it was not decided
12:13:08 <obnox> ndevos: don't know, but I guess he is in meetings currently
12:13:09 <ndevos> well, there are still two weeks before the release, so there is some time
12:13:52 <ndevos> obnox: yes, I think he is, and I think he (and many others) need to learn how to not double book themselves
12:13:57 <ndevos> #topic amye to get on top of disucssion on long-term releases
12:14:28 <ndevos> amye: do you have anything to share about the long-term releases?
12:14:29 <amye> So, is the issue that we don't like the current policy?
12:14:52 <ndevos> I think some users would like to see a longer-term release
12:14:56 <amye> 3 versions being supported at a time?
12:15:20 <ndevos> currently we have a "three latest release" stable track - or however you want to call it
12:15:21 <msvbhat> ndevos: BTW Update from raghu is that he has sent he call for volunteers to @gluster-maintainers list and here is the bug ID for the same https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.8
12:15:22 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:15:46 <ndevos> msvbhat: ok, thanks!
12:16:02 <amye> Right, and at this point in time, it doesn't look like we'll have a release of 3.8 until March, or so - so our 3.4 release should be maintained for another 3 months.
12:16:22 <ndevos> amye: I thought some users would like to see a longer 3.6 release series, even when 3.8/3.9/4.0/4.1 are released
12:16:48 <ndevos> uh, 3.4 is not maintained anymore, we have 3.7, 3.6 and 3.5
12:16:56 <amye> Sorry, typo.
12:17:00 <amye> 3.5 was what I meant
12:17:35 <amye> We can take this offline, I think there are a lot more moving parts here than can be worked out in an IRC meeting.
12:18:03 <ndevos> yeah, I think this is more of "did you make any progress" action item :)
12:18:42 <ndevos> we'll just keep it on the list for next week, and you can think of persuing (sp?) something
12:18:54 <ndevos> #topic hagarth to post Gluster Monthly News this week
12:19:05 <amye> This is not something I can decide for us, so what needs to happen next is a conversation between the tech leads about how long they are willing to be maintainers for a single release.
12:19:10 <ndevos> hagarth should have posted that last week, or even the week before
12:19:17 <hagarth> ndevos: this got punted to amye and sankarshan now ;)
12:19:20 <Saravana_> How Greg maintains LTS for Linux kernel can be looked into and something similar can be arrived at for gluster
12:19:51 <obnox> ndevos: that is not really about double-booking, imho. this is a recurring event and may be overridden by important one-time meetings.. :-)
12:19:59 <ndevos> Saravana_: yeah, that is where the idea came from, I think
12:20:12 <amye> Re: weekly newsletters, we'll be moving to monthly starting in January to be able to highlight what's going on in the project, upcoming events and meetups, ways to get involved.
12:20:23 * sankarshan nods
12:20:33 <ndevos> obnox: maybe "double booking" vs "adjusting priorities" ;-)
12:21:07 <ndevos> amye: will there be a newsletter with contents from the last weeks?
12:21:14 <amye> Back to the topic of long term releases, do we agree that this needs to go to hagarth, ndevos, jdarcy?
12:21:35 <ndevos> #info weekly newsletters, we'll be moving to monthly starting in January to be able to highlight what's going on in the project, upcoming events and meetups, ways to get involved
12:22:23 <ndevos> amye: I guess we need to know if our users want it, and if they would really use a long term release?
12:23:57 <ndevos> amye: bugfixing a stable release is not too much work, for most bugs at least, I do not think it is a technical difficulty, more of a "do we need to?" question
12:24:22 <amye> Maintaining something like this will potentially be a cost against additional development on new things, so this has to go to Hagath as a community technical issue. Do we include things like backporting patches? etc?
12:24:39 <amye> ^hagarth
12:25:03 <ndevos> amye: it includes backporting bug fixes yes, but we normally do not do backporting of new features
12:25:27 <sankarshan> could this be discussed off this meeting and a decision arrived upon?
12:26:01 <amye> This is too big to be solved here, plus we need hagarth. :)
12:26:18 <ndevos> yeah, but amye will need to start the discussion, she needs to understand the important parts :)
12:26:59 <ndevos> amye: so, you're good on getting some discussion rolling and report something back next week?
12:27:31 <amye> I'm going to decline that particular honor, I cannot make this decision for the community.
12:27:44 <amye> I'll touch base with hagarth to get this rolling.
12:28:23 <ndevos> well, sure, no decision, but check what users would like to see and how we could get that done
12:29:08 <ndevos> and keep the maintainers involved, maintainers@gluster.org is the list, I think
12:29:14 <ndevos> #topic hagarth to create 3.6.8 for bugzilla version
12:29:24 <ndevos> raghug: I guess that version was created?
12:30:12 <ndevos> oh, no, it wasnt :-/
12:30:28 <ndevos> #topic raghu to ask for volunteers for release manager for 3.6.8
12:30:49 <ndevos> did raghug send an email for this? anyone volunteered?
12:31:09 <amye> an hour ago
12:31:17 <pranithk> ndevos: he sent on maintainer@gluster.org
12:31:20 <ndevos> ah, thanks!
12:31:35 <ndevos> was there a reply from someone yet?
12:32:05 <ndevos> no, there was not
12:32:05 <Manikandan> ndevos, nothing till now
12:32:07 <pranithk> ndevos: nope
12:32:09 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.maintainers/145
12:32:26 <ndevos> #topic kkeithley to send a mail about using sanity checker tools in the codebase
12:32:44 <ndevos> kkeithley: did you sent that email?
12:33:16 <ndevos> or did anyone see his email?
12:33:40 <ndevos> .. thats a firm "no" in my book
12:33:44 <ndevos> #topic rastar to continue the discussion on rebase+fast forward as an option to gerrit submit type
12:33:56 <ndevos> I also have not seen this thread yet...
12:34:11 <rtalur> No, have not sent a mail on this
12:34:12 <ndevos> did rastar continue the discussion?
12:34:27 <rtalur> but it is discussed a little in testing criteria mail
12:34:27 <ndevos> ah, 2 nicks, how confising :)
12:34:34 <ndevos> *confusing even
12:34:42 <rtalur> My bounce server is down :(
12:35:15 <kkeithley> no
12:35:19 <ndevos> I'm not sure if it should be part of the testing email, that hides the topic a little and people may miss it
12:35:41 <rtalur> ok, about rebase+ fast forward, main objection for it was about too much testing involved
12:35:49 <kkeithley> no, I haven't sent an email about sanity checker tools
12:35:55 <rtalur> what I mean is , it is blocked by a testing decision
12:36:16 <rtalur> Asking the same question here again
12:36:32 <ndevos> #info rebase+fastforward patch submission in Gerrit depends on the regression testing that is needed to be done
12:36:44 <rtalur> rebase+ fast forward would require a atomic (rebase+regression run+merge) of patch
12:37:17 <rtalur> So when a maintainer hits submit , the actual merge would happen after about 2 hours by current standards
12:37:23 <rtalur> would that be ok?
12:38:21 <obnox> rtalur: this also has to catch races: if during the 2 hours, upstream has changed (by a concurrent merge process) then this one needs to rebase and start over
12:38:46 <rtalur> obnox: yes, it would strictly serialize all merges
12:38:49 <ndevos> I would guess *that* is ok, but if two patches take 2x2 hours, it can become quite a queue
12:38:51 <rtalur> and regression runs
12:39:04 <obnox> ndevos: sure it is a Q
12:39:39 <msvbhat> For that to work properly, we should have system where tests run parallylly and fast
12:39:46 <msvbhat> *in parallel
12:39:51 <obnox> in samba we run some of these in parallel (configurable number), and the first one that passes is pushed
12:39:56 <obnox> the others start over and race again
12:40:04 <obnox> it is merely a resource limit decision
12:40:06 <ndevos> well, I like to take some time to do a final review of patches, and merge a few after eachother, 2 hours waiting for them to get merged will be very painful
12:40:28 <obnox> ndevos: but it is needed if you want to be certain it is ok
12:41:08 <ndevos> yeah, I understand the need for it, and I guess it depends on how the tooling will handle it
12:41:26 <rtalur> obnox: ndevos the other method that google-chrome uses is do to a immediate merge but automatic revert if it fails later
12:42:00 <ndevos> #info maintainers need to read the "Gluster testing matrix" email and reply to the rebase+fastforward notes in there
12:42:49 <ndevos> rtalur: hmm, I do not like that much, building a queue would not be too bad if there is an automatic retry
12:43:25 <ndevos> rtalur: all maintainers need to give their opinion about it, so we'll continue that by email
12:43:33 <rtalur> ndevos:
12:43:54 <rtalur> ndevos: ok, I will explain these options in mail and expect more comments from maintainers
12:44:08 <msvbhat> Should I cross post it to maintainers ML as well?
12:44:13 <ndevos> rtalur: oh, yes please, and sent it to the maintainers list
12:44:23 <msvbhat> Okay :)
12:44:50 <ndevos> #action rtalur/rastar will send a seperate email about the Gerrit patch merge strategies to the maintainers list
12:44:59 <ndevos> #topic GlusterFS 3.7
12:45:09 <ndevos> Tracker: https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.7.7
12:45:10 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:45:31 <ndevos> there are two weeks until the next 3.7 release
12:45:49 <ndevos> are there any volunteers to do this release?
12:46:45 <ndevos> #halp need a volunteer release manager for 3.7.7
12:46:58 <ndevos> #topic GlusterFS 3.6
12:47:11 <ndevos> raghug: got an update for us here?
12:47:23 <ndevos> Tracker: https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.8
12:47:24 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:47:36 <kkeithley> If we release on 30 December, will there be anyone around to do builds? And does that matter? (/me will be on PTO that week.)
12:48:03 <ndevos> raghug: is currently listed as the release maintainer for 3.6.8, but also had an AI to find a volunteer
12:48:16 <ndevos> kkeithley: I dont know, its not something I have considered :)
12:48:18 <raghu> I have sent the mail asking for volunteers
12:48:30 <raghu> but to maintainer mailing list
12:48:48 <raghu> I can send it to devel list as well
12:48:54 <ndevos> raghug: right, to the maintainers list is fine, those are the people that should volunteer in the 1st place
12:49:48 <ndevos> the next 3.6 release is planned for around the 20th of the month, we'll need to hurry a little with that
12:50:05 <raghu> ndevos: there were couple of patches which I have merged.
12:50:21 <ndevos> ok, sounds good
12:51:10 <ndevos> raghu: let me know if you have not gotten a volunteer after tomorrow, we should poke a few maintainers directly then
12:51:32 <ndevos> #topic GlusterFS 3.5
12:51:54 <ndevos> 3.5.7 was released over the weekend, and announcements were sent out yesterday
12:52:26 <ndevos> thanks to all packagers, binaries for many distributions are available on download.gluster.org already
12:52:49 <ndevos> 3.5.8 is open for patches, please send backports!
12:53:02 <kkeithley> Hari is finishing up the Ubuntu launchpad builds of 3.5.7.
12:53:07 <ndevos> #topic GlusterFS 3.8
12:53:13 <ndevos> #link https://public.pad.fsfe.org/p/gluster-3.8-features
12:53:31 * msvbhat brb
12:53:37 <ndevos> anyone that can comment on 3.8 progress?
12:53:59 <ndevos> ... I guess not
12:54:05 <ndevos> #topic Gluster 4.0
12:54:08 <ndevos> Tracker: https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-4.0
12:54:38 <ndevos> atinm, kshlm, ..., someone: anything on 4.0?
12:54:51 <atinm> ndevos, the work goes on
12:55:01 <ndevos> \o/
12:55:32 <ndevos> atinm: thats all?
12:56:07 * ndevos heard "yes
12:56:14 <ndevos> #topic Open Floor
12:56:24 <ndevos> #info Weekly reminder to announce Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
12:56:37 <ndevos> #info REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
12:56:51 <ndevos> #info Etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
12:57:10 <ndevos> Did anyone bring an other topic to discuss?
12:57:25 <atinm> ndevos, yes
12:57:33 <ndevos> #chair atinm
12:57:33 <zodbot> Current chairs: atinm ndevos
12:57:43 <ndevos> you can #topic it yourself now :)
12:58:17 <skoduri> we have Gluster meetup at BLR location this friday -  http://www.meetup.com/glusterfs-India/events/227287952/
12:58:36 <ndevos> oh, maybe that "yes" from atinm was delayed on the Gluster 4.0 question :)
12:59:07 <ndevos> #info Gluster meetup in Bengaluru http://www.meetup.com/glusterfs-India/events/227287952/
12:59:37 * obnox needs to drop off for another meeting
12:59:49 * rtalur too
13:00:04 <ndevos> if everyone stays quiet, we're done for todays meeting
13:00:19 <ndevos> thanks for joining all, and see you next week again!
13:00:23 <ndevos> #endmeeting