12:03:01 <kshlm> #startmeeting Weekly Gluster Community Meeting
12:03:01 <zodbot> Meeting started Wed Jan  6 12:03:01 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:03:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:03:01 <zodbot> The meeting name has been set to 'weekly_gluster_community_meeting'
12:03:11 <kshlm> Hey all!
12:03:20 <kshlm> Happy New Year everyone!
12:03:25 <justinclift> :D
12:03:38 <kshlm> #topic Rollcall
12:03:44 * kshlm is here!
12:03:45 * justinclift waves
12:03:48 * jdarcy is
12:03:49 * ndevos is around
12:04:10 <kshlm> 1 more minute of rollcall and I'll start.
12:05:49 <kshlm> Okay. Let's start.
12:05:57 <kshlm> Today's meeting agenda is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:06:09 <kshlm> #topic Last weeks AIs
12:06:51 * aravindavk is here
12:06:51 <kshlm> #topic ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes (next year)
12:07:16 <kshlm> We actually didn't have the meeting last-week, so these are 2 week old AIs.
12:07:16 <ndevos> I raise my "having holidays" card
12:07:26 <kshlm> Okay.
12:08:14 <kshlm> To next week then.
12:08:23 * anoopcs arrives late.
12:08:27 <kshlm> #action ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes (this year)
12:08:56 <kshlm> Skipping raghus AI as I know it hasn't been done.
12:09:06 <kshlm> #topicr astar and msvbhat to consolidate and publish testing matrix on gluster.org. amye can help post Jan 1.
12:09:14 <kshlm> #topic rastar and msvbhat to consolidate and publish testing matrix on gluster.org. amye can help post Jan 1.
12:09:56 <kshlm> Don't see either of them around.
12:10:30 * overclk is here...
12:10:31 <kshlm> msvbhat, rastar Any updates on your plans for this?
12:11:11 <kshlm> Carrying this forward as well.
12:11:20 <kshlm> #action rastar and msvbhat to consolidate and publish testing matrix on gluster.org. amye can help post Jan 1.
12:11:35 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github (after csim comes back on 4th Jan)
12:12:04 <kshlm> This is not done yet. csim is back now, so I'll work with him.
12:12:11 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github (after csim comes back on 4th Jan)
12:13:07 <kshlm> Skipping the next two AIs as they were targetted for later.
12:13:30 <kshlm> #topic hagarth to create 3.6.8 for bugzilla version
12:14:05 <ndevos> seems to exist now :)
12:14:32 <kshlm> Yup. I seem to remember kkeithley getting it done.
12:15:03 <kshlm> Okay on to the next one.
12:15:06 <kshlm> #topic kkeithley to send a mail about using sanity checker tools in the codebase
12:15:40 <kshlm> I haven't seen this mail yet.
12:15:46 <jdarcy> I vaguely recall seeing something like that.
12:15:57 <jdarcy> Was that here?
12:16:04 * kshlm missed a lot of mail over the year-end. So he might be wrong.
12:16:34 <ndevos> I dont remember I have seen it... but has a end-of-year as well
12:16:39 <kshlm> I think this was about making use of static analyzers.
12:17:09 <jdarcy> I believe so.  Found the mail I was thinking of, it was among a smaller group.
12:17:28 <kshlm> Ah. OK.
12:17:43 <kshlm> I'll move this to next week.
12:17:49 <kshlm> #action kkeithley to send a mail about using sanity checker tools in the codebase
12:18:12 <kshlm> #topic rtalur/rastar will send a seperate email about the Gerrit patch merge strategies to the maintainers list
12:18:40 <kshlm> I saw a mail on testing strategies, didn't see one on merging strategies though.
12:18:53 <ndevos> me neither
12:19:07 <kshlm> Carrying this forward as well.
12:19:10 <kshlm> #action rtalur/rastar will send a seperate email about the Gerrit patch merge strategies to the maintainers list
12:19:27 <kshlm> #topic atinm/hagarth to share details on the MVP plan for Gluster-4.0
12:19:42 <kshlm> atinm did this.
12:19:59 <kshlm> But it got no responses as I remember.
12:20:10 <ndevos> yes, he did, but it was rather short, I think - not sure what to add though
12:20:56 <jdarcy> There's a Trello board that has been updated, I think Atin said he'd be making it public today.
12:21:02 <kshlm> #link https://www.gluster.org/pipermail/gluster-devel/2015-December/047528.html
12:21:08 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/13337
12:21:58 <jdarcy> (reads email) "EOD Thursday" and it was Naga, not Atin.
12:22:13 <kshlm> The actual feature owners could possibly expand on atinm's mail. That would help others.
12:22:36 <kshlm> What do you all feel about this?
12:23:35 <ndevos> some more details about the features would have been welcome, a link to the design doc and tasks or such
12:24:17 <ndevos> and yeah, a public Trello board or something can fit in there too
12:24:21 <kshlm> I agree as well.
12:24:45 <kshlm> I don't think the mail captured everything that had been discussed.
12:25:12 <kshlm> So do we add an AI for this, or wait for the mentioned trello board to become public?
12:25:21 <overclk> ndevos, kshlm: as of now details are scattered around all the places (mails, docs, etc..)
12:25:59 <ndevos> overclk: yes, my point! an email with a plan should point to all of those places
12:27:39 <kshlm> We need to have a central location from where we can reach all the relevant information.
12:27:55 <overclk> kshlm, ndevos, each feature owner(s) could possibly consolidate and send out and email (or dump it at a known location)..
12:27:56 <ndevos> if comments on something like the email is wanted, we would need to understand the design a little, and know which tasks and the impact they have
12:28:23 <kshlm> I had thought that the 4.0 feature page would have been a good point to start from.
12:28:47 * overclk dropped out, back now..
12:29:08 <ndevos> it does not really where, but a location that has links to all relevant docs would be a start
12:29:27 <kshlm> The trello board should have the required information.
12:29:39 <ndevos> the glusterfs-specs repository should get the technical design
12:29:53 <kshlm> I say,  we wait for the board to be publicised.
12:30:18 * obnox says hi (late)
12:30:42 <kshlm> And make sure we add any missing information to the board.
12:30:46 <jdarcy> OK, I'm going to create a directory in glusterfs-specs for *actual specs* rather than feature pages.
12:30:59 <ndevos> maybe the trello board can get exported to a html form so that it can get linked on gluster.org?
12:31:50 <ndevos> jdarcy: yeah, its a little free-form at the moment, nobody seemed to have suggestions on how to use it
12:34:25 <kshlm> ndevos, couldn't we just link to the trello board, instead of linking to an export.
12:34:28 <aravindavk> +1 for glusterfs-specs, we can adopt similar to rfc-process of rust-lang https://github.com/rust-lang/rfcs
12:34:30 <ndevos> #links https://github.com/gluster/glusterfs-specs (patches go through Gerrit)
12:35:04 <aravindavk> that page clearly shows active rfc list
12:35:15 <ndevos> I think the workflow for glusterfs-specs was based on how OpenStack does it
12:35:20 <kshlm> aravindavk, Cool. We should pick up ideas from other project who've been doing it.
12:36:00 <kshlm> ndevos, Yes. But I don't think we're doing it right.
12:37:05 <ndevos> kshlm: I'm pretty sure we're doing it wrong, because nobody uses it
12:37:08 <jdarcy> I'm fine with following the OpenStack model for feature pages (ours) or blueprints (theirs), but those aren't specs and we need to stop talking about the two as though they're the same.
12:37:44 <justinclift> jdarcy: What do you recommend? :)
12:37:54 <ndevos> the feature pages were supposed to be part of the glusterdocs for end-users, I though, and the design (in -specs) for developers?
12:38:08 <ndevos> *thoughT
12:38:55 <jdarcy> justinclift: I think we need a repo or part of a repo (don't care where) for the specs, distinct from either feature pages or code.
12:39:45 <justinclift> jdarcy: Is there a template or some other kind of reasonably directive document that people can fill out with the specs?
12:40:12 <justinclift> s/with the specs/with their specs/
12:40:22 <jdarcy> ndevos: Feature pages are really for planning, as the basis for both end-user docs and detailed designs.  Part functional spec, part application form.
12:40:30 <kshlm> As we now seem to be confused with feature-pages and specs, can someone clearly explaing the difference betweenthe two?
12:40:55 <justinclift> To me, a "spec" includes very technical implementation info
12:41:14 <justinclift> eg over the wire protocol, on disk structures, that kind of thing
12:41:22 <justinclift> Is that how other people understand a spec?
12:41:23 <jdarcy> justinclift: I don't think there's a *template* because every design has different parts, but there are examples and best practices.
12:41:40 <jdarcy> justinclift: A design spec, yes.
12:42:23 <jdarcy> I don't want to get too bogged down in terminology, but many of the things I've written e.g. for NSR are very distinct from either user docs or feature pages.
12:43:32 <justinclift> k.  For a "feature page", my understanding has been that it's something higher level, useful for people not-doing-the-coding-on-the-feature.  So they know who to contact, know its' progress, understand the overall concept of it.
12:43:46 <jdarcy> If we want to have a user+developer review process for feature pages, that's GREAT.  Yes, we should.  But a developer-only review process for design specs is something different.
12:43:49 <ndevos> for me, feature pages should be user-facing description of a new feature, including steps on how to test it
12:44:14 <justinclift> Ahh, I'd forgotten the bit about how to test it. That's useful.
12:45:07 <justinclift> ndevos: Unsure where testing info goes though (feature page vs spec). ;)
12:45:15 <ndevos> how the particular feature fits in the a deployment would be part of the general documentation
12:46:08 <ndevos> justinclift: for me, a feature page describes what the feature does and how a user can use it, that should include examples of how to configure it
12:46:26 <jdarcy> Pulling this back to the original AI, is the request for 4.x developers to update *both* feature pages and design specs?
12:46:38 <justinclift> ndevos: Config info, yeah.  Definitely agree.
12:47:05 <ndevos> justinclift: each patch that gets merged should come with a test-case as well, so the technical testing is covered there
12:47:34 <justinclift> No opinion on that :)
12:47:35 <kshlm> Okay, so would this mean that for a feature we'd have a feature-page, which describes the feature and how to test/use it, and a spec which describes design and implementation details?
12:47:55 <jdarcy> khslm: I believe so.
12:48:05 <justinclift> kshlm: That sounds like a proper approach.
12:48:09 <ndevos> jdarcy: it would be good if feature owners can reply to Atins email with links to their current documentation, wip-patches, ...
12:48:31 <ndevos> kshlm: that is how I see it
12:48:46 <kshlm> Okay. Good to see we have an understanding.
12:49:04 <kshlm> We now need to decide where each resides and how we go about reviewing them.
12:49:05 <jdarcy> ndevos: Agreed.
12:49:30 <kshlm> I can start a discussion on the mailing lists about this if required.
12:49:36 <ndevos> kshlm: I dont think we need to so that *now* ;-)
12:49:54 <jdarcy> kshlm: For the sake of expediency, I'll create a subdir in glusterfs-specs for design specs.  I'll call it (no surprise) "design".
12:50:14 <kshlm> jdarcy, Ok. I think that should take care of it.
12:50:29 <ndevos> jdarcy: please move the in_progress/kerberos.md (or whatever) file in design/ then :)
12:50:43 <jdarcy> ndevos: Will do.  Thanks for pointing it out.
12:51:02 <kshlm> Maybe we can write up a README for what needs to go where.
12:51:08 <jdarcy> kshlm: Absolutely.
12:51:15 <kshlm> (in the specs repository)
12:51:25 <kshlm> I volunteer to do that.
12:51:39 <justinclift> :)
12:51:39 <kshlm> #action kshlm to write up a README for glusterfs-specs.
12:51:56 <ndevos> yes, someone please update the README with what should be in -specs, and maybe even what should not be in there
12:52:10 <kshlm> I should have a review-request open for this before next week.
12:52:10 <jdarcy> I'll volunteer to work with Kaushal on that.
12:52:19 <kshlm> jdarcy, Thanks.
12:52:20 <ndevos> awesome, thanks!
12:52:39 <kshlm> Okay. Let's move on the releases.
12:52:46 <kshlm> #topic GlusterFS 3.7
12:53:06 <kshlm> pranith volunteered to release 3.7.7, but hasn't done it so far.
12:53:16 <kshlm> We're about a week late from schedule.
12:53:40 <kshlm> I'll ping him about it tomorrow.
12:53:47 <kshlm> #topic GlusterFS 3.6
12:54:03 <kshlm> I was supposed to do the 3.6.8 release 2 weeks ago.
12:54:18 <kshlm> I just tagged 3.6.8 earlier today.
12:54:20 <ndevos> 3.6.8 just got released before this meeting, oh, was that you?
12:54:29 <kshlm> I think the tarballs should be ready now.
12:54:49 <kshlm> Just 2 commits between .7 and .8.
12:54:58 <kshlm> I'll announce once some RPMS are ready.
12:55:00 <ndevos> I've already build the CentOS-7 Storage SIG packages :)
12:55:15 <kshlm> ndevos, Awesome.
12:55:30 <ndevos> but need to push them to -testing and later on to -release
12:56:06 <kshlm> Just let me know once you've done it. I'll announce the release with the first available packages.
12:56:11 <kshlm> #topic GlusterFS-3.5
12:56:31 <kshlm> ndevos, Got anything to add?
12:56:42 <ndevos> no, not really, there is one patch propsed
12:56:46 <kshlm> Scheduled release should be this weekend.
12:57:19 <ndevos> yeah, I'll review the patch and if it makes sense, I'll do a new release too
12:57:29 <kshlm> Okay.
12:57:41 <kshlm> #topic Gluster 3.8 and 4.0
12:57:55 <kshlm> I'll give my updates on GlusterD-2.0.
12:58:44 <kshlm> I've been working on getting the transaction mechanism for GD2 ready. I should have it working before the end of the week.
12:58:57 <kshlm> atinm was working on creating the RPC connections between peers.
12:59:27 <kshlm> We've also started out working out exactly what is required to bootstrap etcd.
12:59:49 <jdarcy> Was on vacation.  ;)  Just starting to get back to NSR stuff.
13:00:05 <kshlm> jdarcy, :)
13:00:23 <kshlm> overclk, Still around? Any updated on DHT-2?
13:00:29 <overclk> kshlm yes
13:00:52 <overclk> for dht2, the plan is to exit POC by two weeks from now..
13:01:22 <kshlm> Are you still on track for the exit?
13:01:32 <overclk> we have reached a phsae where dht2 can be (ab)used..
13:01:38 <overclk> kshlm, yes - very much.
13:01:55 <kshlm> overclk, awesome.
13:02:37 <kshlm> I think that's it for this week. We have nothing on open floor.
13:02:41 <overclk> that's about it from my side..
13:02:50 <kshlm> Thanks overclk
13:03:15 <kshlm> Here are the weekly reminders.
13:03:38 <kshlm> Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:03:38 <kshlm> REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:03:38 <kshlm> Etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:04:02 <kshlm> Add any relevant information you have to these pads.
13:04:10 <kshlm> Thanks everyone.
13:04:15 <jdarcy> Thanks kshlm.
13:04:24 <kshlm> #endmeeting