12:00:29 <kshlm> #startmeeting Gluster Community Meetings
12:00:29 <zodbot> Meeting started Web Feb 3 18:00:29 2016 UTC. The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:29 <zodbot> The meeting name has been set to 'gluster_community'
17:30:46 <kshlm> Good afternoon everyone!
17:30:48 * ** bluenemo (~bluenemo@unaffiliated/bluenemo) has joined #gluster-
17:31:14 <kshlm> #topic Roll call
17:31:21 * obnox waves
17:31:45 * ndevos _o/
17:31:50 * ** gem (~gem@106.51.133.241) has joined #gluster-meeting
17:31:59 <kshlm> The meeting agenda is at https://public.pad.fsfe.org/p/
17:32:08 * amye is here
17:32:13 <kkeithley_> niels says I should respond to rollcall
17:32:22 * jiffin is here
17:32:26 <Saravanakmr> Hello
17:32:29 * msvbhat is here
17:32:31 * Humble is here
17:32:38 * overclk is here
17:32:41 * ** sakshi (sabansal@nat/redhat/x-kjxwjbqdoohgldzf) Quit (Quit:
17:32:44 * skoduri is here
17:32:54 <kshlm> Okay. Let's start.
17:33:11 <kshlm> #topic AIs from last week
17:33:20 <kshlm> #topic ndevos to send out a reminder to the maintainers
17:33:38 <ndevos> sorry, I'll try next week again
17:33:57 <kshlm> Okay.
17:34:01 <kshlm> #action ndevos to send out a reminder to the maintainers
17:34:15 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for
17:34:36 <kshlm> Still on this.
17:34:43 * ** anil (ashah@nat/redhat/x-jziegnlazfzmbcxj) Quit (Quit: Leaving)
17:34:45 <kshlm> #action kshlm & csim to set up faux/pseudo user email for
17:35:02 <kshlm> #topic rastar and msvbhat to consolidate and publish testing
17:35:17 * ** tdasilva (tdasilva@gateway/shell/panicbnc/x-luyjewjbzivsoibn) has
17:35:24 * ** Apeksha (Apeksha@nat/redhat/x-ywvlqbsvpmdttzks) Quit (Ping
17:35:26 <msvbhat> We have one more week. Haven't done it yet
17:35:32 <ndevos> oh, that is something pranith could give input on too?
17:36:02 <amye> can we start a draft for this?
17:36:21 <msvbhat> Will try and complete it by 10th Feb
17:36:40 <kshlm> Okay.
17:36:43 <ndevos> got an etherpad where a work-in-progress is getting done?
17:36:49 <kshlm> One more week shouldn't be too much.
17:37:09 <kshlm> #action rastar and msvbhat to consolidate and publish
17:37:23 <kshlm> #topic kkeithley to send a mail about using sanity checker
17:37:33 <msvbhat> ndevos: I don;t think we have one. Maybe we should create
17:37:45 <ndevos> msvbhat: drop the 'maybe'
17:37:54 <Humble> :)
17:38:13 <kshlm> kkeithley_, Next week?
17:38:19 <kkeithley_> yeah, sure
17:38:22 <kshlm> Okay.
17:38:44 <kshlm> #action kkeithley to send a mail about using sanity checker
17:38:55 <kshlm> AIs are done.
17:39:01 <kshlm> Short list this time.
17:39:14 <kshlm> #topic GlusterFS-3.7.7
17:39:29 <kshlm> 3.7.7 had some major issues with upgrades.
17:39:40 <kshlm> How soon do we plan 3.7.8?
17:39:49 <ndevos> thats very sad ;-(
17:40:13 <ndevos> we've delayed the 3.7.7 release waaay too long, a quick
17:40:26 <kshlm> pranithk updated the mailing list that he's reverted the
17:40:42 <kshlm> Would that be enough for 3.7.8?
17:40:47 <ndevos> the monthly release schedulde for "stable" updates is not
17:40:51 <amye> (is this a good time to discuss the missing release notes)
17:41:19 <ndevos> yes, release-notes shouldget included in each minor release
17:41:40 <Humble> yep.. however most of the recent releases dont have it
17:41:44 <amye> re: ndevos's maintainer's post "Gluster-Maintainers Missing
17:42:10 <kshlm> I'll add the 3.6.8 release notes.
17:42:16 <ndevos> replies to http://thread.gmane.org/gmane.comp.file-
17:42:22 <Humble> thanks kshlm++
17:42:27 <kshlm> #action kshlm to add 3.6.8 release-notes
17:42:44 <ndevos> just dont re-do the tagging :)
17:42:56 <kshlm> ndevos, I'll remember that.
17:42:57 <kkeithley_> and close the 3.7.7 release tracker BZ and make a new
17:43:16 <kshlm> kkeithley_, who's doing that? pranith?
17:43:20 <kshlm> or me?
17:43:35 <ndevos> the person doing the release of that particular version
17:43:48 <kkeithley_> yes, pranith
17:43:54 <ndevos> we have scripts in https://github.com/gluster/release-tools
17:43:57 <ndevos> *that
19:28:49 * that
17:43:58 <kshlm> #action pranithk to close 3.7.7 tracker and open a 3.7.8
17:44:08 * ** Etzeitet (~Etzeitet@78.158.49.18) has joined #gluster-meeting
17:44:27 <ndevos> it should all be listed on http://gluster.readthedocs.org/
17:44:32 <kshlm> Should we fix a date for 3.7.8 btw.
17:44:46 <ndevos> where is pranithk when you need him?
17:44:47 <kshlm> We have an urgent need for that.
17:45:28 <kshlm> Or do we get a new release-manager?
17:45:38 * ** csaba (csaba@nat/redhat/x-wneticwsbuadcdap) has joined #gluster-
17:45:39 <kshlm> Any volunteers to do the 3.7.8 quickly?
17:45:40 <kkeithley_> BTW, same comment for 3.5.8 and 3.6.8 trackers
17:46:13 <kkeithley_> nm
17:46:49 <kshlm> So we wait for pranith?
17:46:52 <ndevos> praniths mentioning of the patch is in http://
17:47:08 <kkeithley_> nm, just 3.6.8 tracker
17:47:09 <ndevos> but there is no confirmation that he'll do a 3.7.8 with only
17:47:19 <kshlm> #action kshlm to close 3.6.8 tracker.
17:48:01 <kshlm> #action kshlm to ping pranith for 3.7.8
17:48:12 <kshlm> #topic GlusterFS-3.6
17:48:39 * ** asriram (~asriram@171.48.29.211) has joined #gluster-meeting
17:48:41 <kshlm> I announced 3.6.8 last week. But I'm yet to complete the
17:48:53 <kshlm> I'll do them, and I already have AIs for them.
17:49:00 <amye> timeline for release?
17:49:31 <kshlm> Later today.
17:49:35 <amye> kshlm++
17:49:37 <glusterbot> amye: kshlm's karma is now 2
17:49:38 <kshlm> Definitely later today.
17:49:53 <kshlm> Anything else for 3.6?
17:50:10 <kshlm> rabhat should be able to get back to his maintainership of
17:50:20 <kshlm> We should check with him.
17:50:21 <ndevos> ok, sounds good :)
17:51:03 <kshlm> Okay.
17:51:12 <kshlm> #topic GlusterFS-3.5
17:51:19 <kshlm> ndevos, ?
17:51:32 <kshlm> Not much to share here.
17:51:37 <ndevos> some patches are planned for quota, and they should make it
17:51:52 <kshlm> And a new release follows that?
17:51:58 <ndevos> so 3.5.8 is scheduled on time, aroiund the 10th of feb
17:52:06 <kshlm> ndevos, Cool.
17:52:15 <kshlm> #info 3.5.8 on track for 10th Feb
17:52:19 <ndevos> it's only few fixes, 3.5 is rather quiet
17:52:28 <kshlm> #topic GlusterFS-3.8
17:52:40 <kshlm> and Gluster-4.0
17:52:40 * ** lpabon (lpabon@nat/redhat/x-ashbevuguuyovtog) has joined
17:53:06 <kshlm> So anyone have any updates here?
17:53:25 <kshlm> I'll Go ahead with GlusterD-2.
17:53:33 <ndevos> seek() is progressing for 3.8 :)
17:54:03 <kshlm> GD2, we've been working on bootstrapping etcd, and gaurav has
17:54:51 <kshlm> overclk, DHT2 news?
17:54:57 <overclk> kshlm, yeh
17:55:04 * ** Manikandan (Manikandan@nat/redhat/x-ybypbnndapzsbkxc) Quit (Ping
17:55:12 <overclk> So, nothing much changed from last update on dht2
17:55:57 <kshlm> overclk, Okay.
17:56:11 * ** jdarcy (~jdarcy@pool-173-76-100-87.bstnma.fios.verizon.net) has
17:56:13 <overclk> probably by next week, shyam and kotresh would put it up in
17:56:51 <overclk> kshlm, that's about it. probbaly next week much more
17:57:15 <kshlm> No one is here from NSR.
17:57:24 <jdarcy> ?
17:57:29 <overclk> jdarcy just joined :)
17:57:32 <amye> hi jdarcy :)
17:57:33 <kshlm> jdarcy, didn't see you.
17:57:38 <kshlm> Hi!
17:57:44 * obnox waves jdarcy
17:58:08 <jdarcy> Hi all. What's the question about NSR?
17:58:15 <kshlm> Any updates on NSR?
17:58:26 <kshlm> Just a weekly update.
17:58:50 <jdarcy> I got the low-level parts (operation replay) of
17:59:09 <amye> funky how?
17:59:11 <jdarcy> Avra and I have a whole stack of patches that need to get
17:59:22 <jdarcy> amye: Just complicated and weird-looking.
17:59:29 <amye> jdarcy: ack
17:59:40 * ** baojg (~baojg@107.170.0.159) Quit (Remote host closed the
17:59:42 <kshlm> jdarcy, thank you.
17:59:45 * ** hgowtham (hgowtham@nat/redhat/x-yguonlpbhamyzvig) Quit (Quit:
17:59:52 <kshlm> #topic Open Floor
18:00:30 <kshlm> #topic Why is the community meeting so silent?
18:00:37 <kshlm> So can we discuss this here?
18:00:47 * ** ashiq (ashiq@nat/redhat/x-eziealrvsjthkbfg) Quit (Ping timeout:
18:00:55 <kshlm> What do we need to get more voices in here?
18:01:00 <kshlm> Would moving times help?
18:01:11 <ndevos> do we have any ideas how we can improve the community
18:01:14 * ** jiffin1 (Thunderbir@nat/redhat/x-xbnhsoknuembgrdb) has joined
18:01:19 <amye> kshlm: it would certainly help to get US West coast to rotate
18:01:24 <ndevos> (engineers includes developers and qa people)
18:01:47 <kshlm> we'd moved to the current timeslot, to get people in India
18:02:01 <kshlm> But that doesn't seem to have worked.
18:02:18 <amye> Could we have a trial run in say, March, to move this to some
18:02:25 * ** ggarg (ggarg@nat/redhat/x-qancyagbvgmmgcrc) Quit (Ping timeout:
18:02:44 <kshlm> I'm in for having rotating schedules.
18:03:09 <ndevos> who wants to propose a rotating time?
18:03:11 <amye> I will take an AI to propose March rotation on the -devel list
18:03:12 <msvbhat> +1 for rotating the times
18:03:32 <ndevos> and move the current time a little earlier for our friends
18:03:55 <jdarcy> More aggressively promoting the time/place might help. For
18:03:56 <kshlm> #action amye to propose a rotating schedule for community
18:04:03 * ** jiffin (Thunderbir@nat/redhat/x-scnxsrpgvqlvqohq) Quit (Ping
18:04:04 <amye> I think as long as we keep good notes + AIs, we can make this
18:04:04 * ** jiffin1 is now known as jiffin
18:04:08 <amye> jdarcy, ack
18:04:40 <lpabon> here is an example of a rotating meeting by OpenStack Nova:
18:04:55 <kshlm> #url https://wiki.openstack.org/wiki/Meetings/Nova
18:04:56 * ** Humble (hchiramm@nat/redhat/x-baulcvjwvtppfajg) Quit (Ping
18:05:21 * ** Humble (hchiramm@nat/redhat/x-lffswtlhdrgywqta) has joined
18:05:35 <amye> Rotating schedule coming out in March. We can keep Feb the
18:05:50 <amye> Other things for open floor?
18:06:00 <kshlm> I was about to ask the same.
18:06:21 <ndevos> who will be hosting the meeting next week?
18:06:36 <kshlm> I can.
18:06:39 <ndevos> actually, we should put that on the weekly open floor bit
18:06:51 <ndevos> thanks kshlm!
18:07:09 * ** ashiq (ashiq@nat/redhat/x-xofowsshzyarvant) has joined #gluster-
18:07:10 <amye> Release notes - should we update the RTDocs or is what we have
18:07:35 <kshlm> Did we put up release-notes on rtdocs.
18:07:41 <amye> http://gluster.readthedocs.org/en/latest/Contributors-Guide/
18:08:18 <amye> Or am I confusing things? This release process gets us release
18:08:51 <kshlm> Those are the guides. We actually do have release notes at
18:08:51 <ndevos> the release notes should be part of the glusterfs repo, they
18:08:55 <Humble> yes, release notes are part of rtd.
18:09:14 <ndevos> Humble: how do we get the release notes synced from the
18:09:16 <amye> Are the guides that we have currently suitable or do they need
18:09:19 <kshlm> Do the notes get populated at rtd automatically?
18:09:49 <Humble> we have release notes rendered in RTD from glusterdocs
18:09:54 <Humble> not from glusterfs repo..
18:10:24 <Humble> we dont have rendering of glusterfs source code doc repo
18:10:26 <kshlm> Humble, So who adds it to the rtd repo.
18:10:27 <amye> We should at least update this to note what social media
18:10:47 <Humble> its automatic. .as soon as patch is merged in glusterdocs it
18:10:50 <Humble> in RTD.
18:11:11 <Humble> http://gluster.readthedocs.org/en/latest/release-notes/
18:11:12 <kshlm> Humble, but who adds it to the glusterdocs repo?
18:11:22 <Humble> the release maintainer.
18:11:22 <ndevos> but the release-notes are in the glusterfs repo, not
18:11:44 <kshlm> Humble, then we need to have an additional step in the
18:11:49 <ndevos> like https://github.com/gluster/glusterfs/tree/release-3.7/
18:12:13 <kshlm> Can't rtd be configured somehow to pull the notes from the
18:12:39 <amye> That would be awesome. Where do we start with that?
18:12:40 <Humble> we can ..
18:12:44 <ndevos> I always assumed it can, but I have no real clue about it
18:12:58 <Humble> but we need a different poroject in RTD.
18:12:59 <kshlm> So can we set it up then?
18:13:00 <ndevos> who has the power to take care of that?
18:13:08 <Humble> it will confuse users .. Isnt it
18:13:23 <Humble> thats one of the reason for not rendering glusterfs-specs
18:13:48 <ndevos> right, that needs the same solution
18:13:58 <Humble> ndevos, either me or Amye can :)
18:14:22 <ndevos> amye, Humble: who of you can get the #action then?
18:14:23 <kshlm> So until we come up with a solution, release-managers need to
18:14:53 <kshlm> Humble, care to add a note in the release process guide.
18:15:15 <ndevos> maybe, but does glusterdocs have different versions?
18:15:39 <ndevos> the docs should have different version, I guess, but release
18:15:49 <Humble> kshlm, sure.. will do ..
18:16:01 <kshlm> ndevos, what do you mean by different versions?
18:16:04 <Humble> ndevos, http://gluster.readthedocs.org/en/latest/release-
18:16:14 <kshlm> Different versions of the docs ?
18:16:21 <Humble> u have the index page from there u can navigate
18:16:28 * ** aravindavk (aravinda@nat/redhat/x-ercfgghyxaprrpyd) Quit (Ping
18:16:33 <ndevos> docs for 3.7 would be different from 3.8, right? new
18:16:37 <kshlm> They'd be the same in both the glusterfs repo and glusterdocs
18:16:38 <Humble> ndevos, from next version onwards we will have a tagging ..
18:16:49 <Humble> currently only one exist..
18:17:03 <kshlm> ndevos, but the notes are named with different versions so
18:17:13 <Humble> ndevos, again the release notes are arranged in a way where
18:17:18 <Humble> kshlm, yep
18:17:31 <ndevos> kshlm: yes, for the notes yes, I was just wondering if we
18:17:42 <kshlm> ndevos, Oh.
18:17:45 <Humble> only master/latest
18:17:49 <kshlm> Humble can answer that.
18:18:00 <Humble> thats the only branch which is getting rendered.
18:18:21 <kshlm> #action Humble to add a note to https://
18:18:27 <Humble> thanks :)
18:18:43 <kshlm> Okay.
18:18:55 <kshlm> So any more topics to discuss today?
18:19:13 <ndevos> amye, tigert: once that is in place, can the version on
18:19:36 <ndevos> I think it currently lists 3.5.x as latest release...
18:19:39 <amye> ndevos: I think that is separate, that comes from Middleman
18:19:44 <amye> Yep, because it's manual.
18:19:56 <ndevos> so, more steps in the release process? :-/
18:20:05 <amye> So add a note in the release process to 'pester amye '.. yes.
18:20:24 <amye> We can work on making this less manual in the future.
18:20:27 <kshlm> Humble, please add this too :)
18:20:31 <amye> Sorry Humble. :)
18:20:33 <ndevos> amye: I think you can add that to the process page, you can
18:20:43 <amye> 'Please to make an email' :D
18:20:43 <Humble> amye, whats the plan for media wiki migration ? :)
18:20:46 <ndevos> or Humble, I dont mind!
18:20:49 * ** ashiq (ashiq@nat/redhat/x-xofowsshzyarvant) Quit (Ping timeout:
18:20:52 <Humble> amye, np \o/
18:21:18 <amye> Humble: Shaun McC is going to walk us through what he's found
18:21:22 <amye> and we can decide from there.
18:21:31 <Humble> cool .. thanks for the update amye
18:21:38 <amye> we keep finding things from mediawiki that didn't get
18:22:27 <Humble> amye, may be adding an Event Calendar to gluster.org would
18:22:43 <amye> Ack, but please keep the events pad updated if you've
18:22:48 <amye> things like Vault are coming up
18:22:50 <Humble> sure..
18:23:12 <amye> I will be checking on the events pad next week for Monthly
18:23:38 <ndevos> wait, did I not see an email about a calendar for the
18:23:41 <amye> Other things that people want highlighted? I will be
18:24:06 <Humble> https://www.gluster.org/news/
18:24:24 <Humble> amye, do u think updating weekly news in the website is a
18:24:26 <amye> ndevos, ??
18:24:55 <amye> Humble, that's a separate repo, blog.gluster.org/blog is where
18:25:09 <ndevos> hmm, maybe it was in an email search... http://
18:25:12 <Humble> ok.
18:25:38 <kshlm> blog.gluster.org/blog isn't linked to from anywhere on
18:25:50 <kshlm> I can't seem to find a link.
18:26:12 <ndevos> I thought blog.gluster.org is deprecated?
18:26:25 <Humble> ndevos, we could revisit the thread...
18:26:35 <amye> That's where planet feeds from. The home page should be
18:26:54 <Humble> ndevos, yeah, the plan was to deprecate blog.gluster.org
18:27:01 <ndevos> Humble: I think we should pick that up, now we have amye on
18:27:07 <kshlm> blog.gluster.org is the old gluster.org!
18:27:13 <Humble> amye, there you go :)
18:27:15 <amye> We have too many places to update 'news' in. :(
18:27:22 <amye> So let's start consolidating.
18:27:31 <kshlm> Right now?
18:27:33 <kkeithley_> btw, www.gluster.org has breaking news like "Looking for
18:27:42 <Humble> kkeithley_, yeah
18:27:45 <amye> We can double-check with Shaun about what other communities
18:28:17 <amye> #action amye to start killing various news on the gluster.org
18:28:26 <Humble> I think we should enable google indexing for both
18:28:42 <Humble> amye, if we can get some help on that , it would be
18:28:50 <kshlm> #action amye to start killing various news on the
18:30:27 <amye> Ok, I can also take an AI on google indexing for g.o and
18:30:28 <Humble> amye, also we can consolidate gluster videos in gluster.org
18:30:41 <Humble> amye++ , thanks !!
18:30:47 <kshlm> amye will be consolidating everything.
18:30:52 <kshlm> Anyways.
18:31:00 <amye> Who owns the videos?
18:31:11 <kshlm> I think we're done.
18:31:17 <ndevos> Humble: you're also looking into fixing the search on
18:31:29 <kshlm> We've hit the time limit.
18:31:56 <kshlm> I'll end the meeting if we're done.
18:31:59 <Humble> amye, there are different presentation coming from events
18:32:22 <Humble> we have to filter those and place it
18:32:38 <ndevos> #action Humble will try to fix the search results on RTD
18:32:42 <Humble> there is no official channel for us in youtube or similar
18:32:48 <amye> On Blog.gluster.org is where those links have been coming in.
18:33:02 <amye> Sorry, blog.g.o/blog - (yes, that needs to get resolved too)
18:33:22 <amye> kshlm, we can pick this up again. Plenty to do. Thanks for
18:33:32 <kshlm> Okay.
18:33:39 <kshlm> #endmeeting