12:00:05 <kshlm> #startmeeting Gluster Community Weekly Meeting 02-Mar-2016
12:00:06 <zodbot> Meeting started Wed Mar  2 12:00:05 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:06 <zodbot> The meeting name has been set to 'gluster_community_weekly_meeting_02-mar-2016'
12:00:25 <kshlm> Welcome to this weeks meeting.
12:00:33 <kshlm> First up rollcall
12:00:37 <kshlm> #topic rollcall
12:00:47 <josferna_> hi all
12:00:48 * overclk is here
12:00:53 * msvbhat is present
12:01:13 <kshlm> Is this all?
12:01:19 * hchiramm is here
12:01:42 * jiffin is here
12:01:50 <josferna_> hola lpabon !
12:01:58 * aravindavk here
12:01:59 <kshlm> Is this all?
12:02:02 <ggarg> ggarg here
12:02:02 <lpabon> josferna_, buenos dias :-)
12:02:33 <kshlm> Looks like people actually read amye's rescheduling mail.
12:02:54 <overclk> we're not even reaching 10 participants
12:02:56 <kshlm> I hope they read the followup that happened last night/evening/today morning.
12:03:05 * ndevos _o/
12:03:17 <kshlm> Let's start.
12:03:36 <kshlm> As always agenda is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:03:44 <kshlm> #topic Last Weeks AIs.
12:03:54 <kshlm> #topic aravindavk to add Gluster Eventing & REST API support in 3.8 roadmap
12:04:05 <kshlm> aravindavk, Is this done?
12:04:06 <aravindavk> kshlm: done
12:04:12 <kshlm> Do you have a link?
12:04:16 * rastar is here
12:04:23 <post-factum> o/
12:04:31 <aravindavk> kshlm: http://www.gluster.org/community/roadmap/3.8/
12:05:05 <kshlm> Ah, okay.
12:05:11 <kshlm> #url http://www.gluster.org/community/roadmap/3.8/
12:05:14 <kshlm> Thanks aravindavk
12:05:30 <kshlm> Skipping the next two as I know they're not done
12:05:41 * rjoseph is here
12:05:46 <kshlm> #action kkeithley to send a mail about using sanity checker tools in the codebase
12:05:57 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:06:08 <kshlm> I've done the next one.
12:06:25 <kshlm> #topic kshlm to update amye to update the website with latest release notes
12:06:54 <kshlm> The missing notes for 3.7 are now up at https://github.com/gluster/glusterfs/tree/release-3.7/doc/release-notes
12:07:05 <kshlm> amye needs to update the website.
12:07:14 <kshlm> I'll ping her once again on this.
12:07:28 <kshlm> #action kshlm to ping amye to update website to point to correct release
12:07:44 <kshlm> #topic kshlm to follow up with rabhat about 3.6.9 updates
12:07:52 <kshlm> This has been done.
12:08:04 <kshlm> 3.6.9 has been tagged. Just waiting for release.
12:08:16 <kshlm> #topic raghug/kshlm to follow up on maintainers list for a replacement of 3.7.9 release manager
12:08:33 <kshlm> hagarth volunteered to be the manager for the next 2 releases.
12:08:52 <kshlm> This is done as well.
12:09:02 <kshlm> #topic lpabon to review Eventing design
12:09:10 <kshlm> lpabon, Did you do this?
12:09:13 <lpabon> yes
12:09:24 <lpabon> i have also removed my -2 changed to -1
12:09:28 <kshlm> Cool!
12:09:47 <kshlm> #url https://review.gluster.org/13115
12:09:54 <lpabon> yes, it is looking good.  Thanks aravindavk
12:10:05 <aravindavk> thanks lpabon :)
12:10:22 * kshlm was supposed to look at as well.
12:10:47 <kshlm> I'll do that sometime later.
12:10:57 <kshlm> #topic ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:11:05 <kshlm> ndevos just sent it out.
12:11:12 <kshlm> #url http://thread.gmane.org/gmane.comp.file-systems.gluster.maintainers/437
12:11:17 <kshlm> Thanks ndevos
12:11:31 <kshlm> #topic ndevos to announce 3.5.8 availability later this week
12:11:43 <kshlm> ndevos, Was this done?
12:11:52 <ndevos> ah, still waiting for confirmations of packages...
12:12:24 <kshlm> Had I volunteered to build anything for this 3.5.8?
12:12:45 <kshlm> I remember saying I'd do some Debian packaging, but not exactly for which release.
12:12:50 <ndevos> I dont know, nobody sent emails about it to the packaging list
12:13:22 <kshlm> Have any packages been built at all?
12:13:49 <ndevos> I think kkeithley built most (if not all) RPMs
12:14:19 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.maintainers/390/focus=88
12:14:47 <kshlm> Can't we announce with just them?
12:14:57 <kshlm> We cannot keep waiting for ever.
12:15:21 <ndevos> yeah, I guess we can do that
12:15:54 <kshlm> 3.6.9 is pending announcement as well. So can you do this announcement this week?
12:16:05 <kshlm> Just so we get some gap between the two.
12:16:35 <ndevos> and 3.7.9 was supposed to be released a few days back too..
12:16:51 <kshlm> Yup. At least tagged.
12:16:51 <msvbhat> Are the packages built for 3.6.9?
12:16:53 <ndevos> but yes, I can send the announcement today
12:17:06 <kshlm> hagarth was out sick the last 2 days though.
12:17:11 <kshlm> ndevos, thanks.
12:17:28 <kshlm> #action ndevos will send out 3.5.8 announcement after the meeting
12:17:42 <kshlm> Ok. The AIs are done now.
12:17:48 <kshlm> #topic GlusterFs 3.7
12:18:06 <kshlm> So as mentioned already, hagarth volunteered to be the manager for the next two releases.
12:18:33 <kshlm> 3.7.9 was supposed to be tagged earlier this week.
12:18:42 <kshlm> But that didn't happen as hagarth was out sick.
12:19:03 <kshlm> I'll ping hagarth to provide an update on this.
12:19:20 <kshlm> #action kshlm to ask hagarth to provide an update on 3.7.9
12:19:52 <kshlm> Anyone have any additional topics to discuss on 3.7?
12:20:26 <ndevos> I just sent an other backport, maybe it'll make it in?
12:21:11 <kshlm> It's upto hagarth.
12:21:13 * ndevos does not need a response on that, just move on :)
12:21:20 <kshlm> Okay.
12:21:26 <kshlm> #topic GlusterFS 3.6
12:21:45 <kshlm> rabhat tagged the 3.6.9 last week.
12:22:02 <kshlm> He's waiting for packages to be built to make the announcement.
12:22:15 <kshlm> There's nothing more to update.
12:23:11 <kshlm> I can't seem to find the 3.6.9 tag annoucement sent.
12:23:27 <kshlm> Does anyone else have a link to it?
12:23:57 <ndevos> #link http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/89
12:24:25 <kshlm> Thanks ndevos. I was looking at the wrong mailing list.
12:24:40 <kshlm> So any additional topics to discuss for 3.6?
12:25:29 <kshlm> #topci GlusterFS 3.5
12:25:37 <kshlm> #topic GlusterFS 3.5
12:26:15 <kshlm> ndevos, Anything else to add, other than the (todo) announcement?
12:26:57 <ndevos> no patches have been sent, but there is still a week before I consider doing a 3.5.9 release
12:27:15 <ndevos> that's all
12:27:31 <kshlm> Okay. Are you expecting any particular changes?
12:28:28 <ndevos> no, I'm not aware of any urgent bugs
12:28:55 <kshlm> Ok.
12:28:57 <kshlm> Thanks.
12:29:09 <kshlm> #topci GlusterFS 3.8 & 4.0
12:29:29 <kshlm> First up any 3.8 information to be shared?
12:29:51 <post-factum> topci → topic
12:30:02 <kshlm> argh!
12:30:15 <kshlm> #topic GlusterFS 3.8 and 4.0
12:30:21 * msvbhat leaves the meeting now and will read the chatlogs later
12:30:22 <ndevos> msvbhat: maybe you have an update about distaf readiness for 3.8 feature testing?
12:30:25 <kshlm> So any thing to share on 3.8
12:30:37 <msvbhat> ndevos: Ah, Yeah
12:31:07 <msvbhat> ndevos: So, I have made few changes last week. And one of my colleague has some patch it seems.
12:31:47 <msvbhat> ndevos: But other than that anything else is needed fore 3.8 release testing?
12:32:08 <kshlm> msvbhat, How soon can we start writing tests?
12:32:25 <ndevos> msvbhat: we want all new features to provide distaf test-cases, when/how should we start with that
12:32:29 <msvbhat> I will add a HOWTO tomorrow, explaining the details of how to write
12:32:39 <msvbhat> kshlm: Now :)
12:32:45 <kshlm> And how soon can those tests be actually run as a part of the acceptance tests?
12:33:29 <kshlm> #action msvbhat will add a HOWTO for DiSTAF for developers to write tests
12:33:43 <msvbhat> ndevos: As for how, maybe a HOWTO would suffice? I will also try to do a video (with asciinema or normal video)
12:33:50 * kshlm is asking about the progress on centos-ci.
12:34:16 <msvbhat> kshlm: You mean when can we schedule a Jenkins job running distaf tests?
12:34:23 <kshlm> Yeah.
12:34:28 <kshlm> Well I can update that as well.
12:34:32 <ndevos> msvbhat: a HOWTO is definitely needed, but we also need a process to propose/review/include tests somewhere
12:34:45 <msvbhat> kshlm: The centos ci job is still half written. I was on PTO for few days and now i;m lagging behind
12:35:10 <kshlm> ndevos, Why not in the source itself?
12:35:17 <msvbhat> ndevos: Hmm... Maybe I will send a mail later to gluster-devel for suggestions on workflow?
12:35:18 <kshlm> In the glusterfs source.
12:35:29 <kshlm> msvbhat, Do that ASAP.
12:35:46 <ndevos> kshlm: I dont really care where :)
12:36:09 <kshlm> #action msvbhat to mail gluster-devel soliciting opinions on location of DiSTAF tests.
12:36:21 <msvbhat> kshlm: distaf tests in glusterfs source?
12:36:29 <kshlm> Why not?
12:36:43 <overclk> msvbhat, that's the first place to look :)
12:37:02 <msvbhat> kshlm: I do not have a good argument for why not ATM :)
12:37:20 <kshlm> In anycase, I'm working with msvbhat to get the centos-ci jenkins job setup. And same as ms, I've been lagging there as well.
12:37:45 <kshlm> msvbhat, We can continue this on the mailing-lists.
12:37:54 <kshlm> Any other 3.8 updates?
12:38:00 <msvbhat> kshlm: Sure thing. I will send the mail later today
12:38:09 * kshlm has one!
12:38:28 <ndevos> we have nightly builds in the centos-ci already, jenkins jobs could tsart using those ;-)
12:38:34 <ndevos> *start
12:38:51 <kshlm> So one of the features being talked about for 3.8 is subdirectory mount support for native mounts.
12:39:15 <kshlm> I had a good discussion on this with pranithk last week.
12:39:20 <msvbhat> kshlm: I have sent the roadmap update patch to glusterweb. Amye has to merge that. https://github.com/gluster/glusterweb/pull/44
12:39:32 <msvbhat> kshlm: Other update ^^
12:39:56 <kshlm> We'll be putting down the design/spec and starting a discussion on the lists to get initial opinions.
12:40:01 <ndevos> kshlm: discussion in person, or someplace where we can read the logs?
12:40:13 <ndevos> ah, ok!
12:40:21 <kshlm> ndevos, That was in person.
12:40:57 <kshlm> Any 4.0 updates?
12:41:02 <kshlm> overclk, ?
12:41:04 <overclk> yeh
12:41:27 <overclk> we (shyam, myself, kotresh and sushant) had discussion with jdarcy last week on dht2
12:42:07 <kshlm> Any meeting minutes?
12:42:08 <overclk> things are looking good
12:42:20 <overclk> kshlm, just notes here and there.
12:42:38 <kshlm> Can one of you send out the collated notes?
12:42:42 <overclk> kshlm, I'll probably put those in an mail to -devel
12:42:55 <kshlm> Or will jdarcy be sending all of them out enmass?
12:43:13 <overclk> kshlm, I'm not sure about that.
12:43:22 <kshlm> For those who don't know, jdarcy was in Bangalore last week.
12:43:37 <overclk> kshlm, at least with dht2, myself and shyam can do that as there were other discussions too..
12:43:48 <kshlm> And he had a bunch of discussions with developers about the various 4.0 efforts.
12:44:20 <pkalever> How about file level snapshots for 4.0 ?
12:44:21 <kshlm> overclk, Yes. Please do share your notes.
12:44:36 <overclk> kshlm, put an AI on me for DHT2 discussion updates.
12:44:58 <kshlm> #action overclk to share notes from DHT2 discussion with jdarcy
12:45:18 * overclk has nothing else w.r.t. dht2
12:45:25 <kshlm> Similarly to overclk we (GD2 devs) had a discussion with jdarcy.
12:45:29 * msvbhat will afk for rest of the meeting and will read the chatlogs after some time
12:45:38 <kshlm> We discussed plugins, volgen and etcd management.
12:46:07 <kshlm> We'll be pushing notes from the discussions soon (and do RFCs for some of them)
12:47:17 <kshlm> Other than the currently being worked on 4.0 features, the discussions included other things like QOS, brick multiplexing, testing etc.
12:47:44 <kshlm> I expect jdarcy will share all his notes with the community.
12:47:51 <kshlm> Do we put an AI on him?
12:48:51 * overclk thinks yes
12:49:01 <ndevos> +1
12:49:13 <kshlm> I think the same too.
12:49:43 <kshlm> #action jdarcy to share his notes from his Bangalore discussions with the community
12:50:01 <kshlm> #action kshlm/atinm to share notes on the GD2 discussions with jdarcy
12:50:19 <kshlm> So we don't have anyone to provide updates on NSR.
12:50:30 <kshlm> Let's continue onto Open floor.
12:50:36 <kshlm> #topic Open Floor
12:50:37 <overclk> kshlm, it's JBR now ;)
12:50:49 <pkalever> kshlm: How about bringing file level snapshots in 4.0 ?
12:50:54 <kshlm> What?
12:51:39 <kshlm> pkalever, Could you explain it a little more?
12:51:43 <overclk> JBR == Journal Based Replication (that's the name they finalized on)
12:52:09 <kshlm> overclk, was it announced?
12:52:16 <pkalever> kshlm: I would like to work on file level snapshots
12:52:27 <overclk> kshlm, nope. I hope jdarcy will soon.
12:52:39 * overclk will continue after pkalever
12:52:52 <pkalever> as you know yesterday I have posted the detailed mail in devel
12:53:05 <kshlm> pkalever, link please?
12:53:34 <pkalever> #link https://public.pad.fsfe.org/p/Snapshots_in_glusterfs
12:54:00 <kshlm> Have you had any replies yet?
12:55:01 * ndevos has some comments, but did not manage to find time to write an email about it
12:55:01 <pkalever> kshlm: not yet, but I see people are interested some of the teams approached in person
12:55:20 <overclk> pkalever,
12:55:25 <overclk> pkalever, "teams" as in?
12:55:39 <kshlm> pkalever, Please ask them to reply to the mailing  list.
12:55:59 <ndevos> pkalever: "in person" does not help anyone outside of your cubicle, please make sure to get their feedback on the list
12:56:14 <ndevos> kshlm++ "D
12:56:18 <pkalever> kshlm: ndevos thats right
12:57:30 <kshlm> pkalever, Could also share whatever you've discussed till now on the mail thread?
12:57:39 <kshlm> That will be helpful to everyone.
12:58:16 <kshlm> This way the discussion will grow, instead of stagnating and being forgotten.
12:59:16 * pkalever agree with kshlm
12:59:30 <kshlm> We're running out of time and we have one topic left.
12:59:40 <overclk> I have one
12:59:43 <kshlm> #topic overclk: MAINTAINER addition - http://review.gluster.org/#/c/11171/
13:00:07 <overclk> yeh, it's there for about 10 months.
13:00:21 <overclk> last time I checked with hagarth, he was planning monthly maintainer addition
13:00:39 <overclk> but didn't hear anything after that...
13:01:42 <kshlm> I'd say we update whenever we have a new maintainer.
13:01:59 <kshlm> Why should we wait a month to do it?
13:02:01 <overclk> kshlm, ah good.
13:02:15 <kshlm> That's my opinion though.
13:02:35 <kshlm> But I believe everyone will agree with it.
13:02:36 <overclk> kshlm, my opinion too. anyone else has any other opinion?
13:02:54 <overclk> ndevos, aravindavk, hagarth?
13:03:11 <kshlm> hagarth isn't online
13:03:19 <ndevos> sounds good to me, but the responsibilities of maintainers need to be very clear
13:03:33 <overclk> kshlm, at least he'll check that we "want" his opinion :)
13:04:17 <kshlm> ndevos, Is the Maintainers document on rtd good enough?
13:04:20 <overclk> ndevos, should we have a minimum criteria kind o foist for maintainers.
13:04:22 <kshlm> #link https://gluster.readthedocs.org/en/latest/Contributors-Guide/Guidelines-For-Maintainers/
13:04:36 <overclk> s/o foist/of list/
13:04:52 <ndevos> yeah, that is a good start
13:05:08 * aravindavk is happy to take new responsibility :)
13:05:16 <ndevos> and I guess the new maintainer should also subscribe to the maintainers list, and send an introduction/request there
13:05:35 <kshlm> ndevos, What changes would you like to see in the document?
13:06:03 <overclk> also, if maintainership is being transferred, the current maintainer can propose the change in the community.
13:06:17 * kshlm would like to see it correctly formatted first
13:06:48 <ndevos> kshlm: when someone would be able to get maintainership, and how to apply for that (or get proposed by others)
13:07:12 <kshlm> I'd also like to see explicit responsibilities for the maintainers, sub-maintainers and release-maintainers mentioned.
13:07:29 <ndevos> indeed, there are differences there
13:07:55 <kshlm> ndevos, I can start a discussion on this on the maintainers list. We can evolve the document there.
13:08:05 <ndevos> kshlm: sure
13:08:15 <kshlm> #action kshlm to start discussion on improving maintainer documentation https://gluster.readthedocs.org/en/latest/Contributors-Guide/Guidelines-For-Maintainers/
13:08:47 <kshlm> overclk, Do you have anything further to discuss about this?
13:08:57 <overclk> kshlm, nope. thanks!
13:09:04 <kshlm> Cool thanks.
13:09:07 <overclk> I'll act on the patch after the discussions.
13:09:20 <kshlm> So we're done for today, only announcements remaining.
13:09:30 <kshlm> IMPORTANT ANNOUNCEMENT
13:09:41 <kshlm> Next weeks meeting (and the one on 25th) will be held at 1500UTC
13:10:14 <ndevos> #info Next weeks meeting (and the one on 25th) will be held at 1500UTC
13:10:17 <kshlm> This is wrt to the rotating schedules we're trying out this mont.
13:10:55 <kshlm> I'll be sending a proper calendar invite with the minutes mail after the meeting.
13:11:14 <kshlm> And the general announcements
13:11:15 <kshlm> If you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:11:15 <kshlm> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:11:15 <kshlm> Use the following etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:11:34 <kshlm> And that's it.
13:11:44 <kshlm> Thanks for attending todays meeting everyone.
13:11:47 <ndevos> thanks kshlm!
13:11:48 <overclk> cool, thanks kshlm
13:11:52 <kshlm> #endmeeting