12:00:25 <skoduri> #startmeeting Gluster Bug Triage
12:00:26 <zodbot> Meeting started Tue Mar 15 12:00:25 2016 UTC.  The chair is skoduri. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:26 <zodbot> The meeting name has been set to 'gluster_bug_triage'
12:00:39 <skoduri> #info agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:00:39 <skoduri> #topic Roll Call
12:00:50 * jiffin is here
12:00:54 <ggarg> ggarg is here
12:01:02 <skoduri> anyone else?
12:01:20 <skoduri> Manikandan, rafi , ashiq_ ?
12:01:41 * ashiq_ is here
12:01:52 * Saravanakmr is here
12:02:06 <skoduri> okay cool... lets start then
12:02:11 * post-factum is here but going to leave soon
12:02:27 <skoduri> #topic kkeithley_ will come up with a proposal to reduce the number of bugs against "mainline" in NEW state
12:02:41 <skoduri> kkeithley is not here ..but I have an update from him
12:03:19 <skoduri> the bugs which were in NEW state when this AI was added were all closed when the mainline is branched out for 3.7
12:04:05 <skoduri> so this AI doesn't hold now
12:04:05 <jiffin> skoduri: k
12:04:52 <skoduri> #info  bugs against "mainline" in NEW state were addressed when 3.7 branched out
12:05:00 <skoduri> moving on
12:05:03 <skoduri> #topic     hagarth start/sync email on regular (nightly) automated tests
12:05:10 <skoduri> hagarth, are you around?
12:05:31 * Manikandan arrives late
12:05:35 <skoduri> Looks like no..
12:05:41 <skoduri> do we have msvbhat ?
12:06:12 * msvbhat is reading
12:06:22 <skoduri> cool..we have couple AIs on you
12:06:32 <skoduri> #topic msvbhat  will look into using nightly builds for automated testing, and will report issues/success to the mailinglist
12:06:46 <skoduri> msvbhat, do you have any update on this?
12:06:50 <msvbhat> skoduri: I have forgottten these AI :)
12:07:01 * hgowtham is a bit late
12:07:05 <skoduri> :) ..no problm .consider this as reminder
12:07:07 <msvbhat> skoduri: Yes, For nightly builds we have them in CentOS CI
12:07:27 <msvbhat> ndevos is the one who got them done.
12:07:48 <skoduri> msvbhat, oh great...then we can consider it done
12:07:56 <msvbhat> skoduri: But outside of CentOS CI, I don't have any update
12:08:13 <msvbhat> skoduri: Because we don't have all pieces of infra ready
12:08:33 <msvbhat> skoduri: And we have aJenkins job which makes use of it.
12:08:36 <skoduri> msvbhat, anyways we are planning to use CentOS  CI for upstream testi moving forward right?
12:09:05 <msvbhat> skoduri: I'm not sure if that's the end-goal. But at least for now, Yes
12:09:30 <skoduri> #info nightly builds are used in CentOS CI upstream regression testing
12:09:49 <skoduri> msvbhat, thanks...moving to your next AI
12:10:00 <skoduri> #topic     msvbhat            will look into lalatenduM's automated Coverity setup in Jenkins         which    need assistance  from an admin with more permissions
12:10:27 <msvbhat> skoduri: Oh, This is pending from many months :(
12:10:47 <msvbhat> skoduri: I will catch hold of lalatenduM before next week's meeting and get this done.
12:10:48 <skoduri> msvbhat, okay :).. I shall post-pone it for now then..
12:11:08 <skoduri> #action   msvbhat            will look into lalatenduM's automated Coverity setup in Jenkins         which    need assistance  from an admin with more permissions
12:11:14 <skoduri> next one
12:11:22 <skoduri> #topic msvbhat  and ndevos need to think about and decide how to provide/use debug builds
12:11:56 <skoduri> ndevos also couldn't join today's call..
12:12:01 <skoduri> msvbhat, do you have any update?
12:12:24 <msvbhat> skoduri: No, I had forgotten these AIs actually.
12:12:40 <msvbhat> skoduri: Let me discuss this with Niels this week
12:12:54 <skoduri> okay sure..then will add it for next week
12:13:02 <skoduri> #action  msvbhat  and ndevos need to think about and decide how to provide/use debug builds
12:13:05 <msvbhat> skoduri: please defer to next week. I will update by then
12:13:11 <skoduri> #topic msvbhat  provide a simple step/walk-through on how to provide testcases for the nightly rpm tests
12:13:16 <skoduri> how about this?
12:13:32 <skoduri> msvbhat, next week?
12:13:57 <msvbhat> skoduri: No, I don't remember the context :) Was it how to provide distaf testcases for nightly rpms?
12:14:23 <msvbhat> skoduri: If Yes, it will be done by tomorrow. I'm halfway through writing a proper README and HOWTO
12:14:57 <skoduri> msvbhat, :)..well I am not sure when this AI was added..but considering that we are planning to shift/focus on distaf, it makes sense to have a write-up on it
12:15:02 <skoduri> great
12:15:11 <skoduri> I will keep it for next week
12:15:24 <skoduri> #action msvbhat  provide a simple step/walk-through on how to provide distaf testcases for the nightly rpm tests
12:15:36 <msvbhat> skoduri: Sure. But I have this AI in weekly gluster meeting. And I'm on course for completion :)
12:16:08 <skoduri> msvbhat, oh okay..let us then remove it from this meeting agenda as well next week :)
12:16:14 * msvbhat hopes there are no AI on him anymore :)
12:16:31 <skoduri> yes no more on you :)
12:16:37 <skoduri> #topic     ndevos to propose some test-cases for minimal libgfapi test
12:16:41 <msvbhat> \o/
12:16:44 <skoduri> I have an update on this..
12:17:04 <skoduri> ndevos mentioned that there libgfapi-python tests which run on nightly builds
12:17:33 <skoduri> so it is partially done..will still carry-forward this AI
12:17:42 <skoduri> #action  ndevos to propose some test-cases for minimal libgfapi test
12:17:56 <skoduri> #info there are libgfapi-python tests which run on nightly builds
12:18:06 <skoduri> moving on
12:18:14 <skoduri> #topic Manikandan and Nandaja will update on bug automation
12:18:23 <skoduri> Manikandan, gem ..any update on this ?
12:18:25 <Manikandan> We are still waiting for access to gerrit hook scripts and both of us are a bit held up right now
12:19:00 <skoduri> Manikandan, okay...will add it for next week then
12:19:04 <skoduri> #action Manikandan and Nandaja will update on bug automation
12:19:16 <skoduri> I guess we are done with AIs..
12:19:19 <Manikandan> skoduri, cool :)
12:19:21 <skoduri> moving to group triage
12:19:30 <skoduri> #topic Group Triage
12:19:39 <skoduri> #link https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:20:03 <skoduri> please follow the guidelines mentioned in the etherpad while triaging bugs
12:22:14 <Manikandan> hgowtham, would you like this to take this bug - https://bugzilla.redhat.com/show_bug.cgi?id=1315735
12:22:14 <glusterbot> Bug 1315735: unspecified, unspecified, ---, bugs, NEW , Tier: Possible crash/undefined behaviour if thread creation fails
12:22:29 <Manikandan> or may be joseph
12:22:33 <hgowtham> Manikandan, sure
12:22:41 <Manikandan> hgowtham, I guess it should be easier
12:22:45 <Manikandan> hgowtham, cool thanks
12:27:34 <hgowtham> the bug are triaged
12:28:01 <Manikandan> hgowtham, ?
12:28:31 <hgowtham> Manikandan,  yes
12:29:03 <ggarg> bug triaging have done
12:29:12 <skoduri> yes
12:29:21 <skoduri> and a big cheers to the team..
12:29:50 <skoduri> we seem to have triaged all the outstanding bugs even from backlog
12:29:56 <Manikandan> skoduri, yep
12:29:57 <skoduri> \o/
12:30:26 <skoduri> #topic Open Floor
12:30:29 <hgowtham> :)
12:30:50 <skoduri> I have an update from and for kkeithle
12:31:17 <skoduri> #action kkeithle to propose a process of closing bugs against *mainline*
12:32:06 <skoduri> any other topics we need to discuss about?
12:32:20 <Manikandan> skoduri, nothing from me
12:32:44 <skoduri> I think its saravana who should be hosting next week meetings
12:33:03 <skoduri> he seem to have logged off..
12:33:33 <ggarg> skoduri, yeah saravana showed his interest
12:33:34 <skoduri> Does anyone know if he shall host next week meeting?
12:33:54 <skoduri> ggarg, okay cool..I shall add that
12:34:07 <ggarg> skoduri, its already added. just need to remind him
12:34:11 <skoduri> so its
12:34:12 <skoduri> saravanakmr will host meeting on March 22nd
12:34:12 <skoduri> Manikandan will host meeting on March 29th
12:34:22 <hgowtham> (y)
12:34:26 <skoduri> cool..anything else?
12:34:37 <hgowtham> nothing from my side
12:34:44 <ggarg> nothing from my side
12:34:57 <skoduri> okay,,will end the meeting then..
12:35:02 <skoduri> thank you all for attending :)
12:35:07 <skoduri> #endmeeting