15:01:57 <kshlm> #startmeeting Weekly Community Meeting
15:01:57 <zodbot> Meeting started Wed Mar 23 15:01:57 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:57 <zodbot> The meeting name has been set to 'weekly_community_meeting'
15:02:00 <kshlm> Hi all!
15:02:08 <post-factum> \o/
15:02:09 <kshlm> Welcome to today's meeting
15:02:16 <kshlm> #topic Rollcall
15:02:20 * overclk is here
15:02:22 * shyam is here
15:02:28 * post-factum is here
15:02:33 * jdarcy o_O
15:02:41 * atinm waves
15:02:55 * Jiffin is here
15:03:17 <kshlm> Good let's start.
15:03:32 * JoeJulian nods.
15:03:54 <kshlm> As always the agenda is available at https://public.pad.fsfe.org/p/gluster-community-meetings
15:04:13 <kshlm> #topic Next's weeks meeting moderator
15:04:30 <kshlm> Since I always keep forgetting this, let's do this first today.
15:04:38 <atinm> kshlm, +1
15:04:43 <post-factum> wise step!
15:04:46 <kshlm> Any volunteers for hosting next weeks meeting?
15:05:05 <kshlm> atinm, +1 for being the next weeks host?
15:05:17 <atinm> kshlm, a big NO
15:05:24 <kshlm> Anyone else?
15:05:30 <shyam> kshlm: Is it at the same time as today's meeting?
15:05:46 <kshlm> Nope. It's back to 12UTC next week.
15:05:58 * msvbhat arrives bit late
15:06:05 <kshlm> I dunno if we'll be continuing the rotating times into April.
15:06:09 <kshlm> We should have a vote on it.
15:06:38 <shyam> ok, then I cannot volunteer for the 12:00 UTC slot, sorry
15:06:43 <atinm> kshlm, I don't like this model where only few people would be hosting every time
15:07:06 <kshlm> shyam, Thanks for the interest.
15:07:16 <post-factum> 18:00 CET (Amsterdam, etc.) ← I believe this should be 16:00 CET (in pad)
15:07:16 <kshlm> Maybe you can host the next 15UTC meeting.
15:07:17 <jdarcy> I nominate myself.
15:07:28 <kshlm> Thanks jdarcy!
15:07:32 <JoeJulian> I'd offer but I'll be at a conference.
15:07:32 <shyam> kshlm: yes, I can take the 15UTC one
15:07:53 <atinm> jdarcy, thank you!
15:08:06 <kshlm> #info jdacy will host the community meeting on 30/Mar/2016
15:08:11 <kshlm> Okay.
15:08:21 <kshlm> Onto last weeks AIs.
15:08:27 <kshlm> #topic Last weeks AIs
15:08:40 <kshlm> #topic kkeithley to send a mail about using sanity checker tools in the codebase
15:08:57 <kshlm> This hasn't been done yet.
15:09:12 <kshlm> I'll carry it forward.
15:09:16 <kshlm> #action kkeithley to send a mail about using sanity checker tools in the codebase
15:09:34 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
15:09:39 <kshlm> Again not done.
15:09:50 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
15:10:01 <kshlm> #topic msvbhat will add a HOWTO for DiSTAF for developers to write tests
15:10:10 <kshlm> msvbhat, How's this coming along?
15:10:36 <kshlm> You'd shared a small snippet yesterday.
15:11:13 <kshlm> msvbhat, Are you still here?
15:11:16 <msvbhat> kshlm: That's done
15:11:22 <kshlm> Good to know.
15:11:25 * msvbhat fetching links
15:11:33 <kshlm> I was just about to ask for them
15:11:37 <msvbhat> https://github.com/gluster/distaf/blob/master/docs/HOWTO.md
15:11:43 <msvbhat> and
15:11:44 <msvbhat> https://github.com/gluster/distaf/blob/master/README.md
15:11:55 <kshlm> Thanks msvbhat
15:12:02 <JoeJulian> #info https://github.com/gluster/distaf/blob/master/docs/HOWTO.md
15:12:05 <JoeJulian> #info https://github.com/gluster/distaf/blob/master/README.md
15:12:08 <kshlm> It'll be nice if you announce on the mailing list as well.
15:12:08 <msvbhat> There are some small mistakes (spellcheck etc) I will send different patch to that
15:12:31 <msvbhat> Yes, I will do that after running a spell check and proof reading it once
15:12:31 <jdarcy> Should we try to get these somewhere more visible?
15:12:43 <kshlm> jdarcy, More visible as in?
15:12:51 <amye> A blog post? :D
15:12:57 * amye is only halfway here
15:12:59 <msvbhat> jdarcy: I wish to make a asciinema + video next week
15:13:06 <msvbhat> amye: ^^
15:13:13 <jdarcy> msvbhat: That would be awesome.
15:13:37 <jdarcy> kshlm: Blog post would be good, somewhere on the development-workflow page too.
15:14:12 <msvbhat> Okay, There is one more question I wish to ask, but will wait for the open floor
15:14:30 <kshlm> Wouldn't the mailing list be enough?
15:14:48 <JoeJulian> +1 for workflow page
15:14:57 <amye> +1 for workflow page :)
15:15:04 <JoeJulian> New developers should be able to find what they need in one place.
15:15:22 <kshlm> Sorry guys got disconnected.
15:15:31 <kshlm> So I'm assuming it proposed to add distaf to the dev workflow guide?
15:15:36 <kshlm> +1 from me.
15:15:52 <kshlm> msvbhat, Could you do this as well?
15:15:59 <msvbhat> Okay...
15:16:03 <kshlm> THanks.
15:16:15 <kshlm> #action msvbhat to announce DiSTAF HOWTO on mailing lists
15:16:22 <msvbhat> So to be precise, I need to add these links to workflow page with small description right?
15:16:28 <msvbhat> jdarcy: ^^ ???
15:16:37 <kshlm> #action msvbhat to add links to DiSTAF on the dev workflow page.
15:16:43 <kshlm> msvbhat, Yup.
15:16:55 <jdarcy> msvbhat: Correct.
15:17:14 <msvbhat> Great, Will
15:17:17 <msvbhat> *will do
15:17:21 <kshlm> Thanks msvbhat
15:17:28 <kshlm> #topic overclk to share notes from DHT2 discussion with jdarcy
15:17:46 <overclk> kshlm, here's the link: http://www.gluster.org/pipermail/gluster-devel/2016-March/048874.html
15:17:47 <kshlm> overclk, I saw your mail. Could you add a link here please.
15:17:57 <kshlm> Thank you.
15:18:05 <kshlm> #url http://www.gluster.org/pipermail/gluster-devel/2016-March/048874.html
15:18:08 <kshlm> Thanks overclk
15:18:23 <kshlm> #topic jdarcy to share his notes from his Bangalore discussions with the community
15:18:31 <jdarcy> Not done.  Will do today.
15:18:50 <kshlm> Good to know. I'll carry this over.
15:18:54 <kshlm> #action jdarcy to share his notes from his Bangalore discussions with the community
15:19:07 <kshlm> #topic kshlm to ping jdarcy to share his notes
15:19:12 <jdarcy> Just did.  ;)
15:19:17 <kshlm> Well I pinged right now.
15:19:21 <kshlm> So done.
15:19:36 <kshlm> This is probably the latest anyone will ever complete an AI.
15:19:48 <kshlm> :)
15:19:55 <kshlm> #topic ndevos to reach out to packagers about 3.5.9 packaging
15:20:23 <kshlm> I don't remember seeing any mails on the packaging list.
15:20:30 <kshlm> So this is being carried over as well.
15:20:33 <kshlm> #action ndevos to reach out to packagers about 3.5.9 packaging
15:20:47 <kshlm> We're done with the AIs
15:20:54 <kshlm> #topic GlusterFS 3.7
15:21:02 <jdarcy> In other AI news, AlphaGo defeated Lee Sedol.  ;)
15:21:11 <kshlm> 3.7.9 was released! Hurray!
15:21:17 <jdarcy> Yay!
15:21:38 <post-factum> yep, and still not all memleak patches included :(
15:21:55 <shyam> jdarcy: so that's 3-1 to AlphaGo I presume
15:22:20 <kshlm> post-factum, We'll try to get them all in 3.7.10
15:22:57 <kshlm> Can someone find the link to hagarth's announcement email?
15:23:08 <kshlm> I can't seem to find it in gmane/
15:23:21 <jdarcy> I don't see any memory-leak patches still pending on Gerrit.  Any links?
15:23:42 <post-factum> #link https://www.gluster.org/pipermail/gluster-devel/2016-March/048845.html
15:23:49 <Jiffin> #link http://www.gluster.org/pipermail/gluster-devel/2016-March/048845.html
15:24:07 <kshlm> Thanks post-factum & jiffin
15:24:09 <post-factum> #link https://bugzilla.redhat.com/show_bug.cgi?id=1318376#c3
15:24:09 <glusterbot> Bug 1318376: unspecified, unspecified, ---, vbellur, ASSIGNED , Tracker for glusterfs-3.7.10
15:24:19 <post-factum> discussed with skoduri ^^
15:24:33 <post-factum> comment #3
15:25:13 <jdarcy> OK, so 2/3 are merged in master.  Is this a problem with missing backports, then?
15:25:29 <post-factum> correct, 3.7 does not have that backported
15:25:43 <post-factum> anyway, we've just cherry-picked them for own build :)
15:25:56 <skoduri> jdarcy, since rpc_* related fixes are very intricate and resulting other regressions, wedecide to give them enough soak-in time before backporting to stable branch
15:26:15 <skoduri> *we decided
15:26:43 <skoduri> since 3.7.10 release shall be a month away, we can take them then
15:26:45 <jdarcy> OK, that's fine.  Just wanted to understand the context.
15:27:03 <post-factum> also, any comments on this:
15:27:07 <post-factum> #link https://bugzilla.redhat.com/show_bug.cgi?id=1318289
15:27:08 <glusterbot> Bug 1318289: low, unspecified, ---, ravishankar, NEW , [RFE] Add arbiter brick hotplug
15:27:15 <post-factum> ?
15:27:23 <kshlm> skoduri, How much soak-in time do you think you need?
15:27:23 <kshlm> Will they be in for 3.7.10?
15:27:24 <kshlm> (which according to schedule should be tagged next week)
15:28:11 <skoduri> kshlm, As  I mentioned above as we have a month time for 3.7.10 to be released, we can take in that release I suppose
15:28:34 <kshlm> skoduri, But we do not infact have a month.
15:28:38 <post-factum> :)
15:28:38 <atinm> skoduri, that's not right
15:28:53 <skoduri> kshlm, oh
15:29:16 <skoduri> sorry but I thought all the releases have a month gap (3.7 atleast)
15:29:20 <kshlm> So now lets come to the topic of 3.7.10
15:29:21 <jdarcy> That brings up a point regarding process.  As a general rule, minor releases are supposed to be about bug fixes and not new features.  Is this worth an exception?
15:30:46 <post-factum> 3.7.9, for example, introduced new features like fallocate/discard with sharding
15:30:59 <atinm> skoduri, if we go with the schedule then we do have a month's gap, but 3.7.9 is already delayed and we had some conversation around the release schedule in one of the last meetings and people voted to stick to the release schedule
15:30:59 <kshlm> jdarcy, Ideally minor releases should just be bug-fixes. But we don't seem to be doing that.
15:31:42 <kshlm> But this seems to be an enhancement to a larger feature.
15:31:53 <skoduri> atinm, thanks..sorry I had missed the details
15:32:03 <atinm> skoduri, no issues :)
15:32:32 <JoeJulian> If an enhancement makes data safer and/or the system more stable, then I think it should be the exception to the bug-fix-only rule.
15:33:09 <kshlm> What would add-brick support for arbiter come under?
15:33:14 <jdarcy> I'm OK with that.
15:33:32 <post-factum> it definitely makes data safer within existing feature
15:33:35 <JoeJulian> kshlm: imho, both.
15:33:47 <kshlm> post-factum, I think so too.
15:33:51 <kshlm> JoeJulian, yup.
15:34:18 <kshlm> So this can be taken in, if Ravi finishes the change.
15:34:48 <kshlm> Cool.
15:35:00 <kshlm> Now I'd like to also discuss 3.7.10 release times.
15:35:12 <kshlm> We've nearly slipped by a month for 3.7.9,
15:35:25 <kshlm> So should we still try and stick to 30th for 3.7.10?
15:35:56 <post-factum> it is only one week from now
15:36:00 <kshlm> post-factum, Yup.
15:36:15 <atinm> kshlm, if we have some volume (say ~20 patches) I will still stick to it
15:36:25 <msvbhat> How many fixes can go in before 30th?
15:36:41 <kshlm> But from our history, we know it takes at least 1 more week to get the packages ready and announcement to be made.
15:36:51 <post-factum> shortlog:
15:36:53 <post-factum> #link http://termbin.com/4nus2
15:37:29 <kshlm> Oh wow!
15:37:38 <kshlm> We've got so many changes merged already!
15:38:16 <kshlm> if this pace continues we should have a good enough volume of fixes coming in.
15:38:34 <kshlm> So I think we still should target 30th.
15:38:43 <kshlm> Does everyone agree?
15:39:09 * msvbhat nods
15:39:13 <post-factum> 79 files changed, 1897 insertions(+), 532 deletions(-) :)
15:39:34 <JoeJulian> Looks worthy to me
15:39:36 <atinm> kshlm, I do
15:39:58 <kshlm> #agreed Stick to 30th for 3.7.10
15:40:15 <kshlm> post-factum, You should be getting your fixes soon :)
15:40:18 <skoduri> post-factum , one of those rpc_* fixes is not yet reviewed/merged in master ...we shall then try to back-port already merged patches (at-least) provided regression tests pass of-course
15:40:43 <post-factum> kshlm: skoduri: thx, we are also testing them now
15:40:57 <atinm> kshlm, can you send a note to hagarth as well since he will also manage 3.7.10?
15:41:06 <kshlm> atinm, I will.
15:41:31 <kshlm> #action kshlm to update hagarth of 3.7.10 date
15:41:36 <kshlm> Okay.
15:41:44 <kshlm> So anything else on 3.7?
15:42:00 <kshlm> Good.
15:42:06 <kshlm> #topic GlusterFS 3.6
15:42:20 <kshlm> I've got no clue what's happening in 3.6 recently.
15:42:33 <kshlm> Is raghu / rabhat around?
15:44:28 <kshlm> I guess rabhat needs to be prodded.
15:44:41 <kshlm> 3.6.10 due tagging on the 20th.
15:44:51 <JoeJulian> I should check post-factum's list of memory leaks against 3.6 and see if I need any of them.
15:44:58 <kshlm> s/due/was due/
15:45:24 <post-factum> JoeJulian: you may look at 3.7.7/8/9 tracking bugs. I listed them all there
15:45:34 <post-factum> oh, and 3.7.10 as well
15:45:44 <kshlm> Add them to the 3.6.10 tracker
15:45:53 <kshlm> #url https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.10
15:45:54 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
15:46:00 <JoeJulian> Will do.
15:46:09 <kshlm> #action kshlm to ask rabhat for an update on 3.6.10
15:46:27 <kshlm> I don't think we have anything further to add on 3.6
15:46:30 <kshlm> So..
15:46:36 <kshlm> #topic GlusterFS 3.5
15:47:12 <post-factum> silence
15:47:34 <kshlm> None of the release-maintainers are here.
15:47:37 <kshlm> :/
15:48:38 <kshlm> 3.5.9 has been tagged, but hasn't been announced yet.
15:48:48 <amye> Makes it tricky to get release conversation going.
15:48:55 <kshlm> ndevos should have just gotten back home.
15:49:39 <jdarcy> kshlm: From BLR?
15:50:36 <msvbhat> Yes
15:53:18 * msvbhat looks around for kshlm
15:53:43 <post-factum> oh, seems to be disconnected
15:54:22 <jdarcy> Come back, kshlm.  We miss you.
15:54:26 <msvbhat> :)
15:54:31 <atinm> jdarcy, :)
15:54:31 <post-factum> ant failover here :)?
15:54:35 <post-factum> *any
15:54:48 * msvbhat votes for atinm :)
15:55:01 <atinm> kshlm is back!
15:55:02 <overclk> here.. he's back..
15:55:03 * jdarcy \o/
15:55:22 <kshlm> This is embrassing. I got disconnected again.
15:55:39 <kshlm> Where was I?
15:55:41 <atinm> and we just have 5 more minutes as per schedule
15:55:43 <post-factum> 3.5
15:55:43 <JoeJulian> You really should build a better internet provider.
15:55:43 <jdarcy> It's OK, no split-brains were created.
15:56:06 <kshlm> JoeJulian, The problem is there are none better around my home :/
15:56:18 <JoeJulian> That's why you have to build it. ;)
15:56:26 <post-factum> JoeJulian++
15:56:28 <glusterbot> post-factum: JoeJulian's karma is now 4
15:56:42 <kshlm> So we were discussing 3.5 was it.
15:57:02 <JoeJulian> Or discussing the lack of ability to discuss 3.5.
15:57:16 <kshlm> Yup. No maintainers around.
15:57:18 <post-factum> kshlm: no ndevos here, so go on
15:57:31 <kshlm> In anycase, I'll be pinging ndevos for an update.
15:57:39 <jdarcy> That's going to make it hard to talk about 3.8 either.
15:57:40 <kshlm> #topic GlusterFS 3.8 & 4.0
15:57:54 <atinm> Jiffin, can you talk about 3.8 ?
15:58:09 <Jiffin> GlusterFS 3.8 is progressing well
15:58:10 <kshlm> I forgot jiffin was around!
15:58:36 <Jiffin> few features in roadmap still misses the feature page
15:59:02 <atinm> Jiffin, so as per ndevos'es mail have you guys taken an action ;)
15:59:02 <Jiffin> I send out a  reminder to feature owners
15:59:26 <Jiffin> #link http://www.gluster.org/pipermail/gluster-devel/2016-March/048847.html
15:59:31 <Jiffin> atinm, yes
16:00:31 <Jiffin> those features will move to "at risk" category in 3.8 roadmap
16:00:36 <kshlm> IIRC, ndevos said that he wouldn't accept any new features without feature pages after last sunday.
16:00:45 <atinm> Jiffin, I was actually not talking about a reminder
16:01:02 <kshlm> Is this still true? Or are you still waiting for the stragglers?
16:01:10 <Jiffin> atinm, K
16:01:21 <atinm> Jiffin, yup, that's what I meant what kshlm is saying
16:02:01 <Jiffin> kshlm waiting for  couple of days
16:02:18 <kshlm> Jiffin, Okay.
16:02:23 <kshlm> #link https://www.gluster.org/community/roadmap/3.8/
16:02:30 <kshlm> Thanks for the update Jiffin
16:02:38 <kshlm> So onto 4.0.
16:02:51 <atinm> jdarcy, over to you?
16:02:55 <kshlm> We should have a better showing here.
16:03:06 <jdarcy> Back to NSR, pushing patches, etc.  :)
16:03:32 <jdarcy> I'll let Atin and Shyam talk about their pieces.
16:03:37 <shyam> dht2 we are getting back to design and coding after a hiatus
16:04:01 <shyam> dht2 POC was done, but out of the gluster git tree
16:04:21 <shyam> We are restarting coding afresh on master
16:04:44 <shyam> For dht2 in the near future, expect more design documents and some code to trickle in
16:04:56 * shyam is done with his update
16:05:07 <kshlm> shyam, Awesome.
16:05:15 <kshlm> atinm, Now you.
16:05:53 * kshlm doesn't think a lot of progress has happened on GD2 over the last couple of weeks.
16:06:00 <atinm> As far GD2.0 is concerned myself and kshlm shared couple of updates, one was on ETCD bootstrapping and the other on the design discussion with jdarcy on flexi volgen, plugin etc
16:06:25 * kshlm hasn't had much progress anyway.
16:06:28 <jdarcy> I should round all this up into a blog post or something.
16:06:36 <atinm> I am getting a bit ambitious now to move GD2 repo into experimental folder in main repo
16:06:47 <shyam> atinm: yay!
16:06:56 <kshlm> atinm, I'm not still sure if we should.
16:07:03 <kshlm> Right away.
16:07:18 <atinm> kshlm, why do you think that so?
16:07:20 <kshlm> But we can start figuring out how we will move.
16:07:28 <atinm> kshlm, because its still not matured enough?
16:07:30 <kshlm> Still way too much to be done IMO.
16:08:13 <atinm> but there is no harm at the same time if we move it to the main repo
16:08:40 <atinm> there will be an effort required which would be one time and I don't find any strong reason why we can't spend that right away
16:09:45 <atinm> And yes once we get the transaction framework patch ready we should be able to fit the volume commands following the framework
16:09:52 <kshlm> atinm, It will slow down our current efforts a lot.
16:09:57 <atinm> that's kind of an overall plan for the coming month
16:10:04 * atinm is done with his parts
16:10:27 <kshlm> Moving into the main repo will require investing time figuring out proper build mechanism.
16:10:54 <kshlm> This is going to take a lot of effort right now.
16:10:56 <jdarcy> Pretty soon we'll have to figure out how to deal with building a golang executable as part of our patch-acceptance process.
16:11:04 <atinm> kshlm, my whole point is if you do it now or do it later, effort wise it would be same
16:11:43 <kshlm> Let's take continue this discussion later.
16:12:18 <kshlm> We're way over time.
16:12:20 <atinm> kshlm, we can debate over an email as we are running out of time and I don't want people to curse me to screw up their dinner time (IST)
16:12:33 <kshlm> Anything further to discuss?
16:12:40 <msvbhat> I had something in open floow
16:12:44 <msvbhat> *floor
16:12:53 <post-factum> yup, back to 3.7 as well...
16:13:08 <msvbhat> But if its over time, I can update through mail
16:13:24 <msvbhat> Its about distaf testcase location.
16:13:24 <kshlm> post-factum, Did you have any thing to say?
16:13:30 <post-factum> #link https://bugzilla.redhat.com/show_bug.cgi?id=1309462
16:13:31 <glusterbot> Bug 1309462: low, unspecified, ---, ravishankar, MODIFIED , Upgrade from 3.7.6 to 3.7.8 causes massive drop in write performance.  Fresh install of 3.7.8 also has low write performance
16:13:44 <kshlm> msvbhat, The mailing list will be a better place for that discussion.
16:13:45 <post-factum> is there any update on it? i mean new bugreport against arbiter
16:14:13 <msvbhat> kshlm: Many people are slow to respond. Maybe I'll put them in cc this time :)
16:14:22 <kshlm> post-factum, unfortunately none of the afr developers are here to provide an answer that.
16:14:31 <post-factum> :( okay
16:14:45 <JoeJulian> hagarth: said that's fixed in 3.7.9
16:15:15 <atinm> atalur, are you around to take care pf post-factum's question?
16:16:17 <post-factum> it seems 3.7.9 has some improvements, but to to the level of 3.7.6
16:16:30 <JoeJulian> https://botbot.me/freenode/gluster/msg/62715406/
16:17:27 <post-factum> (no selinux here)
16:17:39 <JoeJulian> he wasn't referring to selinux
16:18:07 <JoeJulian> I've got another meeting. Thanks kshlm!
16:18:26 <kshlm> You're welcome JoeJulian .
16:18:36 <post-factum> ok, will test to get fresh numbers against 3.7.9 and write to old bugreport
16:18:47 <kshlm> post-factum, Maybe you should ping itisravi for answers when he's online tomorrow.
16:19:00 <post-factum> kshlm: ok, will try
16:19:04 <kshlm> So that should be it.
16:19:13 <kshlm> Here are the weekly announcements.
16:19:30 <kshlm> Next weeks meeting will be at 1200UTC.
16:19:47 <kshlm> If you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
16:19:48 <kshlm> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
16:19:48 <kshlm> Use the following etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
16:20:14 * kshlm is wondering if anyone is using the backport-requests etherpad.
16:20:25 <kshlm> Thanks everyone for attending today's meeting.
16:20:28 <post-factum> thx!
16:20:30 <kshlm> #endmeeting