12:12:05 <rafi> #startmeeting gluster bug triage meeting
12:12:05 <zodbot> Meeting started Tue Apr 12 12:12:05 2016 UTC.  The chair is rafi. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:12:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:12:05 <zodbot> The meeting name has been set to 'gluster_bug_triage_meeting'
12:12:18 <rafi> #info agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:12:26 <rafi> #topic Roll call
12:12:51 * hgowtham \0_
12:13:01 * skoduri is here
12:13:02 <post-factum> o/
12:13:10 <jiffin> o/
12:13:12 * kkeithley_ is here
12:13:41 * ndevos _o/
12:14:07 <rafi> i think we have good number folks here
12:14:15 <rafi> moving to next topic
12:14:40 <rafi> #topic action items from last meeting
12:15:08 <rafi> #topic msvbhat will look into lalatenduM's automated Coverity setup in  Jenkins  which need assistance from an admin with more permissions
12:15:33 <rafi> I think msvbhat is not around
12:15:46 <rafi> so moving this item to next meeting
12:15:57 <rafi> #action msvbhat will look into lalatenduM's automated Coverity setup in  Jenkins  which need assistance from an admin with more permissions
12:16:11 <rafi> #topic ndevos need to decide on how to provide/use debug builds
12:16:26 <rafi> ndevos: your turn
12:16:31 <ndevos> yes, still need to do that
12:16:50 <rafi> ndevos: no worries
12:17:04 <rafi> ndevos: will carry forward to next meeting
12:17:10 <rafi> ndevos: or do you need more time
12:17:24 <ndevos> put it for next meeting again
12:17:43 <ndevos> I need to do it, just do not know when I have the time for it
12:17:51 <ndevos> and a reminder helps :)
12:17:53 <rafi> #action ndevos need to decide on how to provide/use debug builds
12:17:55 <rafi> ndevos: np
12:18:14 <rafi> #topic  Manikandan and gem  will update on bug automation
12:18:30 <rafi> Manikandan: gem : any updates on this ?
12:19:02 <hgowtham> rafi, i think Manikandan is held up with another meeting
12:19:28 <rafi> hgowtham: oh oh
12:19:39 <hgowtham> :)
12:19:58 <rafi> I remember gem mentioning about pushing some initial script to our repo
12:20:13 <rafi> Do we have any update on that ?
12:20:19 <rafi> ndevos: are you aware of any ?
12:20:36 <gem> rafi, hey!
12:20:43 <gem> rafi, we haven't tested the code yet
12:20:59 <gem> rafi, If we could get access to test it, that would be better
12:21:21 <rafi> gem: you mean access to our infra ?
12:21:24 <ndevos> gem: have you been in tough with kshlm about that?
12:21:51 <gem> ndevos, Manikandan was getting in touch with kshlm regarding this
12:21:55 <ndevos> rafi: I think this is for the scripts that need to run as Gerrit hooks
12:22:13 <ndevos> (so, in the Gerrit process/service itself)
12:22:18 <rafi> ndevos: okey
12:22:42 <ndevos> gem: ok, could you convince Manikandan to send a request on gluster-infra about it?
12:23:00 <gem> ndevos, okay
12:23:09 <rafi> ndevos: i will put an action item ;)
12:23:39 <ndevos> rafi: sure, lets see if gem and Manikandan have something to report next week ;-)
12:23:44 <rafi> #action Manikandan to followup with kashlm to get access to gluster-infra
12:24:40 <rafi> ndevos: they are doing good job, everyone will get the fruits of their job sooner :)
12:25:03 * rafi is eagerly looking for automated bug status
12:25:10 <ndevos> rafi: yes, it would be a great thing to have!
12:25:38 <rafi> coool
12:25:49 <rafi> moving into next topic
12:25:56 <ndevos> gem: for many things, we could even have a Jenkins job do the work, and not rely on Gerrit too much, I think?
12:26:15 <rafi> gem: thanks for updating
12:26:21 <rafi> #topic msvbhat  provide a simple step/walk-through on how to provide testcases for the nightly rpm tests
12:26:39 <rafi> automatically moving to next meeting as msvnhat is not present
12:26:44 <gem> ndevos, yes. we could use jenkins APIs in a lot of places
12:26:44 <rafi> #action msvbhat  provide a simple step/walk-through on how to provide testcases for the nightly rpm tests
12:27:06 <rafi> #action ndevos to propose some test-cases for minimal libgfapi test
12:27:22 <ndevos> yes, need to do that too... stil
12:27:23 <ndevos> l
12:27:36 <rafi> ndevos: okey
12:27:46 <rafi> ndevos: I will propose for next week
12:28:00 <rafi> #action ndevos to propose some test-cases for minimal libgfapi test
12:28:23 <rafi> great, we are done with action items from last meeting
12:28:33 <rafi> here we start the main agenda
12:28:59 <rafi> #topic Group triage
12:28:59 <rafi> we have 7 bugs to traige
12:29:21 <rafi> #info you can fine the bugs to triage here in https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:29:25 <rafi> #link https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:29:55 <rafi> hgowtham: skoduri post-factum jiffin kkeithley_ ndevos gem : let'us start grooup triage
12:30:07 <hgowtham> yes lloking at it
12:30:11 <hgowtham> *looking
12:34:07 <kkeithley_> just to point out, there are a lot of bugs in ndevos'  bugs with incorrect status report that are assigned to nobody, but have patches posted or merged.  There are too many for one person (e.g. me) to fix them all. Maybe in a future meeting we could address those.
12:34:27 <kkeithley_> start to address those
12:36:35 <ndevos> kkeithley_: that gives me an idea!
12:36:48 <ndevos> we can complain about incorrect assignees too :)
12:38:21 <ndevos> #halp extend check-bugs.py to complain about bugs assigned to nobody or bugs@gluster.org but do have patces
12:38:25 <ndevos> #link https://github.com/gluster/release-tools/blob/master/check-bugs.py
12:40:05 <ndevos> #link http://www.gluster.org/pipermail/gluster-devel/2016-April/049043.html
12:40:41 <ndevos> gem: for your automation scripts, do you use check-bugs.py or something similar too?
12:41:04 <ndevos> it could easily be extended to get a bz# as parameter and only check that
12:41:38 <rafi> ndevos: I see a needinfo from you on https://bugzilla.redhat.com/show_bug.cgi?id=1323895 ,
12:41:39 <glusterbot> Bug 1323895: low, unspecified, ---, bugs, NEW , Can I configure data transfer network and ping check network separately?
12:41:49 <rafi> ndevos: i think we can skip this fro now, right ?
12:41:54 <rafi> *for now
12:42:25 <ndevos> rafi: yeah, but maybe someone should ping Du about it?
12:42:33 * ndevos always wonders if he is on irc
12:42:52 <rafi> ndevos: his nink name is raghug
12:43:15 <rafi> ndevos: I will followup on this
12:43:16 <ndevos> ah, right, raghu vs raghug and both are called Raghavendra
12:43:25 <rafi> ndevos: ya :D
12:43:32 <gem> ndevos, we are not using that check-bugs.py. We were writing whole implementation from scratch.
12:43:37 * ndevos probably never learns
12:43:46 <rafi> #action rafi needs to followup on #bug 1323895
12:43:47 <glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1323895 low, unspecified, ---, bugs, NEW , Can I configure data transfer network and ping check network separately?
12:44:02 * gem thinks she should look into it now that she knows about it
12:44:26 <ndevos> gem: ok, well whenever you post your code, we might be able to merge some pieces :)
12:44:51 <ndevos> gem: hmm, and maybe it's doing the inverse from what you are doing....
12:45:28 <gem> ndevos, yes :)
12:45:54 <rafi> I think we are done with group triage
12:46:00 <rafi> moving to next topic
12:46:21 <rafi> #Topic Open Floor
12:46:42 <rafi> please feel free to bring your ideas or concerns
12:46:43 <kkeithley_> bugs with incorrect status report that are assigned to nobody, but have patches posted or merged
12:47:12 * kkeithley_ enjoys repeating himself. ;-)
12:48:05 <rafi> kkeithley_: that's good
12:48:40 <kkeithley_> so we can start to address those next time?
12:48:42 <rafi> i think we can include bugs with incorrect status in bug triage
12:49:01 <rafi> I would like to hear from everyone
12:49:05 <ndevos> kkeithley_: you say "nobody", do you mean "bugs_at_gluster.org"?
12:49:27 <rafi> ndevos: jiffin skoduri hgowtham post-factum gem : ^
12:50:04 <ndevos> well, we could actually script that...
12:50:04 <hgowtham> yes sure :)
12:50:30 <rafi> ndevos: script to get the incorrect bugs ?
12:50:43 <rafi> ndevos: or automatic healing ?
12:50:51 <rafi> ndevos: :)
12:51:08 <ndevos> rafi: the script to get the incorrect bugs is called check-bugs.py, see ^^^
12:51:17 <rafi> ndevos: ya
12:51:36 <ndevos> rafi: the "bug healing" could be "assign the person posting the patch to the bug"
12:52:55 <rafi> ndevos: okey , should we do that now ? or wait for much enhanced automatic bug status update
12:53:39 <ndevos> rafi: the status update that gem and Manikandan work on will only be effective for bugs that get new patches posted/updated
12:53:57 <rafi> ndevos: ya, I was about to ask
12:54:15 <ndevos> rafi: adding it as a task for next weeks meeting would probably be good
12:54:40 <kkeithley_> ndevos: yes, nobody = bugs at gluster dot org
12:56:08 <rafi> ndevos: I'm not good at scripting. please forgive me if this is a stupid question ? is it difficult to read from the older commands and update the assignee ?
12:57:01 <ndevos> rafi: it's easy, there is a bugzilla command (install the python-bugzilla package)
12:57:21 <rafi> ndevos: okey
12:57:31 <ndevos> bugzilla modify --assignee=someone@example.com 123456
12:57:55 <rafi> okey
12:58:01 <ndevos> or, something like that anyway
12:58:13 <rafi> ndevos: okey
12:58:25 <rafi> ndevos: we can discuss this in next meeting
12:58:28 <ndevos> it's more tricky to get the email of the author from the git commit
12:58:38 <rafi> ndevos: we almost there to end the meeting
12:59:08 <rafi> /we have 1 mnt left to finish the meeting :)
12:59:17 <ndevos> well, it's not tricky, I just dont know the syntax immediately: git show --format=%email $commit
12:59:45 <ndevos> but that needs a mapping of the gerrit change-id to commits... hmm
13:00:12 <rafi> #action need to discuss about writing a script to update bug assignee from gerrit patch
13:00:12 * ndevos just rambles on if the moderator does not intervene
13:00:50 <rafi> ndevos: np
13:01:09 <rafi> ndevos: I will take that up, so that I can study that
13:01:40 <rafi> does any one have anything to brig for today ?
13:01:58 <rafi> coool
13:01:58 <ndevos> rafi: cool, thanke
13:02:32 <rafi> I guess all of us are exhausted :D
13:02:38 <rafi> letus stop the meeting]
13:02:46 <rafi> #endmeeting