12:02:54 <kshlm> #startmeeting Weekly community meeting 27/Jul/2016
12:02:54 <zodbot> Meeting started Wed Jul 27 12:02:54 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:54 <zodbot> The meeting name has been set to 'weekly_community_meeting_27/jul/2016'
12:03:13 <kshlm> He was probably napping.
12:03:19 <kshlm> #topic Roll call
12:03:29 * pranithk1 here
12:03:30 * kkeithley is here
12:03:34 * ankitraj here
12:03:40 * hagarth is here
12:03:44 <kshlm> I'll be waiting for a minute to the agenda open.
12:03:50 * samikshan is here
12:03:58 * karthik_ is here
12:04:07 * jiffin is here
12:04:20 <kshlm> hagarth, pranithk1, You guys are here after a long long long time!
12:04:21 * rjoseph is here
12:04:29 * ramky is here
12:05:14 * ndevos arrives, after a short sprint
12:05:14 <kshlm> Okay. Good attendence today.
12:05:20 <kshlm> Welcome everyone!
12:05:30 <kshlm> #topic Next weeks meeting host
12:05:36 * anoopcs is also here
12:05:41 <kshlm> First up we select the host for the next weeks meeting.
12:05:43 <hagarth> kshlm: taking some time off from my school dropoff schedule ;)
12:05:48 <kshlm> Any volunteers?
12:06:02 <kshlm> hagarth, :)
12:06:09 <ankitraj> can a intern be volunteer
12:06:13 <ankitraj> ?
12:06:40 <kshlm> Sure.
12:06:55 * ankitraj interested
12:07:10 <kshlm> Just watch how we do it.
12:07:16 <kshlm> And do the same next week.
12:07:29 <ndevos> ankitraj: we're all part of the Gluster community, we dont care about job titles here ;-)
12:07:37 <ankitraj> kshlm: ok
12:07:54 <kshlm> ankitraj, So you're the next host?
12:08:15 <ankitraj> yea
12:08:18 <kshlm> Okay.
12:08:31 <kshlm> #info ankitraj is next weeks meeting host.
12:08:55 <kshlm> #topic GlusterFS 4.0
12:09:10 <kshlm> Let's have some updates now.
12:09:51 <kshlm> atinm, jdarcy, are you guys here?
12:09:57 <jdarcy> Yes.
12:10:05 <kshlm> Okay. Good. :)
12:10:22 <jdarcy> Not sure if it's still considered 4.0, but multiplexing is coming along nicely.
12:10:44 <jdarcy> I'm at the point where basic stuff works and I'm running real regression tests to see which fail.
12:10:55 <ndevos> nice!
12:11:21 <jdarcy> Patch still at http://review.gluster.org/#/c/14763/
12:11:47 <jdarcy> That's it, pretty much.  Nothing on JBR, and I doubt there will be for a while.
12:11:53 <kshlm> Cool!
12:12:46 <kshlm> Work on GD2 is going on slowly.
12:13:01 <kshlm> ppai got a few fixes merged this week.
12:13:16 <kshlm> I'm still working on the transaction RPCs.
12:13:48 <kshlm> Anyone have updates on DHT2?
12:14:05 <kshlm> If not let's move onto the next topic.
12:14:49 <kshlm> #topic GlusterFS-3.9
12:15:05 <kshlm> pranithk1, Do you have any updates to share with us?
12:15:18 <pranithk1> kshlm: yes
12:15:31 <pranithk1> kshlm: We have 3 more features we need to add to 3.9 schedule
12:15:47 <pranithk1> kshlm: reset-brick, block and object storage related ones
12:16:11 <pranithk1> kshlm: Oh forgot one more, i.e. EC encoding perf improvement patch
12:16:28 <pranithk1> kshlm: We will be updating the doc by end of this week...
12:16:36 <pranithk1> kshlm: I mean the roadmap
12:16:40 <kshlm> Thanks pranithk1.
12:16:44 <ndevos> oh, and md-cache improvements from poornima
12:17:08 <pranithk1> ndevos: Oh cool, more the merrier
12:17:25 <ndevos> maybe Kerberos support too, but that is mostly in the hands of Csaba, and I do not know how much time he can spend on it
12:17:31 <kshlm> pranithk1, Are we going to do anything about sub-directory mounts?
12:17:42 <kkeithley> Jose and I will update roadmap shortly w/ common-HA improvements to include Samba
12:17:43 <ndevos> kshlm: use NFS! :P
12:17:53 <pranithk1> kkeithley: cool.
12:18:04 <pranithk1> kshlm: I think we should talk about it next week...
12:18:29 <kshlm> pranithk1, We should have talked about 3 weeks back.
12:18:39 <kshlm> But I've been out of office.
12:18:41 <pranithk1> kshlm: :-). Well better late than never I guess
12:18:54 <kshlm> Let's see if we can get together earlier.
12:18:59 <pranithk1> kshlm: yeah
12:19:03 <kshlm> Alright.
12:19:14 <pranithk1> kshlm: that's all from me
12:19:21 <kshlm> I'll move on to the next topic then.
12:19:33 <kshlm> #topic GlusterFS-3.8
12:19:42 <kshlm> ndevos, The stage is yours.
12:19:50 <kshlm> Also jiffins
12:20:08 <ndevos> nothing exciting to mention, and 3.8 should be very boring at the moment anyway
12:20:44 <ndevos> I'm asking in many backports if they are really needed, we want bugfixes and stability improvements only
12:21:50 <kshlm> Ah, I knew I'd forgotten something. I need to send the PR for the update release-process and guidelines.
12:21:55 <ndevos> for example, the token-bucket-filter patch to move the functions from bitrot to libglusterfs should probably not be backported, instead *real* backports for eventual bugfixes would be a better approach
12:22:08 <ndevos> yes, I was going to ask about it :)
12:22:28 <kshlm> #action kshlm to send PR for release process document update
12:23:05 <ndevos> and if my firefox would respond, I'd add a link to the patch where the tbf discussion is taking place...
12:24:16 <ndevos> #link http://review.gluster.org/14945
12:25:07 <kshlm> Sorry. I'd hoped my new internet connection wouldn't be giving trouble.
12:25:15 <kshlm> But apprantly it does.
12:25:42 <ndevos> #info do not backport unneeded changes, save your time for working on other things and do not risk instability of the 3.8 release :)
12:26:02 <kshlm> So ndevos, 3.8.2 is on track for the 10th then?
12:26:24 <ndevos> yes, there is no reason to change that atm
12:26:34 <kshlm> Good to know.
12:26:53 <kshlm> I'll move on to the next topic if we have nothing more to discuss about 3.8
12:27:04 <ndevos> nothing from me
12:27:07 <kshlm> #topic GlusterFS-3.7
12:27:25 <kshlm> So I guess I'm the 3.7.14 release manager.
12:27:55 <ndevos> congrats!
12:28:11 <kshlm> Yay me!
12:28:54 <kshlm> As of now, 3.7.14 is on target for the 30th.
12:29:11 <kshlm> I'll be making an announcement of this later today.
12:30:38 <misc> the 30th what ?
12:31:17 <kshlm> 30th of July.
12:31:27 <ndevos> this month, thats the thing with monthly updates :)
12:31:48 <kshlm> There have been 18 changes merged on top of 3.7.13.
12:32:23 <kshlm> A good amount IMO.
12:32:34 <kshlm> And that's it about 3.7.
12:32:53 <ndevos> still some patches pending?
12:33:21 * ndevos tries to trick firefox in showing the search results, but it takes a while...
12:33:23 <kshlm> I see a few more.
12:33:23 <pranithk1> kshlm: I have one patch pending in EC...
12:33:32 <pranithk1> kshlm: I will be sending it by EOD
12:33:34 <kshlm> pranithk1, You have until the 30th.
12:33:39 <kshlm> To get it merged.
12:33:57 <kshlm> Also, remember to add the bug to the tracker bug.
12:33:58 <pranithk1> kshlm: yes sir
12:34:05 <kshlm> Cool!
12:34:54 <kshlm> ndevos, There have been ~15 reviews for 3.7 that have had activity since 3.7.13 was released.
12:35:11 <kshlm> Onto 3.6
12:35:19 <kshlm> #topic GlusterFS 3.6
12:35:47 <kshlm> I sent an update to the -users and -devel lists on the status of 3.6.
12:36:00 <ndevos> thanks kshlm!
12:36:46 <kshlm> So we're now officially not going to be doing any more stability releases for 3.6.
12:37:13 <kshlm> 3.6 will get releases for security or very critical issues.
12:37:29 <kshlm> But only till 3.9 is released.
12:37:50 <kshlm> #link https://www.gluster.org/pipermail/gluster-devel/2016-July/050256.html
12:38:01 <kshlm> And that's about it for 3.6.
12:38:16 <kshlm> Onto the related projects.
12:38:22 <kshlm> #topic NFS Ganesha
12:39:08 <ndevos> we broke building nfs-ganesha against the glusterfs/master branch with http://review.gluster.org/#/c/14702/ :-(
12:39:59 <ndevos> I'll be doing some libgfapi corrections for that, and jiffin wil modify Ganesha when I'm done
12:40:23 <kshlm> How was the breakage detected?
12:40:31 <kshlm> Was it an automated test?
12:40:43 <ndevos> by trying to setup night builds for nfs-ganesha...
12:40:49 <ndevos> *nightly even
12:40:49 <kshlm> Cool!
12:41:31 <kkeithley> hurray for CI
12:41:35 <ndevos> but, it should have been obvious if the patch was reviewed by the gfapi maintainers, they normally pay attention to these minor things
12:42:30 <kshlm> ndevos, Did you miss reviewing it?
12:42:40 <ndevos> I'm updating the job to build against the latest released glusterfs version, so at least we have nightly nfs-ganesha packages
12:42:51 <ndevos> kshlm: yes, me and shyam both
12:43:15 <kkeithley> well, "fix the problem, not the blame"
12:43:35 <kshlm> kkeithley, Yup.
12:43:37 <ndevos> its not too bad, I do not think anyone except ganesha is affected, and it gives us a good reason to really fix it :D
12:43:49 <hagarth> ndevos: can other gfapi consumers be broken now?
12:43:57 <hagarth> ndevos: ah ok, you answered it already
12:44:04 <jiffin> hagarth: it's related upcall
12:44:07 <hagarth> jiffin: ok
12:44:17 <ndevos> hagarth: only if they use the cache-invalidation, and I think only Ganesha uses it
12:44:23 <hagarth> as long as we break things in master and quickly fix, we should be fine
12:44:26 <hagarth> ndevos: ok
12:44:38 <kshlm> Thanks for the update ndevos!
12:44:44 <kshlm> #topic Samba
12:45:08 <kshlm> Do we have any updates for Samba?
12:45:17 <kshlm> I don't see samba-folk around.
12:46:06 <anoopcs> kshlm, Recently we did some re-factoring related to ACL handling code in vfs module for glusterfs in Samba.
12:46:44 <hagarth> some of the mdcache work happening should benefit samba performance afaik
12:46:52 <anoopcs> and will be part of upcoming version 4.5
12:46:59 <anoopcs> hagarth, Yes..yes..Definitely
12:47:25 <kshlm> 4.5!! That's really late
12:47:39 <ndevos> lol
12:47:45 <kshlm> :D
12:47:54 <kshlm> Thanks for the update anoopcs
12:47:55 <hagarth> anoopcs: how is the richacl related work coming along?
12:48:30 <anoopcs> hagarth, rjoseph is working on RichACL support for GlusterFS.
12:49:02 <kshlm> I think rjoseph is present here.
12:49:05 <hagarth> rjoseph: are you around? i see that listed on the roadmap for 3.9
12:49:10 <kshlm> He was during the roll call atleast.
12:49:36 <rjoseph> sorry, was in discussion in samba channel
12:49:48 <anoopcs> w.r.t Samba I don't think its upstream yet..patches have been sent by Andreas long time back.
12:50:15 <rjoseph> Gluster related changes are going on, could not spend more time on this.
12:50:30 <rjoseph> I will be taking this after the SSL changes I am doiing for libgfapi
12:50:43 <ndevos> we have some glfs_set_acl() functions I think, similar ones will be added for richacl
12:50:55 <kshlm> rjoseph, BTW I've got some info to share with you on that.
12:51:14 <rjoseph> kshlm: regarding SSL or RichACL?
12:51:35 <ndevos> rjoseph: oh, are the ssl changes for libgfapi documented somewhere, a feature/design page perhaps?
12:51:49 <kshlm> SSL. About how reconnection failures are handled in the fuse client.
12:52:08 <kshlm> I'll catchup in #gluster-dev after the meeting.
12:52:11 <rjoseph> No, currently investigating this as a bug, looks like I need a feature page for this after all
12:52:12 <anoopcs> kshlm, ndevos : There are no functional changes w.r.t ACL coming with Samba 4.5..Just re-factoring to make it usable for both Ceph and GlusterFS.
12:52:41 <rjoseph> sure kshlm
12:52:43 <ndevos> anoopcs: ok, good to know :)
12:52:55 <kshlm> rjoseph and anoopcs Thanks for all the information!
12:53:18 <anoopcs> kshlm, np
12:53:22 <kshlm> #topic Community Infrastructure
12:53:33 <kshlm> misc, nigelb, Do you have anything to share?
12:54:58 <kshlm> Not much has happened here.
12:55:15 <kshlm> nigelb has been converting more Jenkins jobs to JJB.
12:55:43 <kshlm> He's also been fixing up the storage on netbsd guests.
12:56:22 <anoopcs> and now we have more space on NetBD machines..
12:56:30 <anoopcs> *NetBSD
12:56:31 <kshlm> There was a small period of time yesterday, when www.gluster.org was opening blog.gluster.org
12:56:45 <kshlm> misc, fixed it quickly, and traced that down to a bug in Ansible.
12:56:57 <kshlm> anoopcs, Yes. We have more space now.
12:57:10 <kshlm> NetBSD regression should be more stable now.
12:57:21 <kshlm> And I that's it.
12:57:40 <kshlm> #topic Last weeks AIs
12:58:02 <kshlm> This is probably the first time all the AIs include the same person!
12:58:10 <kshlm> I'm on all of them.
12:58:20 <ndevos> oh, well done!
12:58:29 <nigelb> Ah, kshlm has said everything I wanted to.
12:58:37 <nigelb> Sorry, I was in the middle of something :)
12:58:40 <kshlm> 4 AIs. 2 done.
12:58:53 <kshlm> ndevos did one and I did the other.
12:59:49 <kshlm> I'll be trying to get the centos-ci job for GD2 setup if I get time this week.
12:59:56 <ndevos> oh, sorry, didnt want to take that away from you...
13:00:43 <kshlm> ndevos, No worries. I greatfully accept any volunteering to do my AIs.
13:00:57 * anoopcs would like to inform that glusterfs-coreutils is also being run as part of CentOS CI jobs for Gluster
13:00:58 <kshlm> :)
13:01:05 <kshlm> anoopcs, Cool!
13:01:17 <hagarth> anoopcs: nice!
13:01:24 <anoopcs> #link https://ci.centos.org/view/Gluster/job/gluster_coreutils/
13:01:48 <anoopcs> Thanks to all the help by ndevos
13:02:05 <kshlm> That's all about the AIs.
13:02:06 <ndevos> anoopcs: maybe we should add a badge to the README in the github repo? https://ci.centos.org/view/Gluster/job/gluster_coreutils/badge/
13:02:24 <kshlm> I'll have my name on all the AIs for this week as well.
13:02:40 <anoopcs> ndevos, It's already done by Craig.
13:02:50 <ndevos> oh, wow, he's fast!
13:02:55 <anoopcs> https://github.com/gluster/glusterfs-coreutils
13:03:00 * kshlm notes that we're past scheduled time
13:03:33 <kshlm> We don't have any topics for discussion under Open Floor.
13:03:34 <anoopcs> I'm done.
13:03:41 <kshlm> So I'll end the meeting if we're all done.
13:03:54 <paul98> can i just suggest something?
13:04:07 <kshlm> paul98, Go ahead.
13:04:27 <paul98> can someone look into the disk encryption as the docs are quiet poor, and google doesn't give you much info e.g i don't think many people have tried it, even though it's supported
13:05:07 <paul98> the ssl side is spot on thanks to kshlm just disk encryption is a massive struggle
13:05:24 <pranithk1> paul98: you mean encryption translator
13:05:26 <pranithk1> paul98: ?
13:05:37 <kshlm> pranithk1, yup. the data-crypt xlator
13:05:46 <paul98> pranithk1: yes
13:06:11 <kshlm> Sorry. It's just the crypt xlator.
13:06:36 <kshlm> Does anyone active have knowledge about this?
13:06:44 <pranithk1> paul98: I think the guy who worked on it is not working on it anymore. I heard someone wants to work on it, may be prasanna. May be you should send me a mail? pkarampu@redhat.com
13:07:03 <kshlm> pranithk1, Let's have this on gluster-devel.
13:07:10 <kshlm> Don't do it in private.
13:07:14 <pranithk1> paul98: I can connect you with someone interested. You could probably help us stabilize?
13:07:14 <ndevos> or gluster-users@gluster.org
13:07:26 <paul98> it's something we want to use here
13:07:27 <pranithk1> kshlm: that works better I guess
13:07:43 <paul98> just the lack of documention doesn't help,
13:07:50 <paul98> and it seems no one has tried it before
13:07:55 <pranithk1> paul98: Well, we don't know what is the state of it. We can help you with it.
13:07:57 <paul98> which i'm surprised at
13:08:11 <paul98> but yes i'm keen to help out where needed
13:08:17 <kshlm> The spec in glusterfs-specs lists jdarcy and Edward Shishkin as the owners.
13:08:44 <kkeithley> mainly it was Edward. (oops, fixed the blame)
13:08:46 <ndevos> kshlm: link?
13:08:55 <jdarcy> Pretty much all Edward's code.  I had written an earlier version, but it's now lost in the mists of time.
13:08:59 <jiffin> paul98: https://github.com/gluster/glusterfs/blob/master/tests/encryption/crypt.t sample test case for cryt xlator
13:09:24 <jiffin> it might be helpful
13:09:36 <kkeithley> yesterday JoeJulian posted this comment here in #gluster-meeting.
13:09:39 <kkeithley> [18:48:18] <JoeJulian> Since I cannot attend community meetings in the middle of the night, I'll just drop this here and hope it gets mentioned.
13:09:40 <kkeithley> [18:48:53] <JoeJulian> There are a couple of documentation issues that are months old, one of which shows no evidence of even having been looked at. Can someone please take a look at https://github.com/gluster/glusterdocs/issues and make some progress?
13:09:49 <kshlm> ndevos, https://github.com/gluster/glusterfs-specs/blob/master/done/GlusterFS%203.5/Disk%20Encryption.md
13:10:14 <ndevos> kshlm: thanks, that was for paul98 of course :)
13:10:30 <kshlm> kkeithley, I saw some activity on that from ppai.
13:11:32 <kshlm> ppai should be looking into that.
13:11:44 <kshlm> We're 10 minutes over time.
13:11:50 <kshlm> I'll stop the meeting now.
13:12:01 <paul98> ah cool, i'll go have a read! thnks lads, sorry for making you run over! :)
13:12:06 <kshlm> If you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:12:06 <kshlm> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:12:39 <kshlm> I don't know if we're using the backports etherpad anymore (I know I've not looked at it) but anyways
13:12:50 <kshlm> Use the following etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:12:51 <kkeithley> lol
13:13:05 <kshlm> Thanks for attending today's meeting everyone!
13:13:09 <kshlm> #endmeeting