12:00:29 <ankitraj> #startmeeting Gluster Community Bug Triage Meeting
12:00:29 <zodbot> Meeting started Tue Aug 16 12:00:29 2016 UTC.  The chair is ankitraj. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:29 <zodbot> The meeting name has been set to 'gluster_community_bug_triage_meeting'
12:00:55 <ankitraj> #topic rollcall
12:01:03 * rafi is here
12:01:30 * cloph is just curious
12:01:33 * kkeithley is here
12:01:38 * hgowtham is here
12:02:19 * skoduri is here
12:02:53 <ankitraj> OK, before moving forward I would like to know who is interested in hosting next week bug-traige meeting
12:03:11 * Muthu here
12:03:16 * ndevos _o/
12:03:36 <Muthu> I would like to take up the chair for next week
12:03:55 <ankitraj> ok Muthu I would assign next week chair to you. :)
12:04:24 <ndevos> ankitraj: try to use #info for confirming that
12:04:27 * kkeithley needs a link to the agenda please
12:04:54 <ankitraj> #topic ndevos need to decide on how to provide/use debug builds
12:05:05 * kkeithley had to reinstall his desktop and lost his browser history
12:05:14 <rafi> cloph: you will get a treasure very soon ;)
12:05:19 <ndevos> ankitraj: nstill todo, please note it for next time
12:06:00 <ankitraj> #action  ndevos need to decide on how to provide/use debug builds
12:06:25 <ankitraj> #link for agenda https://public.pad.fsfe.org/p/gluster-bug-triage
12:06:30 <kkeithley> thanks
12:06:55 <ankitraj> #topic jiffin will try to add an error for bug ownership to check-bugs.py
12:07:16 <kkeithley> jiffin is out today
12:07:38 <ankitraj> I will be moving it to next week AI
12:08:15 <ankitraj> #action jiffin will try to add an error for bug ownership to check-bugs.py
12:08:54 * kshlm says hello
12:09:03 <ankitraj> #link https://public.pad.fsfe.org/p/gluster-bugs-to-triage
12:09:18 <ankitraj> kshlm, hello
12:11:00 * rafi got pulled into something else , will join after sometime
12:11:34 <ankitraj> Please, update about your bug status
12:13:48 <ndevos> ankitraj: ah, I think you missed some #topic instructions there
12:14:35 <kshlm> So what do I need to do to triage a bug? Just set it to the correct component and mark as TRIAGED?
12:15:06 <ndevos> kshlm: yes, correct the component, add developers/maintainers on CC and ask for information in case it is missing
12:15:23 <ndevos> kshlm: Triaged means "ready for developers to start working on it"
12:15:43 <kshlm> ndevos, Cool!
12:15:46 <kshlm> I'll get started
12:15:47 <kkeithley> maybe assign it to the lead/owner/maintainer of the component too?
12:16:05 <ndevos> kshlm: sometimes patches have been posted already, in that case, assign the bug to the developer who posted, and set the status to POST/MODIFIED as appropriate
12:16:12 <skoduri> I see many developers cloned their bugs to upstream and haven't updated status/keywords.. :(  Reminders do not seem to have any impact
12:16:42 <ndevos> kkeithley: assigning should not be needed, developers are expected to watch the bugs on CC, and then see who can take it on
12:17:10 <kkeithley> if the bug has a patch posted, set the status to POST.  If the patch is merged, set it to MODIFIED
12:17:21 * ndevos always things assigning is setting the wrong expectations to the person reporting the bug
12:18:10 <ankitraj> #topic group triage
12:18:33 <kkeithley> add Triaged keyword.  (unset the "Add me to the CC list" checkbox)
12:22:36 <ndevos> bugzilla is *very* slow, how is it for others?
12:22:56 <hgowtham> ndevos, its working fine for me
12:23:32 <kkeithley> not slow for me
12:23:44 <ndevos> hgowtham: hmm, it seem not constant at least, sometimes its fast
12:24:04 <hgowtham> ndevos, okie :)
12:29:41 <ndevos> kshlm: when you are done with triaging a bug, mark it strike-through on the etherpad
12:29:53 <kshlm> I just did. :)
12:30:03 <kshlm> I guess that's all for this week.
12:30:12 <ndevos> :)
12:30:20 <kshlm> One thing I'd like to add that the triagers need to keep in mind.
12:30:45 <kshlm> If a bug has been cloned from a RHGS bug, it most likely will have it's description set to private.
12:31:16 <kshlm> Please review the description and open it up if you don't find it has anything that should remain private.
12:32:04 <ankitraj> Thanks for triaging
12:32:06 <ankitraj> :)
12:32:15 <ndevos> yes, indeed, communty bugs need a public description, either open it up or ask the reporter to do so or write something else
12:32:25 <ankitraj> #topic Open floor
12:32:39 <kshlm> Time for the 3.6 bug screen!
12:32:47 <kshlm> And I don't see other maintainers.
12:33:10 * ndevos waves _o\ _o| _o/
12:33:18 <rafi> :)
12:33:27 <kkeithley> what do people think about have a single "umbrella" version. E.g. starting with 3.9 we just have Version 3.9 in bugzilla instead of 3.9.0, 3.9.1, 3.9.2, etc.?
12:33:37 <ndevos> yes, yes YES
12:33:58 <ndevos> we ask for the version in teh bugzilla template anyway
12:34:31 <kshlm> Sounds good to me.
12:35:08 <ndevos> also, I was hoping to see a note from atinm about cleanup and structuring the bugzilla components/subcomponents
12:35:49 <ndevos> we have many components from the glusterfs sources that are mixed with other projects - all are components ricght now
12:35:55 <kkeithley> let's confirm that then during the gluster community meeting tomorrow.
12:36:29 <ndevos> sure, I't just a reminer for atinm to get the (email) thread started :)
12:36:38 <ndevos> *reminder even
12:36:57 <rjoseph> ls
12:37:18 * rjoseph typed in the wrong window
12:37:38 <kshlm> rjoseph, Nope you're in the right window.
12:37:45 <kshlm> Welcome to the bug screen.
12:37:52 <ndevos> rjoseph: really? I was wondering for zodbot to show the bugs we need to cleanup :)
12:38:08 <kshlm> We should begin now.
12:38:29 <rafi> rjoseph: welcome back
12:38:35 <ndevos> kshlm: yeah, got the link(s)?
12:38:55 <kshlm> I've added them to the agenda etherpad.
12:39:16 <kshlm> They're unweildly to paste here.
12:39:41 <post-factum> +1 for umbrella version
12:39:44 <kshlm> I propose we first tackle the bugs in POST, ON_QA or MODIFIED states.
12:39:54 <ndevos> wait, which etherpad?
12:39:58 <rjoseph> rafi: thanks
12:40:27 <rafi> #link https://public.pad.fsfe.org/p/gluster-bug-triage
12:40:30 <kshlm> ndevos, The bug-triage agenda etherpad
12:40:34 <rafi> ndevos: ^
12:40:37 <ankitraj> ndevos, https://public.pad.fsfe.org/p/gluster-bug-triage
12:40:43 <kshlm> https://bugzilla.redhat.com/buglist.cgi?action=wrap&f1=bug_status&f2=version&f4=bug_status&list_id=5674477&o1=notequals&o2=regexp&o4=equals&product=GlusterFS&v1=CLOSED&v2=%5E3.6&v4=POST
12:40:50 <kshlm> Does this link work in IRC?
12:40:54 <rjoseph> ndevos: ya, but no output from zotbot :-)
12:42:25 <ankitraj> Anything else needed to be discussed or shall I end meeting
12:43:10 <ankitraj> Ok ,, Thanks for all joining the meeting..
12:43:18 <kshlm> If anyone wants to stay behind to screen the bugs please stay back.
12:43:34 <ankitraj> #end-meeting
12:44:10 <ndevos> kshlm: should we not have a standard blurp that we can copy/paste in the wontfix 3.6 bugs?
12:44:19 <ndevos> ankitraj: try without the - ;)
12:45:21 <ankitraj> ndevos, Sure
12:45:31 <kshlm> ndevos, Yup. We need one.
12:45:51 <kshlm> I'm creating an etherpad like the bug-triage-list pad.
12:45:58 <kshlm> We can add the blurb there.
12:46:34 <ankitraj> #endmeeting