12:00:33 <samikshan> #startmeeting Weekly Community Meeting 28-Sep-2016
12:00:33 <zodbot> Meeting started Wed Sep 28 12:00:33 2016 UTC.  The chair is samikshan. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:33 <zodbot> The meeting name has been set to 'weekly_community_meeting_28-sep-2016'
12:01:24 <samikshan> #topic Roll Call
12:01:33 * ankitraj here
12:01:35 * kkeithley is here
12:01:51 * ndevos is here
12:01:51 <samikshan> Hey ankitraj, kkeithley
12:02:10 <kkeithley> hi
12:02:12 <post-factum> o/
12:02:23 <ankitraj> hello samikshan
12:02:27 <ankitraj> :)
12:03:12 * jiffin o/
12:03:19 <samikshan> Welcome everyone. I'll wait for some more time for people to come in
12:05:02 <samikshan> Okay the attendance seems to be on the lower side today
12:05:47 * anoopcs is here
12:06:23 <samikshan> I'll start going through the topics. Hopefully more people will be joining in :)
12:06:37 <samikshan> #topic Next week's host
12:07:07 <samikshan> I believe many might be travelling next week this time (Oct 5th)
12:07:26 <ndevos> I guess we'll do a community meeting from Berlin?
12:07:27 <kkeithley> I can't do next week, but I will do the week after. But when I ask for someone to host the next one I had better get a volunteer.
12:07:45 * ankitraj interested
12:08:17 <samikshan> ndevos: Yes we could do that. On Oct 5th itself?
12:08:31 <samikshan> ankitraj: Thanks. :)
12:08:39 <ankitraj> :np
12:08:39 <kkeithley> Wednesday in Berlin?
12:08:54 <ndevos> samikshan: I supposs so, its at 14:00 so it should not be much of an issue
12:09:15 <samikshan> ndevos: Okay let's do it.
12:09:22 <samikshan> kkeithley: Yes.
12:09:25 <ndevos> at least a short meeting :)
12:09:32 <samikshan> Yep, agreed.
12:09:47 <samikshan> #info ankitraj is next week's host
12:09:54 <kkeithley> but most people who are there will be attending a Linuxcon talk, so....
12:10:16 <kkeithley> well, whatever
12:10:45 <ndevos> is there an interesting talk at that time?
12:11:24 <samikshan> I'm not sure. Haven't checked the schedule
12:12:21 <samikshan> Let's just hope to have enough participants; if not, we could maybe have it cancelled
12:12:22 <kkeithley> yes, several...
12:12:32 <samikshan> Okay
12:12:53 <kkeithley> as it is I will have to pick one out of a couple I'd like to see
12:13:17 <samikshan> Ah. Parallel tracks. :-|
12:13:32 <ndevos> talks start at 14:30, maybe you're lucky and the meeting only lasts for 30 minutes :)
12:15:59 <samikshan> Okay. So we're hopefully having a short meeting next week and kkeithley can hopefully join in :)
12:15:59 <kkeithley> okay, well, we've spent 15 minutes just deciding next week's chair!   Let's keep the meeting moving
12:16:09 <samikshan> Haha.. Yes
12:16:15 <samikshan> Moving on to the next topic
12:16:33 <samikshan> #topic GlusterFS-4.0
12:16:56 <samikshan> Anything here?
12:18:14 <samikshan> I guess Jeff sent a few patches on brick-multiplexing
12:18:48 <ndevos> kshlm might have an update for GlusterD2.0?
12:18:50 <samikshan> Other than that, I'm not aware of anything else that is happening in the 4.0 world
12:20:31 <samikshan> Also I guess the first dev-release of GlusterD-2.0 is available now
12:20:49 <samikshan> Was there any mail sent around related to this?
12:21:34 <ndevos> yes, I think I've seen an email about it
12:22:01 <ndevos> #link http://www.gluster.org/pipermail/gluster-devel/2016-September/050988.html
12:22:24 <samikshan> ndevos: Thanks for the link. I was struggling to find it.
12:22:42 <samikshan> Do we have anything else here?
12:22:58 <samikshan> Moving on..
12:23:19 <samikshan> #topic GlusterFS-3.9
12:23:31 <samikshan> aravinda isn't here
12:24:43 <samikshan> RC1 tagging was done I guess.
12:25:15 <ndevos> yes, and packages have been built for many distributions
12:25:20 <kkeithley> yes, and amye suggested a slip for Gluster Summit, but there was a lot of push back to relase on schedule
12:25:21 <samikshan> cool
12:25:47 <samikshan> Okay.
12:25:49 <ndevos> the CentOS Storage SIG repositories are not ready, I hope the CentOS team gets that done this week
12:25:50 <kkeithley> besides centos, which ones?  I haven't built any 3.9 packages
12:26:01 <kkeithley> 3.9rc1
12:26:25 <ndevos> at least CentOS 6 and 7, for multiple architecturees
12:28:01 <samikshan> Alright.
12:28:46 <samikshan> Thanks for those updates ndevos and kkeithley. Do we have anything else on 3.9 before we move on to the next topic?
12:28:58 <kkeithley> nope
12:29:11 * ndevos doent
12:29:11 <samikshan> Okay.
12:29:16 <samikshan> #topic GlusterFS-3.8
12:29:39 <ndevos> still on track, nothing exceptional to mention
12:29:55 <kkeithley> please note for future releases that tags like V3.9rc1 are a PITA.  In the past we agreed on, e.g. V3.9.0rc1 but we didnt' do that for 3.8 either, and Aravinda and Pranith just copied 3.8.
12:30:10 <kkeithley> are a PITA for packaging
12:31:29 <ndevos> kkeithley: I just use 3.9-1rc1 as version, I think, not sure what the problem is?
12:32:19 <kkeithley> it doesn't follow the practice of 3.9.0-1{,rc1}.   Will 3.9.0-X update a 3.9-X rpm?
12:32:39 <ndevos> kkeithley: but 3.9.0rc1 is assumed to be an update over 3.9.0 :-/
12:33:34 <kkeithley> well, RCs are really 3.9.0-0.1rc1, but my point stands
12:33:59 <kkeithley> will 3.9.0-1 update 3.9-1?
12:34:11 <kkeithley> or 3.9-1rc1?
12:34:22 <ndevos> tag would be v3.9.0 and rpm ver/rel 3.9.0-1
12:34:23 <kkeithley> this is not the right venue for this conversation
12:34:54 <samikshan> Is there an earlier related discussion we can find on the MLs? We could reopen that thread or start a new one to discuss these tagging guidelines for future releases?
12:35:05 <kkeithley> a long time ago probably
12:35:05 <samikshan> kkeithley: Agreed.
12:35:49 <ndevos> we should definitely document it in the release steps document
12:36:03 <ndevos> #link http://gluster.readthedocs.io/en/latest/Contributors-Guide/GlusterFS-Release-process/
12:36:28 <samikshan> I think this deserves to be an AI?
12:36:39 <kkeithley> sure
12:37:08 <samikshan> #action document RC tagging guidelines in release steps document
12:37:34 <samikshan> #action Discuss RC tagging guidelines on mailing lists
12:37:54 <samikshan> Hrm. So moving on to next topic
12:38:04 <samikshan> #topic GlusterFS-3.7
12:38:17 <samikshan> Not sure, if we have anything interesting here.
12:39:20 <samikshan> Release is scheduled end of September IIRC from last week's meeting
12:39:23 <kkeithley> other than kshlm asking for someone else to take the 3.7.16 release because he's busy
12:39:41 <kkeithley> but he got no volunteers
12:40:00 <samikshan> Yeah and since no one has volunteered yet, he's assigned himself for now
12:40:02 <kkeithley> s/he's busy/he wants to get some work done on glusterd2/
12:40:11 <samikshan> Yep.
12:41:08 <samikshan> I don't think we have much else to be discussed. Moving on to the next topic.
12:41:35 <samikshan> #topic NFS Ganesha
12:42:09 <kkeithley> 2.4.0 GA'd last week.  It's in Fedora 24, 25, 26
12:42:27 <samikshan> Great.
12:42:30 <kkeithley> packages are trickling out for others.  Debian Stretch on d.g.o already.  Ubuntu Xenial in Launchpad
12:42:45 <kkeithley> IIRC ndevos has built in CentOS Storage SIG
12:43:03 <kkeithley> there will probably be a 2.4.1 in short order
12:43:16 <ndevos> nope, I didnt, I was thinking to put it in the gluster39 repository and keep 2.3.x in the older ones
12:43:43 <kkeithley> as there are a couple known issues. Biggest one being a known performance regression that appeared between -dev26 and -dev27 tags
12:44:41 <samikshan> I also saw that a video on NFS Ganesha was published on YouTube :)
12:44:43 <kkeithley> Look for 2.4.1 around mid-October, near NFS Bake-a-thon, being held in Westford, MA.
12:44:51 <kkeithley> ;-)
12:44:55 <kkeithley> how bad was it?
12:45:06 <samikshan> Was nice. :D
12:45:16 <samikshan> #link https://www.youtube.com/watch?v=54y4WkijkoI
12:45:22 <kkeithley> I didn't publish it. That was Amye, Brian, and Colleen's doing.
12:45:43 <samikshan> :)
12:45:45 <kkeithley> Gluster Community FTW.
12:45:55 <samikshan> \m/
12:45:57 <samikshan> :D
12:46:49 <samikshan> #info NFS Ganesha 2.4.1 expected around mid-October, near NFS Bake-a-thon, being held in Westford, MA
12:47:31 <samikshan> Shall I move on?
12:47:32 <ndevos> wow, amye looks different! she's blond now?
12:48:04 <kkeithley> lol. That's Colleen.
12:48:09 <samikshan> Haha!
12:49:05 * ndevos zzzzzZZZ
12:49:09 <samikshan> Okay.. that was a good laugh
12:49:12 <samikshan> Moving on..
12:49:16 * kkeithley isn't sure who Colleen is, or what her role is.
12:49:45 <samikshan> #topic Samba
12:49:48 <kkeithley> She hosted hagarth's hangout too
12:49:56 <samikshan> kkeithley: Oh
12:50:24 <ndevos> so we have two communit managers now?
12:51:11 * samikshan isn't aware
12:51:27 * ndevos neither
12:51:46 <samikshan> Okay.. is obnox around for some updates on samba?
12:52:08 <ndevos> or rjoseph|afk, or rastar or anoopcs or ...
12:52:21 <ndevos> ira!
12:52:39 <samikshan> anoopcs.. he's around I guess! Hi.
12:52:50 <anoopcs> I don't think we have much to update...
12:53:12 <ira> "No updates."
12:53:13 <samikshan> Great..
12:53:23 <samikshan> Okay
12:53:55 <samikshan> Okay I'll move to project-infra now
12:53:59 <samikshan> Totally missed it
12:54:13 <samikshan> #topic Project Infrastructure
12:54:33 * samikshan waves to nigelb and misc
12:55:04 <misc> hey
12:55:10 <misc> so
12:55:28 <misc> we moved the VM from 1 part of the DC to another part of the DC due to urgent unplanned requests
12:55:44 <misc> we are looking at upgrading gerrit, nigel posted plan on github
12:56:13 <misc> https://github.com/gluster/infra-docs/wiki/Gerrit
12:56:28 <misc> the first part about moving the VM is already started
12:56:37 <misc> I finally finished the ansible migration
12:57:01 <misc> and I have been asked to come to the summit next week, so I will be present if people have infra questions
12:57:23 <samikshan> misc: Awesome! Thanks for those updates :)
12:57:43 <samikshan> #link https://github.com/gluster/infra-docs/wiki/Gerrit
12:58:40 <samikshan> And migration to community cage for review.gluster.org and build.gluster.org is complete too
12:58:40 <misc> I think nigel said that we also managed to get the new builders working, but i do not have details, and he is away due to taking day off from this weekend migration
12:59:03 <samikshan> #link http://www.gluster.org/pipermail/gluster-devel/2016-September/051011.html
12:59:07 <samikshan> Okay
13:00:27 <samikshan> Anything else here?
13:00:47 <samikshan> I'll move on to the action items from next week.. Also we're over time
13:00:56 <samikshan> #topic Last week's AIs
13:01:19 <samikshan> #topic rastar_afk/ndevos/jdarcy to improve cleanup to control the processes that test starts
13:01:36 <samikshan> ndevos: Any idea what's up with this?
13:02:04 <ndevos> no progress that I am aware of
13:02:20 <samikshan> Okay. Keeping it open. :)
13:02:26 <ndevos> it's about killing processes in the test-cases that were started in the background (like 'dd' etc)
13:02:39 <samikshan> #action rastar_afk/ndevos/jdarcy to improve cleanup to control the processes that test starts
13:02:41 <samikshan> Okay
13:03:39 * samikshan hurries over to the next AI
13:03:43 <samikshan> #topic RC tagging to be done by this week for 3.9 by aravindavk/pranithk
13:03:47 <samikshan> This is done
13:03:52 <samikshan> Cool
13:04:21 <samikshan> #topic Open Floor
13:04:41 <samikshan> Nothing is added on the etherpad
13:05:17 <samikshan> Are we missing anything..
13:05:42 <samikshan> Okay. I guess I'll end the meeting. :)
13:05:52 <samikshan> Thanks for attending everyone!
13:05:53 <ndevos> thanks samikshan!
13:06:07 <samikshan> Apologies that this one went a few minutes over time
13:06:29 <samikshan> :)
13:06:42 <kkeithley> topic Next weekly community meeting 12:00 UTC  5 October 2016 | Agenda https://public.pad.fsfe.org/p/gluster-community-meetings | Minutes of all our meetings https://meetbot.fedoraproject.org/sresults/?group_id=gluster-meeting&type=channel"
13:07:45 <samikshan> #endmeeting