15:01:59 <kshlm> #startmeeting Gluster Community Meeting 2017-03-15
15:01:59 <zodbot> Meeting started Wed Mar 15 15:01:59 2017 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:59 <zodbot> The meeting name has been set to 'gluster_community_meeting_2017-03-15'
15:02:11 <kshlm> So who all are in today?
15:02:32 <kshlm> I'll wait for 3 more minutes before continuing.
15:03:11 * kkeithley is here
15:03:17 * pkalever here
15:03:38 <kshlm> Hey!
15:03:46 * major is here ..
15:04:21 * rafi is here
15:05:01 <rafi> major: how is going  brtfs snapshot development :)
15:05:44 * ndevos is dropping by for a few minutes, but needs to go voting (yes, the political kind, outside)
15:05:45 <major> well .. I think it is going good.  I ran into some .. unexpected behavior with restoring the snapshots, though I am not entirely certain it is the wrong behavior.
15:06:30 <major> technically the snapshot restored correctly and was available, just the way the metadata was handled for the original volume and stuff has me scratching my head
15:07:00 <kshlm> Add things you want to discuss on the meeting pad https://bit.ly/gluster-community-meetings
15:07:00 <kshlm> pkalever, You should add your demo as a topic as well.
15:07:00 <kshlm> Is it just the 3 of us?
15:07:20 <BatS9_> Going for the lurker role
15:07:22 <rafi> major: great, keep the community posted , so that everyone are aware of it
15:07:29 <rafi> :)
15:07:44 <kshlm> It seems I had a temporary network issue.
15:07:59 <kshlm> #topic Rollcall
15:08:07 <kshlm> So who all are in today?
15:09:26 <major> @here
15:09:38 * rafi is here
15:09:46 * BatS9_ is hereish
15:10:01 * amye is here
15:10:06 <kshlm> New names!
15:10:18 <kshlm> Hey major! Hey BatS9_ !
15:10:31 <kshlm> Let's start then.
15:10:36 <kshlm> Hey amye and rafi!
15:10:48 * pkalever is here
15:10:59 <rafi> kshlm: hey, we can start :)
15:11:17 <kshlm> #topic Old pending reviews
15:11:25 <kshlm> nigelb, Are you here to discuss this?
15:11:49 <ndevos> is that related to the reviews that have been posted against versions that are EOL?
15:13:15 <rafi> ndevos: I think so ,
15:13:57 <ndevos> well, the other option could be that it is about proposed changes that did not get reviewed in months...
15:13:59 <rafi> ndevos: i think kshlm still experiencing the network problem
15:14:38 <kshlm> Doesn't seem like it.
15:14:38 <kshlm> And I guess no one else has context on this either.
15:14:38 <kshlm> We can take this up in the next meeting then.
15:14:38 <ndevos> and nigelb maybe too?
15:14:40 <rafi> ndevos: nigelb's dashboard feature will help here for that
15:14:57 <ndevos> oh, kshlm is back!
15:14:57 <kshlm> Oh man, I have huge lag.
15:15:38 <ndevos> rafi: it only helps if people start to review... not sure if that is happening enough though
15:15:40 <kshlm> Can someone be an additional chair in case I lag out again.
15:16:14 <ndevos> just #chair random people ;-)
15:16:27 <kshlm> #chair ndevos
15:16:27 <zodbot> Current chairs: kshlm ndevos
15:16:31 * ndevos leaves in a bit, so he cant help
15:16:36 <kshlm> Argh!
15:16:57 <kshlm> #chair rafi
15:16:57 <zodbot> Current chairs: kshlm ndevos rafi
15:17:00 <kshlm> Okay.
15:17:06 <kshlm> So we are dicussin old reviews.
15:17:27 <kshlm> nigelb wants to abandon all old reviews on EOLed branches.
15:17:33 <kshlm> Sounds like a good idea to me.
15:17:37 <rafi> ya
15:17:38 <kkeithley> agreed
15:17:54 <vbellur> +1 to abandon old reviews
15:18:09 <kshlm> That's good.
15:18:10 <rafi> how about abandoning the patches older than 90days, even if it in main brnach
15:18:22 <kshlm> He also suggested abandoning patches older than 90 days.
15:18:37 <kshlm> rafi, You are quick.
15:18:40 <vbellur> rafi: that's a good thought.. I am actually in favor of some timespan
15:19:02 <vbellur> kshlm, rafi: propose this idea on -devel?
15:19:09 <ndevos> +1 on the EOL branches, but leave a note as well :)
15:19:26 <rafi> okey
15:19:55 <ndevos> 90 days seems short for some changes, unless it means '90 days without any action', in that case I'd +1 it too
15:19:57 <amye> 90 days should roughly match up with our release cycle as well.
15:20:18 <major> Leave a note for people to feel free to re-open it if they feel it is still a concern ..
15:20:28 <vbellur> 90 days without any action would be more appropriate
15:20:43 <kkeithley> yes, 90 is too short
15:20:49 <pkalever> +1 vbellur
15:21:11 <ndevos> of course, leave a note pointing to the documentation where this timeout is explained and has a description of the actions to take (if wanted)
15:22:01 <ndevos> 90 days can be short, I'd prefer 6 months more
15:22:13 <ndevos> (that is meant to be 180 days, not 270)
15:23:19 <vbellur> 90 days without any action IMO is not good .. so 90 days LGTM
15:24:59 <kshlm> I'd prefer longer than 90 days too.
15:25:16 <ndevos> well, 90 days shows *many* changes that would be abandoned: https://review.gluster.org/#/q/status:open+before:2016-12-15
15:25:56 <vbellur> ndevos, kshlm: openstack uses 30 days for auto abandoning patches
15:26:15 <ndevos> we're not openstack?
15:26:24 <vbellur> if somebody doesn't act on a patch in 90 days since submission, it most likely indicates that they've lost interest in the patch ?
15:26:25 <amye> 90 days without action is still three months, can we try it and see?
15:26:50 <vbellur> ndevos: we are not but there's no harm in looking imbibing best practices from everywhere
15:27:09 <vbellur> s/looking/looking at and/ :)
15:27:17 <ndevos> vbellur: well, the linux kernel does not have a timeout at all :)
15:27:34 <vbellur> ndevos: we don't want to be as slow and boring as the kernel ;)
15:27:39 <major> I wish the kernel would .. I have some code that I want to just die
15:28:09 <ndevos> I guess a discussion on gluster-devel would be good, accompanied with some queries to check, and the number of changes that would be abandoned
15:28:23 <vbellur> we are a lot more agile than the kernel and I wish that we stay the same and get better at being agile
15:29:11 <vbellur> yes, let us discuss this further on -devel
15:29:15 <major> https://review.gluster.org/#/q/age:3+months
15:29:15 <ndevos> it would surely be good, but it also means we need to encourage reviewing much more, at the moment many maintainers are the main ones that review changes
15:30:19 <ndevos> major: hmm, that query does not look correct
15:31:02 <ndevos> major: https://review.gluster.org/#/q/status:open+age:3months looks more like it
15:31:58 <major> yah, that space in there.. my bad
15:32:12 <kshlm> Looks like we have an agreement on this.
15:32:30 <kshlm> Abandoning old patches is good. But we need to decide how old the patches need to be,
15:32:39 <kshlm> This discussion will happen on -devel.
15:32:41 <ndevos> 3 months shows 500+ patches to be abandoned, that seems a lot
15:32:43 <kshlm> Sounds good?
15:33:09 <vbellur> since we don't have this rule, I think a lot of patches are not attended to
15:33:11 <ndevos> yep, sounds good to me
15:33:15 <vbellur> yes
15:33:23 <kshlm> ndevos, `branch:master` needs to be in the query.
15:33:35 <kshlm> vbellur, ndevos, Who is going to start this discussion?
15:33:40 <ndevos> kshlm: and project:glusterfs
15:33:52 <ndevos> didnt rafi accept the challange?
15:33:59 <kshlm> He did?
15:34:09 <kshlm> Oh yes. He did.
15:34:14 <amye> rafi++
15:34:14 <zodbot> amye: Karma for rafi changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:34:15 <major> ndevos, the vast majority of those are older than 6 months aren't they?
15:34:19 <pkalever> how about https://review.gluster.org/#/q/status:open+before:2016-12-15+Code-Review-1+Code-Review-2
15:34:32 <rafi> :-o
15:34:36 <pkalever> or
15:34:36 <pkalever> https://review.gluster.org/#/q/status:open+before:2016-12-15+Code-Review-2
15:34:38 <kshlm> #action rafi will start the discussion on abandoning old reviews on gluster-devel
15:34:47 <ndevos> major: possibly, I did not really check much
15:34:54 <rafi> kshlm: cool, I will do it
15:35:03 <ndevos> rafi: you got quite some ideas on where to start :D
15:35:10 <kshlm> #agreed Old reviews need to be abandoned.
15:35:17 <kshlm> Ok then.
15:35:47 <kshlm> Does anyone have any other topic to discuss before we go to the demo section?
15:36:06 <rafi> ndevos: something I learned from you :)
15:36:32 <rafi> major: brtfs snapshot
15:36:39 <kshlm> No one?
15:36:51 <kshlm> Okay then.
15:36:55 <rafi> major: do you want to discuss about brrfs snapshot ?
15:37:00 <kshlm> #topic Gluster-Block demo
15:37:11 * ndevos needs to leave now, I'll catch up on the rest in the minutes
15:37:11 <major> rafi, I can .. though I am fairly certain I ramble about it fairly regularly :)
15:37:18 <pkalever> please join https://bluejeans.com/102845329/
15:37:53 <kshlm> This is the first demo of hopefully more demos of different Gluster features in the future.
15:37:54 <rafi> major: we should
15:38:04 <rafi> kshlm: great intiative
15:38:16 <kshlm> pkalever will be doing doing a demo about gluster-block now.
15:38:23 <ndevos> major: rambling during the meeting is good for publicity too, others that do not follow your chats outside of their online time might be interested
15:38:38 <kshlm> Did I lag again?
15:38:48 <ndevos> kshlm: yes, a *lot*
15:39:05 <ndevos> or, rather, I guess we all lagged for you
15:40:04 <vbellur> please hop on to bluejeans .. we'll start the demo in 3 minutes
15:40:06 * ndevos really drops off now
15:40:09 <kshlm> Hello?
15:40:18 <major> ndevos, fair enough
15:41:02 <amye> kshlm, we're over in bluejeans. :)
15:41:03 <kshlm> rafi, vbellur, Could one of you take over chairing the meeting?
15:41:15 <vbellur> kshlm: you are lagging!
15:41:37 <vbellur> #chair vbellur
15:41:55 <ndevos> #chair vbellur
15:41:55 <zodbot> Current chairs: kshlm ndevos rafi vbellur
15:42:02 * ndevos _o/
15:42:05 <rafi> kshlm: sure
16:14:36 <rafi> we jsut finished our first demo in gluster meeting
16:14:49 <rafi> it was great presentation from pkalever
16:14:55 <rafi> pkalever++
16:14:55 <zodbot> rafi: Karma for pkalever changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:15:45 <rafi> #topic Action Item
16:15:49 <rafi> amye to work on revised maintainers draft with vbellur to get out for next maintainer's meeting. We'll approve it 'formally' there, see how it works for 3.11.
16:16:07 <rafi> amye: any thing to update ?
16:16:21 <amye> rafi, that should be vbellur's AI, I've passed it on to him.
16:16:45 <rafi> amye: cool,
16:16:46 <amye> I was OOO for maintainers'
16:17:03 <rafi> vbellur: do you have any thing to add ?
16:17:45 <vbellur> rafi: I will post it this week
16:17:54 <vbellur> amye: it was a joint action item ;)
16:18:05 <rafi> vbellur: great
16:18:15 <vbellur> pkalever: well done!
16:18:27 <pkalever> vbellur: thanks.
16:18:36 <rafi> As most of the people having an AI on their name are away , so we will move to the next topic
16:18:59 <rafi> #topic Open floor
16:19:01 <pkalever> amye: I'm still bad at managing time :p
16:19:18 <rafi> any open discussions,
16:19:47 <rafi> vbellur: how do we decide the demo for next week, through mail ?
16:19:53 <rafi> amye: ^
16:21:07 <major> and suddenly crickets... :)
16:21:37 <vbellur> rafi: yes
16:21:50 <vbellur> anybody who is interested can send out an email
16:22:07 <vbellur> it would be nice to build a backlog
16:22:43 <rafi> vbellur: backlog of what ?
16:22:51 <rafi> vbellur: presentation ?
16:23:09 <pkalever> vbellur: And recorded session with it
16:24:19 <major> I suppose I can ramble about the btrfs code
16:24:31 <vbellur> backlog of demos
16:24:38 <vbellur> major: that would be awesome!
16:25:04 <rafi> major: great
16:25:10 <rafi> major++
16:25:30 <rafi> we can discuss that over mail,
16:25:53 <rafi> major: does that sound like a good idea
16:26:13 <rafi> if we don't have anything else to discuss , I will end the meeting
16:28:29 <vbellur> rafi: thank you!
16:28:37 <rafi> cool
16:28:42 <major> Okay, so should I discuss the btrfs stuff now?
16:29:00 <pkalever> rafi++
16:29:00 <zodbot> pkalever: Karma for rafi changed to 2 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:29:48 <rafi> major: usually the community meeting is scheduled for 1 hour, we are already out of time,
16:29:59 <major> Understood :)
16:30:10 <rafi> major: will it be okey if we add the topic to the next meeting agenda
16:30:20 <major> Certainly
16:30:24 <rafi> major: as an high priority item ;)
16:30:32 <major> gives me a chance to pull up my notes ...
16:30:35 <major> was sort of scrambling for them
16:30:37 <major> :)
16:30:44 <rafi> major: :)
16:31:18 <rafi> major: also you can do a demo, if you are confident about brtfs snapshots :)
16:31:44 <rafi> major: we can let the community know about your awesome work (y)
16:31:55 <major> maybe..
16:32:02 <rafi> for now I will stop the meeting
16:32:05 <major> though knowing me I will end up tanking my gluster cluster ;)
16:32:47 <rafi> major: :)
16:32:49 <rafi> once again thank you all for participating the meeting
16:32:54 <rafi> #endmeeting