15:02:03 <kshlm> #startmeeting Gluster Community Meeting 2017-07-05
15:02:03 <zodbot> Meeting started Wed Jul  5 15:02:03 2017 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:03 <zodbot> The meeting name has been set to 'gluster_community_meeting_2017-07-05'
15:02:19 <kshlm> Welcome everyone!
15:02:23 * amye is here
15:02:25 <kshlm> So who all are here?
15:02:32 * ndevos _o/
15:02:40 * kkeithley is here
15:02:47 <kshlm> Hey amye ndevos kkeithley
15:02:55 <ndevos> hi kshlm!
15:02:56 * vbellur is here .. at least for the first half of this meeting
15:03:01 <kshlm> I'll wait for 3 more minutes before continuing.
15:03:26 <kshlm> The current topics in the hackpad seem to be from the last time.
15:03:41 <kkeithley> similar. I did make some edits
15:03:48 <kshlm> Oh. Cool.
15:04:08 <kshlm> So we can discuss them?
15:05:36 * jstrunk is here
15:05:41 <jstrunk> Hi guys.
15:05:47 <amye> oh hai
15:05:51 <kshlm> Hey jstrunk!
15:06:00 <kshlm> Okay. Let's start.
15:06:16 <kshlm> #topic Experimental features
15:06:37 <kshlm> What more do we need to discuss on this topic?
15:07:13 <kshlm> We have an experimental branch now, that will take in the experimental features.
15:08:07 <kshlm> Patches to this branch will get merged more freely.
15:08:28 <kshlm> And this branch will be rebased to master periodically.
15:08:46 <kshlm> Is there anything else about this that needs to be discussed?
15:08:51 <kshlm> Anyone?
15:09:39 <ndevos> not that I know...
15:10:16 <kshlm> Is it okay to move on then?
15:10:26 <amye> Think so
15:11:22 <kshlm> Okay.
15:11:40 <kshlm> #topic Test cases contribution from community
15:12:41 <kshlm> We are looking to get more use case specific test cases from the community.
15:12:59 <kshlm> So how to we go about doing this?
15:13:30 <amye> 1) Have we asked on the mailing lists?
15:13:40 <kshlm> Not that I know of.
15:13:46 <amye> Let's do that first. :)
15:14:05 <vbellur> right :)
15:14:10 <amye> 1a) Do we know what we're looking for?
15:14:17 <vbellur> who added this topic? is there more context on this one?
15:14:36 <kshlm> vbellur, This is one that kkeithley modified.
15:15:05 <kshlm> We've been discussing testing over the past few meetings.
15:15:08 <kkeithley> what did I modify?
15:15:56 <kshlm> kkeithley, Well you said you modified something. I couldn't make out any changes to the first topic.
15:16:41 <kshlm> We've had the topic on Good build tests for while now under different names.
15:17:17 <kshlm> Anyways, anyone have more context to share on this?
15:17:49 * ndevos does not
15:19:59 <kshlm> I'm looking at the previous meeting logs and I haven't found much.
15:20:14 <kshlm> So let's make some assumptions and move forward.
15:20:58 <kshlm> We need application specific test cases.
15:21:04 <kshlm> What would those be?
15:21:08 <kkeithley> sorry for delay in responding. I didn't change any topics from previous meetings. I removed topics that were covered and not relevant to the next (i.e. this) meeting.
15:21:37 <kshlm> kkeithley, That's cool.
15:22:45 <ndevos> application specific tests, would that be oVirt, OpenStack, Bareos, some dropbox like thingy, webserver, ...?
15:23:19 <ndevos> many other projects/applications have their own test-suites, run those on top of Gluster?
15:23:59 <ndevos> there is a long-standing request to run upstream qemu tests (Advocado test-suite?) configured to use a gluster backend
15:23:59 <kshlm> That would be one way.
15:24:52 <kshlm> Could we use qemu as a pilot for this effort?
15:25:26 <ndevos> sure, but that test-suite is rather complex, and I've not figured out how to run it yet
15:25:55 <kshlm> Okay.
15:26:02 <ndevos> oh, it's pending for just a year now! https://github.com/gluster/glusterfs-patch-acceptance-tests/issues/31
15:26:07 <kshlm> Anything else that is simpler that we can start with?
15:27:23 <ndevos> the cthon04 locking test on top of FUSE/Samba/Ganesha?
15:28:02 <ndevos> thats a single client test, and performs some locking operations that are common for different applications
15:28:16 <kshlm> That isn't a use case though. It's testing a particular feature of the FS.
15:29:02 <ndevos> well, most of the tests are written with specific applications or user interactions in mind
15:30:02 <ndevos> we could run apache benchmartking tool too, users do store their websites on gluster, but I dont know how much value something like that has
15:30:12 <kshlm> That's good. We have two candidates.
15:31:06 <kshlm> Like the qemu test-suite, I think this will mostly come down to running a particular projects test-suite against a gluster backend.
15:31:26 <kshlm> Doing this will get really complex really fast IMO.
15:32:27 <ndevos> yes, and each project tests differently... we need to investigate how their test-suites work, and how to automate the configuration
15:33:11 <kshlm> Doing this for each every project that uses gluster is not something that I wish to do.
15:33:34 <kshlm> Don't we have any stats on what user use Gluster for/with?
15:33:39 <ndevos> no, but if we want to prevent breaking integrations of other projects, we will need to look into it :-/
15:34:15 <ndevos> maybe amye has some stats we can use to decide what applications to look at?
15:34:51 <kshlm> Yup, maybe choose the most popular project for each type of use-case, and try to run tests for those.
15:35:03 <amye> Not to speak of. We would need to be able to start a new thread on the users lists for your use-cases to get more granular data like that.
15:35:23 <kshlm> Cool. So I guess we've come back to amye's first suggestion.
15:35:39 <kshlm> Ask on the mailing lists.
15:35:39 <amye> Suggest that the team driving this starts a thread and can even set up a meeting time in here to discuss with interested parties.
15:35:59 <kshlm> Who is driving this BTW?
15:36:05 <kshlm> vbellur, ^
15:36:42 <kshlm> Is shyam/nigelb/rtalur/someone else?
15:37:36 <ndevos> I dont know... maybe we should add a username next to each agenda topic
15:38:03 <kshlm> I'm guessing shyam. I'll try to figure it out.
15:38:13 <kshlm> I'll add an action item though.
15:39:13 <kshlm> #action The person leading the application specific tests cases should start the survey to collect info on applications used with gluster
15:39:26 <kshlm> #action kshlm to find out who that person is
15:42:49 <kshlm> We don't have anything more discuss on this till the person responsible shows up.
15:43:03 <kshlm> I'll move on to the next topics if there are no objections.
15:44:03 <ndevos> sounds good to me
15:44:32 <kshlm> Okay.
15:44:39 <kshlm> Let's move on the action items.
15:45:17 <kshlm> #topic ndevos will check with Eric Harney about the Openstack Gluster efforts
15:45:49 <ndevos> oh, yes, that is still a TODO - I was distracted with other work
15:46:01 <kshlm> ndevos, Carry this forward?
15:46:19 <ndevos> yes please, I try to have an update before the next meeting
15:46:23 <kshlm> #action ndevos will check with Eric Harney about the Openstack Gluster efforts
15:46:45 <kshlm> Neither jdarcy or nigelb are here, so skipping the next AI
15:47:21 <kshlm> #topic nigelb will document kkeithley's build process for glusterfs packages
15:47:29 <kshlm> kkeithley, Has this happened yet?
15:47:34 <kkeithley> we walked through building packages
15:47:48 <kkeithley> I haven't seen any documentation from him thought
15:47:50 <kkeithley> thgough
15:48:10 <kkeithley> though
15:48:19 <kshlm> Cool. I'll leave this open on nigelb.
15:48:58 <kshlm> #action nigelb will document the walkthrough given by kkeithley on building packages
15:49:23 <kshlm> Looks like JoeJulian isn't in today. So I'll skip the next topic as well
15:49:43 <kshlm> Okay. Onto some updates.
15:50:58 <kshlm> #info 3.11.1 was tagged. But there hasn't been a release announcement that I've seen yet.
15:51:11 <amye> No, there definitely was
15:51:56 <amye> http://lists.gluster.org/pipermail/gluster-users/2017-June/031618.html
15:52:02 <amye> ^ release announcement
15:52:21 <kshlm> Okay. Correction.
15:52:32 <amye> :)
15:52:32 <kshlm> #info 3.11.1 was announced.
15:52:59 <ndevos> I dont think there was a blog post though, or do we not require that anymore?
15:53:44 <kshlm> ndevos, That's what I looked for as well.
15:54:51 <kshlm> Seeing as I'm one of the 3.11 maintainers I can do that.
15:55:17 * kshlm didn't do anything w.r.t 3.11.1 though.
15:55:34 <kkeithley> you can do the blog. ;-)
15:55:48 <amye> We don't need blog posts for point releases
15:56:00 <amye> the major releases, yes
15:56:03 <kshlm> kkeithley, ;-)
15:56:03 <amye> point releases, no
15:56:41 <kshlm> I used to blog posts for 3.7.z releases. But those were on my personal blog rather than blog.gluster.org
15:57:26 <kshlm> They used to show up on the homepage when planet.g.o synced.
15:57:31 <kshlm> I thought that helped.
15:57:47 <amye> Mailing lists posts are appropriate though. Announce through the mailing list, keep working on the next version. If we want to be able to have a special set of links for 'latest point releases' that's easy enough.
15:58:04 <kshlm> That's fine with me.
15:58:43 <amye> Less chaos for everyone trying to be able to get a mailing list post and a blog post out.
15:59:08 <kkeithley> What about 3.10.4? (Now 16 days overdue.)
15:59:24 <kkeithley> Or is it just six days overdue?
15:59:42 <ndevos> only 6, I think?
15:59:42 <amye> http://lists.gluster.org/pipermail/gluster-users/2017-June/031400.html is the last post I saw on this
16:00:28 <kshlm> rtalur was leading this.
16:01:00 <kshlm> I'll ping him for an update.
16:01:18 <kshlm> We're outta time.
16:01:30 <kshlm> One more announcement to make before ending this meeting.
16:01:36 <kkeithley> so gnfs is off by default in the autoconf config. For packaging it's is now/still explicitly enabled. I'm tentatively planning to continue doing that for 3.12 but stop for 4.0. Anyone who wants it can build their own 4.0 packages with it enabled.  Any objections?
16:02:49 <kkeithley> or have more discussion next meeting?
16:02:51 <ndevos> no, disable it!
16:03:10 <ndevos> that was the plan all along, right?
16:03:13 <kkeithley> yes
16:03:21 <kkeithley> maybe I should stop in 3.12?
16:03:31 <kshlm> There is a new GD2 release. We now have RPMs for Fedora 25 and above, and EL7. There have been some changes in the plan for GD2 since the last release. We'll be updating the community about this soon.
16:04:04 <ndevos> keep it with 3.12, it has *just* been made optional
16:04:25 <kshlm> We'll be back to having regular updates on GD2 from now on.
16:04:40 <ndevos> kshlm: should we put GD2 in the testing repository for the CentOS Storage SIG?
16:04:56 <ndevos> or is it too early for that?
16:05:22 <kshlm> ndevos, Not right now. The spec isn't 100% yet.
16:05:47 <ndevos> ok
16:05:59 <kshlm> We require internet access during build, which isn't recommended.
16:06:16 <ndevos> oh, indeed, and probably not possible either
16:06:17 <kshlm> We'll fix that. Then we can have regular builds in the storage-sig.
16:06:55 <kshlm> COPR allows it. That's why I've hosted on it for the moment
16:07:17 <kshlm> That's all I had.
16:07:30 <kshlm> We're 7 minutes past end time.
16:07:38 <kshlm> I'll end the meeting in
16:07:41 <kshlm> 3
16:07:44 <kshlm> 2
16:07:44 <ndevos> 2
16:07:46 <kshlm> 1
16:07:53 <kshlm> #endmeeting