<@davdunc:fedora.im>
16:06:50
!startmeeting fedora_cloud_meeting
<@meetbot:fedora.im>
16:06:50
Meeting started at 2023-12-21 16:06:50 UTC
<@meetbot:fedora.im>
16:06:50
The Meeting name is 'fedora_cloud_meeting'
<@davdunc:fedora.im>
16:07:00
!topic roll call
<@conan_kudo:matrix.org>
16:07:07
!hi
<@zodbot:fedora.im>
16:07:10
Neal Gompa (ngompa) - he / him / his
<@davdunc:fedora.im>
16:07:24
can I chair now?
<@davdunc:fedora.im>
16:07:31
!chair Conan Kudo
<@davdunc:fedora.im>
16:07:34
no.
<@conan_kudo:matrix.org>
16:07:47
still not supported :(
<@davdunc:fedora.im>
16:08:00
we'll get there.
<@davdunc:fedora.im>
16:08:01
:)
<@nhanlon:beeper.com>
16:08:07
!hi
<@zodbot:fedora.im>
16:08:08
Neil Hanlon (neil) - he / him / his
<@davdunc:fedora.im>
16:08:18
hi Neil Hanlon
<@nhanlon:beeper.com>
16:08:28
i *think* I heard !chair isn't supported because it's no longer needed to run commands
<@davdunc:fedora.im>
16:08:49
well that's cool.
<@conan_kudo:matrix.org>
16:09:01
well, the point of chair was to filter who could run them... :/
<@conan_kudo:matrix.org>
16:09:05
but okay
<@nhanlon:beeper.com>
16:09:12
right, yeah. just repeating what I heard
<@nhanlon:beeper.com>
16:09:23
(read)
<@davdunc:fedora.im>
16:09:28
I appreciate that.
<@davdunc:fedora.im>
16:09:40
cool.
<@davdunc:fedora.im>
16:10:00
okay.
<@davdunc:fedora.im>
16:10:42
!topic Action items from last meeting
<@davdunc:fedora.im>
16:11:05
!info davdunc and ngompa to schedule a hackfest on the Fedora Calendar and post to the mailing list.
<@davdunc:fedora.im>
16:11:10
we did it.
<@davdunc:fedora.im>
16:11:19
we will do another one after the shutdown.
<@davdunc:fedora.im>
16:11:35
. . . and another . . . and another. . . you get the picture.
<@conan_kudo:matrix.org>
16:12:06
the Cloud hackfests were rather productive
<@conan_kudo:matrix.org>
16:12:13
we've made a ton of progress in the two we've had so far
<@davdunc:fedora.im>
16:12:18
indeed!
<@davdunc:fedora.im>
16:12:33
!info davdunc to include oracle cloud upload in the saturday hackfest and testing
<@davdunc:fedora.im>
16:12:40
I didn't get that completed.
<@davdunc:fedora.im>
16:13:11
I am looking forward to completing the ansible work before the next meeting though.
<@davdunc:fedora.im>
16:13:35
!info davdunc to complete blogpost for fedora magazine with @themayor and team.
<@davdunc:fedora.im>
16:13:41
I am behind on that one too.
<@davdunc:fedora.im>
16:14:31
bstinson asked me if I was still working on it. i have good intentions, but having to reprioritize. If someone completes a blogpost before me, I won't be sad.
<@davdunc:fedora.im>
16:15:04
Anything to add?
<@conan_kudo:matrix.org>
16:15:17
we still need to sync up with the Azure folks
<@davdunc:fedora.im>
16:15:42
it's there. Sandeep is pretty active on CoreOS, but we haven't been as available.
<@davdunc:fedora.im>
16:15:50
he's willing.
<@conan_kudo:matrix.org>
16:15:59
cool
<@davdunc:fedora.im>
16:16:02
Sandeep is from Azure team. PM.
<@conan_kudo:matrix.org>
16:16:25
ah okay
<@davdunc:fedora.im>
16:16:48
I ahve been buried under a management shuffle and all of the requirements necessary to ensure support for my LOB.
<@davdunc:fedora.im>
16:17:24
so i havne't been available this past ... month really.
<@conan_kudo:matrix.org>
16:17:32
oof
<@conan_kudo:matrix.org>
16:17:41
hopefully things are going to be better going forward?
<@davdunc:fedora.im>
16:17:53
yea. The good news is that it's over as of yesterday.
<@davdunc:fedora.im>
16:17:54
:)
<@davdunc:fedora.im>
16:18:06
so I am back to being a builder.
<@nhanlon:beeper.com>
16:18:12
also, sorta same. I'm transitioning into a new fully-foss-focused role :)
<@davdunc:fedora.im>
16:18:23
Neil Hanlon: that is fabulous.
<@davdunc:fedora.im>
16:18:34
I hope we can be a part of that.
<@davdunc:fedora.im>
16:18:39
okay. . .
<@nhanlon:beeper.com>
16:18:44
That is the plan! :D
<@davdunc:fedora.im>
16:18:51
Can we discuss the new PRD?
<@conan_kudo:matrix.org>
16:19:12
didn't we already approve that last year?
<@davdunc:fedora.im>
16:19:29
sorry.
<@davdunc:fedora.im>
16:19:37
I said that when I meant "Change Proposal
<@davdunc:fedora.im>
16:19:38
"
<@conan_kudo:matrix.org>
16:20:11
ah okay
<@conan_kudo:matrix.org>
16:20:29
sure, topic change away :)
<@davdunc:fedora.im>
16:21:06
!topic KIWI builder for Cloud Images Change Proposal
<@davdunc:fedora.im>
16:21:30
<@conan_kudo:matrix.org>
16:22:55
this change document went through a lot of churn in the last couple of days :)
<@davdunc:fedora.im>
16:23:02
as we have been discussing for some time now, we have kiwi image build support for a lot of the image types we wanted to build.
<@conan_kudo:matrix.org>
16:23:02
but I'm pretty pleased with the end result
<@davdunc:fedora.im>
16:23:17
yea. great additions Conan Kudo
<@conan_kudo:matrix.org>
16:23:28
thanks to Davide Cavalca for stepping up and helping on structuring it after davdunc made the proposal and I cleaned it up
<@davdunc:fedora.im>
16:23:30
much better organization than when I started.
<@davdunc:fedora.im>
16:23:38
Davide Cavalca++
<@zodbot:fedora.im>
16:23:40
davdunc gave a cookie to dcavalca. They now have 17 cookies, 2 of which were obtained in the Fedora 39 release cycle
<@davdunc:fedora.im>
16:24:06
I am super grateful for everyone who looked it over.
<@davide:cavalca.name>
16:24:14
thanks, happy to help
<@davide:cavalca.name>
16:24:24
hopefully the discussion will be productive
<@dustymabe:matrix.org>
16:24:32
did someone say CoreOS :)
<@davdunc:fedora.im>
16:24:38
I hope so, yes. :)
<@davdunc:fedora.im>
16:24:39
haha.
<@conan_kudo:matrix.org>
16:24:43
hey dustymabe rises from the crypt :P
<@davdunc:fedora.im>
16:24:47
I did dustymabe !
<@davdunc:fedora.im>
16:24:57
because . . . AWESOME!
<@nhanlon:beeper.com>
16:25:16
great job on the Change Proposal, everyone! :D
<@davdunc:fedora.im>
16:25:20
I was saying that Sandeep was active in the coreos updates.
<@davdunc:fedora.im>
16:25:39
on the Azure side and that he was waiting on me to finish an article.
<@davdunc:fedora.im>
16:25:54
thanks Neil Hanlon
<@davdunc:fedora.im>
16:27:35
back on topic: I think it's important that we recognize that this provides us a lot of build types that we need today.
<@davdunc:fedora.im>
16:28:12
we are looking at kiwi as a companion to the work on osbuild and not a replacement for working directly with the image builder team.
<@davdunc:fedora.im>
16:28:35
So we will continue to work on both.
<@conan_kudo:matrix.org>
16:28:57
one thing I expect we'll wind up doing is developing some communities of practice blueprints for people who want to use osbuild
<@davdunc:fedora.im>
16:29:03
We need the kiwi builds today because we can achieve our goals faster.
<@conan_kudo:matrix.org>
16:29:12
I wanted for us to do that with ImageFactory too, but I couldn't even get the tool to run locally
<@davdunc:fedora.im>
16:29:18
that sounds like a GREAT idea Conan Kudo
<@nhanlon:beeper.com>
16:29:53
oh, ImageFactory...
<@conan_kudo:matrix.org>
16:30:12
even if we use one tool for our images, I want us to give people options for their own tooling and provide a level of support where reasonable
<@davdunc:fedora.im>
16:30:14
we should follow the rules that the Karsten's team developed in the Operate First initiatives and build our own Architectural Decision Records.
<@conan_kudo:matrix.org>
16:30:32
like, similarly I'd like to work with Davide Cavalca and his team to offer some samples with mkosi too
<@davdunc:fedora.im>
16:30:43
I mean, the ChangeProposal is that, but we should probably have something more discoverable in the cloud-sig repo.
<@davide:cavalca.name>
16:30:59
Daan is still working on that mkosi koji plugin btw
<@davide:cavalca.name>
16:31:10
which will make mkosi more viable for these kind of things in the future
<@davdunc:fedora.im>
16:31:32
yea. we really want to get rid of all of the python-2.7
<@conan_kudo:matrix.org>
16:31:38
and I've got some dusty old kiwi samples for building layered descriptions that I think we can turn into something the SIG offers
<@davdunc:fedora.im>
16:31:49
awesome.
<@conan_kudo:matrix.org>
16:31:52
for those who want to build their own images from scratch
<@davdunc:fedora.im>
16:32:05
so . . . I'm working on the toddler effort.
<@conan_kudo:matrix.org>
16:32:27
and maaybe, if appliance-tools can still make working cloud images, we can keep some sample kickstarts too :)
<@davdunc:fedora.im>
16:32:29
but we'll make that a part of the working group efforts in our hackfests.
<@conan_kudo:matrix.org>
16:32:32
and maybe, if appliance-tools can still make working cloud images, we can keep some sample kickstarts too :)
<@davdunc:fedora.im>
16:32:42
that would be cool.
<@davdunc:fedora.im>
16:32:59
we have UEFI only support moving into kiwi too, right Conan Kudo
<@conan_kudo:matrix.org>
16:33:17
there's a ticket for that.. one sec
<@conan_kudo:matrix.org>
16:33:36
<@davdunc:fedora.im>
16:34:13
excellent.
<@conan_kudo:matrix.org>
16:34:22
it's not a blocker for the UKI images stuff since you need to use "custom" mode, but I'd like this to be easier and declarative for regular use-cases
<@conan_kudo:matrix.org>
16:34:36
like, there's no reason for hybrid boot on Azure images, for example
<@davdunc:fedora.im>
16:34:36
we don't want to leave behind the UKI work. I think that's very important.
<@davdunc:fedora.im>
16:35:03
I like the way you are thinking about it.
<@davdunc:fedora.im>
16:35:35
okay. . . Any other feedback? dustymabe did you get a chance to review at all?
<@davdunc:fedora.im>
16:35:58
no pressure. It's a busy time and you have a lot on your plate.
<@conan_kudo:matrix.org>
16:36:35
I should note there are a series of releng tickets that need to be processed for this
<@conan_kudo:matrix.org>
16:36:54
<@conan_kudo:matrix.org>
16:37:02
<@conan_kudo:matrix.org>
16:37:09
those are the two main ones left
<@davdunc:fedora.im>
16:37:55
thanks for that Conan Kudo
<@conan_kudo:matrix.org>
16:38:03
I've wired up our kiwi descriptions to Fedora CI as well
<@conan_kudo:matrix.org>
16:38:23
<@davdunc:fedora.im>
16:38:27
oh yea.
<@davdunc:fedora.im>
16:38:36
we should move to that as a topic!
<@davdunc:fedora.im>
16:38:44
I want some show and tell.
<@conan_kudo:matrix.org>
16:38:56
alright let's go :)
<@davdunc:fedora.im>
16:39:04
last chance for more discussion on the Change
<@davdunc:fedora.im>
16:39:21
!topic Fedora CI for Kiwi descriptions
<@davdunc:fedora.im>
16:39:35
<@davdunc:fedora.im>
16:39:49
Conan Kudo: tell us what you've done here.
<@davdunc:fedora.im>
16:39:58
So cool!
<@conan_kudo:matrix.org>
16:40:46
So, I've wired up fedora-kiwi-descriptions to the Zuul instance in Fedora's Software Factory. With this, we now have image builds validating our description targets on every pull request.
<@davdunc:fedora.im>
16:41:17
it sounds like you learned a lot about tmt definitions as well in Zuul.
<@davdunc:fedora.im>
16:41:33
magnificent work.
<@davdunc:fedora.im>
16:41:59
Is there anything we need to know about working with them?
<@conan_kudo:matrix.org>
16:43:01
so when we're onboarding new image outputs or layered image types, the structure in place should give you useful hints
<@davdunc:fedora.im>
16:43:14
got it.
<@conan_kudo:matrix.org>
16:43:40
For example, I think there was a request for a KubeVirt targeted disk image? We should be able to add that now and ensure it's tested to build and work.
<@davdunc:fedora.im>
16:44:00
that's fabulous.
<@conan_kudo:matrix.org>
16:44:19
If the necessary output form for a new image isn't supported in kiwi, we can talk to them upstream in #kiwi:matrix.org and get that sorted out.
<@davdunc:fedora.im>
16:44:34
yea. kubevirt is an interesting use case.
<@conan_kudo:matrix.org>
16:45:12
I think the next new image that's probably coming are some UKI-based images
<@conan_kudo:matrix.org>
16:45:29
so we should engage with those change proposers to get them to make a pull request to add it
<@davdunc:fedora.im>
16:45:53
I am excited because this definitely makes a broader contribution space and opportunity for contributors from many other spaces to come together around fedora and especially the cloud edition.
<@conan_kudo:matrix.org>
16:46:01
The next step that would be great for someone to do is write documentation about this.
<@davdunc:fedora.im>
16:46:31
(╯°□°)╯︵ ┻━┻ documentation
<@davdunc:fedora.im>
16:46:43
we need so much work on cloud docs.
<@conan_kudo:matrix.org>
16:46:44
We actually don't have a documentation site on https://docs.fedoraproject.org/en-US/docs/
<@conan_kudo:matrix.org>
16:46:47
that's surprising
<@davdunc:fedora.im>
16:46:58
can I change the topic to docs?
<@conan_kudo:matrix.org>
16:47:09
let's do that
<@davdunc:fedora.im>
16:47:24
!topic Docs is our New Year's resolution
<@davdunc:fedora.im>
16:47:52
we can't waste any more time getting docs in place.
<@conan_kudo:matrix.org>
16:48:31
We actually _have_ to do it now since we're changing literally everything about how Cloud images are built and work.
<@davdunc:fedora.im>
16:48:32
I can't really add it as a requirement, but we have to make this discoverable and helpful to users.
<@davdunc:fedora.im>
16:49:51
let's endeavor to add that as a part of our working group requirements and dedicate 20% of our working time to documentation for every hack time.
<@conan_kudo:matrix.org>
16:50:50
Yes. I hope this will also help us bring in more contributors who want to show how to use things too.
<@davdunc:fedora.im>
16:51:17
!action reserve 20% of hackfest time for working on documentation
<@davdunc:fedora.im>
16:51:37
just putting that up there so that people will know.
<@davdunc:fedora.im>
16:51:47
okay. one more topic.
<@davdunc:fedora.im>
16:51:55
!topic calls for papers
<@davdunc:fedora.im>
16:52:11
we have a few CFPs out there that I would like to work on.
<@davdunc:fedora.im>
16:52:28
we should have some support for FOSDEM Fedora spaces too.
<@davdunc:fedora.im>
16:53:09
first up - Devconf.cz should have something around our work on the kiwi definitions and builds for F40.
<@davdunc:fedora.im>
16:53:45
Open Source Summit North America is open and we should do something there on image use across multi-cloud
<@davdunc:fedora.im>
16:54:11
and I would love to have a cloud workshop or two that we can do for building images.
<@conan_kudo:matrix.org>
16:54:37
Texas LinuxFest is open for another week or so too, and would probably be a good target for this.
<@davdunc:fedora.im>
16:54:48
100% Conan Kudo
<@nhanlon:beeper.com>
16:54:50
LFNW is open until Jan 02, as well (not sure if that's been discussed)
<@davdunc:fedora.im>
16:55:01
Neil Hanlon: YES!
<@conan_kudo:matrix.org>
16:55:12
LFNW == Linuxfest Northwest
<@nhanlon:beeper.com>
16:55:21
yes, thank you Conan Kudo
<@davdunc:fedora.im>
16:55:32
Neil Hanlon: that's a great place for us to discuss that work too.
<@davdunc:fedora.im>
16:56:00
also, it happens to be one of my favorite conferences!
<@nhanlon:beeper.com>
16:56:09
I'm personally interested in the overlap with this initiative and the stuff I'm doing w/ Rocky cloud images. Really love the work and enablement y'all have been doing in the images space :)
<@davdunc:fedora.im>
16:56:35
good. ..
<@davdunc:fedora.im>
16:56:45
!info Devconf.cz CFP is open
<@davdunc:fedora.im>
16:56:48
<@davdunc:fedora.im>
16:57:26
!info Open Source Summit CFP is open
<@davdunc:fedora.im>
16:57:29
<@davdunc:fedora.im>
16:58:10
!info LinuxFest Northwest CFP is open
<@davdunc:fedora.im>
16:58:12
<@davdunc:fedora.im>
16:58:36
Let's chat with Justin W. Flory (he/him) about what we can do for him at Fosdem.
<@davdunc:fedora.im>
16:58:45
okay
<@davdunc:fedora.im>
16:58:54
!topic open floor
<@conan_kudo:matrix.org>
16:59:05
you forgot about TXLF
<@davdunc:fedora.im>
16:59:10
Anything we didn't cover that we need to talk about.
<@davdunc:fedora.im>
16:59:42
!info Texas Linux Festival CFP is open
<@davdunc:fedora.im>
16:59:45
<@davdunc:fedora.im>
16:59:55
got it!
<@davdunc:fedora.im>
16:59:56
;)
<@davdunc:fedora.im>
17:00:23
alright... I have one more that we need to reaction
<@davdunc:fedora.im>
17:00:49
!action include dnf5 plugin for cloud builds
<@conan_kudo:matrix.org>
17:01:33
kiwi already supports using dnf5, so we can do that whenever we want :)
<@davdunc:fedora.im>
17:01:42
awesome1
<@davdunc:fedora.im>
17:01:46
okay.
<@davdunc:fedora.im>
17:01:53
anything from anyone else?
<@davdunc:fedora.im>
17:01:59
3
<@davdunc:fedora.im>
17:02:00
2
<@davdunc:fedora.im>
17:02:03
1
<@nhanlon:beeper.com>
17:02:12
+1 :)
<@davdunc:fedora.im>
17:02:15
thanks for being here
<@davdunc:fedora.im>
17:02:23
thanks for the help and all the effort
<@davdunc:fedora.im>
17:02:31
!endmeeting