<@tflink:fedora.im>
14:02:41
!startmeeting PyTorch
<@meetbot:fedora.im>
14:02:41
Meeting started at 2023-12-07 14:02:41 UTC
<@meetbot:fedora.im>
14:02:41
The Meeting name is 'PyTorch'
<@tflink:fedora.im>
14:02:54
!topic welcome
<@tflink:fedora.im>
14:03:16
!chair Kaitlyn
<@tflink:fedora.im>
14:03:37
sorry, this is the first time I've tried to use the new meetbot
<@tflink:fedora.im>
14:04:17
!halp
<@tflink:fedora.im>
14:04:25
!undo
<@kaitlynabdo:fedora.im>
14:04:26
no worries, ive never used it either so thanks!
<@tflink:fedora.im>
14:04:56
sorry to whoever ends up reading these logs, they might be a bit messy :)
<@tflink:fedora.im>
14:05:06
!hello
<@zodbot:fedora.im>
14:05:08
Tim Flink (tflink)
<@kaitlynabdo:fedora.im>
14:05:16
so the two things i have on the agenda for today is just general updates and then talk about a change proposal
<@tflink:fedora.im>
14:05:38
is it just the three of us?
<@kaitlynabdo:fedora.im>
14:06:06
i think so
<@trix:fedora.im>
14:07:05
everyone is _using_ the shiny new pytorch :)
<@tflink:fedora.im>
14:07:52
I guess we can get started, then
<@tflink:fedora.im>
14:07:57
!topic General Updates
<@trix:fedora.im>
14:08:09
which is my update.. pytorch is in rawhide
<@tflink:fedora.im>
14:08:20
\o/
<@kaitlynabdo:fedora.im>
14:08:22
OMG thats great!!!
<@mystro256:fedora.im>
14:08:54
👍️
<@mystro256:fedora.im>
14:09:10
🎊
<@mystro256:fedora.im>
14:09:36
oh look at that, element show confeti
<@kaitlynabdo:fedora.im>
14:10:05
so ive never submitted a change proposal before, has anyone here done that?
<@tflink:fedora.im>
14:10:28
I assume that's all the updates, then?
<@trix:fedora.im>
14:10:39
more updates...
<@trix:fedora.im>
14:11:03
most of ROCm math is in, ROCm AI is current todo list
<@trix:fedora.im>
14:11:56
I am workingon the pytorch examples.. lots of things to do there, i have torchtext,data,viedo queued up for review
<@tflink:fedora.im>
14:12:36
!info pytorch is now in rawhide
<@tflink:fedora.im>
14:12:52
!info most of ROCm math has been packaged
<@trix:fedora.im>
14:13:31
i am reviewing openvino, it has issue with large third_party like pytorch
<@tflink:fedora.im>
14:13:52
!info more packages are pending, torch text, data and video
<@tflink:fedora.im>
14:14:25
yeah, that does seem to be a common thing to do nowadays. is it like pytorch where it's all git subrepos?
<@trix:fedora.im>
14:15:42
yeah. so there is stuff to unwind in openvino.
<@tflink:fedora.im>
14:16:19
oof, I was hoping you were going to say no but kinda knew better
<@trix:fedora.im>
14:17:55
if we could find the intersection of openvino needs and pytorch packages we could still use, i think we could move both along.
<@trix:fedora.im>
14:18:24
some things like mkl depend on dpc++ and i don't think we have that compiler in fedora
<@tflink:fedora.im>
14:18:48
are there still pytorch deps left to package? obviously not the critical ones but any for additional functionality that isn't currently enabled?
<@trix:fedora.im>
14:19:24
yes. still functionality to do.. we just have a minimal thing going
<@trix:fedora.im>
14:19:43
folks are asking about opencl support
<@trix:fedora.im>
14:20:28
lots of hw we could plug in. just my focus is on rocm. so looking for who wants to handle others
<@tflink:fedora.im>
14:22:44
!info there are still pytorch deps left to do for additional functionality
<@tflink:fedora.im>
14:22:48
!link https://fedoraproject.org/wiki/SIGs/PyTorch/packagingStatus
<@tflink:fedora.im>
14:23:00
anything else before we move on?
<@trix:fedora.im>
14:23:15
nope.. i'm typed out!
<@tflink:fedora.im>
14:24:04
thanks for the updates!
<@tflink:fedora.im>
14:24:25
!topic Change Proposal
<@kaitlynabdo:fedora.im>
14:26:52
is this release of pytorch ready so that we can submit a change proposal?
<@trix:fedora.im>
14:27:44
what is needed for 'ready' ?
<@trix:fedora.im>
14:27:59
i do not know what a change proposal is
<@kaitlynabdo:fedora.im>
14:28:52
if its something that will be part of the next fedora release
<@trix:fedora.im>
14:29:22
its in rawhide, doesn't it just roll into the next release automatically ?
<@tflink:fedora.im>
14:29:49
yeah, it'd be more of an advertising thing. not sure if a change proposal is strictly required for pytorch
<@kaitlynabdo:fedora.im>
14:30:03
the change proposal is just some paperwork that is supposed explain what youre putting into it
<@kaitlynabdo:fedora.im>
14:30:09
^^ yes exactly
<@kaitlynabdo:fedora.im>
14:30:45
the change proposal is just some paperwork that is supposed explain what youre putting into it and why
<@trix:fedora.im>
14:30:47
ok lets work on the paperwork.. maybe i can get a tour of pacific islands out of it !?!?
<@tflink:fedora.im>
14:30:58
when are the F40 change proposals due?
<@kaitlynabdo:fedora.im>
14:31:13
https://fedorapeople.org/groups/schedule/f-40/f-40-key-tasks.html
<@tflink:fedora.im>
14:31:34
2024-01-26 is what it looks like
<@kaitlynabdo:fedora.im>
14:31:38
1/16/24 since this is a self contained change
<@kaitlynabdo:fedora.im>
14:31:45
so weve got some time
<@kaitlynabdo:fedora.im>
14:32:29
what ill do is start putting together stuff and then ill share it w everyone
<@tflink:fedora.im>
14:32:29
with a 2024-02-06 branch date if there are more packages/functionality we wanted to get into F40
<@trix:fedora.im>
14:32:36
nice! a schedule.. i am clueless you can see
<@trix:fedora.im>
14:32:59
if you want to poke me offline, i can help out
<@tflink:fedora.im>
14:34:14
!info 2024-01-26 is the F40 due date for self-contained changes
<@tflink:fedora.im>
14:35:14
!action Kaitlyn to start putting a F40 change proposal draft for pytorch
<@kaitlynabdo:fedora.im>
14:36:31
ya next steps then are to start putting together the change proposal and also like tim said focus on if theres any more packages/functionality to add that will be included in the change
<@mystro256:fedora.im>
14:37:21
Are we starting to actually put pytorch and rocm as a part of fedora change proposals now?
<@mystro256:fedora.im>
14:37:41
I.e. should I start worrying about planning what ROCm release goes into what Fedora release?
<@tflink:fedora.im>
14:38:12
I'm not sure that we need to be doing change proposals for every release
<@mystro256:fedora.im>
14:38:16
I'm sort of doing it adhoc right now
<@trix:fedora.im>
14:38:30
6 is coming up.. and we have about 4 ai ones yet to do
<@trix:fedora.im>
14:38:49
could we pause on 6 to to get the ai ones in ?
<@mystro256:fedora.im>
14:39:04
6 as in ROCm 6.0?
<@trix:fedora.im>
14:39:07
yes
<@tflink:fedora.im>
14:39:30
is there a huge difference in packaging the remaining bits for 5.7 vs 6?
<@mystro256:fedora.im>
14:39:36
I'd like to get 6.0 into F40 if we have the runway for it
<@mystro256:fedora.im>
14:39:50
I think there's some breaking changes, but I need to review the changes
<@tflink:fedora.im>
14:39:51
is the release date for 6.0 public?
<@trix:fedora.im>
14:40:11
folks are asking for 6 now..
<@mystro256:fedora.im>
14:40:24
not sure, but it's soon™
<@mystro256:fedora.im>
14:40:40
yeah and if I don't get it into f40, I'll need to wait till 41, since it's breaking
<@tflink:fedora.im>
14:40:44
it looks like 6.0 was announced yesterday?
<@mystro256:fedora.im>
14:40:52
backporting 5.7 wasn't that bad for f39 in comparison
<@mystro256:fedora.im>
14:41:00
hold on, let me check
<@tflink:fedora.im>
14:41:23
https://www.phoronix.com/review/amd-instinct-mi300-rocm6/2
<@tflink:fedora.im>
14:41:58
it doesn't give a date, just that 6.0 is coming
<@trix:fedora.im>
14:42:32
can we do both ?
<@mystro256:fedora.im>
14:42:41
both what?
<@tflink:fedora.im>
14:42:57
6.0 at the same time we get the last ai-related packaged reviewed?
<@trix:fedora.im>
14:43:03
rocm 6 and the 4 or so remaining ai packages to get rocm+pytorch going
<@mystro256:fedora.im>
14:43:27
sure, I can put the ai/ml when I'm updating to 6.0, and we can see if there's any buzz
<@mystro256:fedora.im>
14:43:39
sure, I can poke the ai/ml when I'm updating to 6.0, and we can see if there's any buzz
<@tflink:fedora.im>
14:43:59
are those remaining packages needed for rocm support in pytorch? I assume so
<@trix:fedora.im>
14:44:34
yes, generally we need MIOpen and it has some dependencies not currently track on the HC page
<@mystro256:fedora.im>
14:44:51
is there anything in 6.0 you're waiting for?
<@mystro256:fedora.im>
14:45:02
I know there's some issues blocking debian, but I haven't reviewed it
<@trix:fedora.im>
14:45:27
if i _had_ an mi300 to play with, yes.. but i don't so 5.7 is ok
<@mystro256:fedora.im>
14:46:01
ok, well I'll monitor the rocm announcements and start a sidetag when I'm starting the upgrade
<@mystro256:fedora.im>
14:46:30
Point being, F40 should have 6.0 in it, so we'll try to make it as smooth as possible
<@trix:fedora.im>
14:46:48
ok. we do that
<@tflink:fedora.im>
14:47:03
sounds good
<@mystro256:fedora.im>
14:47:24
someone will have to take over when 6.1 comes out because I'll be on parental leave
<@tflink:fedora.im>
14:47:40
whether we want to do a F40 change proposal for rocm is probably a question for another time
<@tflink:fedora.im>
14:48:15
Jeremy Newton congratulations, we'll make sure that someone is doing that work
<@mystro256:fedora.im>
14:48:24
thanks!
<@trix:fedora.im>
14:48:49
yes.. the awesome rocm-packagers sig!
<@tflink:fedora.im>
14:49:02
:)
<@trix:fedora.im>
14:49:15
we will keep stuff going
<@tflink:fedora.im>
14:49:18
anyhow, we seem to have drifted topic a bit
<@tflink:fedora.im>
14:49:28
anything else on the F40 change proposal for pytorch?
<@trix:fedora.im>
14:49:58
just get the doc started and we can help out
<@kaitlynabdo:fedora.im>
14:50:16
yep thats it from me
<@tflink:fedora.im>
14:50:26
ok, moving on to ...
<@tflink:fedora.im>
14:50:29
!topic open floor
<@tflink:fedora.im>
14:50:38
any other topics that folks want to bring up?
<@tflink:fedora.im>
14:51:06
just to summaraize some things from before
<@tflink:fedora.im>
14:51:16
!info rocm 6.0 is expected for F40
<@tflink:fedora.im>
14:51:27
!info a few deps are remaining to get rocm support into pytorch
<@tflink:fedora.im>
14:52:02
anything else or shall we set the timer and adjourn?
<@tflink:fedora.im>
14:52:24
next meeting will be google, right?
<@tflink:fedora.im>
14:52:43
are we doing it on the 21st or will it be after the first of the year?
<@kaitlynabdo:fedora.im>
14:52:57
its going to be after the first of the year and yes it will be google
<@kaitlynabdo:fedora.im>
14:53:28
ill send out emails and post something on fedora discussion when the next meeting happens in the new year so some more ppl might join
<@tflink:fedora.im>
14:53:30
January 4th, then?
<@kaitlynabdo:fedora.im>
14:53:42
yes!
<@tflink:fedora.im>
14:53:59
!info no pytorch meeting in 2 weeks
<@tflink:fedora.im>
14:54:11
!info next pytorch meeting will be on January 4, 2024
<@tflink:fedora.im>
14:54:18
!undo
<@tflink:fedora.im>
14:54:32
!info next pytorch meeting will be via google meeting on January 4, 2024
<@tflink:fedora.im>
14:54:48
I guess I'll find out if !undo works when I look at the meeting logs :)
<@tflink:fedora.im>
14:55:02
anyhow, it sounds like that's it for today
<@tflink:fedora.im>
14:55:21
unless there are more bits to discuss, will end the meeting in a minute or so
<@kaitlynabdo:fedora.im>
14:55:37
yep i think so, how do we get meeting notes from meetbot
<@tflink:fedora.im>
14:56:05
the link will show up here after I end the meeting, at least
<@kaitlynabdo:fedora.im>
14:56:22
oohh okay sounds good
<@tflink:fedora.im>
14:56:38
not sure if the integration with meetbot.fp.o is working yet
<@tflink:fedora.im>
14:57:01
Thanks for coming, everyone
<@tflink:fedora.im>
14:57:05
!endmeeting