2023-11-06 13:02:21
         <@ankursinha:fedora.im>  
        !startmeeting NeuroFedora - 2023-11-06
        
2023-11-06 13:02:21 <@meetbot:fedora.im> Meeting started at 2023-11-06 13:02:21 UTC
2023-11-06 13:02:21 <@meetbot:fedora.im> The Meeting name is 'NeuroFedora - 2023-11-06'
2023-11-06 13:02:43 <@ankursinha:fedora.im> #Agenda is on the blog: https://neuroblog.fedoraproject.org/2023/11/06/next-open-neurofedora-meeting-06-November-1300-utc.html
2023-11-06 13:02:53 <@ankursinha:fedora.im> !topic Intros and roll calll
2023-11-06 13:02:56 <@ankursinha:fedora.im> !hello ankursinha
2023-11-06 13:02:57 <@zodbot:fedora.im> Ankur Sinha (ankursinha) - he / him / his
2023-11-06 13:03:08 <@gui1ty:fedora.im> !hello
2023-11-06 13:03:09 <@zodbot:fedora.im> Sandro . (gui1ty)
2023-11-06 13:03:43 <@gui1ty:fedora.im> There was no announcement today, but I guess the meeting room is mentioned in the announcement as well.
2023-11-06 13:03:59 <@ankursinha:fedora.im> ah, i forgot to send the announcement out..
2023-11-06 13:04:03 <@ankursinha:fedora.im> I knew I was forgetting something
2023-11-06 13:04:06 <@ankursinha:fedora.im> I'll send one out now
2023-11-06 13:05:28 <@ankursinha:fedora.im> done
2023-11-06 13:07:51 <@ankursinha:fedora.im> !topic Tasks from last meeting
2023-11-06 13:08:13 <@ankursinha:fedora.im> !info last meeting logs are here: https://meetbot.fedoraproject.org/neuro_matrix_fedoraproject-org/2023-10-23/neurofedora.2023-10-23-13.01.html
2023-11-06 13:09:03 <@music:fedora.im> !hello
2023-11-06 13:09:03 <@zodbot:fedora.im> Benjamin Beasley (music) - he / him / his
2023-11-06 13:09:26 <@ankursinha:fedora.im> !info vxl update: WIP PR here : https://src.fedoraproject.org/rpms/vxl/pull-request/2 (backported patches etc, but now it fails with a compilation error, needs more debugging)
2023-11-06 13:10:46 <@ankursinha:fedora.im> !info python-lqrt review: PENDING
2023-11-06 13:11:11 <@ankursinha:fedora.im> !action FranciscoD: update python-lqrt package as per review comments
2023-11-06 13:11:48 <@ankursinha:fedora.im> !topic open pagure tickets
2023-11-06 13:11:50 <@ankursinha:fedora.im> !info https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
2023-11-06 13:12:10 <@ankursinha:fedora.im> !info: move meeting to the fedora-meeting rooms: https://pagure.io/neuro-sig/NeuroFedora/issue/564
2023-11-06 13:12:29 <@ankursinha:fedora.im> !info we'll find an empty slot in one of the meeting rooms and use that from next meeting onwards
2023-11-06 13:12:44 <@gui1ty:fedora.im> šŸ‘ļø
2023-11-06 13:13:46 <@ankursinha:fedora.im> is anyone in all the meeting rooms now? do they look free?
2023-11-06 13:14:01 <@ankursinha:fedora.im> https://matrix.to/#/#meeting:fedoraproject.org looks free
2023-11-06 13:14:10 <@gui1ty:fedora.im> Let's make that an action item, maybe? We probably need to change the meeting announcement and/or fedcal entry.
2023-11-06 13:14:36 <@gui1ty:fedora.im> I haven't entered the Matrix meeting rooms yet.
2023-11-06 13:14:45 <@ankursinha:fedora.im> https://matrix.to/#/#meeting-1:fedoraproject.org is also free
2023-11-06 13:15:10 <@ankursinha:fedora.im> https://matrix.to/#/#meeting-2:fedoraproject.org is also free
2023-11-06 13:15:14 <@ankursinha:fedora.im> so we can choose which ever
2023-11-06 13:15:35 <@gui1ty:fedora.im> ``` You were removed from Fedora Meeting by appservice Reason: You have been kicked for being idle ```
2023-11-06 13:15:41 <@ankursinha:fedora.im> maybe we do meeting-2? least busy?
2023-11-06 13:15:49 <@ankursinha:fedora.im> uh
2023-11-06 13:15:53 <@ankursinha:fedora.im> I expect you can re-join?
2023-11-06 13:16:18 <@gui1ty:fedora.im> I can. I just find it amusing. No lingering in empty meeting rooms. Just like in rl.
2023-11-06 13:16:53 <@ankursinha:fedora.im> I doubt I'll be lurking in the rooms for anything apart from our meetings, so I hope being active in them once every 2 weeks is enough..
2023-11-06 13:17:43 <@ankursinha:fedora.im> i also wish we could have different icons for the fedora channels---I've got >10 rooms here all just with fedora logos, gotta hover to figure out which channel is which
2023-11-06 13:18:27 <@gui1ty:fedora.im> That should be possible. Shall I inquire with our friendly sysadmin folks?
2023-11-06 13:18:44 <@ankursinha:fedora.im> sure if you have some time to spare
2023-11-06 13:18:53 <@ankursinha:fedora.im> I *think* someone has to make new logos or icons etc
2023-11-06 13:19:39 <@gui1ty:fedora.im> I know fedora-design team had some interns creating a ton of logos a while ago. I'll dig into it.
2023-11-06 13:19:56 <@ankursinha:fedora.im> !action everyone: decide what meeting room we want to use
2023-11-06 13:20:08 <@ankursinha:fedora.im> !action everyone: set up recurring meeting on fedocal?
2023-11-06 13:20:32 <@ankursinha:fedora.im> although folks are using discussion.fp.o for vacations and things nowadays apparently?
2023-11-06 13:20:37 <@ankursinha:fedora.im> instead of fedocal?
2023-11-06 13:21:02 <@gui1ty:fedora.im> Are they? They'll miss out on badges... šŸ¦”
2023-11-06 13:21:25 <@ankursinha:fedora.im> https://discussion.fedoraproject.org/t/new-site-feature-set-your-vacation-away-status-or-mood-or-whatever/45170
2023-11-06 13:21:46 <@ankursinha:fedora.im> i'm not a fan---it isn't integrated with other things, and I can't see how to schedule my vacation there
2023-11-06 13:22:11 <@gui1ty:fedora.im> Yeah, it doesn't feel like the right place. Feature creep...
2023-11-06 13:22:11 <@ankursinha:fedora.im> it also inst a general calendar, so i don't think it can be used for meeting schedules etc., although I think discourse has its own calendar plugin..?
2023-11-06 13:24:03 <@ankursinha:fedora.im> https://discussion.fedoraproject.org/t/considering-a-general-reorganization-of-this-site/34174/29 -> something about claendar here
2023-11-06 13:24:08 <@ankursinha:fedora.im> I've never used it..
2023-11-06 13:24:37 <@ankursinha:fedora.im> https://discussion.fedoraproject.org/t/switch-to-using-the-discourse-calendar-plugin-for-fedora-magazine/34547 etc
2023-11-06 13:24:45 <@ankursinha:fedora.im> i think we stick to fedocal for the moment..
2023-11-06 13:24:51 <@ankursinha:fedora.im> and I keep sending out announcements as usual..
2023-11-06 13:25:01 <@ankursinha:fedora.im> s/and/or/
2023-11-06 13:25:34 <@gui1ty:fedora.im> Could that announcement not be sent out by fedocal? Just wondering.
2023-11-06 13:25:38 <@ankursinha:fedora.im> i like sending them out---it gives it a more human touch šŸ‘½ļø
2023-11-06 13:25:48 <@ankursinha:fedora.im> yeh, it can
2023-11-06 13:27:15 <@ankursinha:fedora.im> but i think most folks now almost treat automated reminders etc. as spam, since there's no human behind the action
2023-11-06 13:27:24 <@ankursinha:fedora.im> we can go either way, I don't mind sending out an e-mail
2023-11-06 13:27:49 <@gui1ty:fedora.im> I'll leave that up to you. I don't mind either way.
2023-11-06 13:28:16 <@ankursinha:fedora.im> !info https://pagure.io/neuro-sig/NeuroFedora/issue/563 -> python packags that use nodejs
2023-11-06 13:28:17 <@gui1ty:fedora.im> Having it automated, protects you from forgetting, though. šŸ§ 
2023-11-06 13:29:11 <@ankursinha:fedora.im> I think we're leaning towards dropping python packages that use nodejs, so plotly and bokeh, simply because packaging the nodejs correctly is practically impossible
2023-11-06 13:29:20 <@ankursinha:fedora.im> but I thought I'd ask the list once
2023-11-06 13:30:07 <@ankursinha:fedora.im> they'll be dropped in the f40 cycle, so we have time
2023-11-06 13:30:30 <@gui1ty:fedora.im> I have no ambition dipping my toes into NodeJS.
2023-11-06 13:30:48 <@ankursinha:fedora.im> me neither
2023-11-06 13:30:59 <@ankursinha:fedora.im> and music said they don't intend to work on nodejs either
2023-11-06 13:31:30 <@ankursinha:fedora.im> I'll do a quick check to see what exactly plotly and bokeh are doing, and then if we must drop them, we drop them
2023-11-06 13:32:09 <@gui1ty:fedora.im> If `plotly` goes, I can close two of my review requests...
2023-11-06 13:32:37 <@ankursinha:fedora.im> !topic package health check
2023-11-06 13:32:48 <@ankursinha:fedora.im> !info neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
2023-11-06 13:34:20 <@gui1ty:fedora.im> Looks like I have some work to do on `spyder` and `python-lsp-server` for F38.
2023-11-06 13:39:08 <@gui1ty:fedora.im> Or maybe not. According to Koschei everything is āœ…
2023-11-06 13:40:31 <@ankursinha:fedora.im> I see a few new versions, and a few FTBFS bugs, but nothing critical
2023-11-06 13:40:46 <@ankursinha:fedora.im> I need to update the mpi packages, nest and so on, when I get time
2023-11-06 13:40:52 <@ankursinha:fedora.im> they just take forever to test builds etc
2023-11-06 13:41:02 <@music:fedora.im> (Iā€™m still here, but not with my full attention.)
2023-11-06 13:42:07 <@ankursinha:fedora.im> anyone see any critical bugs etc. that we should prioritise?
2023-11-06 13:42:50 <@ankursinha:fedora.im> weird import error in the build, gotta see what's going on
2023-11-06 13:43:39 <@gui1ty:fedora.im> Nothing that stands out.
2023-11-06 13:44:06 <@gui1ty:fedora.im> Soon F37 will be put to sleep...
2023-11-06 13:44:22 <@ankursinha:fedora.im> !info packages are in good health---new versions need packages to be updated, a few FTBFS issues, and the usual long standing harder ones are still WIP
2023-11-06 13:44:43 <@ankursinha:fedora.im> !topic open package reviews check
2023-11-06 13:45:07 <@ankursinha:fedora.im> !info neuro-sig package review tracker is here: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
2023-11-06 13:45:17 <@ankursinha:fedora.im> !info two new reviews looking for reviewers
2023-11-06 13:46:12 <@ankursinha:fedora.im> !info python-chart-studio looking for review: https://bugzilla.redhat.com/show_bug.cgi?id=2246777
2023-11-06 13:46:32 <@ankursinha:fedora.im> !info python-plotly-geo is looking for review: https://bugzilla.redhat.com/show_bug.cgi?id=2246778
2023-11-06 13:47:07 <@gui1ty:fedora.im> These are supplementing `pl;otly`. So, ...
2023-11-06 13:47:10 <@ankursinha:fedora.im> Penguinpee: pyuca still in legal review?
2023-11-06 13:47:12 <@gui1ty:fedora.im> These are supplementing `plotly`. So, ...
2023-11-06 13:47:35 <@gui1ty:fedora.im> Yes. I've gotta poke 'em, I guess.
2023-11-06 13:47:40 <@ankursinha:fedora.im> cool
2023-11-06 13:47:53 <@ankursinha:fedora.im> yeh, do you want to hold off with the two packages supplementing plotly, in case we drop it?
2023-11-06 13:48:52 <@gui1ty:fedora.im> Yes. One of them was commented on. I could close them as _not planned_. Should we keep `plotly`, I can always re-open.
2023-11-06 13:49:18 <@ankursinha:fedora.im> sounds like a plan, yeh
2023-11-06 13:49:53 <@ankursinha:fedora.im> !info close pyuca and plotly-geo review as "not planned" currently, until we're sure what we want to do with plotly
2023-11-06 13:50:16 <@ankursinha:fedora.im> !topic Comp-neuro iso task check
2023-11-06 13:50:18 <@gui1ty:fedora.im> Not `pyuca`, but `chart-studio`.
2023-11-06 13:50:25 <@ankursinha:fedora.im> uh, sorry
2023-11-06 13:50:31 <@gui1ty:fedora.im> `pyuca` is for `spyder`.
2023-11-06 13:50:35 <@ankursinha:fedora.im> no undo here yet, right?>
2023-11-06 13:50:55 <@ankursinha:fedora.im> !info correction: close chart-studio and plotly-geo review as "not planned" currently, until we're sure what we want to do with plotly
2023-11-06 13:50:56 <@gui1ty:fedora.im> Doesn't matter. It's on record, anyway.
2023-11-06 13:51:13 <@ankursinha:fedora.im> !info https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 -> all green, iso task chugging along
2023-11-06 13:51:22 <@ankursinha:fedora.im> !topic neuro query of the week
2023-11-06 13:51:30 <@ankursinha:fedora.im> (or just science)
2023-11-06 13:52:07 <@ankursinha:fedora.im> a few LLM related things came to my attention:
2023-11-06 13:52:18 <@ankursinha:fedora.im> !info [2309.07683] Assessing the nature of large language models: A caution against anthropocentrism : https://arxiv.org/abs/2309.07683
2023-11-06 13:52:24 <@ankursinha:fedora.im> (since they're all the rage nowadays)
2023-11-06 13:53:03 <@ankursinha:fedora.im> !info [2308.02312] Who Answers It Better? An In-Depth Analysis of ChatGPT and Stack Overflow Answers to Software Engineering Questions: https://arxiv.org/abs/2308.02312
2023-11-06 13:53:30 <@ankursinha:fedora.im> !info Meet Nightshade, the new tool allowing artists to 'poison' AI models | VentureBeat: https://venturebeat.com/ai/meet-nightshade-the-new-tool-allowing-artists-to-poison-ai-models-with-corrupted-training-data/
2023-11-06 13:54:52 <@ankursinha:fedora.im> that's all I have
2023-11-06 13:55:32 <@ankursinha:fedora.im> !topic next meeting day etc
2023-11-06 13:55:52 <@ankursinha:fedora.im> in 2 weeks as usual I guess?
2023-11-06 13:56:06 <@ankursinha:fedora.im> !info Next meeting on 20 Nov 1300 UTC (but probably in a meeting channel!)
2023-11-06 13:56:10 <@ankursinha:fedora.im> !topic open floor
2023-11-06 13:56:18 <@ankursinha:fedora.im> anything else---we have 4 minutes :)
2023-11-06 13:56:20 <@gui1ty:fedora.im> Cool. I'm always interested in counterarguments for AI worshipers.
2023-11-06 13:56:35 <@gui1ty:fedora.im> Nothing more from my side.
2023-11-06 13:58:34 <@ankursinha:fedora.im> let's close and use 2 minutes to get tea/coffee šŸ«–
2023-11-06 13:58:36 <@ankursinha:fedora.im> !endmeeting