2023-11-20 13:00:48
         <@ankursinha:fedora.im>  
        !startmeeting Neurofedora - 2023-11-20
        
2023-11-20 13:00:48 <@meetbot:fedora.im> Meeting started at 2023-11-20 13:00:48 UTC
2023-11-20 13:00:49 <@meetbot:fedora.im> The Meeting name is 'Neurofedora - 2023-11-20'
2023-11-20 13:00:55 <@ankursinha:fedora.im> !meetingname neurofedora
2023-11-20 13:01:08 <@ankursinha:fedora.im> !info Agenda is here: https://neuroblog.fedoraproject.org/2023/11/20/next-open-neurofedora-meeting-20-November-1300-utc.html
2023-11-20 13:01:14 <@ankursinha:fedora.im> !topic Introductions and roll call
2023-11-20 13:01:22 <@ankursinha:fedora.im> !group members neuro-sig
2023-11-20 13:01:23 <@zodbot:fedora.im> Members of neuro-sig: aekoroglu, alciregi, anilbey, Ankur Sinha, blackfile, bt0dotninja, fangq, gicmo, Sandro ., hardeborlaa, ignatenkobrain, ilgrad, iztokf, lbazan, Maíra Canal, Aniket Pradhan, mhough, Benjamin Beasley, Josh Santos, sagitter, sergiopr, shaneallcroft, vanessakris, Zbigniew Jędrzejewski-Szmek
2023-11-20 13:01:43 <@ankursinha:fedora.im> @room hello folks, please join for the meeting
2023-11-20 13:01:59 <@ankursinha:fedora.im> never mind, we'll do meeting rooms next time..
2023-11-20 13:02:24 <@gui1ty:fedora.im> !hi
2023-11-20 13:02:25 <@zodbot:fedora.im> Sandro . (gui1ty)
2023-11-20 13:05:48 <@ankursinha:fedora.im> !topic Tasks from last meeting
2023-11-20 13:06:06 <@ankursinha:fedora.im> !info last meeting logs: https://meetbot.fedoraproject.org/neuro_matrix_fedoraproject-org/2023-11-06/neurofedora-2023-11-06.2023-11-06-13.02.html
2023-11-20 13:06:29 <@ankursinha:fedora.im> !info FranciscoD: update python-lqrt package as per review comments
2023-11-20 13:06:33 <@ankursinha:fedora.im> not sure if I did this..
2023-11-20 13:06:50 <@ankursinha:fedora.im> not yet
2023-11-20 13:06:54 <@ankursinha:fedora.im> !action FranciscoD: update python-lqrt package as per review comments
2023-11-20 13:07:18 <@ankursinha:fedora.im> !info everyone: decide what meeting room we want to us
2023-11-20 13:07:24 <@ankursinha:fedora.im> did we agree on a meeting room?
2023-11-20 13:07:42 <@ankursinha:fedora.im> all 3 seem empty now..
2023-11-20 13:07:46 <@ankursinha:fedora.im> so we could use whichever
2023-11-20 13:07:53 <@gui1ty:fedora.im> not really beyond any meeting room that's available will do
2023-11-20 13:08:11 <@ankursinha:fedora.im> since meeting is free, should we do that one?
2023-11-20 13:08:25 <@gui1ty:fedora.im> let's throw a dice 🎲
2023-11-20 13:08:27 <@music:fedora.im> Definitely don’t adopt `python-ratelimiter` or `python-pyvhacd`.
2023-11-20 13:08:32 <@ankursinha:fedora.im> #meeting:fedoraproject.org
2023-11-20 13:09:41 <@gui1ty:fedora.im> maybe something for open floor to discuss further
2023-11-20 13:10:14 <@ankursinha:fedora.im> cool, yeh, let's do that in open floor or package health check
2023-11-20 13:10:26 <@ankursinha:fedora.im> I propose we use #meeting:fedoraproject.org since it's available
2023-11-20 13:10:34 <@ankursinha:fedora.im> I'll set up a recurring meeting on fedocal
2023-11-20 13:10:49 <@ankursinha:fedora.im> !action FranciscoD: set up regular meeting on fedocal
2023-11-20 13:11:16 <@ankursinha:fedora.im> !topic Packages health check
2023-11-20 13:11:33 <@ankursinha:fedora.im> !info neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
2023-11-20 13:11:56 <@gui1ty:fedora.im> no open Pagure tickets I assume?
2023-11-20 13:12:15 <@ankursinha:fedora.im> oops, skipped that one
2023-11-20 13:12:20 <@ankursinha:fedora.im> but no, no new pagure tix
2023-11-20 13:12:35 <@ankursinha:fedora.im> one's on the meeting room, one's on vxl
2023-11-20 13:13:09 <@ankursinha:fedora.im> !info vxl -> patches backported but it doesn't build, so gotta see what code changes are required there to get that going.
2023-11-20 13:13:25 <@ankursinha:fedora.im> I saw lots of PRs, anything that urgently requires my attention?
2023-11-20 13:13:36 <@ankursinha:fedora.im> otherwise I'll get to any remaining ones in the next couple of days
2023-11-20 13:13:54 <@gui1ty:fedora.im> nothing urgent I believe
2023-11-20 13:15:58 <@ankursinha:fedora.im> awesome
2023-11-20 13:16:48 <@ankursinha:fedora.im> ITK is impacted by jsoncpp being orphaned..
2023-11-20 13:17:19 <@ankursinha:fedora.im> Miro looked into updating MUSIC to work with cython 3 -> https://github.com/INCF/MUSIC/issues/77
2023-11-20 13:17:42 <@ankursinha:fedora.im> found a cython regression which has now been fixed, not sure if it's made it to Fedora yet, though
2023-11-20 13:18:56 <@music:fedora.im> The commit https://github.com/cython/cython/commit/bbbe428ee5c52dd8fad10b0ee3bb2e33b5a8918c is newer than the last commit to `Cython` in dist-git, so I’d say no
2023-11-20 13:19:26 <@music:fedora.im> Looks like it’s destined for release with Cython 3.0.6
2023-11-20 13:19:47 <@music:fedora.im> https://github.com/cython/cython/issues/5818#event-10951750500
2023-11-20 13:20:56 <@ankursinha:fedora.im> I'll make a note on the rhbz so we remember to keep an eye out for the new cython version
2023-11-20 13:20:57 <@gui1ty:fedora.im> Is the Python SIG aiming to get rid of the Cython compat package? I saw a couple of PRs submitted for switching to updated Cython 3.x.
2023-11-20 13:21:19 <@ankursinha:fedora.im> I've not noticed an announcement saying so yet, but I expect it'll be on the cards at some point
2023-11-20 13:23:28 <@music:fedora.im> yes
2023-11-20 13:24:20 <@music:fedora.im> Not as an urgent thing, but it seems like keeping it around would be a headache for Miro to keep alive, and there are only a few packages that still need it in Rawhide.
2023-11-20 13:25:25 <@gui1ty:fedora.im> Makes sense. So they are actively pursuing moving all dependent packages to Cython 3.x. 🤞
2023-11-20 13:27:57 <@music:fedora.im> Yup. Several people have been knocking out bugs, with informal coordination in https://bugzilla.redhat.com/show_bug.cgi?id=2245645.
2023-11-20 13:28:01 <@gui1ty:fedora.im> It looks like the list of FTBFS packages has grown since last meeting. I guess F37 is not worth pursuing any longer. But lots of rawhide FTBFS as well.
2023-11-20 13:28:21 <@music:fedora.im> That bug provides a motivation/deadline, too: retire the compat package rather than trying to fix it for Python 3.13.
2023-11-20 13:28:58 <@ankursinha:fedora.im> makes sense
2023-11-20 13:29:12 <@ankursinha:fedora.im> only MUSIC remains for us, so removal of the cython compat shouldn't affect us
2023-11-20 13:29:24 <@ankursinha:fedora.im> `ModuleNotFoundError: No module named 'numpy.distutils'`
2023-11-20 13:29:25 <@ankursinha:fedora.im> hrm..
2023-11-20 13:29:50 <@ankursinha:fedora.im> https://numpy.org/doc/stable/reference/distutils_status_migration.html#distutils-status-migration
2023-11-20 13:30:37 <@gui1ty:fedora.im> Thanks music! So it's kinda part of the move to Python 3.13, which in itself will bring interesting deprecations as well.
2023-11-20 13:31:11 <@gui1ty:fedora.im> Yeah. They've gotten rid of it.
2023-11-20 13:32:15 <@ankursinha:fedora.im> gradunwarp is probably fixed in git, just not released: https://github.com/Washington-University/gradunwarp/blob/master/pyproject.toml#L5
2023-11-20 13:34:29 <@ankursinha:fedora.im> A few of the FTBFS bugs are for python 3.12
2023-11-20 13:34:34 <@ankursinha:fedora.im> s/3.12/3.13/
2023-11-20 13:35:22 <@music:fedora.im> I’ve already fixed a few of those, so feel free to CC me if you run across something that’s non-obvious.
2023-11-20 13:35:22 <@ankursinha:fedora.im> !info python 3.13 is due for release 2024-10-01: https://devguide.python.org/versions/
2023-11-20 13:35:28 <@ankursinha:fedora.im> cool
2023-11-20 13:35:54 <@ankursinha:fedora.im> We'll have to do the fixing here, I can't see upstreams already preparing for 3.13, especially if it's not yet available on CI like github actions etc.
2023-11-20 13:36:44 <@gui1ty:fedora.im> Well, Python 3.13 is planned for F41, is it not?
2023-11-20 13:37:08 <@music:fedora.im> It depends. Some upstreams are happy to get early fixes, especially non-disruptive ones, and to merge them if they look OK.
2023-11-20 13:37:12 <@ankursinha:fedora.im> https://fedoraproject.org/wiki/Changes/Python3.13
2023-11-20 13:37:22 <@music:fedora.im> Others are like “we’ll start looking at Python 3.13 when it’s released”
2023-11-20 13:37:37 <@ankursinha:fedora.im> yeh, I meant that upstreams won't necessarily look at fixing things themselves this early---they'll be happy to take our patches
2023-11-20 13:38:20 <@gui1ty:fedora.im> 🩹
2023-11-20 13:38:34 <@music:fedora.im> 🐍
2023-11-20 13:39:08 <@ankursinha:fedora.im> looks like we have new octave related ftbfs
2023-11-20 13:39:13 <@ankursinha:fedora.im> assuming octave was updated..
2023-11-20 13:39:52 <@ankursinha:fedora.im> yeh, to 8.4.x: https://src.fedoraproject.org/rpms/octave/commits/rawhide
2023-11-20 13:40:41 <@ankursinha:fedora.im> ``` 'LANG': 'C.UTF-8', 'LC_MESSAGES': 'C.UTF-8', 'SYSTEMD_NSPAWN_TMPFS_TMP': '0', 'SYSTEMD_SECCOMP': '0'} and shell False DEBUG util.py:446: No matches found for the following disable plugin patterns: local, spacewalk, versionlock DEBUG util.py:446: Error: DEBUG util.py:446: Problem: package octave-devel-6:8.4.0-1.fc40.x86_64 from build requires octave = 6:8.4.0-1.fc40, but none of the providers can be installed DEBUG util.py:446: - package octave-devel-6:8.4.0-1.fc40.x86_64 from build requires liboctave.so.10()(64bit), but none of the providers can be installed DEBUG util.py:446: - package octave-devel-6:8.4.0-1.fc40.x86_64 from build requires liboctinterp.so.11()(64bit), but none of the providers can be installed DEBUG util.py:446: - package octave-devel-6:8.4.0-1.fc40.x86_64 from build requires liboctgui.so.9()(64bit), but none of the providers can be installed DEBUG util.py:446: - conflicting requests DEBUG util.py:446: - nothing provides libsundials_sunlinsolklu.so.4.6.1()(64bit) needed by octave-6:8.4.0-1.fc40.x86_64 from build DEBUG util.py:448: (try to add '--skip-broken' to skip uninstallable packages) DEBUG util.py:595: Child return code was: 1 ```
2023-11-20 13:41:01 <@gui1ty:fedora.im> you beat me to it...
2023-11-20 13:41:23 <@ankursinha:fedora.im> so octave is FTI at the moment then?
2023-11-20 13:41:48 <@ankursinha:fedora.im> or koschei picked tried builds at a bad time?
2023-11-20 13:41:57 <@ankursinha:fedora.im> I'll go try a quick mockbuild and see what we get
2023-11-20 13:43:01 <@ankursinha:fedora.im> still getting it in mock, trying with `--enablerepo=local`
2023-11-20 13:43:01 <@music:fedora.im> https://bugzilla.redhat.com/show_bug.cgi?id=2249025
2023-11-20 13:43:42 <@ankursinha:fedora.im> ah, cool---I guess we wait for this to be fixed then
2023-11-20 13:44:30 <@music:fedora.im> wonder if it ftbfs or if it just needs a rebuild for a petsc/sundials update
2023-11-20 13:45:03 <@music:fedora.im> ``` Error: Problem: cannot install the best candidate for the job - nothing provides libsundials_sunlinsolklu.so.4.6.1()(64bit) needed by octave-6:8.4.0-1.fc40.x86_64 from fedora ```
2023-11-20 13:45:12 <@ankursinha:fedora.im> probably just a rebuild
2023-11-20 13:45:30 <@ankursinha:fedora.im> I think some co-ordination issues caused that one---octave was re-built for the new sundials just before the update: https://src.fedoraproject.org/rpms/octave/commits/rawhide
2023-11-20 13:47:08 <@music:fedora.im> but then the latest octave is only a week old, https://bodhi.fedoraproject.org/updates/FEDORA-2023-afc259b420
2023-11-20 13:47:44 <@music:fedora.im> but then there was https://src.fedoraproject.org/rpms/sundials/c/327d656fb4a9d59c48d2dbb2a663347df7319da6?branch=rawhide
2023-11-20 13:48:51 <@ankursinha:fedora.im> looks like all sundials deps need another round of rebuilds then..
2023-11-20 13:49:02 <@gui1ty:fedora.im> Well, looks like orion gets to take care of his own fallout.
2023-11-20 13:49:24 <@gui1ty:fedora.im> Well, looks like Orion gets to take care of his own fallout.
2023-11-20 13:49:26 <@ankursinha:fedora.im> yeh, he'll get to it
2023-11-20 13:49:38 <@ankursinha:fedora.im> we'll just wait until octave is fixed, not much we can do until then
2023-11-20 13:50:18 <@music:fedora.im> I’m doing a local rebuild of `octave`. If it succeeds and is installable I’ll open a PR for the rebuild.
2023-11-20 13:50:18 <@ankursinha:fedora.im> other than that the packages seem fine---the usual new versions and so on
2023-11-20 13:50:56 <@gui1ty:fedora.im> ⏱️
2023-11-20 13:53:01 <@ankursinha:fedora.im> !info Packages look fine---some new versions, octave packages FTBFS because of octave FTI, a few new python 3.13 related FTBFS bugs
2023-11-20 13:53:06 <@ankursinha:fedora.im> !topic Open reviews check
2023-11-20 13:53:18 <@ankursinha:fedora.im> !info review tracker bug: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
2023-11-20 13:53:40 <@ankursinha:fedora.im> !info 4 reviews, 2 in progress, 2 *new*
2023-11-20 13:54:08 <@gui1ty:fedora.im> I'm not going to review Rust packages, if you don't mind.
2023-11-20 13:55:01 <@ankursinha:fedora.im> I'll take a look---tinkered with rust but not really dived into, so maybe this will be a chance to do that
2023-11-20 13:59:11 <@ankursinha:fedora.im> !topic Comp neuro compose check
2023-11-20 13:59:21 <@music:fedora.im> I’m starting to be OK with simple Rust reviews. I’m trying to do a few for Fabio Valentini since he’s been reviewing my first Rust packages. This one is a little uglier as an unbundling patch is required, but nothing terribly crazy. You can always ask Fabio or someone else in rust-sig to double-check your work if you want.
2023-11-20 13:59:26 <@ankursinha:fedora.im> !info All greens here: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
2023-11-20 14:00:11 <@ankursinha:fedora.im> we're out of time today, so we'll skip the rest of the agenda.
2023-11-20 14:00:38 <@ankursinha:fedora.im> Penguinpee: music : did you want to have a quick chat about the orphaned packages and which we should take on?
2023-11-20 14:00:41 <@ankursinha:fedora.im> !topic Open floor
2023-11-20 14:01:12 <@gui1ty:fedora.im> Yes. But we can also do that outside of the meeting.
2023-11-20 14:01:28 <@ankursinha:fedora.im> OK cool, let me close the meeting, and we can do that then
2023-11-20 14:01:30 <@ankursinha:fedora.im> !endmeeting