13:00:18 <bexelbie> #startmeeting Atomic Developer Bundle Weekly Meeting
13:00:19 <zodbot> Meeting started Mon May  9 13:00:18 2016 UTC.  The chair is bexelbie. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:19 <zodbot> The meeting name has been set to 'atomic_developer_bundle_weekly_meeting'
13:00:24 <bexelbie> .hello bex
13:00:25 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
13:00:41 <bexelbie> #link https://titanpad.com/adbmeeting
13:01:01 <bexelbie> #chair lalatenduM
13:01:01 <zodbot> Current chairs: bexelbie lalatenduM
13:01:35 <bexelbie> dharmit, tkral surajd ccaf ADB meeting ping
13:01:53 <dharmit> .fas dharmit
13:01:55 <zodbot> dharmit: dharmit 'Dharmit Shah' <shahdharmit@gmail.com> - shahdharmit 'Dharmit Shah' <shahdharmit@gmaill.com>
13:02:01 <surajd> .fas surajd
13:02:01 <zodbot> surajd: surajd 'Suraj Deshmukh' <surajssd009005@gmail.com>
13:02:09 <tkral> .hellomynameis tkral
13:02:12 <zodbot> tkral: tkral 'Tomas Kral' <tkral@redhat.com>
13:02:22 * bexelbie will be impersonating lalatenduM by running the meeting this week
13:02:36 <bexelbie> We have a few agenda items in the etherpad (linked above)
13:02:39 <lalatenduM> bexelbie++
13:02:39 <zodbot> lalatenduM: Karma for bex changed to 4 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:02:46 <bexelbie> ADB Release this week
13:02:52 <bexelbie> #topic ADB Release this week
13:02:58 <bexelbie> We should be doing an ADB release this week
13:03:00 <lalatenduM> I will suggest to skip the release this week
13:03:04 <bexelbie> lalatenduM, is reporting that there have not been a lot of commits
13:03:09 <bexelbie> and as you just saw is suggesting we skip this week
13:03:17 <lalatenduM> :)
13:03:34 <bexelbie> praveenkumar, is unfortunately skipping, but I believe he has unreleased code in adb-utils he would like to see released
13:03:45 <lalatenduM> Blame lots of meetings for lack of commits
13:03:48 <ccaf_OTG> .hellomynameis containscafeine
13:03:49 <zodbot> ccaf_OTG: containscafeine 'Shubham Minglani' <shubham@linux.com>
13:03:49 <bexelbie> I suggest we find out if he wants to release adb-utils and if he does, rebuild ADB for htat reason
13:04:05 <bexelbie> especailly if agenda item #2 vsm needs it
13:04:09 <bexelbie> nshaikh, ping ADB meeting
13:04:33 <lalatenduM> The issue is , even if release adb-utils now , we need atleast 2 to 3 days of tim efor testing
13:05:00 <lalatenduM> we need automated testing
13:05:21 <bexelbie> lalatenduM, so are you proposing we block the release on lack of testing resources in addition to lack of direct code commits?
13:05:27 <bexelbie> s/block/skip/
13:05:41 <lalatenduM> yeah, we can target next week
13:05:56 <bexelbie> lalatenduM, do we have reason to be confident that testing resources will be available then?
13:06:27 <lalatenduM> bexelbie: yes , we wil get time to test it
13:06:30 * bexelbie wants to avoid a replay of this convo next week if possible
13:06:42 <bexelbie> ok
13:07:06 <lalatenduM> as we will build teh box on Monday and we will have Monday, Tuesday , Wednesday
13:07:21 <bexelbie> #idea It is proposed that we push the ADB release from this week to next week to allow for testing resources to be available and because of few direct commits to the code base
13:07:32 <lalatenduM> for that to happen adb-utils needs to be released before friday this week
13:07:54 <bexelbie> #action bexelbie to follow up with praveenkumar about ensuring adb-utils is released this week
13:08:07 <bexelbie> anyone have any questions/concerns with those two items?
13:08:35 * bexelbie plays jeapordy theme music
13:08:50 <bexelbie> lalatenduM, will you take responsibility for the build on Monday?
13:10:11 <bexelbie> lalatenduM, ^^
13:10:21 <lalatenduM> bexelbie: yes
13:10:46 <bexelbie> #action lalatenduM to build a new ADB next week on Monday as part of the delayed release from this week
13:10:47 <bexelbie> lalatenduM, ty
13:10:47 <lalatenduM> Sorry got side tracked
13:10:51 <bexelbie> no worries :)
13:10:53 <bexelbie> nshaikh, are you here?
13:11:04 <bexelbie> Any more questions/comments on the ADB release?
13:11:25 <bexelbie> going 1
13:11:27 <lalatenduM> bexelbie: Also we need to send a mail to container-tools about this i.e. we are skipping release thsi week
13:11:42 <bexelbie> lalatenduM, will you do that or do we need another responsible party?
13:11:56 <lalatenduM> bexelbie: I will do that
13:12:13 <bexelbie> #action lalatenduM to notify container-tools about the delayed release of ADB
13:12:19 <bexelbie> going twice
13:12:31 <bexelbie> going troika ...
13:12:36 <bexelbie> and next topic
13:12:44 <bexelbie> #topic vagrant-service-manager release
13:13:03 <bexelbie> nshaikh, doesn't appear to be here, so I will speak (barring another maintainer wishing to do so)
13:13:36 <bexelbie> VSM has had a few commits, but nothing "game changing".  There is a patch being worked that will add a lot of debug output ( budhram ) so I'd like to delay the release for that
13:13:55 <bexelbie> Having a new ADB and a new VSM will allow us to optimize our testing resources as well, in my opinion
13:13:59 <bexelbie> any questions/comments?
13:14:17 <lalatenduM> bexelbie: teh last release fof vsm was 27 days ago https://github.com/projectatomic/vagrant-service-manager/releases/tag/v1.0.1
13:14:24 <bexelbie> lalatenduM, that is correct
13:14:34 <bexelbie> there have been 2 code patches since then and a bit of docs changes
13:14:51 <lalatenduM> bexelbie: I think we did moere than tha :)
13:14:52 <bexelbie> I do not believe there is a need to rush this release for those two patches when we can land some more and optimize testing resources
13:15:02 <lalatenduM> that*
13:15:19 * bexelbie rereads
13:15:21 <lalatenduM> https://github.com/projectatomic/vagrant-service-manager/issues/181  has lots of issues
13:15:46 <bexelbie> we did
13:15:55 * bexelbie misread 27 days ago as having happened sooner :)
13:16:16 <bexelbie> ok, I retract the skip and suggest that we release VSM this week
13:16:23 <bexelbie> any questions/comments/support for this plan?
13:16:23 <lalatenduM> +1
13:16:44 <bexelbie> anyone else?
13:17:09 <bexelbie> I believe nshaikh should be able to make the release and I will initially task him with it ... I will take backup in case he can't (as he isn't here)
13:17:45 <bexelbie> #action bexelbie to work with nshaikh to get vagrant-service-manager released this week
13:17:53 <bexelbie> Any other vsm release questions?
13:17:55 <bexelbie> going 1
13:18:32 <bexelbie> going twice
13:19:04 <bexelbie> going troika ....
13:19:07 <bexelbie> #topic Open Floor
13:19:20 <bexelbie> Any conversatoin about ADB, adb-utils, vsm, or other areas related to this project?
13:19:24 <bexelbie> conversation
13:19:40 <dharmit> bexelbie: I've added another topic to the meeting. Is it not relevant for this meeting?
13:19:49 <bexelbie> it is :)
13:19:50 <dharmit> * added topic to the pad
13:19:52 * bexelbie just noticed it
13:19:57 <dharmit> cool. :)
13:19:58 <dharmit> I've made sure to explain in detail what the PR is trying to accomplish. It'd be helpful if someone can review it so that we can remove references to my fork. And then maybe I or someone else can write similar jobs for openshift and k8s. Basically want to ensure that lalatenduM doesn't have to ping anyone for testing the box when new release is almost ready except the tests.
13:20:01 <bexelbie> #topic testing releases of ADB
13:20:17 <dharmit> oops, pasted a bit early. :)
13:20:22 <bexelbie> #link https://github.com/projectatomic/adb-tests/pull/31
13:20:47 <bexelbie> #info feedback is needed on adb-test#31 so we can get some automated testing in place
13:21:14 <lalatenduM> dharmit: this time will review it :)
13:21:25 <bexelbie> dharmit, can you describe more clearly what you are asking for reviewers to do other than look at your code?
13:21:33 <bexelbie> are you needing people to do work on other orchestrators or just review?
13:21:39 <dharmit> bexelbie: sure thing.
13:22:47 * bexelbie lets dharmit finish typing
13:22:47 <dharmit> I don't need others to work on other orchestrators (k8s or ose). for now, I'd like someone like lalatenduM or bexelbie or praveenkumar or nshaikh to take a look at the code. Maybe point at a few things that can be done better than they are.
13:23:24 <bexelbie> for those of you following along, the code for review is in python
13:23:32 <bexelbie> so if you have nice python chops, please pile on
13:24:29 <bexelbie> #action Reviewers need for https://github.com/projectatomic/adb-tests/pull/31 - python code for automated testing of Mesos -- this will serve as a model for other orchestrators and testing
13:24:44 <bexelbie> Any questions/comments?
13:25:02 <budhram> navid told me he will be releasing VSM today
13:25:12 <bexelbie> budhram, cool
13:25:32 <budhram> I added comments on his PR for release
13:25:38 <bexelbie> other questions related to testing or the requested code review?
13:26:01 <bexelbie> budhram, can you #link the PR please?
13:26:10 <bexelbie> anything before moving on/back to Open floor
13:26:10 <bexelbie> ?
13:26:19 <budhram> #link https://github.com/projectatomic/vagrant-service-manager/pull/182
13:26:23 <bexelbie> ty budhram
13:26:47 <bexelbie> #topic Open Floor
13:27:02 <bexelbie> Any conversation/issues/questions for the project not already addressed?
13:27:53 <bexelbie> ??
13:28:16 <bexelbie> Any last minute issues before this meeting adjourns?
13:28:43 <bexelbie> lalatenduM, please mention the vsm and adb-utils releases in your delay annoucement
13:28:48 <bexelbie> upcoming releases
13:28:59 <lalatenduM> bexelbie: sure
13:29:02 <bexelbie> lalatenduM, ty
13:29:12 <bexelbie> ok, hearing no objections, .. I am ending the meeting
13:29:29 <bexelbie> #endmeeting