13:05:27 <sgallagh> #startmeeting OpenLMI (2013-10-28)
13:05:27 <zodbot> Meeting started Mon Oct 28 13:05:27 2013 UTC. The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:05:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:05:33 <sgallagh> #meetingname OpenLMI Public IRC Meeting
13:05:33 <zodbot> The meeting name has been set to 'openlmi_public_irc_meeting'
13:05:48 <sgallagh> #chair sgallagh tsmetana
13:05:48 <zodbot> Current chairs: sgallagh tsmetana
13:05:54 <sgallagh> #info Meetings are recorded and will be posted on www.openlmi.org. Opinions expressed do not necessarily reflect the reviews of the participant's employer.
13:06:07 <sgallagh> #topic Roll Call and Introductions
13:06:37 <sgallagh> So who do we have here today? I'm aware that it's a holiday in the Czech Republic today, so many of our usual attendees aren't around.
13:07:46 <sgallagh> praveen_pk: Would you care to introduce yourself briefly?
13:07:52 <praveen_pk> sure
13:08:09 <praveen_pk> I am part of Linux Engineering team at Dell.
13:08:33 <praveen_pk> I time to time work with WBEM technologies along with other things..
13:10:06 <praveen_pk> Dell is interested in enabling some remote management capabilities on Dell Servers, so I am following openlmi forum
13:10:41 <sgallagh> praveen_pk: Excellent, thank you. We'll ask you to go into a little more detail on that in a few minutes.
13:10:55 <sgallagh> I should introduce myself as well, since it was rude not to do so at first.
13:11:12 <sgallagh> My name is Stephen Gallagher and I am a software architect working at Red Hat
13:11:50 <sgallagh> Helping direct the efforts of the OpenLMI team is one of my primary tasks.
13:12:11 <sgallagh> My goals are to make system management simpler, more powerful and more standardized.
13:12:19 <sgallagh> kkaempf: Are you around today?
13:12:50 <kkaempf> sgallagh: I try ;-) Maybe some minutes late.
13:13:12 <sgallagh> kkaempf: Not a problem.
13:13:42 <sgallagh> For the record kkaempf is Klaus Kaempf of SUSE, representing their manageability efforts as well.
13:14:22 <sgallagh> praveen_pk: So you know, our goals for these first few meetings is to hear from each of the groups interested in OpenLMI about what they'd like to see (and contribute) to the upstream direction.
13:14:25 <sgallagh> #topic Round-table Goals for OpenLMI
13:14:46 <praveen_pk> yes.
13:14:53 <sgallagh> praveen_pk: Since you're the newest addition to our family, I'd like to give you the opportunity to talk first today about what you would like to see.
13:15:06 <sgallagh> We can start with a high-level view; no need to get into specifics right away.
13:15:43 <praveen_pk> One of the topics I want implemented is a new provider to publish the BMC information of a server.
13:16:15 <praveen_pk> I started a thread on the mailing list on this topic.. I have action item to get back on that.
13:16:26 <sgallagh> praveen_pk: Yes, thank you for starting that discussion.
13:17:07 <praveen_pk> Another item that will be worthwhile investigating will be the enabling a plugin for Nagios, which can use the LMI capabilities.
13:17:12 <sgallagh> That looks like it would be extremely useful. Finding that information today is usually a matter of consulting a database (or more likely, someone's clipboard)
13:17:32 <praveen_pk> sgallagh: Agreed
13:17:49 <sgallagh> praveen_pk: Hmm... that sounds interesting. What sort of integration do you see with Nagios?
13:18:11 <sgallagh> Rules-based responses to events?
13:18:44 <praveen_pk> sgallagh: my understanding is Nagios currently runs some agents on target system to gather information to its central management station.
13:19:17 <rdoty> Yes, Nagios has a fairly large set of monitoring agents
13:19:54 <praveen_pk> If a plugin which uses CIM-XML and extracts the information from target systems, that will increase the adoption rate of the LMI
13:20:35 <praveen_pk> **a plugin is enabled,
13:21:56 <praveen_pk> As new capabilities are added to LMI Providers, this plugin should be able to show more information about the target server.
13:22:00 <sgallagh> praveen_pk: I assume you're talking about a server-side NAGIOS plugin that will talk to the CIMOM, rather than installing something on the target system and talking CIM through the loopback?
13:22:07 * sgallagh nods
13:22:19 <praveen_pk> sgallagh: yes
13:22:44 <sgallagh> That could be really useful.
13:23:14 <sgallagh> You're right that this could help drive adoption by demonstrating the utility of OpenLMI as well
13:23:54 <sgallagh> praveen_pk: Is that something you would be interested in working on developing (with our help)?
13:24:33 <rdoty> praveen_pk: for Nagios, are you looking at gathering static information or dynamic monitoring data?
13:24:55 <praveen_pk> sgallagh: Unfortunately, I cannot make a commitment about implementing it...
13:25:08 <praveen_pk> I was thinking it will be a good idea to work on.
13:25:53 <praveen_pk> rdoty: I haven't investigated Nagios enough to answer that. I am guessing both if possible
13:26:24 <rdoty> Well, anything is possible...
13:26:39 <sgallagh> praveen_pk: Sure, I generally agree.
13:26:47 <sgallagh> I just wanted to make sure that if you were going to work on it, we helped you. (Or at least didn't get in your way)
13:27:04 <praveen_pk> sgallagh, Got it
13:27:11 <sgallagh> We'll certainly put that on our list of future enhancements to look into
13:27:28 <rdoty> It might be interesting to take a look at what has been done in the Performance Copilot provider
13:31:54 <sgallagh> praveen_pk: So those are two very useful ideas. We'll certainly be considering them. Care to try for a third? :)
13:32:02 <sgallagh> Any other good ideas we should look into?
13:32:40 <praveen_pk> sgallagh: Cant think of any more now
13:33:05 <sgallagh> Sure, didn't mean to put you on the hook. You were on a roll though :)
13:33:29 <praveen_pk> sgallagh: :)
13:33:35 <sgallagh> kkaempf: How are you doing this week?
13:34:05 <rdoty> What is the next step in getting information on the iDRAC IP?
13:34:28 <rdoty> I've seen some discussion about the object model. Do you have all the information to create the object model and mof file?
13:35:05 <praveen_pk> rdoty: I am still waiting on inputs from one of my teams. Will get an update in the next two days.
13:35:17 <rdoty> OK
13:35:24 <praveen_pk> Once we finalize the model we can start working on it.
13:36:20 <rdoty> Yes, it's easier that way. ;-)
13:36:48 <praveen_pk> :)
13:37:39 <sgallagh> praveen_pk: If your team would like a second set of eyes on the model before you begin implementation, I strongly encourage you to submit it to the mailing list for discussion
13:38:17 <praveen_pk> sgallagh: will do
13:39:44 <sgallagh> Ah, I've not been a good secretary today.
13:39:53 * sgallagh starts catching up on meeting minute notes.
13:40:38 <sgallagh> #info praveen_pk submitted a proposal to the mailing list for retrieving information about the BMC from the OS installed on the server.
13:41:13 <sgallagh> #info praveen_pk recommends that OpenLMI work on producing a NAGIOS plugin that speaks WBEM to retrieve monitoring data from client machines.
13:41:54 <sgallagh> #info sgallagh has requested that praveen_pk volunteer their planned models for the BMC lookup to the openlmi-devel mailing list for discussion and collaborative refinement.
13:42:25 <sgallagh> kkaempf: Have you got anything to discuss this week?
13:43:06 <kkaempf> sgallagh: uhm, no, last week was too busy to think about this :-/
13:44:35 <sgallagh> kkaempf: Understood, completely.
13:44:35 <praveen_pk> just another thought, do we need to think of some role based segregation of the provider capabilities?
13:44:53 <sgallagh> praveen_pk: That's something that's been on my mind a lot lately, actually.
13:45:33 <rdoty> kkeampf: what has been your experience with CIM and access controls?
13:45:58 <rdoty> Does the current "all or nothing" model work, or do you see demand for finer grain control?
13:46:13 <sgallagh> It's difficult to accomplish right now (and I suspect it will need standards work to fix).
13:46:13 <sgallagh> Right now there's a trinary permission state (denied, read-only, read-write) on the entirety of a namespace.
13:46:26 <sgallagh> We can try separating some of the models into different namespaces, but they tend to have a lot of common dependencies which would need to be duplicated in all of the namespaces that needed them
13:47:02 <sgallagh> #topic CIM Access Control
13:47:22 <sgallagh> #info praveen_pk raised the topic of role-based segregation of provider capabilities
13:48:15 <sgallagh> praveen_pk: Has Dell done any work in this space?
13:48:35 <praveen_pk> sgallagh: yes & no
13:48:43 <sgallagh> Would you care to elaborate? :)
13:48:57 <praveen_pk> we have some role based capabilities enabled in our iDRAC.
13:49:29 <sgallagh> #info Dell's iDRAC has some role-based capabilities.
13:49:34 <sgallagh> How is that implemented?
13:50:28 <praveen_pk> sgallagh: If I can recollect collect, we have a database with users and their capabilities captured
13:50:43 <praveen_pk> Every request is verified against the database
13:50:56 <praveen_pk> s/collect/correctly/
13:51:03 <rdoty> Where does this database live?
13:51:05 <sgallagh> praveen_pk: How does that verification happen? I assume this required modifications to SFCB or Pegasus (whichever is in the iDRAC)
13:51:32 <sgallagh> #info Dell iDRAC maintains a user/capability database internally and verifies requests against it.
13:51:59 <praveen_pk> sgallagh: I will have to get back to our team and ask for more information about it.
13:52:15 <sgallagh> praveen_pk: Mind if I list that as an action item for you?
13:52:23 <sgallagh> I'd like to have this on the agenda for next week's meeting
13:52:51 <praveen_pk> sgallagh: sure.. I am not sure how much of that info I can share publicly. Either way, will you an update.
13:53:21 <praveen_pk> s/will/will get/
13:53:24 <sgallagh> #action praveen_pk to dig up information on the iDRAC access-control implementation and discuss further next week
13:53:28 <sgallagh> praveen_pk: Thanks!
13:54:15 <sgallagh> We're getting to the top of the hour. Does anyone have anything else they'd like to raise this week?
13:55:02 <sgallagh> praveen_pk: Which CIMOM does the iDRAC use?
13:55:10 <praveen_pk> SFCB
13:55:46 <praveen_pk> But remote management is enabled only via WSMAN.
13:55:56 <praveen_pk> no CIM-XML access.
13:56:36 <sgallagh> OK, good to know.
13:57:14 <sgallagh> praveen_pk: According to the terms of its license, you need to make the source available (including your modifications)
13:57:43 <sgallagh> Could you ask your team about getting us that source so we could investigate how the access-control works and possibly propose it as a standard extension?
13:57:51 <praveen_pk> sgallagh: most likely done somewhere. Will check and get back
13:58:04 <sgallagh> praveen_pk: Thank you very much
13:58:24 <sgallagh> #action praveen_pk to look into providing the source for Dell's SFCB modifications
13:59:15 <sgallagh> #info We will look into the Dell access-control method to investigate its suitability as a suitable extension to the standard.
13:59:27 <sgallagh> Ok, I think we're just about out of time for today.
13:59:39 <sgallagh> Thank you very much for your participation praveen_pk and kkaempf.
13:59:46 <sgallagh> See you next week!
13:59:57 <praveen_pk> bbye :)
13:59:59 <sgallagh> #endmeeting