#openlmi: OpenLMI Public IRC Meeting (2013-11-18)

Meeting started by sgallagh at 14:06:17 UTC (full logs).

Meeting summary

  1. Roll Call (sgallagh, 14:06:26)
  2. Pegasus per-user provider invocation (sgallagh, 14:09:37)
    1. Pegasus starts new provider for each logged-in user. One provider binary can run in parallel several times, each with different user. (sgallagh, 14:10:28)
    2. OpenLMI does not expect to handle large numbers of users concurrently, but must be able to support more than one at a time. (sgallagh, 14:17:55)

  3. Planning the next major development cycle of OpenLMI (sgallagh, 14:19:53)
    1. AGREED: We will declare OpenLMI 1.0.0 with the current releases of the assorted components (sgallagh, 14:30:44)
    2. AGREED: Bumping the Z component will happen if we make bugfix releases of the components. (sgallagh, 14:31:08)
    3. AGREED: Bumping the Y component will be for minor functionality additions with no compatibility breakage (sgallagh, 14:31:27)
    4. AGREED: Bumping the X component will be for major functionality additions or any compatibility breakage. (sgallagh, 14:31:51)
    5. AGREED: Converting to per-user provider backends will be an OpenLMI 1.1 feature (sgallagh, 14:37:46)
    6. OpenLMI 1.1 should convert any providers for which there exists PolicyKit support to using per-user provider backends. (sgallagh, 14:55:19)
    7. OpenLMI 1.1 should add WS-MAN support for both client and managed systems (sgallagh, 14:55:33)
    8. ACTION: sgallagh Add OpenLMI 1.1 planning to next week's agenda (sgallagh, 14:56:57)

  4. Open Floor (sgallagh, 14:57:25)


Meeting ended at 15:01:30 UTC (full logs).

Action items

  1. sgallagh Add OpenLMI 1.1 planning to next week's agenda


Action items, by person

  1. sgallagh
    1. sgallagh Add OpenLMI 1.1 planning to next week's agenda


People present (lines said)

  1. sgallagh (89)
  2. tsmetana (27)
  3. jsafrane (17)
  4. zodbot (7)
  5. aledvink (4)
  6. rnovacek (1)


Generated by MeetBot 0.1.4.