13:11:40 <rbowen> #startmeeting
13:11:40 <zodbot> Meeting started Tue Jun  3 13:11:40 2014 UTC.  The chair is rbowen. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:11:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:11:49 <rbowen> #meetingname RDO Community Sync
13:11:49 <zodbot> The meeting name has been set to 'rdo_community_sync'
13:12:15 <rbowen> addchair kashyap
13:12:20 <rbowen> #addchair kashyap
13:12:21 <rbowen> Gah
13:12:25 <rbowen> zodbot: addchair kashyap
13:12:25 <zodbot> rbowen: Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
13:12:36 * rbowen glares at zodbot
13:12:38 <mburned> rbowen: it's #chair kashyap
13:12:40 <kashyap> rbowen, It's okay, you can just proceed :)
13:12:46 <rbowen> OK.
13:13:02 <rbowen> #link https://etherpad.openstack.org/p/rdo_community_manager_sync
13:13:24 <rbowen> Hmm. It looks like I was offline when I made some edits to the etherpad.
13:13:54 <rbowen> We had a nice surge in downloads after the Icehouse packages went out.
13:14:28 <rbowen> Still working on how to best define "download", but I've been tracking unique visitors to the repo, and that's up in the 2500/day range now, which is kind of cool.
13:15:09 <rbowen> Which brings us to testing.
13:15:12 <rbowen> #topic Test day
13:15:38 <rbowen> I presume that we want to try to do a test day around the first milestone, but we want to be a little more cautious about that than we were last time around.
13:15:43 <kashyap> Yeah Juno cycle just started. . .
13:16:08 <rbowen> Juno dates are ... hold on, I had that page around here somewhere, I think.
13:16:48 <rbowen> June 12.
13:17:02 <rbowen> Wow. That's soon.
13:17:19 <kashyap> Yeah
13:17:35 <rbowen> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
13:18:25 <rbowen> #info First Juno milestone is June 12. We should discuss with QE what kind of test day we want to do around that, if any.
13:18:26 <kashyap> Have to check with packagers if they'd be ready in a week
13:19:00 <rbowen> #info Also check with packagers to see what the timeline will be for package availability around M1.
13:19:07 <kashyap> pixelb, jruzicka: Heya, Juno-1 milestone seems be on June-12, do you think we could have packages ready a few days before that for a test day?
13:19:21 <sgordon> :o
13:19:40 <rbowen> What we talked about last time was a split dev/user testing days.
13:19:55 <rbowen> So kind of "internal" testing until it's solid enough to unleash on the unsuspecting public.
13:20:20 <rbowen> And then once that happens, announce a more public test day where people can try something that's likely not to kill their kittens.
13:20:22 <sgordon> did we get to the point of setting some requirements as to what good enough looks like?
13:20:42 <sgordon> e.g. allinone works, multinode works with defaults
13:20:48 <rbowen> I think "good enough" is when you can ...
13:20:50 <rbowen> right, what you said.
13:21:04 <rbowen> allinone works for most people most of the time.
13:21:16 <sgordon> i guess in both cases works is if i can then on top of that get a vm with networking up
13:21:20 <kashyap> rbowen, Good point, it slipped my mind re: dev/user testing
13:21:26 <rbowen> #info Define "good enough" as allinone works, multinode works with defaults and then announce a public test day.
13:21:46 <rbowen> And here's hoping that during the Juno cycle networking "just work" most of the time.
13:22:14 <rbowen> So, we can start a mail thread on rdo-list to get folks thinking about this in the week leading up to M1, and see what happens.
13:22:35 <rbowen> #action Start discussion on rdo-list about scheduling test day when M1 packages are "good enough"
13:22:54 <rbowen> Anything more to discuss there?
13:22:58 <rbowen> Moving along.
13:23:09 <rbowen> #topic Hangout
13:23:22 <rbowen> #info hewbrocca will be doing a hangout THIS FRIDAY on TripleO.
13:23:45 <rbowen> 1pm Eastern. (It looks like Google thought I was in Pacific time when I created the event.)
13:24:27 <rbowen> So if folks could help get the word out on that, that would be great. Share the G+ event, retweet from @rdocommunity, etc.
13:24:51 <rbowen> #topic Newsletter
13:25:10 <rbowen> I've got a draft newsletter about ready to go. I need to send it today or tomorrow.
13:25:45 <rbowen> I did a survey in the last newsletter. We send out to about 3000 recipients, and we got 6 responses on the survey. This wasn't wildly encouraging to me.
13:26:15 <kashyap> I think we should maybe include more technical content like bug stats, "interesting" bugs of the week
13:26:20 <rbowen> I didn't expect hundreds, but I expected more than 6. I don't know if that's because people hate surveys, or because nobody's reading the newsletter. But I welcome suggestions of how to improve the newsletter.
13:26:32 <rbowen> And obviously I need to start earlier on putting it together.
13:26:49 <rbowen> kashyap: That's a great idea. It would require quite a bit of help from the developer community.
13:27:09 <kashyap> rbowen, I'll see what I can do there
13:27:15 <rbowen> Although some of that stuff goes to the rdo-list, and I can curate that into the newsletter.
13:27:53 <rbowen> #info Newsletter goes to 2500 - 3000, only 6 responded to survey.
13:28:07 <rbowen> #info Need to try to make the newsletter more engaging, more technical content
13:28:21 <rbowen> #info Will try to add bug stats, development stats, interesting bugs, etc.
13:28:36 <rbowen> kashyap: Do you have something that we could add by today or tomorrow, or should I aim for next month on that?
13:29:04 <kashyap> rbowen, Well, I post frequent reports like this to my Fedora People page - http://kashyapc.fedorapeople.org/virt/openstack/bugzilla/rdo-bug-status/all-rdo-bugs-03-06-2014.txt
13:29:37 <kashyap> It's run by this script -- https://github.com/kashyapc/rdo-bug-query/blob/master/query-all-rdo-bugs.sh
13:29:51 <rbowen> At the *very* least I can link to that, but I'll see if I can do something more engaging than just a link. Thanks.
13:30:45 <rbowen> Ok, and also if folks can have a quick look at the draft - https://etherpad.openstack.org/p/rdo_june_2014_newsletter - and let me know what you think that would be great too.
13:30:58 <rbowen> #topic Events
13:31:09 <rbowen> #info OpenStack Israel yesterday
13:31:22 <rbowen> #info Cincinnati CentOS dojo tomorrow
13:31:31 <rbowen> #info OpenStack Days UK (London) tomorrow
13:31:44 <rbowen> #info OSCon end of July
13:31:56 <rbowen> #info Flock beginning of August
13:32:16 <rbowen> So, lots of events this week, and then some more coming up.
13:32:39 <rbowen> If people are going to be at an event, please consider taking some pictures, and writing up a blog post or two.
13:32:41 <kashyap> coolsvap|afk, I hope folks get time to write a blog post or so
13:32:52 <kashyap> (Ugh, didn't mean to prompt him, bad IRC tab completion)
13:33:14 <rbowen> There was some awesome blog posts that came out of the OpenStack Summit in Atlanta. I'm still catching up on those, and some folks are still posting them.
13:34:05 <rbowen> Oh, and LinuxCon Japan was awesome. red_trela was there, and I didn't even really get a chance to say hello, much less actually talk with him. Sorry. :-(  I think I got out of the hotel twice while I was there.
13:34:50 <rbowen> #topic Bug triage
13:35:26 <kashyap> I just posted the URL above for current status
13:35:51 <rbowen> kashyap: What do you think we can do to try to get more folks involved in some kind of regular bug sprint? Do you think that's a useful thing to try to do, or are most of the things more "internal"?
13:36:28 <kashyap> rbowen, No, I don't see anything internal.
13:36:56 <rbowen> It seems like it would be a way to get people more engaged, but it's kind of a hard thing to try to sell for folks to devote time to that. But I think it's worth trying.
13:36:58 <kashyap> It's just bug-triaging people don't find it extremely enthusiastic, but it's a necessary thing to "keep the needle moving"
13:38:14 <kashyap> rbowen, Yeah, it frequently requires reproduction of issues, interpreting reporter's not-so-thoroughly-written-bugs,  back-and-forth with the reporter, etc
13:38:15 <rbowen> There have been some great blog posts lately about getting started working on OpenStack upstream. But they all seem to focus on how it's harder than it needs to be.
13:39:02 <rbowen> Do you have a scheduled bug triage "event" coming up?
13:39:38 <kashyap> rbowen, Third Wednesday of the month, so 17-JUNE-2014
13:39:58 <kashyap> Tomorrow, /me is participating in upstream Nova bug triage day
13:40:24 <rbowen> #info 17-June-2014 bug triage (third Wednesday of the month)
13:40:38 <rbowen> #info Nova bug triage day (upstream) tomorrow.
13:40:59 <kashyap> rbowen, Err, it's 3rd Tuesday, but I don't think it really doesn't matter
13:41:03 <rbowen> #link http://kashyapc.fedorapeople.org/virt/openstack/bugzilla/rdo-bug-status/all-rdo-bugs-03-06-2014.txt
13:41:25 <rbowen> #info That's third Tuesday, not Wednesday. :-)
13:41:38 <rbowen> #topic Ask.openstack.org
13:41:59 <rbowen> I've got ask.openstack stats in the agenda. I've fallen kind of behind the last few weeks, so the unanswered counts are pretty high.
13:42:18 <rbowen> So I'll be focusing on that as soon as I'm done with the dojo tomorrow.
13:42:35 <rbowen> Folks can expect me to start bugging them for help on posts in the coming days. :-)
13:43:00 <rbowen> #info Unanswered counts have crept back up. Expect me to start bugging you for help in the next week or so.
13:43:13 <rbowen> Then, finally ...
13:43:26 <rbowen> #topic CentOS Cloud SIG
13:43:46 <rbowen> We had some folks that were going to work on the CentOS side, but things have been pretty hectic, so this has been sidelined.
13:44:22 <rbowen> But it would be awesome if someone from within the CentOS community would step up to drive this from that side. So we're kind of fishing here.
13:44:57 <rbowen> Looking at the user survey numbers from OpenStack summit, compared to 6 months ago, CentOS is creeping up on Ubuntu's numbers.
13:46:06 <rbowen> Anyways, this channel is the wrong audience for that message, but that's something that I, and some other folks, hope to be spending more time on in the coming weeks.
13:46:27 <kashyap> Re: CentOS thing, I feel it ought to be raised on relevant upstream mailing lists and gauge what the community reponse is, IMHO
13:47:16 <rbowen> Yes, I agree. My hope, however, was that before I do that, we have at least some of the folks here on that mailing list, so that when the questions come, we have a number of people who can help address them.
13:47:40 <rbowen> So getting some idea of how many folks are already on that list would likely give me more confidence about broaching the topic.
13:48:29 <kashyap> Hmm
13:48:36 <rbowen> I know some folks are, because I've seen posts there. Perhaps I need to just jump in and see what happens.
13:48:51 <rbowen> And then call for help when I get out of my depth.
13:49:44 <rbowen> Anyways, that's all I've got. Feedback welcome on rdo-list once I post the meeting notes.
13:50:11 <kashyap> Yep, thank you too.
13:50:12 <rbowen> #info Looking for assistance in getting more engaged with the CentOS community.
13:50:18 <rbowen> #endmeeting