15:03:54 <apevec> #startmeeting RDO packaging meeting (2015-02-25)
15:03:54 <zodbot> Meeting started Wed Feb 25 15:03:54 2015 UTC.  The chair is apevec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:03 <apevec> #topic roll call
15:04:11 <apevec> o/
15:04:12 <rbowen> o/
15:04:18 <xaeth> o/
15:04:19 <apevec> #chair rbowen
15:04:19 <zodbot> Current chairs: apevec rbowen
15:04:32 <apevec> #chair xaeth
15:04:32 <zodbot> Current chairs: apevec rbowen xaeth
15:04:36 <ryansb> \o
15:04:41 <apevec> number80, jruzicka around?
15:04:54 * number80 waves
15:05:17 <apevec> jpena there for Packstack team?
15:05:43 <jpena> apevec: here I am
15:06:32 * apevec looks up minutes from last week
15:06:46 <apevec> #topic review action items from last week
15:07:01 <bigpup6> can someone help me
15:07:09 <bigpup6> I followed this guide https://openstack.redhat.com/Neutron_with_existing_external_network
15:07:25 <bigpup6> none of my images seem to be able to talk to the network
15:07:25 <apevec> bigpup6, please hold on until meeting is done
15:07:31 <bigpup6> ok
15:07:32 <bigpup6> sorry
15:07:45 <apevec> #info RDO update CI status - jobs run, but do not vote?
15:07:49 <apevec> eggmaster, ^
15:08:19 <apevec> #info voting/merging manually works
15:09:36 <apevec> eggmaster, BTW you can drop internal gerrit, I'll close that one today
15:10:07 <apevec> #action apevec to followup with eggmaster re. RDO update CI
15:10:36 <apevec> #info Kilo Packstack/OPM - progress made, jpena had succsefull install!
15:10:55 <apevec> jpena, ^ please summarize what's left to do?
15:11:14 <apevec> can openstackclient be workedaround in puppet?
15:11:20 <eggmaster> ohai
15:11:22 <eggmaster> o\
15:11:23 <eggmaster> er
15:11:29 <eggmaster> o/
15:11:47 <jpena> so, we need to get https://review.gerrithub.io/#/c/217116/ (and associated reviews) merged. Alternatively, we can just patch the spec file to not remove the shaebang for ruby files (if we think it's faster)
15:11:49 <apevec> eggmaster, hi, just assign yourself action items for the minutes :)
15:12:08 <eggmaster> apevec: yeah so, just by way of info for everyone,
15:12:11 <apevec> jpena, ack - please propose that 1 line change separately
15:12:21 <jpena> the openstackclient issue can be worked around, and it's being reviewed at https://review.openstack.org/#/c/159150/
15:12:36 <jpena> social has created the patch
15:12:45 <apevec> nice
15:12:51 <jpena> apevec: sure, I'll prepare the patch in a sec
15:12:58 <eggmaster> the post-build step won't trigger for unknown reasons. I need to hack in the ssh cmd to -2/+2 as part of the buildflow dsl.
15:13:19 <apevec> #action jpena will propose Delorean openstack-puppet-modules.spec patch
15:14:43 <apevec> jpena, re. puppet-keystone patch - we'll need to carry it in master-patches until it's merged
15:15:03 <jpena> apevec: ack
15:15:13 <apevec> hm, it failed unit tests
15:15:20 <social> jpena: I would appreciate help with that one
15:15:42 <jpena> social: ok
15:16:37 <apevec> #action jpena to help with puppet-keystone patch https://review.openstack.org/159150
15:18:53 <apevec> #info changes to build_rpm_opm.sh to build from master-patches are under review
15:19:33 <apevec> jpena, other action for gchamoul from last week was to create kilo branch but that's not considered now right?
15:19:41 <apevec> for packstack/kilo
15:19:57 <apevec> BTW last week's minutes: http://meetbot.fedoraproject.org/rdo/2015-02-18/rdo.2015-02-18-15.01.html
15:20:49 <apevec> jpena, i.e. we can keep working on packstack master for kilo
15:20:58 <jpena> apevec: yes, let's keep working on master
15:21:05 <apevec> ack
15:21:36 <apevec> next EL6 status, last week update was that number80 started on clients
15:21:45 <apevec> number80, xaeth ^ any other news this week?
15:22:25 <xaeth> i haven't changed much.  still waiting on review feedback
15:22:25 <apevec> also was el6 juno spec posted?
15:22:29 <number80> apevec: still working on some missing runtime deps (testing stuff)
15:22:46 <apevec> xaeth, did I miss your post on rdo-list?
15:23:01 * number80 has everything on a copr
15:23:15 <apevec> number80, wanna share link or not yet?
15:23:23 <apevec> I guess not if deps are missing
15:23:34 <xaeth> dont recall posting to list.  shared here and alee was gonna help
15:23:46 <deepakcs> apevec, quick q, i see manila support in packstack was added, anyone working on adding gluster driver support ?
15:23:58 <apevec> xaeth, please paste link again, I lost it
15:24:46 <apevec> deepakcs, you can later ask Packstack guys
15:24:52 <apevec> meeting in progress...
15:24:56 <deepakcs> apevec, sorry, will do
15:25:15 <xaeth> apevec np.  1 m
15:26:31 <xaeth> #info barbican package review: https://bugzilla.redhat.com/show_bug.cgi?id=1190269
15:27:24 <apevec> ah that's barbican review, I must've mixed up who is working on EL6 Juno...
15:27:49 <apevec> number80, ^ what was the nickname?
15:28:23 <xaeth> ah.. sorry ya.. i was trying to make juno work on el6 for barbican... got like 70-80 packages built, then isolated and minimized my footprint
15:28:44 <apevec> ah that's also good work
15:28:48 <number80> apevec ?
15:29:02 <apevec> number80, somebody was working on EL6 juno nova
15:29:08 <number80> alphacc
15:29:31 <apevec> number80, ah yes, did you see draft spec posted anywhere?
15:29:49 <number80> apevec: nope
15:30:10 <apevec> ok, then we'll need to follow up
15:30:48 <apevec> #action followup with alphacc re. el6 juno openstack-nova.spec
15:31:03 <apevec> number80, ^ or you want to take it?
15:31:09 <apevec> since you're working on el6 clients
15:32:00 <apevec> last action from last week was about trunk.rdoproject.org
15:32:28 <apevec> IP is still old, but there's now redirect for trunk.rdoproject.org/repos/current
15:32:53 <apevec> rbowen, do you have a landing page ?
15:33:05 <rbowen> Sorry, no, I will get that done today. Traveling last week.
15:33:22 <apevec> ok
15:33:27 <rbowen> #action rbowen will provide landing page for trunk.rdoproject.org (See last week's minutes for details)
15:33:51 <apevec> thanks
15:33:55 <apevec> #topic package reviews for new Kilo deps for Rawhide
15:34:13 <apevec> we need to start ^ for new oslo libs
15:34:33 <apevec> so we have them ready in Rawhide for RC import
15:34:46 <apevec> but earlier is better
15:35:00 <apevec> initial specs are in Delorean, but probably need some cleanup
15:35:05 <apevec> e.g. python-oslo-context
15:35:23 <number80> apevec: let's finish clients first :)
15:35:26 <apevec> we've started collecting new deps at the bottom https://etherpad.openstack.org/p/RDO-Trunk
15:35:33 * number80 is having crappy WiFi experience
15:35:35 <apevec> number80, ack
15:35:48 <apevec> all clients need updates
15:36:17 <ryansb> was going to ask that in the next agenda item
15:36:33 <apevec> actually, let's bring up that agenda item now
15:36:43 <apevec> it's related
15:36:44 <ryansb> cool, can you #topic it
15:36:54 <apevec> #topic python-client packaging strategy
15:36:54 <ryansb> err, doesn't matter much I guess.
15:37:11 <apevec> for reference current setup is:
15:37:26 <apevec> http://openstack.redhat.com/Clients
15:37:34 <apevec> ryansb, what's your proposal?
15:38:09 <apevec> looking at upstream, new client releases break gate hard
15:38:41 <ryansb> yeah, I was wondering if we were going to stay with our current stable-x plan going forward
15:39:07 <ryansb> but with delorean, I was going to propose that we use the latest clients
15:39:08 <apevec> ryansb, looks like upstream will introduce them
15:39:22 <apevec> ryansb, sure, delorean is always tracking master
15:40:52 <ryansb> Makes sense, then I don't have a change to propose
15:41:24 <apevec> would be good to hear from jruzicka, our client über-maitainer
15:42:51 <apevec> ok, last item
15:43:06 <apevec> ihrachyshka pinged me about ovs update in RDO repo
15:43:10 <apevec> eh
15:43:15 <apevec> #topic ovs update in RDO repo
15:43:48 <apevec> #action apevec to update openvswitch in RDO repo https://bugzilla.redhat.com/show_bug.cgi?id=1193429
15:44:29 <apevec> actually, nothing to discuss for that :)
15:44:45 <apevec> #topic open floor
15:44:51 <apevec> anything else ?
15:45:48 <bigpup6> apevec is the meeting still going on?
15:45:56 <apevec> #endmeeting