15:00:34 <apevec> #startmeeting RDO packaging meeting (2015-06-24)
15:00:34 <zodbot> Meeting started Wed Jun 24 15:00:34 2015 UTC.  The chair is apevec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:45 <apevec> #chairs number80 jruzicka
15:00:50 <apevec> #topic roll call
15:00:57 <apevec> o/
15:01:07 <jpena> o/
15:01:16 <number80> o/
15:01:17 <apevec> #chair jpena
15:01:17 <zodbot> Current chairs: apevec jpena
15:01:23 <apevec> #chair number80 jruzicka
15:01:23 <zodbot> Current chairs: apevec jpena jruzicka number80
15:01:33 <jruzicka> \o/
15:01:33 <jruzicka> |
15:01:33 <jruzicka> / \
15:02:08 <apevec> jumping jakub? :)
15:03:13 <chandankumar> o/
15:03:17 <jruzicka> bigger picture
15:03:19 <jruzicka> :-p
15:04:08 <apevec> ok, let's start
15:04:21 <apevec> #topic Icehouse EOL 2014.1.5 rebases for RDO Icehouse and f21
15:04:40 <apevec> #info Last RDO Icehouse update before moving it under EOL/
15:04:43 <elmiko> o/
15:04:50 <eggmaster> o/
15:05:13 <apevec> Can I get ack from package maintainers they can push rdopkg new-version 2014.1.5 asap ?
15:05:33 <number80> +2 for the storage stuff
15:05:46 <apevec> https://wiki.openstack.org/wiki/ReleaseNotes/2014.1.5
15:05:59 <apevec> I'm finishing Keystone
15:06:15 <apevec> number80, so you take care of glance and cinder
15:06:30 <number80> yup
15:06:45 <apevec> remaining are nova neutron horizon heat ceilo  and trove
15:07:02 <apevec> vkmc, can you rebase trove to 2014.1.5 ?
15:07:15 <vkmc> apevec, sure thing
15:07:16 <apevec> although, that's no-op for Trove
15:07:24 <number80> ceilometer falls to pkilambi
15:07:26 <apevec> but just to align versions before moving it EOL
15:07:41 <number80> prad^
15:08:03 <number80> .whoowns openstack-heat
15:08:03 <zodbot> number80: sdake
15:08:09 <apevec> ihrachyshka, can you do neutron 2014.1.5 rebase in f21 ?
15:08:21 <ihrachyshka> apevec, sure. do we have a bug?
15:08:27 <ihrachyshka> I was waiting for it
15:08:37 <apevec> number80, I suspect that's not up to date
15:08:48 <apevec> ryansb, ^ you own heat in RDO right?
15:09:03 <number80> apevec: yes, that's why I wanted to check
15:09:22 <sdake> number8 what can I do for you
15:09:23 <jruzicka> number80, quite some rebases for you... let me know if I can ease further pains with `rdopkg new-version` ;)
15:09:24 <apevec> ihrachyshka, for RDO we didn't have rebase bzs, but I can file them
15:09:39 <terje> Hi, in Icehouse when I would create a network and subnet, I would get a qdhcp and qrouter namespace. The qrouter namespace would contain the gateway for my guest network. In Juno, this qrouter namespace is not created for some reason.
15:09:59 <number80> jruzicka: I'm using intensively reqquery because I may have few ideas of improvements :)
15:09:59 <jruzicka> terje, pkg meeting underway, please wait til it's over
15:10:08 <terje> oops, my bad.
15:10:54 <mburned> oh, i'm late
15:11:03 <mburned> o/
15:11:07 <apevec> number80, could we use upstream-monitoring to file rebase BZs for Fedora/RDO ?
15:11:13 <mburned> o>
15:11:21 <apevec> #chair mburned
15:11:21 <zodbot> Current chairs: apevec jpena jruzicka mburned number80
15:11:48 <number80> apevec: I'll check but I fear that it won't support our 1:1 mapping
15:11:58 <apevec> yeah...
15:12:05 <apevec> ok I'll file manually
15:12:06 <ihrachyshka> apevec, I thought we had. well ok, will do tomorrow
15:12:25 <apevec> #action apevec to files Icehouse 2014.1.5 Rebase bugzillas
15:12:33 <apevec> #undo
15:12:34 <zodbot> Removing item from minutes: ACTION by apevec at 15:12:25 : apevec to files Icehouse 2014.1.5 Rebase bugzillas
15:12:39 <apevec> #action apevec to file Icehouse 2014.1.5 Rebase bugzillas
15:12:51 <apevec> <- nitpicker
15:13:12 <elmiko> hey, that stuff is going in the logs man ;)
15:13:29 <jruzicka> nitpicking +2
15:13:45 <apevec> number80, and we'll use this opportunity to find out out of date owners in pkgdb
15:13:48 <number80> btw, for icehouse, copr builders are still running for EL
15:14:08 <number80> apevec: +1
15:14:18 <jruzicka> the eternal struggle of copr builders ...
15:14:22 <apevec> #action  ALL use this opportunity to find out out of date openstack-* owners in pkgdb
15:14:56 <apevec> jruzicka, yeah, RDO Icehouse is still Copr for EL*
15:15:15 <apevec> ok, next topic
15:15:18 <jruzicka> rdopkg info maintainers:jruzicka
15:15:28 <jruzicka> that's how to query rdoinfo for maintainers
15:15:44 <apevec> jruzicka, ah nice
15:16:11 <apevec> would be good to sync that to pkgdb
15:16:25 <apevec> #topic Liberty-1 missing deps, Fedora package reviews?
15:16:59 <apevec> on https://etherpad.openstack.org/p/RDO-Trunk under NEW PACKAGE REVIEWS there's only fastenres which is done now
15:17:03 <number80> had the topic coming this week
15:17:38 <apevec> this is preparation for liberty-1 test builds in CBS https://trello.com/c/GPqDlVLs/63-rpm-liberty-1
15:17:38 <number80> waiting feedback for barbican
15:17:56 <elmiko> i have some updates about the barbican stuff, but really more questions
15:18:19 <apevec> ok, barbican can be added when ready, but it shouldn't block anything else in liberty?
15:18:22 * redrobot lurks
15:18:26 <number80> nope
15:18:27 <apevec> or is there dependency now?
15:18:30 <apevec> ok
15:18:46 <elmiko> re: barbican, are we talking about this review https://bugzilla.redhat.com/show_bug.cgi?id=1190269 ?
15:18:56 <number80> elmiko: yes
15:19:24 <elmiko> so, i have some systemd service files to starting and stopping the controller
15:19:41 <apevec> BTW with liberty-1 semver version reset is coming, we have that all merged now https://review.gerrithub.io/#/q/I6a35fa0dda798fad93b804d00a46af80f08d475c
15:19:42 <elmiko> and i'm working to get them integrated into the rpm, as well as testing them locally
15:19:52 <apevec> it introduced Epoch: 1 everywhere
15:20:11 <number80> elmiko: ack
15:20:20 <elmiko> i am very curious though, for the fedora package will it be acceptable to require uwsgi for the time being so that we will have an independent runner for barbican?
15:20:31 <number80> elmiko: yes
15:20:49 <elmiko> in the future i believe we will remove the uwsig req. by including a runner script in the upstream barbican
15:20:52 <elmiko> number80: ack, thanks
15:21:27 <elmiko> great, i'll keep working with the initiator of that bz to get these systemd service files in there. thanks again
15:22:49 <apevec> any other known concerns with liberty-1  we should be all aware?
15:23:32 <number80> currently, I'm wondering about packstack for liberty as it seems we could already start using packages for testing
15:23:38 <number80> jpena^
15:23:53 <number80> it's likely to be early but i may be wrong
15:23:54 <apevec> the one in Delorean Trunk should be ready for liberty
15:24:00 <number80> \o/
15:24:20 <jruzicka> ou yeah
15:24:21 <jpena> number80: so far it is working, I'm giving it a test now to iron out any missing dependency
15:24:24 <apevec> it is used in CI and it was passing IIRC
15:24:37 <number80> jpena++
15:24:39 <zodbot> number80: Karma for jpena changed to 3:  https://badges.fedoraproject.org/tags/cookie/any
15:24:43 <jpena> last time it ran it found a missing dep in cinder
15:24:44 <apevec> jpena++ indeed
15:24:44 <zodbot> apevec: Karma for jpena changed to 4:  https://badges.fedoraproject.org/tags/cookie/any
15:24:53 <number80> oops, forgot that topic in the agenda
15:25:33 <number80> (updated agenda with broken CI for updates)
15:25:50 <apevec> yeah, let's move to that topic, if nothing else for liberty-1
15:26:18 <apevec> #action apevec to start rpm-liberty-1 merges
15:26:51 <apevec> number80, ^ you can try procedure I've put in trello card for storage packages if you like
15:27:09 <apevec> we can't merge to Fedora master yet,
15:27:22 <number80> ack
15:27:22 <apevec> so we'll create rpm-liberty-1 in openstack-packages repos
15:27:29 <apevec> #topic CI is broken for rdo-updates
15:27:36 * apevec looks for the link
15:28:42 <apevec> e.g. https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rdopkg-smoketest-kilo-f22/38/console
15:28:58 <apevec> eggmaster, ^ 00:00:35.050 /tmp/shiningpanda8679888286891065037.sh: line 3: /home/rhos-ci/jenkins/workspace/rdopkg-smoketest-kilo-f22/khaleesi-settings/rdopkg/rdopkg-ci-scripts/jenkins_job_scripts/rdopkg-smoketest: No such file or directory
15:29:03 <number80> that's a bit annoying, as we're lacking of reviewers and that means approving updates without any feedback in some case (like I did this morning for Cinder CVE update)
15:29:38 <apevec> eggmaster, we also need to switch all fedora jobs to run selinux permissive
15:29:53 <eggmaster> apevec: yeah so we were talking about moving these to use trystack, but then trystack went away as an option :P
15:30:17 <apevec> oh, again trystack in trouble? It was working some time
15:30:34 <number80> migration to new hardware :)
15:30:48 <eggmaster> apevec: I need to update the jobs (at least) to use a branch on khaleesi-settings, b/c the scripts went away with the refactor.
15:30:59 <apevec> eggmaster, yeah, I suspected that
15:31:01 <eggmaster> apevec: I will also add the selinux permissive when i make that update.
15:31:10 <eggmaster> will do today
15:31:14 <apevec> thanks!
15:31:30 <apevec> #action eggmaster will fix rdo-update CI today
15:31:35 <number80> eggmaster++
15:31:42 <number80> slinaber++
15:31:51 <number80> arf, no FAS account, no cookies :(
15:31:57 <apevec> ah :)
15:32:03 <eggmaster> it's slinabery
15:32:08 <number80> slinabery++
15:32:09 <zodbot> number80: Karma for slinabery changed to 1:  https://badges.fedoraproject.org/tags/cookie/any
15:32:11 <number80> \o/
15:32:11 <eggmaster> nom nom
15:32:12 <apevec> I'll give ++ when CI is fixed ;)
15:32:21 <eggmaster> hehe
15:32:32 * eggmaster doesn't eat cookies before they are hatched
15:32:37 <number80> well, it's incentive because it's a real blocker for me :)
15:32:47 <apevec> ok, last but not least:
15:32:56 <apevec> guest typer flepied !
15:33:00 <apevec> #topic debtor discussion (flepied demo)
15:33:03 <number80> flepied: around?
15:33:06 <flepied> hi
15:33:38 <flepied> I have a link for the demo of debtor on the kilo packages:
15:33:49 <flepied> https://flepied.fedorapeople.org/rdo-kilo/latest/score.html
15:34:23 <ryansb> flepied++ awesome
15:34:23 <zodbot> ryansb: Karma for flepied changed to 1:  https://badges.fedoraproject.org/tags/cookie/any
15:34:24 <apevec> for intro, debtor is https://github.com/enovance/debtor/
15:34:44 <elmiko> very neat
15:35:02 <flepied> it's an experimental tool to check the distance to the upstream patches in the packages
15:35:18 <number80> as it is, it's already very valuable
15:35:30 <apevec> yeah, horizon looks bad b/c RPM has downstream theme included
15:36:11 <apevec> what I got from mrunge is that horizon is not pluggable enough to make theme as separate project viable (yet?)
15:37:02 <flepied> apevec: I got some discussion with pmyers_ about that
15:37:20 <apevec> other than that, debtor mostly confirms RDO is vanilla upstream, as advertised! :)
15:37:39 <flepied> \o/
15:38:17 <number80> flepied++
15:38:19 <zodbot> number80: Karma for flepied changed to 2:  https://badges.fedoraproject.org/tags/cookie/any
15:38:56 <apevec> questions for flepied while we have him here?
15:39:04 <flepied> yes let me know if you think of any improvement for debtor
15:39:51 <number80> atm, I think we should think about sending weekly reports to the list
15:39:55 <gfidente> rhefner, that won't work with defines
15:40:39 <jruzicka> very nice!
15:40:41 <flepied> number80: we could work on that
15:41:00 <apevec> flepied, does it compare patches against stable/kilo or master ?
15:41:20 <flepied> stable/kilo if possible else master
15:42:23 <jruzicka> # translate package name to git repo name
15:42:39 <jruzicka> I should release pymod2pkg with CLI :)
15:42:57 <flepied> apevec: I have to go
15:43:16 <number80> flepied: thank you for your time :)
15:43:17 <apevec> flepied, thanks!
15:43:29 <apevec> #topic open floor
15:43:34 <flepied> it was a peasure, see you
15:44:40 <apevec> ok,  anything else we missed on agenda?
15:46:22 <apevec> thanks everyone!
15:46:25 <apevec> #endmeeting