15:05:57 <rbowen> #startmeeting RDO Community
15:05:57 <zodbot> Meeting started Wed Dec  9 15:05:57 2015 UTC.  The chair is rbowen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:57 <zodbot> The meeting name has been set to 'rdo_community'
15:06:01 <rbowen> #link https://etherpad.openstack.org/p/RDO-Packaging
15:06:07 <rbowen> #topic Agenda https://etherpad.openstack.org/p/RDO-Packaging
15:06:22 <rbowen> #topic Test Day
15:06:33 <rbowen> Oh, wait
15:06:36 <rbowen> #topic Roll Call
15:06:43 <jpena> o/
15:06:44 <rbowen> Anybody here for the RDO meeting?
15:06:57 <elmiko> o/
15:07:03 <number80> o/
15:07:10 <rbowen> #chair jpena elmiko number80
15:07:10 <zodbot> Current chairs: elmiko jpena number80 rbowen
15:07:11 <imcsk8> o/
15:07:15 <rbowen> #chair imcsk8
15:07:16 <zodbot> Current chairs: elmiko imcsk8 jpena number80 rbowen
15:07:39 <alphacc> o/
15:07:46 <rbowen> Oh, hmm. The agenda says today is chaired by apevec.
15:07:51 <rbowen> #chair alphacc
15:07:52 <zodbot> Current chairs: alphacc elmiko imcsk8 jpena number80 rbowen
15:07:57 <rbowen> apevec: Are you here?
15:08:11 <number80> rbowen: looks like RH VPNs are still having issues in Europe
15:08:18 <rbowen> ok
15:08:23 <rbowen> #topic Test Day
15:08:30 <rbowen> We are planning a test day for Dec 10, 11th
15:08:44 <rbowen> #link https://www.rdoproject.org/testday/rdo-test-day-mitaka-01/
15:09:05 <number80> I'll be around on Dec, 10 (morning EDT), then meetings + flying back home
15:09:21 <rbowen> I've mentioned it over on the centos mailing lists as well. If folks can get last-minute reminders out to their various networks, that would be great.
15:09:35 <rbowen> Can someone take us through the listed blockers in the agenda?
15:09:52 <rbowen> Are these things with workarounds, or are they going to make testing impossible?
15:10:18 <number80> imcsk8: ^
15:10:22 <jpena> I can talk about aodh support. Some issues have been identified during the review.
15:10:44 <imcsk8> i fixed the apache configuration problem
15:10:49 <imcsk8> for aodh
15:11:06 <jpena> with today's latest patch set, it should be ok, but it is not merged yet. I'd delay alarm testing until the next test day
15:12:02 * apevec back
15:12:03 <number80> jpena: can we have an OPM update today if we have fixes?
15:12:06 <rbowen> ok, is this noted on the TestedSetups page or the workarounds page?
15:12:12 <rbowen> #chair apevec
15:12:12 <zodbot> Current chairs: alphacc apevec elmiko imcsk8 jpena number80 rbowen
15:12:14 <apevec> rbowen thanks for starting the meeting
15:12:21 <rbowen> No problem.
15:12:26 <apevec> jpena, re. OPM update:
15:12:40 <apevec> we're building from master-patches
15:12:56 <apevec> which is still liberty based and we need to keep it that way
15:13:01 <SteveO_> hello
15:13:13 <apevec> until I figure out delorean/rdoinfo change to allow building from liberty-patches
15:13:38 <apevec> jpena, social - so I'd say let's cherry pick aodh to master-patches
15:13:48 <number80> SteveO_: Hi (for the record, we're having a meeting atm)
15:13:59 <imcsk8> the patch needed for aodh to use mongodb hasn't landed on OPM master or master-patches
15:14:07 <apevec> jpena, planB is to drop alarm like rdom
15:14:31 <apevec> imcsk8, yep, that's what needs to be cherry picked
15:14:38 <number80> imcsk8: ack
15:14:42 <jpena> apevec: I would vote for dropping, we need to cherry pick both puppet-aodh and packstack patches
15:14:58 <SteveO_> I'm a bit of a newb, and maybe out of my depth right now, but I want to install Openstack/RDO but am limited to only using CentOS 6.7 as my highest release
15:15:01 <SteveO_> oh, okay
15:15:08 <apevec> jpena, ok, please propose that as wip patch in gerrit
15:15:21 <imcsk8> apevec, number80, jpena i can add the patch to OPM and merge the packstack patch but i'm not sure if that can introduce problems
15:15:26 <apevec> we won't merge it upstream, just for the quick review before adding to rpm
15:15:41 <apevec> imcsk8, yeah, let's not do that day before testday :)
15:15:48 <number80> imcsk8: I would suggest that we drop alarm from the main test scenarios and add it as an advanced one
15:15:48 <jpena> apevec: you mean a patch to drop ceilometer-alarm?
15:15:50 <apevec> so planB it is, everyone ack ?
15:16:20 <apevec> other packstack blockers are good to go imho: glance store and nagios4 fix
15:16:25 <rbowen> SteveO_: Someone will be able to help you in a moment. We're having a weekly meeting at the moment, but we'll be done in the next 20-30 minutes.
15:16:37 <SteveO_> no problem, i'll check back in a bit. thanks!
15:16:47 <number80> apevec: ack, this is milestone 1, no need to pressure
15:16:53 <imcsk8> ack
15:17:15 <apevec> #decsion drop ceilo alarm in packstack for the testday
15:17:24 <apevec> #agreed drop ceilo alarm in packstack for the testday
15:17:27 <jpena> so to clarify, plan B is to have a WIP patch for packstack that drops ceilometer-alarm configuration. Correct?
15:17:34 <apevec> jpena, correct
15:17:43 <jpena> apevec: ack, the patch will be ready in a minute
15:17:46 <apevec> #action jpena to propose  WIP patch for packstack that drops ceilometer-alarm configuration
15:18:06 <trown|BOS> o/
15:18:13 <jschlueter> o/
15:18:13 <apevec> that was all packstack blockers
15:18:13 <number80> #chair trown|BOS
15:18:13 <zodbot> Current chairs: alphacc apevec elmiko imcsk8 jpena number80 rbowen trown|BOS
15:18:28 <apevec> trown|BOS, ^ what about rdom - quickstart images are good to go?
15:18:38 <number80> #chair jschlueter_bos
15:18:38 <zodbot> Current chairs: alphacc apevec elmiko imcsk8 jpena jschlueter_bos number80 rbowen trown|BOS
15:19:08 <trown|BOS> apevec: liberty images are good to go, CI run for mitaka images is on overcloud deploy
15:19:14 <imcsk8> jpena: we need to merge the  nagios fix https://review.openstack.org/#/c/255030/
15:19:27 <trown|BOS> apevec: so should know by the end of the meeting
15:19:30 <jpena> imcsk8: ack, will review it
15:19:40 <apevec> trown|BOS, thanks!
15:20:15 <number80> good
15:20:35 <devvesa> number80: are you available now?
15:20:52 <number80> devvesa: post-meeting, yes
15:20:53 <apevec> meeting in progress..
15:21:28 <apevec> #action trown to report status of mitaka rdom quickstart images
15:21:52 <apevec> trown|BOS, what about instructions for rdom quickstart?
15:22:04 <apevec> we need to add them on the testday page
15:22:34 <trown|BOS> #action trown add instructions to testday page for rdom quickstart
15:22:39 <apevec> paramite, ^ you played with tripleo-quickstart, can you add your notes too ?
15:23:14 <apevec> ok, so by EOD we should be in a reasonable state for the testday!
15:23:36 <number80> yeah, we're progressing
15:23:37 <apevec> please raise any and all issues you find out on #rdo and/or rdo-list !
15:23:40 <number80> RDO++
15:23:49 <rbowen> Awesome
15:24:03 <apevec> next topic?
15:24:12 <number80> opstools!
15:24:15 <EmilienM> o/
15:24:24 <number80> #topic optools repo
15:24:44 <EmilienM> I created a Trello card about it
15:24:44 <apevec> right, that was discussed briefly back in June on rdo-list
15:24:56 <EmilienM> #link https://trello.com/c/X9dJ0iTQ/110-monitoring-packaging
15:24:57 <apevec> and yes now we have a Trello card!
15:25:15 <apevec> EmilienM, so first priority is to package those monitoring scripts
15:25:47 <number80> It should be handed to a separate SIG but to accelerate the bootstrap, I'd build them in a separate tag in CBS meanwhile
15:25:52 <apevec> #action apevec to review draft spec https://github.com/EmilienM/osops-tools-monitoring
15:26:07 <EmilienM> apevec: my file is really wip
15:26:13 <EmilienM> and I don't think I can provide more now
15:26:21 <EmilienM> but you know better
15:26:24 <apevec> EmilienM, ok, I'll help
15:26:30 <EmilienM> thanks!
15:26:43 <apevec> number80, under cloud7-openstack-* ?
15:26:44 <dmsimard> sorry guys i'm quite late
15:27:00 <number80> apevec: yes, until we agree on the transition path
15:27:05 <apevec> dmsimard, we're done all action items are yours :)
15:27:09 <apevec> number80, ack
15:27:10 <number80> if it's a separate tag, it's easier
15:27:14 <apevec> yes
15:27:38 <apevec> number80, please propose tag hierachy in that trello card, so we can review it
15:27:45 <number80> apevec: ok!
15:28:10 <number80> #action number80 propose a tag hierarchy for opstools in trello card
15:28:26 <number80> I think we can move to the next topic
15:28:48 <number80> #topic draft guidelines
15:29:05 <apevec> YES we need those
15:29:18 <apevec> b/c initial spec proposals vary widely
15:29:19 <number80> I just pushed what I wrote this week-end
15:29:21 <number80> https://github.com/hguemar/openstack-packaging-doc/tree/guidelines
15:29:34 <apevec> and it just takes too much time to iterate on known issues
15:29:49 <number80> There are more topics to add, and I'm reviewing our current specs to identify our current practices
15:30:03 <apevec> number80, also need to include template spec that jpena is working on
15:30:16 <apevec> https://github.com/javierpena/openstack-example-spec
15:30:47 <number80> apevec: yes, this is planned, I have a lot of catch-up this week :)
15:31:04 <number80> #action number80 continue the guidelines work + include jpena template spec
15:31:08 <number80> jpena++
15:31:56 <number80> if you have feedbacks, they're welcome: mails, github issues, yelling over irc
15:32:10 <apevec> number80, SURE
15:32:30 <apevec> ok, that was last topic on the agenda
15:32:38 <apevec> #topic open floor
15:32:42 <number80> well, last call :)
15:32:57 <apevec> and for next chair we have volunteer
15:33:10 <trown|BOS> have or need?
15:33:17 <number80> yeah, I have to share the burden from time to time
15:33:28 <number80> but anyone who wants it, can get it :)
15:33:37 <trown|BOS> I can do it next week
15:33:42 <apevec> let's vote!
15:33:48 <number80> trown|BOS: +1
15:33:53 <dmsimard> trown|BOS: https://review.openstack.org/#/c/253717/ is merged (yay) but CI is being a pain for https://review.openstack.org/#/c/253716/ ...
15:34:19 <number80> (I'll take the next one then)
15:34:30 <trown|BOS> dmsimard: ya folks are working on it in #tripleo I have images building that have that patch
15:34:50 <apevec> dmsimard, yeah, pre-built rdom quickstart images should be good
15:34:53 <number80> #agreed trown|BOS will chair next week meeting, number80 the one after that
15:35:28 <dmsimard> apevec: cool. I'm going to give the aodh packstack review a shot, is the puppet-aodh patch in opm now é?
15:35:42 <imcsk8> dmsimard: nope
15:35:44 <apevec> dmsimard, we just decided to drop aodh in packstack too
15:35:48 <trown|BOS> btw that job has progressed to tempest run, so we should be in good shape to have mitaka images in a couple hours (still have the jobs that consume the images to run)
15:35:51 <apevec> for this testday
15:35:58 <dmsimard> apevec: that's not very ambitious
15:36:00 <dmsimard> :)
15:36:08 <apevec> that's day before testday
15:36:13 <apevec> we won't merge it upstream
15:36:25 <apevec> it will be only temp in RPM
15:36:32 <number80> dmsimard: having a test day at milestone 1 is already a milestone for us as a team :)
15:36:37 <jpena> btw the latest delorean package for openstackclient does not work
15:36:53 <trown|BOS> jpena: liberty  or trunk?
15:36:54 <apevec> jpena, is that missing dep?
15:36:56 <dmsimard> We can do it today ? There's only two things missing: the puppet-aodh patch in opm and the packstack review which could get merged today if my tests are positive
15:37:01 <paramite> trown|BOS, yes I can
15:37:03 * number80 expects that we'll keep
15:37:07 <jpena> apevec: yes, that missing dep in trunk
15:37:15 <dmsimard> Come on, let's be positive and do it today :)
15:37:18 <apevec> dmsimard, we'll do that next week
15:37:34 <apevec> dmsimard, also packstack cannot > rdom ;)
15:37:47 <trown|BOS> paramite: saw your PR thanks! will review after meeting. I may be able to help with your image issue too
15:38:13 <dmsimard> apevec: different people work on both for the most part, unless you're putting imcsk8 and jpena on rdo-m :P
15:38:28 <dmsimard> bah, I was certain we could get everything up and ready :(
15:39:05 <jpena> dmsimard: it's doable, but the chances we break something else are higher than the benefit ;)
15:39:18 <imcsk8> dmsimard, i agree with jpena
15:39:31 <dmsimard> jpena: people are going to be testing current-passed-ci
15:39:33 <dmsimard> not current
15:39:38 <imcsk8> murphy's laws are a bitch
15:39:46 <dmsimard> worst case we promote the hash before the patch landed
15:39:48 <dmsimard> or something
15:39:50 * dmsimard shrugs
15:39:55 <apevec> dmsimard, right, so let's put this alarm revert in -passed-ci
15:40:05 <apevec> then we're free to merge aodh
15:40:33 <apevec> we'll just keep -passsed-ci fixed this week (once we have it later today :)
15:40:55 <number80> dmsimard: we can have a mini-test day next week
15:41:02 <number80> just for aodh
15:41:14 <dmsimard> number80: every day is test day for me ^_^
15:41:20 <apevec> hehe
15:41:30 <apevec> trown|BOS, what's the eta for adoh support in rdom?
15:41:36 <apevec> aodh even
15:41:39 <number80> dmsimard: :)
15:41:57 <dmsimard> apevec: it's not even dropped yet
15:42:02 <dmsimard> alarming, I mean
15:42:07 * number80 will attend other duties
15:42:10 <apevec> yes, that's action for jpena
15:42:14 <number80> do not forget to close the meeting :)
15:42:22 <apevec> ok, let's close it
15:42:22 <trown|BOS> apevec: more of an EmilienM question, since he has the patches up to add support
15:42:30 <rbowen> Thanks, apevec
15:42:39 <apevec> trown|BOS, ok
15:42:40 <trown|BOS> apevec: undercloud is pretty much there if tripleoci wasnt broken, overcloud seems trickier
15:43:00 <apevec> ok, last call
15:43:05 <apevec> closing in 3
15:43:13 <EmilienM> apevec: aodh is going to be this month
15:43:22 <EmilienM> undercloud -> almost merged
15:43:28 <EmilienM> overcloud -> wip but soon
15:43:33 <EmilienM> and then Gnocchi will follow.
15:43:50 <apevec> EmilienM, thanks, we'll then have mini-testday as number80 suggested
15:43:56 <EmilienM> apevec++
15:43:58 <apevec> ok, thanks folks!
15:44:02 <apevec> #endmeeting