15:00:20 <trown> #startmeeting RDO meeting (2015-12-16)
15:00:20 <zodbot> Meeting started Wed Dec 16 15:00:20 2015 UTC.  The chair is trown. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:20 <zodbot> The meeting name has been set to 'rdo_meeting_(2015-12-16)'
15:00:25 <chandankumar> o/
15:00:29 <eggmaster> o/
15:00:33 <trown> #link https://etherpad.openstack.org/p/RDO-Packaging
15:00:37 <rbowen> ¯\_(ツ)_/¯
15:00:47 <trown> #chair chandankumar eggmaster rbowen trown
15:00:47 <zodbot> Current chairs: chandankumar eggmaster rbowen trown
15:01:18 <imcsk8> o/
15:01:36 <trown> #chair imcsk8 number80
15:01:36 <zodbot> Current chairs: chandankumar eggmaster imcsk8 number80 rbowen trown
15:01:45 <number80> o/
15:02:28 <trown> #topic Magnum Packaging updates
15:03:01 <chandankumar> Initial review of magnum spec is done https://github.com/MatMaul/openstack-magnum-spec
15:03:22 <mvelten> hi !
15:03:32 <trown> #chaire mvelten
15:03:38 <trown> #chair mvelten
15:03:38 <zodbot> Current chairs: chandankumar eggmaster imcsk8 mvelten number80 rbowen trown
15:03:44 <chandankumar> i will be creating a RDO package review  bug with the help of mvelten.
15:03:51 <mvelten> I have still one remark to adress on the review
15:03:54 <number80> ack
15:04:00 <mvelten> will do that now
15:04:08 <chandankumar> mvelten: ack
15:04:17 <trown> great
15:04:19 <number80> please add #action in the logs :)
15:04:44 <trown> #action mvelten to address remark on magnum spec review
15:04:52 <trown> mvelten: like that ^ :)
15:05:06 <chandankumar> python-magnumclient package review still in progress https://bugzilla.redhat.com/show_bug.cgi?id=1286772
15:05:15 <chandankumar> please have a look.
15:05:37 <mvelten> ok is it done or should I do it so the bot register it ?
15:05:47 <trown> mvelten: nope done this time
15:05:54 <trown> anyone can use action
15:06:15 <mvelten> ok thx, chandankumar : I will have a look this week
15:06:25 <jpena> o/
15:06:32 <chandankumar> #chair jpena
15:06:32 <zodbot> Current chairs: chandankumar eggmaster imcsk8 jpena mvelten number80 rbowen trown
15:06:32 <trown> #chair jpena
15:06:32 <zodbot> Current chairs: chandankumar eggmaster imcsk8 jpena mvelten number80 rbowen trown
15:06:40 <number80> next I guess
15:06:52 <trown> #topic Python3 Packaging
15:07:27 <chandankumar> python-oslo-serilaization, python-debtcollector , python-context is done from my side
15:07:46 <chandankumar> Here is the trello card for python 3 https://trello.com/c/ReowuP4z/105-python3
15:07:55 <chandankumar> <EOF>
15:08:02 <number80> https://trello.com/c/ReowuP4z/105-python3
15:08:13 <jpena> We have a gerrit topic to group the reviews: https://review.gerrithub.io/#/q/topic:py3
15:08:23 <number80> https://trello.com/c/ReowuP4z/105-python3
15:08:25 <jpena> #link https://review.gerrithub.io/#/q/topic:py3
15:08:51 <trown> so the goal is to complete python3 by Mitaka GA?
15:08:55 <number80> Has CI reported any issue?
15:09:12 <number80> trown: preferably milestone2 :)
15:09:20 <number80> for clients
15:09:26 <number80> (that includes oslo too)
15:09:52 <number80> I prefer we go at a slower pace, to check issues before hand
15:10:15 <trown> number80: I do not think we are running any unittests in RDO CI, and Mitaka has a host of issues that are being worked through upstream
15:10:32 <trown> wrt the CI comment
15:11:18 <trown> ok anything else regarding python 3?
15:11:22 <number80> trown: ack, I was mostly thinking about RPM dependencies issues
15:11:38 <number80> jpena: any pymysql update?
15:11:45 <trown> number80: cool so far so good then :)
15:12:17 <jpena> number80: yes, all puppet module reviews are now finished.
15:12:44 <jpena> I have started https://review.openstack.org/257866, it still depends on all the relevant OPM modules being bumped
15:13:05 <number80> jpena: awesome
15:13:51 <number80> then, we still have to check the trove review
15:14:15 <jpena> oh, true
15:14:32 <number80> I'll ping Victoria about it
15:15:09 <trown> ok moving on
15:15:09 <trown> #topic opstools import status
15:15:22 <trown> is this EmilienM?
15:15:24 <number80> #info CBS target was created for optools
15:15:40 <EmilienM> hello
15:15:55 <number80> I had a call w/ Graeme about it, and I'll be importing the packages for the optools chain
15:16:08 <EmilienM> nice
15:16:20 <EmilienM> number80: I did some patches in oschecks
15:16:20 <number80> it'll be a separate repo, we'll need some documentation on the RDO website though
15:16:25 <EmilienM> maybe we can update the rpm
15:16:28 <number80> great
15:17:26 <number80> #action number80 import packages
15:17:35 <number80> I'll be sprinting on this week
15:17:53 <number80> EmilienM: did you update the trello card?
15:18:04 <EmilienM> number80: no, should I ?
15:18:09 <number80> https://trello.com/c/X9dJ0iTQ/110-monitoring-packaging
15:18:26 <number80> EmilienM: any relevant news is I'll be relying on it :)
15:18:31 <EmilienM> ok
15:18:34 <EmilienM> I'll if I have
15:19:13 <number80> (already added an item in the checklist to update oschecks)
15:19:32 <number80> anything else?
15:19:45 <number80> #chair EmilienM
15:19:45 <zodbot> Current chairs: EmilienM chandankumar eggmaster imcsk8 jpena mvelten number80 rbowen trown
15:20:03 <trown> #topic RDO liberty/F24 status
15:21:19 <rbowen> Whose topic is this?
15:21:20 <number80> Since Alan is in PTO, let me know if you find service packages without rdo-liberty branches on github
15:21:25 <rbowen> oh
15:21:35 <number80> I'll do the wrap-up
15:22:00 <number80> #info hunt missing rdo-liberty branches for services packages on openstack-packages
15:22:04 <trown> number80: I found one the other day...
15:22:10 <trown> #link https://github.com/openstack-packages/python-proliantutils
15:22:18 <trown> number80: but I will make that branch
15:22:21 <number80> trown: ack
15:22:25 <number80> trown++
15:22:33 <trown> #action trown add rdo-liberty branch to python-proliantutils
15:23:23 <number80> that's all I had :)
15:24:05 <trown> #topic Mitaka 2 test day date poll
15:24:08 <rbowen> #link http://openstack.etherpad.corp.redhat.com/rhos-pgm-2015
15:24:22 <rbowen> There are two possible dates for the Mitaka 2 test day, and they are both kind of awful.
15:24:33 <rbowen> So, vote for which one is less awful.
15:24:42 <number80> rbowen: can we copy this on a public etherpad?
15:24:52 <number80> (this one is not visible outside redhat VPN)
15:25:05 <rbowen> I'm awful sorry, that's the wrong URL.
15:25:07 <rbowen> #undo
15:25:08 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x26d03350>
15:25:14 <trown> ya it has lots of internal stuff too :p
15:25:18 <rbowen> One moment ...
15:25:21 <number80> np
15:25:45 * number80 puts himself in contributors shoes by disabling VPN from times to times :)
15:26:01 <rbowen> Now I can't find the URL. ONe second ...
15:26:09 <number80> no rush :)
15:26:13 <rbowen> #link
15:26:15 <rbowen> #link http://doodle.com/poll/bvd8w85kuqngeb7x
15:26:21 <rbowen> That other URL was completely not the right one.
15:26:55 <trown> rbowen, that one 404s for me
15:26:58 <rbowen> Meanwhile the mitaka1 test day went really well, and din't require a lot of babysitting, so I'm not terribly worried if the date doesn't work for me.
15:27:08 <rbowen> Gah!
15:27:29 <rbowen> How about ...
15:27:30 <rbowen> http://doodle.com/poll/f2vm4cxs4nfuxdg2
15:27:34 <rbowen> #undo
15:27:34 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x388d01d0>
15:27:36 <rbowen> #link http://doodle.com/poll/f2vm4cxs4nfuxdg2
15:27:41 <rbowen> One of these times, I'll get it right.
15:27:42 <trown> that is the one
15:27:52 <rbowen> Yay!
15:27:54 <number80> good
15:28:21 <trown> #undo
15:28:21 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2f77a110>
15:28:34 <number80> Well, both days, I should be home so works for me
15:28:37 <trown> #link http://doodle.com/poll/f2vm4cxs4nfuxdg2
15:28:41 <rbowen> ok.
15:28:58 <trown> just realized i redid that... should be right now in the minutes anyways
15:29:04 <rbowen> Next topic,
15:29:08 <trown> I will edit it if needed before sending out
15:29:12 <number80> rbowen: we'll try to be more on schedule for test days, in the future
15:29:23 <trown> #topic Mitaka 1 test day results
15:29:25 <rbowen> Mitaka1 test day results are at  https://www.redhat.com/archives/rdo-list/2015-December/msg00081.html
15:29:45 <rbowen> Fewer tickets opened than last time, which might reflect lower participation, or it might reflect better CI. Hard to say at this point.
15:30:09 <trown> ya... I think milestone 1 just has a lot less hype then GA
15:30:24 <number80> we definitively have better CI
15:30:25 <rbowen> Yes, and also probably fewer new things that could break.
15:30:29 <trown> people are still processing liberty
15:30:32 <rbowen> But the CI helped enormously, I'm sure.
15:30:59 <trown> ya CI is improved alot from this point in the liberty cycle
15:31:11 <rbowen> What we can do better, though, is more explanation/recipes for the tests that folks should be doing. Our current test matrix assumes a lot of knowledge.
15:31:34 <rbowen> That's something we'll get to eventually, I expect.
15:31:34 <dmsimard> Hi, I'm late again. Sorry. :(
15:31:49 <trown> #chair dmsimard
15:31:49 <zodbot> Current chairs: EmilienM chandankumar dmsimard eggmaster imcsk8 jpena mvelten number80 rbowen trown
15:32:08 <number80> rbowen: post-milestone 2, let's have a mock test day and fix that
15:32:09 <trown> rbowen: ya that is something I wanted to work on for RDO Manager that I just didnt get to
15:32:10 <rbowen> Anyways, if there's some other stat I should be tracking around test days, let me know. I'm going to start tracking this on http://rdoproject.org/testday over the coming ones.
15:32:24 <rbowen> <EOL>
15:32:25 <number80> just few of us running through test cases and improve documentation
15:32:29 <trown> awesome
15:32:43 <trown> #topic RDO Day @ FOSDEM schedule
15:32:55 <rbowen> #info https://www.rdoproject.org/events/rdo-day-fosdem-2016/ RDO Day @ FOSDEM schedule
15:33:18 <rbowen> FYI, we have officially "sold out" our location.
15:33:28 <number80> rbowen++
15:33:31 <trown> woot
15:33:34 <number80> Great
15:33:35 <trown> rbowen++
15:33:42 <rbowen> So additional registrations will be put in a wait status, so that we'll know how much larger we need the location to be for next year.
15:33:55 <trown> leanderthal++ for the talk on RDO Manager
15:33:55 <zodbot> trown: Karma for leanderthal changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:33:56 <rbowen> But we've definitely outgrown the IBM facility.
15:34:07 <rbowen> Yeh, lots of great content on the schedule. I'm pretty excited.
15:34:21 <rbowen> On a related note
15:34:29 <rbowen> If you haven't booked accomodations in Brussels yet, do it NOW
15:34:40 <rbowen> It's getting hard to find rooms.
15:34:48 <rbowen> That's all I have on that.
15:35:22 <trown> #topic ask.openstack.org triage
15:35:26 <rbowen> I need help triaging the questions on http://ask.rdoproject.org/  . We're getting pretty far behind. Not even answering, necessarily, but routing them to the right people.
15:35:58 <rbowen> A lot of the older ones can probably just be closed, but I think I've closed the ones that are obviously dead or EOL or whatever.
15:36:24 <rbowen> Anyways, that's a great place for people to get involved, if you're just kind of lurking here and looking for somewhere to plug in.
15:36:31 <rbowen> Jump in.
15:36:38 <rbowen> <EOL>
15:37:47 <trown> #topic open discussion
15:38:05 <trown> anyone have anything else they would like to discuss?
15:38:55 <trown> whoops, I skipped next week meeting attendance
15:39:07 <trown> I will not be here next week...
15:39:21 <trown> #undo
15:39:21 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x3978d190>
15:39:34 <trown> #topic next week meeting attendance
15:39:48 <chandankumar> i will be available by next week.
15:39:57 <trown> number80: I see you put yourself as chair
15:39:59 <rbowen> I will be completely offline all next week, I hope.
15:40:10 <number80> who will be there?
15:40:18 <number80> 3 people?
15:40:20 <jpena> I'll be there next week
15:40:27 <jpena> (last day before holidays)
15:40:28 <number80> then, we keep the meeting
15:40:31 <imcsk8> i'll be here too
15:40:35 <number80> great :)
15:41:40 <trown> cool
15:41:51 <trown> #action number80 to chair next meeting
15:42:02 <trown> #topic open discussion
15:42:22 <trown> anything else?
15:43:42 <trown> ok, thanks everyone for attending
15:43:52 <trown> #endmeeting