15:01:10 <chandankumar> #startmeeting RDO meeting (2016-03-09)
15:01:10 <zodbot> Meeting started Wed Mar  9 15:01:10 2016 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:10 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-03-09)'
15:01:14 <chandankumar> \o/
15:01:20 <trown> o/
15:01:24 <dmsimard> \o
15:01:32 <gkadam> o/
15:01:41 <EmilienM> o/
15:01:44 <apevec> o/
15:01:45 <jpena> \o
15:01:50 <larsks> \o/
15:02:00 <chandankumar> #chair trown apevec jpena dmsimard larsks gkadam
15:02:00 <zodbot> Current chairs: apevec chandankumar dmsimard gkadam jpena larsks trown
15:02:12 <chandankumar> #link https://etherpad.openstack.org/p/RDO-Meeting
15:02:48 <chandankumar> number80, jruzicka ?
15:03:01 <chandankumar> so starting with first agenda
15:03:12 <chandankumar> #topic RDO-Delorean renaming
15:03:13 <apevec> yes
15:03:17 <apevec> for 3rd time!
15:03:29 <trown> I have heard its a charm
15:03:30 <chandankumar> Here is the suggested names https://etherpad.openstack.org/p/RDO-Delorean-rename
15:03:51 <apevec> lol bftf
15:04:06 <apevec> flepied, ^ is that yours? :)
15:04:12 <chandankumar> trunkchaser
15:04:14 <flepied> flepied: yes :-)
15:04:21 <flepied> apevec: yes
15:04:24 <trown> I like bftf
15:04:28 <chandankumar> #chair flepied
15:04:28 <zodbot> Current chairs: apevec chandankumar dmsimard flepied gkadam jpena larsks trown
15:04:29 <apevec> how do you spell it ?
15:04:43 <flepied> no idea :-)
15:04:48 <apevec> beefteef ?
15:04:48 <chandankumar> hehe
15:04:57 <tristanC> should we start a civs vote with the current proposal ?
15:04:58 <apevec> beefteak ?
15:05:00 <trown> mrfusion is nice
15:05:08 <dmsimard> bftf ?
15:05:15 <apevec> tristanC, haha, I was waiting for you :)
15:05:23 <chandankumar> ikenga what about this one?
15:05:28 <apevec> but not sure we need that complication
15:05:34 <apevec> let's just vote now on irc
15:05:40 <tristanC> heh, well I like most of the proposition, civs would sort them by popularity
15:05:43 <apevec> it has been announcemed last week
15:05:51 <trown> single vote per person?
15:05:57 <leifmadsen> naming things is the hardest part of a project
15:05:58 <number80> i/
15:06:05 <chandankumar> #chair number80
15:06:05 <zodbot> Current chairs: apevec chandankumar dmsimard flepied gkadam jpena larsks number80 trown
15:06:15 <trown> leifmadsen: I would go further and say it is the hardest problem in all of CS
15:06:24 <leifmadsen> trown: I don't disagree :D
15:06:35 <number80> chandankumar: ikenga is an african god of time and achievement
15:06:49 <apevec> I liked "outatime" but that's not poetic enough
15:06:55 <number80> (and w/o trademark issue)
15:07:03 <dmsimard> bttf ? back to the future ?
15:07:04 <chandankumar> let us start voting on the names.
15:07:08 <jpena> I like outatime to :)
15:07:09 <larsks> ikenga sounds too much like icinga to me...
15:07:15 <dmsimard> larsks: +1
15:07:22 <trown> mrfusion is a bit too male maybe
15:07:30 <apevec> yeah, no gods please
15:07:30 <leifmadsen> I still like proximo :)
15:07:37 <larsks> I like "proximo".  It even rhymes well "RDO Proximo!"
15:07:45 <flepied> do we vote on the etherpad with a + when we like it ?
15:07:45 <chandankumar> larsks, +1
15:07:50 <leifmadsen> or just "prox" for "deploy the prox!"
15:08:00 <number80> I don't see the link with prox
15:08:03 <larsks> Would you, could you, with a prox?
15:08:15 <trown> I would not could not with a prox
15:08:17 <apevec> so one thing: I'd like we do not use this project name anymore in repo and jobs
15:08:20 <apevec> just trunk
15:08:23 <dmsimard> outatime is okay, let's just brand the repositories as "rdo trunk repositories"
15:08:27 <dmsimard> apevec: yeah exactly
15:08:28 <apevec> rdo-trunk-master
15:08:34 <apevec> rdo-trunk-liberty etc.
15:08:43 <trown> +1
15:08:45 <saneax> o/
15:08:51 <chandankumar> #chair saneax
15:08:51 <zodbot> Current chairs: apevec chandankumar dmsimard flepied gkadam jpena larsks number80 saneax trown
15:09:04 <number80> trunkchaser is simple and just work
15:09:09 <trown> that makes naming a bit easier too, since it doesnt have to sound good between rdo and upstream release name
15:09:31 <apevec> number80, yeah but I think it might have implications in lingo
15:09:38 <trown> lol
15:09:59 <flepied> I like trunkchaser
15:10:14 <chandankumar> what about voting on trunkchaser?
15:10:19 <leifmadsen> +1 trunkchaster
15:10:21 <leifmadsen> +1 trunkchaser
15:10:32 <gkadam> +1 trunkchaser
15:10:44 <flepied> +1 trunkchaser
15:10:49 <apevec> but it is descriptive indeed
15:10:55 <saneax> +1 trunkchaser
15:11:03 <dmsimard> it drifts away from the back to the future theme :(
15:11:05 * larsks obstains
15:11:20 <apevec> yeah, that's negative side
15:11:22 <jpena> -1 to trunkchaser, too similar to "tailchaser" for me
15:11:49 <trown> outatime has alot of votes on the etherpad
15:11:57 <trown> +1 outatime
15:12:16 <dmsimard> While it drifts away from the back to the future theme, I have to concede that it is good at describing what it does. In keeping with the bttf theme, I have to +1 outatime
15:12:17 <number80> I'm crossing the ones removed
15:12:24 <tristanC> i like the shallow reference to licence plate text, that's a neat source of name :)
15:12:28 <chandankumar> + 1 outatime
15:12:46 <jpena> +1 outatime
15:12:53 <gkadam> +1 outatime
15:12:56 <number80> +1 outatime
15:13:03 <apevec> +1 outatime
15:13:03 <tristanC> +1 outatime, go :)
15:13:11 <dmsimard> gkadam +1'd both options lol
15:13:18 <chandankumar> we have 6 votes on outatime on etherpad https://etherpad.openstack.org/p/RDO-Delorean-rename
15:13:25 <gkadam> Ou
15:13:26 <gkadam> O
15:13:30 <trown> is anyone -1 to outatime?
15:13:47 <number80> please no :)
15:13:50 <trown> derekh: dprince ^
15:14:05 <dmsimard> http://i.imgur.com/gEC8fTp.jpg
15:14:05 <gkadam> dmsimard , *outatime is cool too !
15:14:21 <apevec> yes, grandpa derekh where art thou?
15:15:12 <apevec> BTW http://www.outatimemovie.com/ is coming
15:15:13 <flepied> isn't it trademarked ?
15:15:24 <apevec> so yeah, might be (TM) again :(
15:15:28 <dmsimard> omg
15:15:33 <jruzicka> oh hey
15:15:37 <trown> foiled again
15:15:44 <dmsimard> I give up
15:15:44 <chandankumar> #chair jruzicka
15:15:44 <zodbot> Current chairs: apevec chandankumar dmsimard flepied gkadam jpena jruzicka larsks number80 saneax trown
15:15:52 <dprince> trown: outatime is fine w/ me
15:15:54 <derekh> apevec: sorry wasn't following, did we not rename last week?
15:16:08 <apevec> derekh, nope ... (TM) issues
15:16:12 <trown> derekh: we are renaming every week now, just for fun
15:16:15 <trown> jk
15:16:17 <jruzicka> trunkaneer
15:16:19 <apevec> lol
15:16:26 <derekh> +trunkchaser from me , but fine with either
15:16:42 <apevec> trunkmolester ?
15:16:46 <dmsimard> ew
15:16:48 <jruzicka> :D
15:16:52 <apevec> or rather otherway around...
15:16:55 <dprince> yeah, I like trunkchaser better
15:17:11 <jruzicka> trunkchaser is very accurate, I thought that has some problems?
15:17:38 <apevec> jruzicka, iirc in lingo might have some pejorative meaning
15:17:47 <dprince> DLRN
15:17:53 <apevec> but if dprince says it's fine, then we're good
15:18:12 <apevec> dprince, DLRN?
15:18:15 <dprince> dude, I'd just call it DLRN  (take out the vowels')
15:18:21 <dprince> They'll never konw
15:18:26 <trown> hmm is DLRN allowed? It could be another acronym that doesnt stand for anything like RDO
15:18:49 <dmsimard> lol ^
15:18:53 <dprince> and our icon is a license plate w/ 'outatime' on it
15:19:25 <larsks> RDO DLRN, SRSLY? I'd like to buy a vowel!
15:19:50 <apevec> ok, so -2 based on (TM) for outatime
15:19:57 <trown> I do not think DLRN would have trademark issues from the Delorean Motor Company
15:19:57 <number80> s/chaser/tailer/
15:20:03 <number80> ?
15:20:14 <apevec> revoting now for trunkchaser vs DLRN ?
15:20:26 <dmsimard> +1 trunkchaser
15:20:31 <jpena> +1 DLRN
15:20:37 <chandankumar> +1 DLRN
15:20:39 <trown> +1 DLRN
15:20:44 <apevec> http://linkresearchlab.org/dlrn/
15:20:49 <apevec> DIGITAL LEARNING RESEARCH NETWORK
15:20:52 <apevec> man
15:21:14 <flepied> +1 DLRN
15:21:17 <trown> UT Arlington... is that even a real school?
15:21:22 <dprince> apevec: meh, I'd ignore them
15:21:40 <apevec> oh it's dLRN :)
15:22:15 <jruzicka> OMG IT'S JUST 4 LETTERS
15:22:15 <derekh> +1 DLRN if its not TM issue
15:22:20 <jruzicka> +1 dlrn
15:22:48 <apevec> +1 DRLN it's almost like CE_RN_
15:22:55 <number80> hat's also a music band => http://dlrn.co/
15:22:56 <apevec> err +1 DLRN
15:23:27 <chandankumar> https://soundcloud.com/dlrn
15:23:43 <derekh> is it actually a tradmark problem if its a chash in a different industry ? /me doesn't know much about such things
15:24:01 <derekh> *clash
15:24:32 <trown> I am not too worried about a band either...
15:24:33 <apevec> ianal but you don't want to try I guess
15:24:38 <pabelanger> apevec: not sure, I'll have to ask around -infra to see why there is a difference
15:24:46 <pabelanger> apevec: should be able to do that shortly
15:25:08 <number80> qryberna (delorean in ROT13)
15:25:50 <trown> we are about halfway through the meeting btw
15:26:01 <number80> well, I'm +0 to anything
15:26:08 * chandankumar reminds we have 35 left.
15:26:10 <number80> just name the thing
15:26:24 <chandankumar> *35 mins
15:26:41 <derekh> could we just ask a lawer, give them 5 or six options and see if they flag problems
15:26:57 <apevec> ok, so DeLoReaN aka DLRN has 7 +1
15:27:35 <apevec> derekh, not sure we can use corp lawerys for this
15:27:40 <derekh> apevec: ok
15:27:53 <apevec> so let's agree on DLRN ?
15:28:17 <trown> lets
15:28:34 <jpena> apevec: it seems to be the most voted, let's give it a try with some legal department if we have concerns
15:28:34 <derekh> +1
15:28:35 <apevec> #agreed reaname delorean to DLRN
15:28:46 <number80> amen
15:29:08 <chandankumar> since delorean is renamed, we need to make an announcement for Delorean rename
15:29:20 <apevec> #action apevec to blog about DLRN rename
15:29:37 <chandankumar> we need also to update the delorean repo
15:29:40 <apevec> then post, tweet etc. rbowen will help
15:29:51 <apevec> chandankumar, this will be code change, yes
15:29:54 <chandankumar> and fixed rdo websites
15:29:58 <apevec> but we'll keep backward compat links
15:30:01 <apevec> like delorean.repo
15:30:17 <apevec> but otherwise as mentioned, it won't have project name in paths or job names
15:30:24 <apevec> rdo-trunk-master
15:30:27 <apevec> rdo-trunk-mitaka
15:30:29 <apevec> etc.
15:30:39 <derekh> sorry, my fault
15:30:43 <chandankumar> ok
15:31:01 <apevec> #action apevec to open trello card with rename tasks: website, project, etc.
15:31:23 <apevec> ok, we can move oN!
15:31:33 <chandankumar> #topic Packaging Updates
15:31:44 <chandankumar> #link https://trello.com/c/UxssYzQl/142-python-service-tests-subpackage-for-openstack-projects
15:32:01 <number80> I have a question about the naming
15:32:04 <apevec> https://review.gerrithub.io/#/q/topic:rdo-tests
15:32:05 <chandankumar> reviews for python-test-packages for all openstack projects is up
15:32:16 <chandankumar> #link https://review.gerrithub.io/#/q/topic:rdo-tests
15:32:19 <number80> why python-xxx-tests and not openstack-xxx-tests?
15:32:29 <apevec> number80, b/c it's python code
15:32:38 <chandankumar> feel free to review it.
15:32:39 <apevec> also there will be tests in clients
15:32:51 <dmsimard> apevec: everything in openstack is python code by that logic..
15:33:09 <apevec> is it not?
15:33:48 <apevec> number80, also that seems to naming convention in few other python packages in Fedora
15:34:02 <trown> hmm I think unittests belong to the library part of the code, hence python-* naming
15:34:03 <number80> well, naming convention is <main-package>-tests
15:34:10 <trown> oh
15:34:11 <apevec> number80, link?
15:34:29 <apevec> again, naming discussion... :(
15:34:33 <trown> lol
15:34:54 <dmsimard> It's a known fact that naming things suck.
15:36:00 <number80> that's general guideline, like %{name}-doc
15:36:32 <apevec> number80, hmm, not convinced
15:37:03 <apevec> let's proceed with python-*-tests, until we have non-python library code in tests
15:37:10 <chandankumar> ok
15:37:10 <number80> ack
15:37:34 <chandankumar> python-congressclient is done by mflobo it just requires a final review https://trello.com/c/6GYLXjA0/118-add-congress-in-rdo
15:37:48 <number80> yes, I was reviewing it but mock build fails
15:38:21 <jpena> about the -tests subpackages, what is the guideline when the package already included the tests inside the main python- package? Is it ok to just take them out, or could it cause issues?
15:38:57 <number80> jpena: splitting tests in subpackage is not a problem
15:39:13 <apevec> jpena, you just need to depend on python-*
15:39:29 <apevec> i.e. it can't be standalone
15:39:42 <apevec> which is the case anyway, code-wise
15:39:50 <jpena> ok, I was thinking of the tempest use case, just to be safe
15:40:32 <chandankumar> just a reminder, if you are packaging a new package for RDO, just block your package review by this bug https://bugzilla.redhat.com/show_bug.cgi?id=1290163
15:40:38 <apevec> some projects do have standalone functional tests in separate project, iirc sahara?
15:41:01 <apevec> chandankumar, you can use bug alias:
15:41:18 <apevec> RDO-MITAKA-REVIEWS
15:41:25 <chandankumar> sure.
15:41:33 <apevec> easier to remember than #
15:41:50 <apevec> just enter it in Blocks: field
15:42:00 <tosky> sahara-tests, yes
15:42:02 <chandankumar> #info use RDO-MITAKA-REVIEWS bug alias to block new package reviews
15:42:05 <tosky> it's an entire separate repository
15:42:17 <tosky> but it has no releases yet; a release will come soon
15:42:33 <apevec> tosky, ok, then we'll have separate RPM package
15:43:08 <apevec> but pkg review could be started with git snapshot tarball already
15:43:32 <apevec> https://fedoraproject.org/wiki/Packaging:SourceURL#Git_Hosting_Services
15:44:09 <apevec> I'll add that to the checklist
15:44:40 <chandankumar> apevec, can we move to next topic?
15:45:05 <apevec> yes, I'm done
15:45:12 <chandankumar> #topic Updates on RDO Mitaka test day
15:45:18 <chandankumar> apevec, trown go ahead
15:45:51 <trown> our stable repo is from Fri, so good to go for test day in that regard
15:46:08 <apevec> and that's about mitaka-3 code
15:46:16 <chandankumar> #link Current-passed-ci promoted https://ci.centos.org/view/rdo/job/rdo-delorean-promote-mitaka/303/
15:46:24 <trown> it did not require any workarounds in the undercloud.qcow2 image this time which is neat
15:46:27 <apevec> stable/mitaka branches are being created this week
15:46:46 <apevec> so we'll create new DLRN instance
15:47:15 <trown> # oooq demo after the meeting http://www.youtube.com/watch?v=4O8KvC66eeU
15:47:16 <dmsimard> hmm, that also means we need to branch integration tests
15:47:16 <apevec> shall we wait until all projects have stable/mitaka ?
15:47:38 <apevec> we could also switch them one by one in rdoinfo
15:47:39 <chandankumar> #link Tripleo Demo http://www.youtube.com/watch?v=4O8KvC66eeU
15:47:43 <apevec> err no
15:47:47 <apevec> it's automatic :)
15:48:03 <trown> apevec: I think we should branch as soon as some do, then we will gradually have them all on mitaka as they branch
15:48:25 <apevec> yes, we just need instance configured for mitaka
15:48:27 <trown> apevec: that would be very helpful to tripleo where we kind of want to be the last to branch
15:48:51 <jpena> the puppet-dlrn stuff is ready to create the new instance, we can do it as soon as it's needed (tomorrow?)
15:48:52 <apevec> jpena already has puppet-dlrn (renamed it, right? :) change ready
15:48:59 <apevec> touche
15:49:06 <trown> sweet
15:49:51 <apevec> jpena, I'll check what's the status upstream, but I think we could start it now
15:49:58 <apevec> it will fallback to master
15:50:00 <jpena> apevec: ack
15:50:21 <jpena> apevec: will we have newton tags in rdoinfo now, or next week?
15:50:27 <apevec> #action jpena and apevec to start stable/mitaka DLRN instance
15:50:45 <apevec> #action apevec to add newton tags in rdoinfo
15:50:53 <apevec> jpena, I'll send PR after the meeting
15:51:00 <jpena> ok
15:51:13 <trown> #action trown help tripleo move to mitaka instance once created
15:51:49 <apevec> trown, dmsimard - also ci.centos jobs?
15:51:57 <dmsimard> yeah, that's what I mentioned
15:52:06 <dmsimard> We will need to branch weirdo and ooo-q
15:52:15 <trown> apevec: ya not sure we need newton promote just yet
15:52:30 <apevec> yeah, don't add newton jobs just yet
15:52:41 <dmsimard> trown: I'll just create a mitaka branch for weirdo and have it configure the mitaka trunk repos
15:52:42 <apevec> but switch mitaka to stable
15:52:51 <dmsimard> instead of centos-master
15:52:55 <trown> yep
15:53:21 <trown> dmsimard: I don't plan to branch oooq, it should be able to deploy all RDO supported releases from a single branch
15:53:48 <trown> it deploys liberty and mitaka now, so I don't see an issue adding one more
15:53:53 <apevec> it's just path to undercloud.qcow right?
15:53:54 <dmsimard> trown: hm, ok.
15:54:07 <chandankumar> apevec, can we move to next topic?
15:54:22 <apevec> I think we can, trown, dmsimard ?
15:54:28 <trown> good
15:54:37 <dmsimard> sure
15:54:42 <trown> thanks for keeping it moving chandankumar
15:54:49 <chandankumar> #topic gerrithub for redhat-openstack/website
15:55:04 <apevec> that came up today on #rdo
15:55:14 <apevec> hmm rbowen not here
15:55:21 <apevec> pkovar, ^ what do you say?
15:55:29 <lyarwood> is hguemar in here under a different irc nick?
15:55:38 <trown> ya maybe we could postpone that for a meeting with rbowen... since we are almost outatime anyways
15:55:39 <apevec> lyarwood, just but meeting
15:55:49 <apevec> trown, ack
15:56:05 <apevec> also that would break "Edit me on github"
15:56:09 <trown> ya
15:56:21 <apevec> ok, postponed
15:56:24 <lyarwood> kk, my corp irc client just died, need to tell him my github account is `lyarwood`
15:56:37 <apevec> number80, ^
15:56:44 <apevec> ah damn I revealed it
15:56:45 <chandankumar> #topic Way to mirror our trunk mirrors
15:56:55 <chandankumar> #link https://www.redhat.com/archives/rdo-list/2016-March/msg00031.html
15:57:02 <chandankumar> dmsimard, Go ahead
15:57:09 <dmsimard> hi
15:57:11 <dmsimard> I'm dmsimard
15:57:20 <trown> hi dmsimard
15:57:28 <apevec> hi dmsimard
15:57:28 <dmsimard> so, that ML thread is about ipv6 availability and I covered that part in my reply
15:57:44 <dmsimard> not a huge deal in my opinion though it did bring up that we have no easy way of reproducing our mirrors elsewhere
15:58:04 <dmsimard> I feel the delorean instance could provide a rsync server instance or something like that.
15:58:06 <apevec> thanks for investigating that, we should turn it into faq
15:58:29 <dmsimard> the OP in question proxies through an ipv4 machine to reach our mirrors
15:59:18 <apevec> rsync wouldn't save much since we have separate hash for each build?
15:59:19 <dmsimard> but then again, there's the fact that there are the delorean repository and then the delorean-deps so it's two different things entirely
15:59:40 <apevec> or would we just publish via rsync passed-ci ?
15:59:50 * chandankumar reminds we are running out of time.
15:59:53 <trown> maybe weekly?
16:00:14 <dmsimard> I haven't yet reached out to kbsingh to see if the cbs/buildlogs had rsync available
16:00:28 <apevec> sounds like this could be continued on rdo-list thread
16:00:34 <dmsimard> but I know some official centos mirrors offer it (i.e, iWeb)
16:00:46 <dmsimard> sure.
16:00:52 <apevec> dmsimard, I guess they have something private for their mirros?
16:01:01 <dmsimard> I don't know *how* we could do it, but bringing up that we could offer something
16:01:08 <dmsimard> apevec: something private ?
16:01:19 <apevec> I mean, only available to mirrors ?
16:01:21 <apevec> dunno
16:01:47 <dmsimard> iWeb has centos mirrors available over both http and rsync in both ipv4 and ipv6
16:02:03 <apevec> anyway, yes for to be discussed w/ KB
16:02:26 <apevec> dmsimard, yeah, I mean rsync on master mirror.c.o
16:02:49 <dmsimard> k let's follow up on the ML
16:02:50 <flepied> trown live on youtube !
16:02:51 <chandankumar> apevec, can we move to next topic?
16:03:18 <trown> ya, waiting on yall to start the demo :p
16:03:30 <dmsimard> https://www.youtube.com/watch?v=4O8KvC66eeU
16:03:36 <apetrich> trown, sweet
16:03:56 <dmsimard> no beret trown :(
16:04:08 <apevec> dmsimard, yeah - here it is https://wiki.centos.org/HowTos/CreatePublicMirrors
16:04:24 <trown> I am going to get started :), we are 5 over
16:04:25 <apevec> ok, let's close this meeting and watch trown TV !
16:04:34 <chandankumar> #topic chair for next meeting
16:04:47 <chandankumar> anyone up for chairing next meeting?
16:04:49 <dmsimard> I'll chair
16:05:01 <chandankumar> #action dmsimard will chair for next meeting
16:05:11 <chandankumar> let me close the meeting
16:05:15 <chandankumar> #endmeeting