15:00:01 <jruzicka> #startmeeting RDO meeting (2016-04-13)
15:00:01 <zodbot> Meeting started Wed Apr 13 15:00:01 2016 UTC.  The chair is jruzicka. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:01 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-04-13)'
15:00:10 <trown> Hammer Time
15:00:15 <jschlueter> o/
15:00:18 <chandankumar> https://etherpad.openstack.org/p/RDO-Meeting
15:00:19 <EmilienM> o/
15:00:21 <trown> o/
15:00:22 <chandankumar> \o/
15:00:23 <mflobo> o/
15:00:26 <jjoyce> o/
15:00:28 <apevec> o/
15:00:44 <jpena> o/
15:01:04 <chandankumar> #chair trown jschlueter EmilienM trown mflobo jjoyce apevec jpena
15:01:11 <dmsimard> \o
15:01:20 <number80> o/
15:01:22 <fbo_> o/
15:01:28 <imcsk8> o/
15:01:32 <jruzicka> #chair dmsimard number80 fbo_ imcsk8
15:01:32 <zodbot> Current chairs: dmsimard fbo_ imcsk8 jruzicka number80
15:01:40 <rbowen> o/
15:01:48 <amoralej> o/
15:01:53 <tristanC> o/
15:01:57 <jruzicka> #chair trown jschlueter EmilienM trown mflobo jjoyce apevec jpena
15:01:57 <zodbot> Current chairs: EmilienM apevec dmsimard fbo_ imcsk8 jjoyce jpena jruzicka jschlueter mflobo number80 trown
15:01:57 <jruzicka> trown trams_ tristanC trozet rbowen amoralej tristanC
15:02:14 <number80> a large crowd today
15:02:19 <EmilienM> (not sure why we set chairs)
15:02:34 <jruzicka> #chair chandankumar
15:02:34 <zodbot> Current chairs: EmilienM apevec chandankumar dmsimard fbo_ imcsk8 jjoyce jpena jruzicka jschlueter mflobo number80 trown
15:02:37 <mrunge> o/
15:02:44 <jruzicka> #chair mrunge
15:02:44 <zodbot> Current chairs: EmilienM apevec chandankumar dmsimard fbo_ imcsk8 jjoyce jpena jruzicka jschlueter mflobo mrunge number80 trown
15:02:54 <mrunge> heh :-/
15:02:57 <apevec> EmilienM, so that everyone can command the bot
15:02:58 <trown> EmilienM: with out that you can't use zodbot commands
15:03:25 <mrunge> chaired by all, than means?
15:03:34 <apevec> mrunge, support group?
15:03:40 <number80> the one true chair is jruzicka today
15:03:41 <apevec> in circle
15:03:42 <EmilienM> mhh ok. Just other meetings don't do that.
15:03:54 <EmilienM> anyway, let's keep going
15:03:55 <jruzicka> #topic Mitaka Test Day
15:04:06 <flepied1> o/
15:04:14 <apevec> rbowen, yeah, how come it's not Thu/Fri like last few ? :)
15:04:25 <jruzicka> #chair flepied1
15:04:25 <zodbot> Current chairs: EmilienM apevec chandankumar dmsimard fbo_ flepied1 imcsk8 jjoyce jpena jruzicka jschlueter mflobo mrunge number80 trown
15:04:25 <rbowen> Yeah, I just made a mistake, and have been confused all along
15:04:29 <rbowen> #link https://www.rdoproject.org/testday/mitaka/ga/
15:04:32 <trown> :)
15:04:46 <rbowen> And I thought yesterday was Wednesday ALL DAY
15:04:47 <trown> today has been very quiet thus far, had me double check it was today
15:05:04 <rbowen> so we'll probably have more activity tomorrow.
15:05:10 <mrunge> uhm, I thought today is Wednesday?
15:05:19 <rbowen> Well, yes, but so was yesterday. :-)
15:05:50 <rbowen> I don't think there's anything to say about test day, except, please test.
15:06:02 <apevec> mrunge, it's Thu in Toyo :)
15:06:03 <rbowen> And sorry about the day confusion.
15:06:15 <apevec> yes, and add test cases
15:06:22 <apevec> about what you care about
15:06:31 <rbowen> Lots of test cases, the more detailed instructions the better.
15:06:54 <apevec> testcases w/o instructions should be removed
15:08:17 <jruzicka> #topic DLRN instance migration to ci.centos.org infra
15:08:32 <EmilienM> Puppet OpenStack CI is succesfuly testing more services: zaqar/mistral
15:08:43 <jpena> so this is mine
15:08:50 <jruzicka> jpena, go on then ;)
15:09:02 <jpena> we are (again) in the process of migrating the dlrn instance, now to the ci.centos.org infrastructure.
15:09:28 <jpena> the biggest advantage is that we will be able to use the CentOS CDN to distribute our content, so much more reliable
15:09:44 <jpena> we're tracking the tasks at https://trello.com/c/6O18whhA/146-migrate-dlrn-instance-to-centos-infrastructure
15:10:12 <jpena> and right now, we have 2 blockers: https://review.gerrithub.io/271544 (needed to publish the hashed repos and build logs)
15:10:15 <EmilienM> jpena: that's an excellent news
15:10:35 <apevec> #info new DLRN instance in ci.centos infra will be able to publish RDO trunk repos in CentOS CDN
15:10:36 <jpena> and the creation of a job to publish the content from the dlrn instance to buildlogs
15:11:05 <apevec> jpena, that will be jenkins job?
15:11:05 <jpena> dmsimard: that is something only kbsingh can do for us, right? ^
15:11:09 <tosky> (sorry, late)
15:11:19 <dmsimard> right
15:11:32 <sanjay__u> O/
15:12:11 <jpena> once those tasks are finished, we'll have an estimated date for the migration, and we will communicate so all RDO Trunk consumers can adapt their jobs
15:12:13 <apevec> jpena, dmsimard - ah so that will be cron job ?
15:12:15 <dmsimard> I'll catch up with him today to see what bits we are missing
15:12:31 <jpena> dmsimard: perfect!
15:12:41 <dmsimard> apevec: by default it'd be in the 2 hourly cron for buildlogs but we have some flexibility
15:12:47 <apevec> jpena, we could do backward compat redirects on public trunk.rdoproject ?
15:13:00 <apevec> so that old links can work
15:13:09 <jpena> apevec: that's on the to-do list, I'll check how to do it
15:13:15 <chandankumar> jpena, added some comments on the review, it would be good to have.
15:13:15 <apevec> but let's get content on CDN first
15:13:25 <dmsimard> apevec: backwards compat or just delorean.repo's pointing to the CDN links ?%
15:13:41 <kbsingh> we should have first cut images today
15:13:48 <flepied1> what will be the url to access the repos ?
15:14:17 <number80> flepied1: if we have backward compat redirection, the same
15:14:19 <apevec> dmsimard, I was thinking redirect
15:14:29 <jpena> dmsimard: basically redirect from https://trunk.rdoproject.org/centos7-master/current/ to http://buildlogs.centos.org/whatever
15:14:36 <jpena> and so on
15:14:47 <dmsimard> flepied1: something like http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master
15:14:57 <EmilienM> thanks for the info
15:15:32 <dmsimard> jpena, apevec: so we will do away with the delorean.repos then ? Cause they will point to a hashed repo.
15:15:32 <flepied1> dmsimard: thx
15:16:04 <dmsimard> The .repo's could be statically hosted on rdoproject.org
15:16:25 <dmsimard> i.e, http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master/delorean.repo would actually be garbage
15:16:48 <dmsimard> am I making sense ?
15:16:57 * dmsimard hasn't had enough caffeine this morning
15:17:09 <jpena> dmsimard: right, it wouldn't be useful in buildlogs, just if you want to use the hashed repo in trunk.rdo
15:17:10 <apevec> I think we'll need hashes on CDN too
15:17:43 <apevec> then GC older ones
15:17:43 <dmsimard> but the repo on the CDN will have a static URL, say http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master
15:17:56 <dmsimard> not http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master/uu/uuid/
15:18:02 <dmsimard> right ?
15:18:46 <imcsk8> also, can it be useful to have a "latest" directory pointing to the latest build?
15:19:47 <dmsimard> apevec, jpena: my question ^ ?
15:20:06 <jpena> dmsimard: I assumed it would have a static URL
15:20:07 <apevec> thinking... my issue was about updates, when we push new repo
15:20:33 <apevec> it would break those with old yum metadata cached
15:20:51 <dmsimard> I think I discussed this with KB already but I forget what was the answer
15:20:52 <apevec> but we can avoid that by preserving last 3, like KB is doing
15:21:25 <dmsimard> I'll check that.
15:21:37 <apevec> it's createrepo option --retain-old-md
15:22:04 <dmsimard> #action dmsimard to check with KB the specifics of pushing repos and prevent breaking repositories in flight
15:22:25 <dmsimard> #action jpena to create redirects from old URLs to the new URLs
15:22:49 <apevec> but for that to work we need to also keep those last N old builds around, so we need GC strategy too
15:22:50 <dmsimard> I can take an action to create the static .repo files to host on rdoproject.org
15:23:15 <dmsimard> rbowen: can we host arbitrary text files on rdoproject.org ?
15:23:23 <number80> dmsimard: yes
15:23:26 <rbowen> Yes
15:23:29 <dmsimard> ok
15:23:46 <apevec> dmsimard, why wouldn't we put them on buildlogs ?
15:23:48 <rbowen> It should be only markdown files that are procesed in any way.
15:24:06 <apevec> also, with static url we can have those repo definitions in release RPMs
15:24:06 <jruzicka> markdown to rule them all
15:24:33 <apevec> www.rdoproject.org is not HA
15:24:39 <dmsimard> apevec: not a bad idea
15:24:48 <dmsimard> let's do that instead
15:25:04 <apevec> #action apevec to add trunk repos in rdo release rpms
15:25:16 <apevec> once we have the content out there
15:25:31 <dmsimard> so they'll be added but disabled, yes ?
15:25:36 <apevec> yes
15:25:43 <dmsimard> makes sense
15:25:58 <trown> neat
15:26:17 <apevec> see my plan to advertise trunk repos as rdo hotfixes in https://review.gerrithub.io/272121
15:26:45 * jpena likes the plan
15:27:10 <dmsimard> so that means regardless of repo, people just yum install rdo-release and possibly enable the trunk repos
15:27:11 <dmsimard> I like that
15:28:14 <dmsimard> I guess we'll also need to do the same for centos-release-openstack-mitaka
15:28:18 <dmsimard> and others
15:28:41 <dmsimard> that'll solve a lot of confusion regarding RDO repositories
15:29:07 <trown> one rpm to rule them all
15:29:13 <dmsimard> should we move to next topic ?
15:29:18 <apevec> yes, by release rpms I mean both, centos and generic rdo
15:29:32 <jruzicka> indeed, one rpm package to ensure proper setup is very nice feature
15:29:43 <jruzicka> 1) install this rpm
15:29:48 <jruzicka> 2) install da cloud
15:29:50 <jruzicka> 3) ?
15:29:53 <jruzicka> 4) profit
15:30:01 <imcsk8> 5) be happy?
15:30:19 <apevec> now, that's really turning into support group :)
15:30:26 <apevec> let's move on!
15:30:36 <trown> hello my name is trown and I am a RDOholic
15:30:41 <jruzicka> #topic RDO promotion CI for master
15:30:57 <apevec> ok RDOholic ^ :)
15:31:13 <trown> created pipeline for master: https://ci.centos.org/view/rdo/job/rdo-delorean-promote-master/
15:31:33 <trown> image building is broken because there is not repo script for master, but I have all the patches up to fix that
15:31:43 <trown> dmsimard will add weirdo jobs
15:31:53 <trown> EOF
15:32:03 <dmsimard> yes. Master jobs for weirdo today.
15:32:11 <apevec> nice, Newton here come
15:32:13 <dmsimard> Things will break.
15:32:16 <apevec> we*
15:32:24 <trown> things are definitely broken for tripleo
15:32:44 <trown> using https://etherpad.openstack.org/p/delorean_master_current_issues to track issues as in the past
15:33:13 <apevec> yeah, breaking early is the game here
15:33:45 <jruzicka> Oh things WILL break.
15:33:49 <trown> next?
15:33:59 <jruzicka> #topic packaging wishlist for Newton
15:34:58 <apevec> number80, ^ - also new packes we'll push as updates to rdo mitaka
15:35:01 <apevec> packages
15:35:12 <number80> yup
15:35:27 <apevec> number80, did you want to create RDO-NEWTON bz tracker?
15:35:28 <number80> we had that discussion w/ senlin and it's the same recurring discussion
15:35:48 <number80> no, have people prepare a list so that we could start have them ready
15:35:53 <apevec> should it be RFE bz against RDO/distribution ?
15:36:04 <number80> more geared toward users/ops sharing their wishlist
15:36:13 <apevec> number80, so etherpad?
15:36:16 <number80> Yes
15:36:31 <apevec> can you take action to create and advertise it?
15:36:43 <apevec> rbowen, ^ or you have better suggestion?
15:37:03 <apevec> how to implement "ponies" list?
15:37:15 <chandankumar> what about creating a RDO wishlist to collect ideas to make RDO more better.
15:37:55 <number80> /buffer 48
15:37:59 <number80> (sorry)
15:38:10 <apevec> chandankumar, yes, that's "ponnies" :)
15:39:02 <apevec> I think we can start with generic wishlist etherpad, w/ General and New Packages sections ?
15:39:25 <imcsk8> that sounds good
15:39:27 <mflobo> I agree
15:39:45 <dmsimard> number80 is excited to see requests for zookeeper and cassandra
15:39:58 <number80> dmsimard: I'm so not doing those :)
15:40:04 <dmsimard> :P
15:40:13 <apevec> we might want to add a field: Will you be willing to maintain the packge: yes/no
15:40:36 <chandankumar> apevec, +1
15:40:38 <number80> +2
15:40:42 <jpena> +1
15:40:51 <number80> no +V?
15:40:59 <number80> let's merge
15:41:08 <chandankumar> it might help to onboard new contributors from upstream to maintain the package
15:41:21 <apevec> number80, can you take action to create that etherpad?
15:41:30 <apevec> then we work on template request on it
15:41:41 <number80> #action hguemar create ponies list for Newton
15:41:56 <apevec> like Color: pink :)
15:42:17 <mflobo> please promote the etherpad whislist in openstack-dev mailing list
15:42:18 <trown> Ponie: Applejack
15:42:32 <apevec> number80, ^ what mflobo said
15:42:51 <apevec> and let's move on? maybe topics left...
15:42:54 <jruzicka> #topic RPMFactory migration next week
15:42:54 <number80> #action hguemar promote ponies list on openstack-dev
15:43:08 <number80> fbo_, flepied1 ?
15:43:21 <number80> FYI we have a migration plan
15:43:32 <number80> http://softwarefactory-project.io/etherpad/p/Retro_Planning_RDO_-_RPMF
15:43:36 <fbo_> Well we released SF 2.2.0 and upgraded review.rdoproject.org with it
15:44:00 <jruzicka> #info jruzicka to release new rdopkg with rpmfactory support this week
15:44:01 <fbo_> The node has been synced with rpmf.beta and rpmf.beta is now shutdown
15:44:07 <apevec> I need to double-check all projects have *-rdo branches
15:44:10 <rbowen> Not sure when I fell off the channel. :(
15:44:32 <rbowen> Freenode seems to be having a really bad day.
15:44:36 <chandankumar> fbo_, i am not getting what is internal logging on sign up page on review.rdproject.org
15:44:36 <fbo_> apevec, yes saw the rename was partial on gerrithub I guess
15:44:59 <apevec> fbo_, yes, we reamed packages which had GA rebuild
15:45:10 <fbo_> Now I'm syncing rdo-<release> branches to <release>-rdo inside review.rdoproject
15:45:10 <chandankumar> *login
15:45:26 <apevec> #action apevec to check all openstack-packages to have *-rdo distgit branches renamed
15:45:27 <fbo_> So all should be renamed when you'll do the migration
15:45:35 <number80> chandankumar: use github
15:45:57 <fbo_> chandankumar, you should use the github login
15:46:12 <fbo_> the internal is specific for the admin user and local users
15:46:55 <chandankumar> got that
15:47:05 <fbo_> So I guess we are on track for next week, from our side we still have to rename project with namespace
15:47:16 <fbo_> we are currently doing that
15:47:51 <apevec> #info rpmfactory migration on track for the next week
15:47:55 <tristanC> fbo_: we may also want to force https usage on login and in ci links too
15:48:09 <fbo_> we started so if you navigate through review.rdoproject.org you may see sometime service unavailable that's because renaming require gerrit restarts ...
15:48:25 <apevec> so please bear with us next week, contributor's workflow should get much better after this migration is done
15:48:36 <fbo_> tristanC, it's seems to be the case in the SF conf atm
15:49:05 <apevec> rdo packaging docs should be also updated during the next week
15:49:47 <jruzicka> yeah, it's gonna be a bumpy road next week(s) but it's gonna be great once done so please bear with us :)
15:50:01 <fbo_> apevec, I guess we can align end of this week about next tasks in the retro planning to start the next week on the right track ?
15:50:23 <apevec> ack
15:50:45 <number80> roger
15:50:53 <jruzicka> #topic Doc Day
15:51:01 <apevec> last 10mins, all for rbowen ^
15:51:09 <jruzicka> (we kind of missed it this time around)
15:51:22 <rbowen> Yes, we missed it. Perhaps we can do one next week if I dig out a litt
15:51:27 <rbowen> eunless someone else wants to take this.
15:51:43 <rbowen> I'm also doing interviews for blog post and/or podcast about what people did in Mitaka
15:51:58 <rbowen> Before we move on to Newton, we need to celebrate the awesome stuff y'all did this time around.
15:52:09 <rbowen> There's an email thread. Email me. We'll do it.
15:52:23 <rbowen> And finally, I posted a BoF agenda etherpad to rdo-list this morning
15:52:31 <apevec> yes, let's brag, we have things to be proud off !
15:52:31 <rbowen> Please add what we need to talk about, and a name next to each item.
15:52:46 <rbowen> I have two people signed up so far, and I'm hoping to do these for the next month or so, as Newton ramps up.
15:52:55 <rbowen> So think about what you wnt to talk about, and we'll schedule it
15:53:01 <rbowen> Or we can do it at Summit, if you're going to be there.
15:53:11 <jruzicka> I suggest finishing the migration before bragging :-p
15:53:12 <rbowen> I'm looking for around 10 minutes - not a big production.
15:53:18 <number80> rbowen: I nominate EmilienM as Official Mass Bug reporter
15:53:21 <rbowen> :)
15:53:31 <chandankumar> those who are not going to submit can participate in it?
15:53:31 <number80> he'll probably have nice stories
15:53:46 <apevec> rbowen, speaking of etherpads, I've started directory of RDO releated ones in https://etherpad.openstack.org/p/RDO
15:53:58 <apevec> b/c I always forget what was the etherpad name :)
15:54:04 <rbowen> Oh! That's really useful. Thank you.
15:54:14 <apevec> so please add there when you create RDO etherpad!
15:54:18 <rbowen> Perhaps a name/description next to each would be helpful
15:54:22 <trown> nice meta-pad
15:54:25 <apevec> so meta
15:54:48 <jruzicka> #info RDO meta-pad: https://etherpad.openstack.org/p/RDO
15:54:48 <apevec> rbowen, name should be descriptive, otherwise it's not a good name :)
15:54:48 <rbowen> such wow
15:54:56 <jruzicka> :D
15:55:09 <rbowen> /EOL
15:55:22 <jruzicka> So in the speed of light
15:55:24 <apevec> done in 5
15:55:44 <jruzicka> all right, time's out
15:55:45 <jruzicka> 4
15:55:46 <jruzicka> 3
15:55:48 <jruzicka> 2
15:55:50 <jruzicka> 1
15:55:50 <jpena> wait
15:55:56 <jpena> who's gonna chair the next meeting?
15:55:56 <rbowen> Chair for next week?
15:56:00 <trown> I didnt think you wer going to pull it off jruzicka, with the first topic taking 30 minutes
15:56:00 <jruzicka> dramatic
15:56:21 <trown> or guess it was the second topic
15:56:48 <jruzicka> the time a topic gets is proportional to amount of words people write so that's pretty fair :)
15:56:59 <jpena> ok, since amoralej is still too shy to propose himself, I can chair the next meeting
15:57:12 <amoralej> ok, ok, I wil
15:57:13 <jruzicka> #topic next chair
15:57:15 <trown> :)
15:57:15 <amoralej> will
15:57:19 <jruzicka> #info jpena to chair next meeting
15:57:22 <imcsk8> hehehe
15:57:36 <jruzicka> 3
15:57:37 <jruzicka> 2
15:57:38 <jruzicka> 1
15:57:40 <jruzicka> #endmeeting