15:00:15 <imcsk8> #startmeeting RDO meeting - 2016-09-21
15:00:15 <zodbot> Meeting started Wed Sep 21 15:00:15 2016 UTC.  The chair is imcsk8. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:15 <zodbot> The meeting name has been set to 'rdo_meeting_-_2016-09-21'
15:00:23 <leifmadsen> o/
15:00:24 <imcsk8> #topic roll call
15:00:24 <weshay> 0/
15:00:26 <coolsvap> o/
15:00:27 <dmsimard> \o
15:00:29 <rbowen> ¯\_(ツ)_/¯
15:00:44 <jruzicka> (•_•) ( •_•)>⌐■-■ (⌐■_■)
15:00:52 <rbowen> Hmm. The openstack bot is awol.
15:00:53 <jpena> o/
15:01:03 <apevec> oOo
15:01:04 <imcsk8> #chair leifmadsen weshay coolsvap dmsimard rbowen jruzicka jpena apevec
15:01:04 <zodbot> Current chairs: apevec coolsvap dmsimard imcsk8 jpena jruzicka leifmadsen rbowen weshay
15:01:17 <dmsimard> jruzicka wins this week's rollcall
15:01:17 <chandankumar> \o/
15:01:21 <amoralej> o/
15:01:30 <imcsk8> #chair chandankumar amoralej
15:01:30 <zodbot> Current chairs: amoralej apevec chandankumar coolsvap dmsimard imcsk8 jpena jruzicka leifmadsen rbowen weshay
15:01:48 <imcsk8> ok, lets start
15:01:56 <imcsk8> #topic     Need volunteers/topics to speak at the RDO/Ceph meetup in Barcelona - https://etherpad.openstack.org/p/rdo-barcelona-meetup-schedule  We need to finalize the schedule soon so that we can start event promotion.
15:02:14 <rbowen> We currently have just 2 people/topics on the schedule.
15:02:31 <leifmadsen> quick meetings are quick
15:02:42 <jruzicka> Oh I got my ATC and ticket to the summit, so I can rant about something.
15:02:44 <rbowen> The austin schedule is https://etherpad.openstack.org/p/rdo-austin-bof for some idea of what we discussed there.
15:02:47 <dmsimard> rbowen: I think it'd be silly to not take the opportunity to talk about rdo+ceph givent he people there
15:03:00 <amoralej> more user-oriented or contributors-oriented?
15:03:04 <rbowen> The format is rather different from last time.
15:03:15 <rbowen> 5-10 minute slots, alternating with our friends from Ceph.
15:03:18 <dmsimard> rbowen: so let's do something rdo+ceph (i.e, how we are setting up ceph with rdo deployments)
15:03:25 <rbowen> But we can do discussion items once presentations are over.
15:03:29 <rbowen> And, also, free drinks.
15:03:39 <openstackgerrit> Javier Peña proposed openstack/packstack: Fix Neutron lbaas and add it to scenario002  https://review.openstack.org/374229
15:03:43 <rbowen> "free"
15:03:45 <dmsimard> gfidente: are you going to barcelona ?
15:04:12 <rbowen> Anyways, if you just want to propose *topics*, we can have open discussion. You don't have to prepare slides, or even particular comments.
15:04:24 <dmsimard> ok
15:04:40 <number80> o/
15:04:43 <rbowen> </topic>
15:04:47 <imcsk8> #chair number80
15:04:48 <zodbot> Current chairs: amoralej apevec chandankumar coolsvap dmsimard imcsk8 jpena jruzicka leifmadsen number80 rbowen weshay
15:04:59 <imcsk8> ok, next topic...
15:05:05 <imcsk8> #topic Updates on tempest/rally
15:05:06 <trown> o/
15:05:11 <imcsk8> #chair trown
15:05:11 <zodbot> Current chairs: amoralej apevec chandankumar coolsvap dmsimard imcsk8 jpena jruzicka leifmadsen number80 rbowen trown weshay
15:05:33 <gfidente> dmanchad, rbowen /me would be happy to talk a little about rdo+ceph as well
15:05:33 <chandankumar> I have created a draft blog on how to run tempest on packstack env with latest changes in tempest packaging
15:05:35 <chandankumar> https://github.com/redhat-openstack/website/pull/702
15:05:43 <rbowen> gfidente: Excelent. Thanks.
15:05:50 <chandankumar> Feel free to try it and have your comments there
15:05:57 <gfidente> maybe a walkthrough of http://giuliofidente.com/2016/08/ceph-tripleo-and-the-newton-release.html ?
15:06:20 <gfidente> if for end users
15:06:28 <rbowen> gfidente: That would be awesome. Thank you.
15:06:32 <chandankumar> I have also written a magic script which will install all tempest test packages based on openstack environment
15:06:39 <dmsimard> gfidente: has to be like 10 minutes tops iiuc :P
15:06:42 <chandankumar> https://review.gerrithub.io/#/c/295082/
15:06:59 <gfidente> dmsimard, even better, we just discuss the features there
15:07:08 <gfidente> instead of showing things from an actual live terminal session'
15:07:23 <chandankumar> On rally side, the rally spec got cleaned up https://review.rdoproject.org/r/#/c/2237/ and new rally rpm will be available soon.
15:07:28 <gfidente> and collect feedback, which would be the most precious part of the discussion I think
15:07:35 <chandankumar> that's it from my side.
15:08:02 <imcsk8> ok, lets move on
15:08:14 <imcsk8> #topic rdo-infra-list mailing list
15:08:25 <apevec> gfidente, it's also joint meetup w/ Ceph folks
15:08:33 <dmsimard> Hi
15:08:36 <dmsimard> I'm sorry.
15:08:47 <dmsimard> I was the first one to tell Duck I didn't want a rdo-infra mailing list.
15:09:11 <dmsimard> But the truth is we need somewhere that isn't someone's inbox to send potentially spammy emails (such as CI and monitoring related)
15:09:22 <Duck> quack
15:09:22 <gfidente> apevec, well the walkthrough would only be useful to end users I suppose
15:09:27 <dmsimard> I don't want to send those to rdo-list and expect everyone to filter them out
15:09:30 <imcsk8> #chair Duck
15:09:30 <zodbot> Current chairs: Duck amoralej apevec chandankumar coolsvap dmsimard imcsk8 jpena jruzicka leifmadsen number80 rbowen trown weshay
15:09:44 <jruzicka> dmsimard, thanks man :)
15:09:46 <Duck> sorry I'm late, long previous conficall
15:09:53 <rbowen> +1. Mailing lists are cheap, and easy to filter.
15:09:56 <openstackgerrit> Merged openstack/packstack: Change ironic identity to authtoken  https://review.openstack.org/368232
15:10:22 <dmsimard> So, what do we do ? Can we create a rdo-infra-list either on redhat.com (and migrate later?), waiting for rdoproject.org might take a while
15:10:25 <apevec> dmsimard, if traffic would be spam only, that's fine
15:10:27 <Duck> dmsimard: I think a new Ml is lightweight, and the tags you suggested could work but people don't get it
15:10:29 <rbowen> As I was mentioning earlier, I would like our lists to move over to @rdoproject.org eventually, but if that's not available now, we can create an @redhat.com one very quickly and easily.
15:10:34 <apevec> but I'd set reply-to: rdo-list
15:10:38 <rbowen> It takes a day or less to spin up a new list.
15:10:44 <apevec> so that no discussion happen there
15:11:08 <dmsimard> apevec: I think that makes sense, at least to begin with
15:11:13 <dmsimard> it's something that can be reconsidered later
15:11:21 <dmsimard> as necessary
15:11:26 <trown> +1 on reply-to: rdo-list
15:11:29 <imcsk8> +1 for mailing list
15:11:37 <rbowen> So, rdo-infra@redhat.com for now? I can get that requested today if so.
15:11:40 <jruzicka> +1 for not spamming rdo-list
15:11:48 <rbowen> Can you set a reply-to at the list level?
15:12:01 <rbowen> If not, any automated mailings would need to set that themselves.
15:12:02 <Duck> nice :-)
15:12:21 <rbowen> #action rbowen to request rdo-infra@redhat.com creation.
15:12:22 <apevec> rbowen, there is somehting, we use it for upstream stable-maint
15:12:23 <rbowen> Good?
15:12:27 <apevec> I'll have a look
15:12:29 <dmsimard> rbowen: for the interest of consistency, I'd do with rdo-infra-list@ (we have rdo-list@) but yes I'm fairly sure we can set the reply-to
15:12:40 <imcsk8> #action rbowen to request rdo-infra-list mailing list
15:12:51 <apevec> #undo
15:12:51 <zodbot> Removing item from minutes: ACTION by imcsk8 at 15:12:40 : rbowen to request rdo-infra-list mailing list
15:12:52 <rbowen> we also have rdo-newsletter, so we're already inconsistent. :-)
15:12:52 <apevec> #undo
15:12:52 <zodbot> Removing item from minutes: ACTION by rbowen at 15:12:21 : rbowen to request rdo-infra@redhat.com creation.
15:12:55 <rbowen> But, sure.
15:13:09 <rbowen> I'll get that requested right away.
15:13:11 <apevec> now redo :)
15:13:14 <dmsimard> rbowen: thanks
15:13:21 <rbowen> #action rbowen to request rdo-infra-list@redhat.com creation.
15:13:25 <dmsimard> EmilienM: FYI ^ we'll have rdo-infra-list for CI stuff.
15:13:35 <EmilienM> cool
15:14:03 <imcsk8> should we continue with next topic?
15:14:08 <dmsimard> yeah we're done
15:14:15 <imcsk8> #topic RC testday Sep29/30
15:15:39 <rbowen> Last week we talked about ways to make test day more inviting.
15:15:46 <rbowen> That conversation is ongoing on rdo-list.
15:16:12 <apevec> yeah, we have one week more time to improve it
15:16:16 <rbowen> The test day is just a week out, so probably most of that stuff will be things that we try to do for the next time around.
15:16:29 <weshay> hrybacki, ^
15:16:29 <rbowen> But better test case descriptions are always welcome and helpful.
15:16:51 <apevec> on the repo level, we ( number80 / amoralej / me) are wrapping up RC builds today
15:16:55 <rbowen> Having test day be a way to 1) welcome new users and 2) give existing users a feature preview, are goals, as well as just bug finding.
15:17:04 <number80> yep
15:17:09 <weshay> maybe have folks try to add scenarios to CI vs.. just test them
15:17:20 <rdogerrit> hguemar created rdopkg: Fix macro expansion when redefining macros  http://review.rdoproject.org/r/2587
15:17:23 <hrybacki> rbowen: did you get any feedback regarding the docs on images.rdoproject.org ?
15:17:36 <rbowen> Meanwhile, https://dashboards.rdoproject.org/rdo-dev is all green so we're in good shape for the test day on that front.
15:17:40 <weshay> code vs. test, then we could use those additions for future releases
15:17:41 <rbowen> hrybacki: I didn't see any, no.
15:18:26 <hrybacki> rbowen: we're expanding them to include upgrade and update scenarios right now. Aside from more coverage what can I do to increase visability/encourage use of these for the next test day?
15:18:29 <rbowen> But those are linked from the test day pages now as examples of how to test, so that's goodness.
15:18:39 * hrybacki nods
15:18:46 <rbowen> We should link them from the right places in the test matrix
15:19:05 <rbowen> Everything in the test matrix just links to Quickstart, which is not very helpful in most cases.
15:19:11 <imcsk8> #chair weshay hrybacki
15:19:11 <zodbot> Current chairs: Duck amoralej apevec chandankumar coolsvap dmsimard hrybacki imcsk8 jpena jruzicka leifmadsen number80 rbowen trown weshay
15:19:33 <jpena> maybe it's a crazy idea, but what about having some pre-made pool of VMs to test with? Just OS and basic repos, and have a way to handle them to testers during the test days
15:19:47 <rbowen> That would be awesome. How do we make that happen?
15:19:51 <imcsk8> jpena: sounds nice
15:19:57 <rbowen> Is that possible for this time, or something to work towards for next time?
15:20:10 <hrybacki> rbowen: okay. Closer to the next test day I'll link up with you, discuss scenarios we have covered and update the matrix at that point?
15:20:14 <apevec> jpena, hmm, that gives them root acess?
15:20:30 <rbowen> hrybacki: That would be great. Thanks.
15:20:35 <hrybacki> np!
15:20:43 <jpena> apevec: yeah, it'd require some controls on who gets the VMs
15:21:25 <jpena> rbowen: we'd need some public cloud to help with the resources, so I think it could be a longer-term goal
15:21:44 <jpena> not sure how much we could use of TryStack
15:21:49 <chandankumar> jpena: what about using trystack resources for trying out?
15:21:54 <apevec> jpena, not sure about trust model here, also if it is ok w/ OS1 fineprint to share account
15:22:01 <rbowen> jpena: Probably not for this time, right.
15:22:23 <apevec> trystack needs upgrade, which is not scheduled before summit iiuc
15:22:38 <imcsk8> we could have ansible playbooks for test cases
15:23:39 <weshay> yup
15:23:52 <apevec> ok, let's collect those ideas in the thread started by rbowen
15:23:57 <dmsimard> We're looking at outages from ci.centos, review.r.o, rcip-dev and trystack in the near future
15:24:28 <imcsk8> anything else on this topic?
15:24:30 <apevec> let's move to that as a next topic?
15:24:31 <dmsimard> apevec: they want to do trystack before summit last I heard from wfoster
15:24:53 <imcsk8> #topic Announcements
15:24:54 <rbowen> There was a mention of that on the Facebook group. I was just looking for the date ...
15:25:10 <dmsimard> They'll have a parallel cloud up soon (i.e, they're not "upgrading" afaict)
15:25:12 <rbowen> It says "mid september"
15:25:22 <rbowen> "We'll be planning an upgrade to the Mitaka OpenStack release in mid-September"
15:25:37 <rbowen> I think one could possibly say we're still in mid-September.
15:25:40 <wfoster> dmsimard: we'll be deploying a separate stack for trystack and then migrating the older compute nodes into it later (we actually need to install 10GbE NICs in the older gear because we have a 10GbE switch for backend traffic now).
15:25:56 <dmsimard> wfoster++
15:25:56 <zodbot> dmsimard: Karma for wfoster changed to 1 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:26:07 <wfoster> so far as you guys are concerned you shouldn't be impacted until we migrate rest of existing stuff back in
15:26:29 <wfoster> and we'll be giving you plenty of notice
15:26:40 <dmsimard> Yeah I think we'll be fine on that front
15:26:59 <apevec> just not at the same time w/ rcip outage
15:27:19 <dmsimard> It's also worth mentioning that the rcip-dev cloud (that hosts review.r.o) will have a period of downtime at some point, still not clear on the date but I've asked for >= oct 15 at the very least
15:27:39 <dmsimard> Turns out CentOS are not the only ones having to physically move servers around
15:28:17 <number80> all the community cage is moving, or the whole RDU datacenter?
15:28:37 <dmsimard> number80: iiuc rcip-dev is actually hosted in enovance premises in Paris
15:28:38 <apevec> rcip is in Paris?
15:28:53 <number80> rcip is supposed to be in Montréal
15:28:57 <number80> -dev
15:28:59 <dmsimard> nope
15:29:06 <jruzicka> rcip is and is not
15:29:11 * jruzicka enters zen mode
15:29:43 <imcsk8> is there anything else on the topic?
15:29:58 * number80 not convinced
15:30:16 <dmsimard> number80: nothing to be convinced about, it's a fact :p
15:30:37 <number80> dmsimard: it's a fact, it's not in Paris ...
15:30:49 <dmsimard> lol
15:30:59 <imcsk8> ok, next topic
15:31:00 <apevec> we can take details about infra outages on the list/irc
15:31:04 <number80> ack
15:31:16 <imcsk8> #topic Chair for next meeting
15:31:24 <amoralej> i can take it
15:31:24 <rbowen> We should have an infra list by tomorrow ... :-)
15:31:34 <imcsk8> cool thanks amoralej !
15:31:35 <apevec> rbowen, NOT for discussions!
15:31:43 <rbowen> heh. Right.
15:31:49 <imcsk8> #topic Open Floor
15:32:36 <imcsk8> we still have 28 minutes, we can finish the meeting or keep going on this topic
15:32:36 <Duck> thanks rbowen
15:32:53 <amoralej> about infra, there was some discussion about disaster recovery testing for review.r.o some time ago
15:33:01 <Duck> please help us checking the inventory
15:33:04 <rbowen> Oh. It's already been created. Awesome.
15:33:04 <amoralej> did we test it?
15:33:12 <rbowen> Info will be sent to rdo-list momentarily.
15:33:56 <apevec> amoralej, not that I know, SF team took it into their backlog iirc
15:36:25 <weshay> open floor. we need a file server :)
15:37:03 <apevec> hey it's not xmas yet!
15:37:12 <imcsk8> hehehe
15:37:27 <number80> weshay: is swift server not good enough?
15:37:31 <apevec> but I heard St Wfoster has one?
15:37:47 <weshay> number80, adarazs tried it, reported it wasn't
15:38:09 <number80> ack
15:38:19 <adarazs> weshay, number80: wait, it's actually okay, I just didn't find os-loganalyze
15:38:22 <wfoster> we have a Netapp in RDU2 but it's not wired up yet.  That will happen after Summit when we can get 10GbE nics installed in the older machines and pull together the current Liberty + new, parallel RDO Mitaka environment.
15:38:40 <number80> adarazs: maybe it's worth pinging tristanC about it
15:38:41 <adarazs> number80, weshay: I just added this comment: https://trello.com/c/yv58BCKt/170-log-server-avail-over-http-for-3rd-party-openstack-ci#comment-57e2a809ea9789881c9168fa
15:38:51 <wfoster> into one big, sweet, backend 10GbE networked super trystack (with hopefully openstackid auth)
15:39:01 <weshay> adarazs, thanks..
15:39:03 <weshay> wfoster++
15:39:04 <zodbot> weshay: Karma for wfoster changed to 2 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:39:05 <adarazs> number80: I pretty much figured it out, works like a charm.
15:39:07 <dmsimard> rbowen: wow that was fast
15:39:16 <apevec> wfoster++ no more FB!
15:39:17 <zodbot> apevec: Karma for wfoster changed to 3 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:39:48 <adarazs> number80: we just need an instance on the same cloud where the swift is to host the os-loganalyze, update our collect logs playbook to upload to swift and we're good.
15:39:51 <adarazs> weshay: ^
15:40:09 <weshay> which cloud is that on? rcip?
15:40:20 <rbowen> dmsimard: Yeah, there's a form to fill out, and it's all automated, apparently.
15:40:23 <adarazs> weshay: yes.
15:40:33 <rbowen> The form says 3 days to get it created, but it was instant.
15:40:37 <dmsimard> adarazs: yeah I got the email, I'll get you a VM - it won't be beefy but should be enough
15:40:39 <adarazs> number80, weshay: and I'm talking about the log aspect now. :)
15:41:06 <jruzicka> wfoster++
15:41:07 <zodbot> jruzicka: Karma for wfoster changed to 4 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:41:25 <adarazs> dmsimard: I don't think it needs to be too beefy, it needs to run apache with a wsgi and that's it. it needs a floating ip too :)
15:41:36 <dmsimard> adarazs: well I mean, we're talking about *apache* here :P
15:42:05 <adarazs> dmsimard: but probably very few requests per day :)
15:44:07 <dmsimard> I think we're done here
15:44:13 <imcsk8> yup
15:44:23 <apevec> everyone gets 15min life back
15:44:28 <jruzicka> high speed!
15:44:30 <imcsk8> hehehe nice!
15:44:40 <imcsk8> ok, i'll end the meeting...
15:44:52 <dmsimard> apevec: re: PBR I think the only thing to watch out for will be packstack spec file
15:45:01 <imcsk8> #endmeeting