15:01:33 <amoralej> #startmeeting RDO meeting - 2017-03-01
15:01:33 <zodbot> Meeting started Wed Mar  1 15:01:33 2017 UTC.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:33 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-03-01'
15:01:34 <openstack> Meeting started Wed Mar  1 15:01:33 2017 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:37 <openstack> The meeting name has been set to 'rdo_meeting___2017_03_01'
15:01:46 <rbowen> Oh, is it that time already?
15:01:47 <amoralej> #topic rollcall
15:01:55 <rbowen> o/
15:01:55 <dougbtv> o/
15:02:02 <number80> o/
15:02:03 <jruzicka> o/
15:02:05 <leifmadsen> o/
15:02:08 <trown> o/
15:02:18 <jpena> o/
15:02:41 <amoralej> #chair myoung rbowen dougbtv number80 jruzicka leifmadsen trown jpena
15:02:41 <zodbot> Current chairs: amoralej dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:02:42 <openstack> Current chairs: amoralej dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:03:39 * apevec not here, but on other mtg...
15:03:49 * apevec will read back
15:04:31 <amoralej> ok, then let's start with topics
15:05:08 <amoralej> #topic openstack-puppet-modules in pike cycle
15:05:26 <chandankumar> \o/
15:05:29 <amoralej> we discussed earlier today about what to do with o-p-m
15:05:36 <amoralej> #chair chandankumar
15:05:36 <zodbot> Current chairs: amoralej chandankumar dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:05:37 <openstack> Current chairs: amoralej chandankumar dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:05:44 <number80> +1 to drop it
15:06:01 <amoralej> but in fabor of?
15:06:11 <amoralej> s/fabor/favor/
15:06:12 <leifmadsen> is there a discussion somewhere that can be linked for reference?
15:06:21 <leifmadsen> I abstain :)
15:06:22 <number80> adding individual requires to puppet-tripleo and openstack-packstack
15:06:27 <trown> +1
15:07:07 <jpena> +1, p-o-i doesn't need it at all if I remember correctly
15:07:12 <number80> opm was meant to be transitional solution between monolithic opm and individual puppet modules packages
15:07:20 <amoralej> #info conext about discussion in http://eavesdrop.openstack.org/irclogs/%23rdo/latest.log.html#t2017-03-01T12:44:26
15:07:26 <leifmadsen> thx
15:07:52 <amoralej> one of the proposals is to convert puppet-tripleo in new meta-package for tripleo only
15:08:08 <amoralej> which i don't know if it's the right solution
15:08:21 <amoralej> and making o-p-m to depend on it for backwards compatibility
15:08:59 <amoralej> right now dib elements for overcloud image creation is using o-p-m and instack-undercloud use o-p-m also
15:09:22 <dmsimard> \o
15:09:31 <amoralej> anyway, i think it's something we need to discuss with tripleo team, as they are the only user and may require changes in their side
15:10:08 <amoralej> #chair number80
15:10:08 <zodbot> Current chairs: amoralej chandankumar dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:10:09 <openstack> Current chairs: amoralej chandankumar dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:10:10 <trown> amoralej: if the dib elements switched to including puppet-tripleo it would work
15:10:15 <amoralej> #chair dmsimard
15:10:15 <zodbot> Current chairs: amoralej chandankumar dmsimard dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:10:16 <openstack> Current chairs: amoralej chandankumar dmsimard dougbtv jpena jruzicka leifmadsen myoung number80 rbowen trown
15:10:19 <dmsimard> +1 on splitting opm down to individual requires
15:10:39 <number80> EmilienM: ^
15:10:42 <trown> amoralej: right now they dont because puppet-tripleo is really used on the undercloud, but it would not hurt anything to install it on the overcloud
15:10:46 <amoralej> but puppet-tripleo is an real puppet module
15:11:01 <amoralej> adding requirements on it not purely required by it may be a bit artifical, not?
15:11:06 <number80> yep, but it calls other puppet modules?
15:11:13 <trown> ya but it is an integration layer
15:11:18 <amoralej> but i think not all of them
15:11:23 <apevec> amoralej, it has list of modules in upstream source
15:11:34 <apevec> amoralej, that must be synced to rpm deps
15:11:39 <amoralej> you mean https://github.com/openstack/puppet-tripleo/blob/master/Puppetfile_extras ?
15:11:42 <EmilienM> not all of them I confirm
15:11:56 <EmilienM> amoralej: this file is for modules that have unit tests in puppet-tripleo
15:12:00 <number80> I'm fine with asking tripleo folks, we're only on the first week of Pike cycle
15:12:32 <number80> Proposal: discuss this on rdo-list
15:12:47 <amoralej> ok
15:12:49 <EmilienM> mhh, yeah works for me
15:13:05 <amoralej> i'll add action to myself
15:13:11 <rbowen> Aso, if I might suggest something
15:13:13 <number80> do as you like
15:13:31 <rbowen> If we could phrase it, rather than dropping something, asking for osmoene from the community to step up to do it
15:13:56 <number80> rbowen: actually, OPM is just an empty package pulling other stuff
15:14:06 <rbowen> Oh, my mistake. carry on.
15:14:10 <number80> no worries
15:14:23 <amoralej> #action amoralej to send a mail to rdo-list about future of openstack-puppet-modules package
15:14:37 <rbowen> I'm looking for places where we can call out things to the community where people can step in and do things that are not getting done due to lack of time, or whatever.
15:15:04 <amoralej> let's move on to next topic
15:15:13 <amoralej> #topic announcements
15:15:30 <amoralej> #info RDO Ocata - https://www.rdoproject.org/blog/2017/02/rdo-ocata-released/
15:15:45 <amoralej> #info Videos from PTG beginning to appear at https://www.youtube.com/playlist?list=PLOuHvpVx7kYksG0NFaCaQsSkrUlj3Oq4S
15:15:50 <rbowen> Thanks to everyone that helped get Ocata out the door, and put together awesome release notes.
15:16:00 <rbowen> And to everyone that participated in my video project.
15:16:14 <rbowen> I've published 6 or 7 of the videos, and have another 15 or so to go.
15:16:38 <apevec> amoralej, ah, it's actually tripleo-puppet-elements/elements/puppet-modules/source-repository-puppet-modules
15:16:41 <rbowen> That's all. :-)
15:16:53 <apevec> sorry for OT, balancing w/ other mtg...
15:17:08 <amoralej> testing days for ocata GA are tomorrow and friday, right? https://www.rdoproject.org/testday/ocata/final/
15:18:34 <amoralej> #info RDO Ocata GA test days are on 2-3 March
15:18:52 <number80> thanks rbowen for working on that project :)
15:19:08 <rbowen> Thanks to petr for geting the test day pages ready while I've been traveling.
15:19:32 <rbowen> I'm heading to SCALE tomorrow, so please, folks, pay attention to the channel and help people that are trying to test.
15:20:14 <amoralej> #action all support RDO users on Ocata GA test days
15:20:25 <amoralej> :)
15:20:45 <amoralej> ok, next topic
15:20:53 <trozet> amoralej: hi
15:21:24 <amoralej> trozet, we are in rdo meeting, can we talk later?
15:21:36 <trozet> amoralej: oh sorry, yeah
15:21:41 <amoralej> #topic Updates on Tempest
15:21:53 <chandankumar> Tempest rpm support in oooq: https://review.openstack.org/#/c/431916
15:22:01 <amoralej> #info Tempest rpm support in oooq: https://review.openstack.org/#/c/431916
15:22:10 <amoralej> #info     Enable Tempest rpm for weirdo poi jobs: https://review.rdoproject.org/r/5273
15:22:17 <amoralej> #undo
15:22:17 <zodbot> Removing item from minutes: INFO by amoralej at 15:22:10 : Enable Tempest rpm for weirdo poi jobs: https://review.rdoproject.org/r/5273
15:22:18 <openstack> Removing item from minutes: #info Enable Tempest rpm for weirdo poi jobs: https://review.rdoproject.org/r/5273
15:22:23 <amoralej> #info Enable Tempest rpm for weirdo poi jobs: https://review.rdoproject.org/r/5273
15:22:31 <chandankumar> This patch will add support for tempest rpm as well as venv support with plugins by supporting mitaka , newton , ocata and further release
15:22:33 <amoralej> al yours chandankumar
15:22:47 <chandankumar> Feel free to take a look and comment on that
15:22:59 <chandankumar> since it is a huge changes
15:23:17 <chandankumar> My second ongoing work is Enable Tempest rpm for weirdo poi jobs: https://review.rdoproject.org/r/5273
15:23:24 <chandankumar> it is done from my side
15:23:37 <amoralej> in fact, as we enabled it by default in weirdo we are already testing from rpm in p-o-i jobs in ocata and master
15:23:52 <chandankumar> amoralej: dmsimard: https://review.rdoproject.org/r/#/c/5273/ feel free to take a look
15:23:59 <amoralej> it already discovered we had wrong version on rdoinfo for dlrn builds in ocata
15:24:34 <chandankumar> oh
15:25:21 <chandankumar> one more thing current tempest newton is tagged with temepst-13.0 are we moving to tempest-14 for newton and keeping tempest-15 for ocata?
15:26:08 <chandankumar> amoralej: ^^
15:26:18 <amoralej> yes, we should
15:26:25 <amoralej> in fact we have 14.0.0 in stable repos
15:26:31 <amoralej> iirc, lemme check
15:26:39 <chandankumar> amoralej: one worry is it might break tempest plugins
15:26:43 <amoralej> we test it with 14.0.0
15:27:03 <dmsimard> chandankumar: I didn't see the new patchsets for the ci-config patch, I'll look
15:27:08 <amoralej> we need it, currently stable/newton ceilometer doesn't work with 13.0.0
15:27:14 <amoralej> sorry
15:27:20 <amoralej> in newton we have backports
15:27:23 <amoralej> that's shy
15:27:28 <amoralej> that's why
15:27:45 <amoralej> we are still using the redhat fork in newton
15:27:46 <chandankumar> amoralej: so we need to backport to tempest -14 to newton branch in redhat-openstack/tempest
15:28:00 <amoralej> i think we already backport all required changes
15:28:13 <amoralej> it should be ok
15:29:15 <chandankumar> amoralej: i will take a look
15:29:27 <chandankumar> that's it from my side
15:29:30 <amoralej> i think we are not forced to move to 14 as we backported changes in redhat-openstack/tempest but as we are testing it with 14.0.0 in p-o-i jobs it may be convenient to do it
15:30:14 <chandankumar> amoralej: can you point me ceilometer issue and the patch which fix it
15:30:32 <chandankumar> amoralej: if needed i can simply backport that patch to newton branch
15:31:01 <chandankumar> for the shake of not breaking other plugins
15:31:16 <amoralej> chandankumar, i think it's already done, i'll send it after the meeting
15:31:20 <amoralej> ok?
15:31:27 <chandankumar> amoralej: Thanks, that will work
15:31:46 <amoralej> there not other topics on the etherpad
15:31:53 <amoralej> #topic open floor
15:32:07 <amoralej> any other topic that you'd like to discuss?
15:33:16 <dmsimard> I can drop a small fyi
15:33:48 <rdogerrit> Javier Peña proposed DLRN: Add unit tests for dlrn/shell.py  https://review.rdoproject.org/r/5492
15:34:02 <dmsimard> There will soon be a centralized instance of ARA (starting with a POC that will contain only review.rdoproject.org jobs)
15:34:49 <dmsimard> So a bit like how http://status.openstack.org/openstack-health/#/ aggregates results from jobs, there will be an aggregation for ara as well
15:35:22 <amoralej> that's nice dmsimard, is there any plan to have it for jobs in ci.centos.org also?
15:36:02 <dmsimard> amoralej: yeah, the more things we aggregate the better it will be I think
15:36:49 <dmsimard> The new UI is almost good to go (WIP here http://46.231.133.111/reports/index.html ) and is the last thing I want before cutting the release that will contain the necessary wsgi bits for better centralized deployment
15:36:53 <weshay> dmsimard, cool
15:37:53 <trown> neat
15:38:27 <myoung> dmsimard: please add me to any updates re: ara aggregation, I would like to do something similar for rdophase2 jobs that are currently generating ara reports
15:39:01 <dmsimard> myoung: sure thing, there is someone working on an ansible role to deploy ara with wsgi backend :)
15:39:57 <dmsimard> I don't have anything else
15:40:02 <myoung> dmsimard: we are currently also publishing all the rdophase2 artifacts (including ara reports) to thirdparty logs server
15:40:18 <myoung> dmsimard: if your existing work can just scrape from there, #win
15:40:51 <dmsimard> myoung: more or less, it'll be centralized through wsgi/mysql but you'll keep the ability to generate static reports for a single playbook for standalone viewing
15:43:28 <amoralej> more topics?
15:44:49 <rbowen> Nope
15:44:57 <amoralej> #topic chair for next meeting
15:45:05 <amoralej> volunteers?
15:45:28 <chandankumar> amoralej: i can do
15:45:48 <amoralej> #info chandankumar will chair next meeting
15:46:13 <amoralej> i'm giving you some minutes back :)
15:46:19 <amoralej> thanks for joining
15:46:35 <amoralej> #endmeeting