15:01:03 <chandankumar> #startmeeting RDO meeting - 2017-06-21
15:01:03 <zodbot> Meeting started Wed Jun 21 15:01:03 2017 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:03 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-06-21'
15:01:04 <openstack> Meeting started Wed Jun 21 15:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <openstack> The meeting name has been set to 'rdo_meeting___2017_06_21'
15:01:12 <rdobot> [sensu] NEW: master.monitoring.rdoproject.org - check-delorean-master-current @ http://tinyurl.com/zqowcwb |#| Build failure on centos7-master/current: vitrage: http://trunk.rdoproject.org/centos7-master/report.html
15:01:25 <chandankumar> number80: jpena amoralej jruzicka dmsimard meeting time
15:01:30 <jpena> o/
15:01:35 <fultonj> o/
15:01:47 <chandankumar> #chair jpena fultonj
15:01:47 <zodbot> Current chairs: chandankumar fultonj jpena
15:01:47 <openstack> Current chairs: chandankumar fultonj jpena
15:01:48 <ykarel> O/
15:01:52 <amoralej> o/
15:02:01 <chandankumar> #chair ykarel amoralej
15:02:01 <zodbot> Current chairs: amoralej chandankumar fultonj jpena ykarel
15:02:02 <openstack> Current chairs: amoralej chandankumar fultonj jpena ykarel
15:02:29 <chandankumar> If you have missed to add today's meeting agenda add here: https://etherpad.openstack.org/p/RDO-Meeting
15:03:06 <jistr> jschlueter: yea when a gate fails, it actually needs to do the CI loop again twice -- once for check, and then it goes to gate again
15:03:19 <dmsimard> \o
15:03:26 <chandankumar> #chair dmsimard
15:03:26 <zodbot> Current chairs: amoralej chandankumar dmsimard fultonj jpena ykarel
15:03:27 <openstack> Current chairs: amoralej chandankumar dmsimard fultonj jpena ykarel
15:03:42 <chandankumar> jschlueter: EmilienM trown rdo meeting time
15:04:06 <EmilienM> I'm here ;-)
15:04:12 <chandankumar> #chair EmilienM
15:04:12 <zodbot> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena ykarel
15:04:13 <openstack> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena ykarel
15:04:27 <number80> o/
15:04:29 <jruzicka> o/
15:04:33 <chandankumar> #chair number80 jruzicka
15:04:33 <zodbot> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 ykarel
15:04:34 <openstack> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 ykarel
15:04:58 <chandankumar> so starting with the first topic
15:05:06 <chandankumar> #topic  tripleo-common adding a dependency from a package in the Ceph SIG repo
15:05:11 <chandankumar> dmsimard: all yours.
15:05:23 <dmsimard> fultonj: ^
15:05:36 <dmsimard> so context is https://www.redhat.com/archives/rdo-list/2017-June/msg00050.html
15:05:54 <fultonj> ack
15:06:08 <dmsimard> To draw a parallel, we currently bundle the virt sig repo as part of both rdo-release and centos-release-openstack-*
15:06:27 <dmsimard> because we have a spec requirement from nova on qemu-kvm >=2.3
15:07:08 <dmsimard> in hindsight, people that deploy other hypervisors (xen/xenserver/vmware/etc) end up installing qemu-kvm anyway because of that requirement and that's probably not okay
15:07:15 <trown> o/
15:07:29 <chandankumar> #chair trown
15:07:29 <zodbot> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 trown ykarel
15:07:29 <openstack> Current chairs: EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 trown ykarel
15:07:40 <dmsimard> now, we have tripleo-common that wants to depend on a package from the ceph storage SIG repo, ceph-ansible, so that when you install tripleo-common, ceph-ansible is installed
15:08:18 <fultonj> so basically, i wanted to get a few playbooks in /usr/share/ceph-ansbile and don't care how they get there
15:08:25 <fultonj> on the undercloud
15:08:38 <fultonj> the rpm that provides them is in the centos-sig
15:09:00 <fultonj> which brought in the dependency idea to solve it
15:09:08 <amoralej> maybe the package could be installed by undercloud installation process instead of being a dependency for tripleo-common?
15:09:26 <amoralej> depending on your undercloud configuration options
15:09:35 <jpena> would it be possible to cross-tag the package for rdo, or does it bring more dependencies from the sig repo?
15:09:53 <dmsimard> gfidente: where is the spec file for ceph-ansible ?
15:10:15 <dmsimard> jpena: I know it depends on ansible but don't know what else
15:10:17 <fultonj> amoralej: https://review.rdoproject.org/r/#/c/6809
15:10:33 <fultonj> amoralej: wrong url
15:10:39 <fultonj> https://review.openstack.org/#/c/469644/14//COMMIT_MSG@16
15:10:57 <fultonj> ^ if it won't get into RDO i was thinking users/ci could install it separately
15:11:04 <fultonj> and see if i could add a quickstart option
15:12:24 <fultonj> there are deps of ansible and other pkgs for ceph-ansible
15:12:30 <fultonj> getting pkg list
15:12:38 <trown> why cant we just install the package at run time via tripleo-common when it is needed?
15:12:41 <trown> missing that part
15:13:10 <dmsimard> trown: via tripleo-common, what do you mean ?
15:14:10 <amoralej> i'd say this discussion is similar to the one that we had in https://review.rdoproject.org/r/#/c/6957/
15:14:18 <amoralej> what should be package requires
15:14:31 <amoralej> vs being installed as part of undercloud installation logic
15:14:55 <fultonj> trown: do you mean the mistral workflow which runs the playbook could install the playbook on the undercloud ?
15:14:56 <amoralej> when doing a "openstack undercloud deploy"
15:15:18 <amoralej> fultonj, i'd say not when running the workflow
15:15:24 <fultonj> so far the workflow has been careful not to modify the undercloud much; e.g. creating tmp inventory
15:15:30 <amoralej> but when installing deploying the undercloud
15:15:31 <fultonj> tmp files etc
15:15:36 <fultonj> amoralej: yes, i agree
15:16:00 <fultonj> https://cbs.centos.org/repos/storage7-ceph-jewel-candidate/
15:16:01 <amoralej> i.e. if there is a option "i_want_to_manage_ceph: true" in undercloud.conf file
15:16:05 <fultonj> https://cbs.centos.org/repos/storage7-ceph-common-candidate/
15:16:05 <amoralej> :)
15:16:44 <fultonj> i enabled the two repos above before I 'yum install ceph-ansible'
15:17:44 <amoralej> it only depends on ansible
15:18:23 <amoralej> http://paste.openstack.org/show/613306/
15:18:58 <fultonj> jschlueter: had made a subpkg
15:19:44 <fultonj> https://review.rdoproject.org/r/#/c/6809
15:20:24 <jschlueter> that was an initial idea for how to gate the ceph-ansible dependency
15:21:20 <fultonj> does anyone who normally reviews for tripleo-common think this plan is OK?
15:21:26 <fultonj> https://review.openstack.org/#/c/469644/14//COMMIT_MSG@16
15:22:38 <fultonj> basically: user installs the package if they want to manage ceph (if we're not going to add the dependecny to tripleo)
15:23:05 <fultonj> sorry, if we're not going to add the dependecny to _rdo_
15:23:17 <dmsimard> fultonj: I think installing things only when they're required is a sensible approach
15:23:27 <dmsimard> fultonj: regardless of context
15:23:28 <chandankumar> dmsimard: +1
15:24:32 <fultonj> dmsimard: any recomendations on how they get installed in the big picture for this?
15:24:50 <Duck> sorry I'm late
15:25:01 <fultonj> not so much "with yum" but a recomendation on how to solve the problem
15:25:13 <dmsimard> fultonj: I lack some knowledge around tripleo but I'm sure we can get help figuring it out
15:25:22 <chandankumar> #chair Duck
15:25:22 <zodbot> Current chairs: Duck EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 trown ykarel
15:25:24 <openstack> Current chairs: Duck EmilienM amoralej chandankumar dmsimard fultonj jpena jruzicka number80 trown ykarel
15:27:01 <dmsimard> fultonj: apevec mentioned the best we could do would be to add the repository to rdo-release but to keep it disabled -- so in the end it wouldn't change the fact that you need to do *something* to enable it
15:27:22 <dmsimard> let's try and figure out what that *something* is
15:27:26 <number80> yum-config-manager
15:27:44 <dmsimard> number80: well, of course, but what that translates to in the context of tripleo and where it needs to be done
15:27:50 <fultonj> dmsimard: yeah, that's where i'm going at this point
15:28:17 <dmsimard> we have other topics to cover for the meeting, I think we've mostly agreed on course of action so let's move on unless there's anything else to add
15:28:47 <chandankumar> dmsimard: any action item for the same?
15:29:19 <dmsimard> would need someone to help fultonj figure out how to make this happen in tripleo
15:29:28 <fultonj> yes please
15:29:47 <amoralej> fultonj, dmsimard, shouldn't repo being configured and package installed somewhere in https://github.com/openstack/instack-undercloud?
15:29:48 <chandankumar> i think trown will be the best person for the same.
15:29:57 <fultonj> trown: EmilienM ?
15:30:11 <trown> ya instack-undercloud seems correct
15:32:09 <fultonj> trown: may i ping you later regarding this?
15:32:23 <amoralej> fultonj, this is an element enabling CR repo in centos, i.e. https://github.com/openstack/instack-undercloud/blob/master/elements/centos-cr/pre-install.d/00-enable-cr-repo
15:33:14 <fultonj> ok, thanks
15:33:47 <fultonj> is it not appropriate to ask the user to install it?
15:34:07 <fultonj> (perhaps we're out of time)
15:34:11 <chandankumar> dmsimard: will i move to next topic?
15:34:12 <amoralej> asking users doing things is error prone
15:35:58 * chandankumar waits.
15:36:32 <amoralej> chandankumar, let's go for next topic!
15:36:35 <amoralej> :)
15:36:42 <chandankumar> #topic Package naming convention for RDO packages
15:37:51 <chandankumar> Last week while fixing tempest plugin packages issues, i found that it would be good if we have rdo packaging naming convention somewhere so that people can create the required subpackage or later on add the subpackage to the existing one
15:37:56 <dmsimard> amoralej: sorry there's folks destroying parts of my basement right now :P
15:38:04 <chandankumar> for that i have created an etherpad
15:38:12 <chandankumar> #link https://review.rdoproject.org/etherpad/p/rdo_packages_naming
15:38:17 <amoralej> dmsimard, oh, sorry
15:38:49 <chandankumar> Feel free to dump your ideas to the etherpad so that we can publish it on RDO packaging docs
15:39:09 <chandankumar> number80: jruzicka jpena amoralej any views on that?
15:39:48 <jpena> chandankumar: that deserves a page somewhere in the rdo documentation
15:39:49 <jruzicka> any standard is better then no standard :)
15:40:04 <jpena> so let's discuss in the etherpad, then publish it
15:40:07 <jruzicka> consistence makes automation easy
15:40:12 <jruzicka> so yes, we want that
15:40:39 <chandankumar> jpena: yes , once done, i will add it there.
15:41:14 <jruzicka> chandankumar++
15:41:14 <zodbot> jruzicka: Karma for chandankumar changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:41:21 <chandankumar> if you think any more subpackages needs to be added feel free to add it that doc
15:41:49 <chandankumar> jschlueter: https://review.rdoproject.org/etherpad/p/rdo_packages_naming we need your input also on that
15:41:55 <chandankumar> i mean everybody
15:42:10 <number80> Yeah
15:42:31 <jruzicka> going through existing packages in rdoinfo in search of irregularities might also be in order
15:42:46 <amoralej> chandankumar, the only problem i see is what hapens if tempest plugin has a module name different that <service>-tests-tempest
15:42:54 <amoralej> as we had for patrole
15:43:04 <jschlueter> chandankumar: will look
15:43:12 <chandankumar> amoralej: more coming soon
15:43:17 <jruzicka> furthermore, I was thinking about having some page for irregular packages...
15:43:31 <chandankumar> amoralej: one more spec related to ha testing might be a seperate project
15:43:51 <amoralej> as fedora guidelines say says "The package name should reflect the upstream name of the Python module"
15:43:53 <chandankumar> amoralej: and there will be some corner cases
15:44:07 <jruzicka> like a public shaming to enforce consistency :D
15:44:35 <amoralej> in fact i'd say we have some irregularities for networking packages also, but they are more consistent upstream, i think
15:45:02 <jschlueter> encouragement to sperate unittest from tempest tests subpackage would be nice
15:46:19 <chandankumar> what about dropping an email to rdo-list for more inputing on RDO naming conventions?
15:46:44 <jpena> +1 to that
15:46:53 <amoralej> +1
15:47:15 <chandankumar> #action chandankumar to drop an email for inputs on RDO packages naming conventions
15:47:32 <amoralej> other point is that, when we decided to separte tempest from unit tests, agreement was to use -tests-tempest and -tests-unit
15:47:58 <chandankumar> amoralej: ah i forgot completely about that
15:48:10 <chandankumar> amoralej: time to enforce the rule for new packages reviews
15:48:13 <amoralej> i'm looking for the bz where we disucssed that
15:49:32 <chandankumar> that's it from myside.
15:49:53 <chandankumar> amoralej: will i move to next topic?
15:50:19 <amoralej> ok
15:50:27 <chandankumar> #topic RDO Cloud scheduled maintenance on June 22, 1:00 UTC (1 hour)
15:50:37 <chandankumar> dmsimard: i think it is your's topic?
15:50:38 <jpena> so just a heads up
15:50:41 <jpena> that's mine
15:50:55 <dmsimard> in reality this also affects OS1
15:50:57 <jpena> I first thought the maintenance would happen on July 22, but no, it's tonight
15:51:13 <dmsimard> so servers on OS1 will also be impacted
15:51:22 <dmsimard> trown, adarazs ^ I think thirdparty logs and images is on os1
15:51:29 <rdobot> [sensu] NEW: master.monitoring.rdoproject.org - check-delorean-master-head-current @ http://tinyurl.com/hcnq3ll |#| Build failure on centos7-master-head/current: gnocchi, python-openstackclient, python-pankoclient, oslo.config, rally, networking-bagpipe: http://trunk.rdoproject.org/centos7-master-head/report.html
15:51:33 <jpena> it's expected to last for 1 hour, and VMs will be down. That means www, CI will be impacted
15:51:40 <chandankumar> jpena: do we have mail out regarding outage on RDO list?
15:51:46 <jpena> also the master-head dlrn builder, but that's not a big deal
15:51:59 <jpena> chandankumar: I think we didn't, let's send it
15:52:16 <chandankumar> #action jpena to send outage mail to rdo list
15:52:27 <chandankumar> #info RDO Cloud scheduled maintenance on June 22, 1:00 UTC (1 hour)
15:52:52 <chandankumar> jpena: Thanks :-)
15:54:43 <chandankumar> jpena: will i move to next topic?
15:54:48 <jpena> sure
15:54:59 <chandankumar> #topic chair for next meeting
15:55:10 <chandankumar> Anyone willing to volunteer for next meeting?
15:55:12 <chandankumar> ykarel: ?
15:55:24 <ykarel> chandankumar, Ok
15:55:31 <chandankumar> ykarel: Thanks :-)
15:55:38 <dmsimard> adarazs, amoralej: container build job is going to time out again.. will investigate
15:55:44 <chandankumar> #action ykarel to chair for next meeting.
15:55:51 <chandankumar> moving to open floor now
15:55:57 <chandankumar> #topic open floor
15:56:09 <chandankumar> we still have 5 mins,
15:56:24 <jpena> I think it's chandankumar's birthday today, so time to sing :)
15:56:52 <chandankumar> If you have any package review or patch review pending or needs to attension feel to bring it up right now
15:56:58 <chandankumar> jpena: Thanks :-)
15:59:45 <chandankumar> last one min left, if no other topic can we end it?
16:00:26 <chandankumar> times up!
16:00:30 <chandankumar> #endmeeting