15:02:57 <amoralej> #startmeeting RDO meeting - 2017-07-19
15:02:57 <zodbot> Meeting started Wed Jul 19 15:02:57 2017 UTC.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:57 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-07-19'
15:02:58 <openstack> Meeting started Wed Jul 19 15:02:57 2017 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:01 <openstack> The meeting name has been set to 'rdo_meeting___2017_07_19'
15:03:08 <amoralej> #topic roll call
15:03:15 <rbowen> o/
15:03:19 <jruzicka> o/
15:03:21 <number80> o/
15:03:24 <PagliaccisCloud> o/
15:03:40 <dmsimard> \o
15:03:43 <trown> o/
15:03:52 <amoralej> #chair rbowen jruzicka number80 PagliaccisCloud dmsimard trown
15:03:52 <zodbot> Current chairs: PagliaccisCloud amoralej dmsimard jruzicka number80 rbowen trown
15:03:53 <openstack> Current chairs: PagliaccisCloud amoralej dmsimard jruzicka number80 rbowen trown
15:04:59 <amoralej> ok, let's start with the first topic
15:05:05 <dmsimard> amoralej, apevec, adarazs: btw before I forget, I likely fixed the image upload issue. Bad ownership/group after rsync from the original server.
15:05:14 <chandankumar> \o/
15:05:32 <amoralej> dmsimard, i changed ownership also, but still failed with a different error
15:05:40 <amoralej> #topic Hosting office hour this week or next week for creating more easy fix. [Chandan Kumar]
15:05:45 <amoralej> chandankumar, that's yours
15:06:05 <dmsimard> amoralej: ok I'll look
15:06:16 <chandankumar> We have started creating easyfixes to onboard more RDO contributor
15:06:28 <chandankumar> each issue has a list of projects which needs to be fix
15:06:51 <chandankumar> but people are coming and started fixing all the projects associated wiht it
15:07:08 <chandankumar> and we run out of issues
15:07:28 <apevec> and that's a good thing :)
15:07:39 <jschlueter> o/
15:07:42 <chandankumar> we need to add more easy fix issues or we need to define next step after fixing one pathc
15:07:44 <chandankumar> *patch
15:07:49 <amoralej> yeah, we only need to be faster creating issues that they fixing it :)
15:08:00 <chandankumar> for creating easy fixes more we need calloboration
15:08:02 <amoralej> #chair chandankumar jschlueter
15:08:02 <zodbot> Current chairs: PagliaccisCloud amoralej chandankumar dmsimard jruzicka jschlueter number80 rbowen trown
15:08:05 <openstack> Current chairs: PagliaccisCloud amoralej chandankumar dmsimard jruzicka jschlueter number80 rbowen trown
15:08:19 <chandankumar> So i was thinking of having an office hours for a day
15:08:26 <chandankumar> to create more issues
15:08:26 <dmsimard> chandankumar: yeah I like where this is going, good job with the initiative
15:08:41 <rbowen> I'm thrilled to see people taking us up on the easyfix initiative. chandankumar++
15:08:41 <zodbot> rbowen: Karma for chandankumar changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:08:59 <jruzicka> I thought our job was to increase the number of issues to 0 :)
15:09:14 <apevec> chandankumar, gamify! after getting n XPs in easyfixes, get on the next level, notsoeasyfix !
15:09:31 <PagliaccisCloud> i saw an easyfix for docs this morning - more of those would be awesome
15:09:46 <PagliaccisCloud> it would help target focus for gaps in documentation
15:09:59 <rbowen> Many of the things in the docs ticket queue would be appropriate to copy over to easyfix
15:10:01 <jruzicka> isthereevenafix
15:10:27 <rbowen> https://github.com/redhat-openstack/website/issues
15:10:33 <snecklifter> icantbelieveitsnotfixed
15:10:46 <jruzicka> :D
15:11:00 <PagliaccisCloud> oh dear Jesus ;_;
15:11:49 <jruzicka> I'll tag easyfix and notsoeasyfix rdopkg issues on next bug triage after release
15:11:49 <chandankumar> so what is the next step from here?
15:12:27 <rbowen> If we have something like what jruzicka is suggesting, we need to be sure to check these other queues periodically, and point to those issues from the easyfix queue.
15:12:39 <rbowen> As well as ensuring that once they're resolved one place, we also close it the other place.
15:13:57 <rbowen> When are you thinking of doing the "office hours"?
15:14:18 <rbowen> Also, that can be both for looking for new issues, but also for helping people with their first patches.
15:14:46 <rdogerrit> David Moreau Simard created openstack/watcher-distgit rpm-master: Add runtime requires on python-croniter  https://review.rdoproject.org/r/7745
15:14:56 <chandankumar> rbowen: may be this week or next week before any day?
15:15:54 <rbowen> Pick a time, and we can start promoting it. Definitely a good thing to do.
15:16:18 <chandankumar> Next week tuesday 25th July, 17
15:16:23 <chandankumar> if it is ok?
15:16:33 <number80> i'd say the week after that, so we can promote it widely
15:16:43 <number80> 1 week is a bit short
15:16:54 <rbowen> Next week is fine, but as number80 says we'll have poor turnout the first time.
15:17:21 * number80 is +0 on next week, so up to everyone else :)
15:18:27 <chandankumar> number80: let's keep it for a month every week each tuesday for few hours (when everybody is available)
15:19:02 <number80> chandankumar: ok, do you have RDO calendar access?
15:19:03 <jruzicka> easyfix tuesday? :)
15:19:14 <chandankumar> number80: nope
15:19:16 <number80> You should add it so it sends automatic reminders
15:19:30 <number80> #action number80 gives access to RDO calendar to chandankumar
15:19:39 <rbowen> Tuesday ... like all day? Or a particular time?
15:19:47 <chandankumar> i will drop a mail email about the same
15:20:21 <chandankumar> rbowen: all day does not looks good, pick a time, might 5:00 P.M(IST)
15:20:35 <chandankumar> i hope this time everybody is available
15:20:53 <chandankumar> for one or two hours
15:21:28 <chandankumar> number80: rbowen ^^
15:21:31 <rbowen> +1
15:21:54 <apevec> what time is that in UTC?
15:21:57 <jruzicka> UTC plz
15:22:15 <number80> chandankumar: let's try that and we'll revisit later, we may want to change the slots depending the people
15:22:19 <chandankumar> 11:30 AM
15:22:27 <chandankumar> UTC
15:22:27 <number80> (who are participating
15:22:51 <amoralej> maybe alternating time zones
15:23:05 <apevec> yeah, we'll need two slots
15:23:15 <number80> (to convert time to UTC) TZ=UTC date -d "5PM IST"
15:23:38 <apevec> to cover NA
15:23:52 <amoralej> i think twice per month, each in a different TZ would be good
15:24:13 <chandankumar> amoralej: +1
15:25:06 <number80> This one should work for both CET and EDT, so let's agree for that timeslot for the first session
15:25:15 <chandankumar> so we time for second slot.
15:25:36 <amoralej> i think the time that chandankumar is good for the first session
15:25:46 <chandankumar> so for first slot is 11:30 A.M. (UTC) ok?
15:26:06 <amoralej> +1
15:26:07 <number80> chandankumar: I'd request on announce mail that we'd like to hear feedback from people who couldn't attend to provide what time would work for them so we can plan the next session
15:26:18 * chandankumar is alive till 12:00 A.M. (IST),after that status==404
15:26:31 <chandankumar> number80: good idea
15:26:49 <amoralej> who will send the mail, chandankumar? rbowen?
15:26:50 <number80> Yep, we'll look at how we will cover if it doesn't work for you
15:27:16 * rbowen nominates chandankumar.
15:27:23 * chandankumar hides.
15:27:27 <amoralej> #action chandankumar to send a mail announcing first easyfix office hours session
15:27:33 <amoralej> chandankumar, it's yours :)
15:27:51 <chandankumar> amoralej: no problem i will do that
15:27:58 <amoralej> ok, next topic?
15:28:23 <chandankumar> so we have office hours for coming next tuesday to create more easy fixes
15:28:47 <chandankumar> *from
15:28:52 <number80> Yep
15:29:04 <chandankumar> Any queries related to easyfix or office hours?
15:29:13 <amoralej> #agreed to have office hours for coming next tuesday to create more easy fixes
15:29:40 <rbowen> next
15:30:13 <amoralej> #topic broken update CI: to ninja or to not ninja
15:30:37 <amoralej> #info p-o-i newton jobs are broken. Fix is https://review.openstack.org/#/q/I85510dda99e600226f78f8cbc1361e099b68a7c9,n,z
15:30:52 <amoralej> number80, you added this?
15:30:59 <number80> Yep
15:31:18 <dmsimard> define ninja
15:31:19 <amoralej> it seems zuul is kind of queueing jobs...
15:31:22 <number80> you suggested that we might ninja-merge them or not
15:31:26 <number80> just to discuss it
15:31:36 <number80> dmsimard: here newton jobs are broken, not the updates
15:31:49 <dmsimard> amoralej: I'll look, maybe zuul-merger bomb
15:32:00 <dmsimard> number80: what newton jobs ?
15:32:02 <amoralej> #info pending reviews https://review.rdoproject.org/r/#/c/7717/
15:32:02 <number80> so should we wait the fixed to be merged?
15:32:07 <amoralej> dmsimard, i mean upstream zuul
15:32:09 <dmsimard> number80: gate? promotion? review.rdo?
15:32:10 <dmsimard> amoralej: oh
15:32:21 <amoralej> jobs are queued >20h
15:32:23 <number80> Yeah, what amoralej said :)
15:33:09 <amoralej> number80, i think it's ok to merge it and manually tag it for those two
15:33:13 <amoralej> reviews
15:33:13 <dmsimard> Well we can't ninja merge upstream anyway
15:33:28 <dmsimard> as in, bypass the gate
15:33:40 <dmsimard> I just asked about the queues to infra
15:33:43 <number80> well one of them is blocking rpm-packaging upstream, so that's why I raised it
15:34:03 <amoralej> yeah, it's just net new packages in deps, right?
15:34:41 <morsik> Hi, where can I request for patch specific component? Actually it's Nova and it was patched by upstream in Ocata, but not in Newton: https://review.openstack.org/#/c/468147/
15:35:12 <amoralej> changes look ok from repoclosure side and only p-o-i newton is failing
15:35:19 <amoralej> number80, you have my +1 :)
15:35:22 <dmsimard> morsik: we're in meeting right now, feel free to join in and we'll get back to you in a bit
15:35:26 <number80> yes
15:35:54 <number80> #action (*) merge new deps updates pending for -testing
15:36:06 <number80> should be good
15:36:25 <rdogerrit> Merged openstack/watcher-distgit rpm-master: Add runtime requires on python-croniter  https://review.rdoproject.org/r/7745
15:36:25 <rdogerrit> Merged openstack/ovsdbapp-distgit rpm-master: Sync requirements  https://review.rdoproject.org/r/7654
15:36:49 <apevec> be care ful even w/ net new deps, they might introduce provides
15:36:57 <apevec> which then break old stuff
15:37:00 <apevec> but +1 in this case
15:37:36 <apevec> repoclosure is good sanity check
15:38:55 <amoralej> #topic chair for next meeting
15:38:58 <amoralej> volunteers?
15:40:04 <amoralej> don't be shy :)
15:40:13 <number80> I'll take it
15:40:26 <number80> #action number80 chair Jul, 26 meeting
15:40:36 <amoralej> thx number80
15:40:41 <amoralej> #topic open floor
15:40:58 <amoralej> any other topic you want to discuss?
15:41:23 <rbowen> If anyone is planning to attend any of the upcoming OpenStack days:
15:41:24 <rbowen> https://www.openstack.org/community/events/openstackdays#tab=events_tab
15:41:32 <rbowen> Please let me know, so I can send RDO stickers along with you. :-)
15:41:55 <snecklifter> rbowen: I am speaking at the UK one
15:41:59 <rbowen> Benelux, UK, and Italy, in September.
15:42:18 <rbowen> snecklifter: awesome. I'll send you some. Get me a mailing address when you get a chance.
15:42:26 <snecklifter> rbowen: ok
15:43:01 <chandankumar> https://review.rdoproject.org/r/#/q/owner:tribecca%2540tribecc.us+status:open  easyfix reviews
15:43:37 <chandankumar> https://review.rdoproject.org/r/#/q/owner:%22Ricardo+Arguello%22+status:open
15:43:55 <chandankumar> Feel free to take a look at it
15:45:26 <rdogerrit> Alfredo Moralejo proposed openstack/neutron-distgit rpm-master: Move package description to global variable and replace with it.  https://review.rdoproject.org/r/7735
15:46:18 <PagliaccisCloud> something is broken in my keystoneclient update. i'm still trying to figure it out
15:46:28 <amoralej> ok, if there is nothing else, i'll close the meeting
15:46:36 <amoralej> and give you some time back
15:46:38 <dmsimard> morsik: to get back to you
15:46:46 <amoralej> #endmeeting