15:01:26 <chandankumar> #startmeeting RDO meeting - 2017-08-02
15:01:26 <zodbot> Meeting started Wed Aug  2 15:01:26 2017 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:26 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-08-02'
15:01:27 <openstack> Meeting started Wed Aug  2 15:01:26 2017 UTC and is due to finish in 60 minutes.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:30 <openstack> The meeting name has been set to 'rdo_meeting___2017_08_02'
15:01:56 <chandankumar> Feel free to add today's meeting agenda here https://etherpad.openstack.org/p/RDO-Meeting
15:02:07 <chandankumar> #topic Roll Call
15:02:10 <chandankumar> \o/
15:02:12 <jpena> o/
15:02:14 <number80> o/
15:02:21 <ykarel> o/
15:02:24 <rbowen> o/
15:02:32 <chandankumar> #chair jpena number80 ykarel rbowen
15:02:32 <zodbot> Current chairs: chandankumar jpena number80 rbowen ykarel
15:02:33 <openstack> Current chairs: chandankumar jpena number80 rbowen ykarel
15:03:20 <rdogerrit> Merged rdoinfo master: Promote CBS tags update for newton-release  https://review.rdoproject.org/r/8068
15:03:26 <chandankumar> amoralej: jruzicka meeting time
15:03:34 <amoralej> o/
15:03:41 <jruzicka> \o/
15:03:41 <chandankumar> #chair amoralej
15:03:41 <zodbot> Current chairs: amoralej chandankumar jpena number80 rbowen ykarel
15:03:42 <openstack> Current chairs: amoralej chandankumar jpena number80 rbowen ykarel
15:03:47 <rdogerrit> Alfredo Moralejo created config master: Install rdopkg from pip  https://review.rdoproject.org/r/8083
15:03:49 <chandankumar> #chair jruzicka
15:03:49 <zodbot> Current chairs: amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:03:49 <openstack> Current chairs: amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:03:53 * Duck o/
15:04:00 <chandankumar> #chair Duck
15:04:00 <zodbot> Current chairs: Duck amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:04:02 <openstack> Current chairs: Duck amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:04:51 <chandankumar> so starting with the first topic
15:04:56 <chandankumar> #topic RDO cross-training
15:05:03 <chandankumar> number80: please go ahead.
15:05:54 <number80> Ok, since some people expressed their wish to learn about our processes and infra, I suggest that we hold presentation or Q/A sessions
15:06:28 <number80> so if you want to request topics or do presentations, please add your name on the list
15:07:05 <number80> Goal is to enable more people helping
15:07:19 <rbowen> If we do any kind of presentations, it would be nice to capture them in video, so that they are reusable. I've been wanting to start the old hangout series back up again, but other things keep getting in the way ...
15:07:37 <jruzicka> rather then presentations I'd have that documented in some always available format
15:07:43 <number80> rbowen: that's the plan if presenters agree
15:07:56 <number80> jruzicka: they are complementary
15:08:12 <jruzicka> number80, the closer the better ;)
15:08:33 <jruzicka> as opposed to having separate docs and presenations, each out of sync in a different way :)
15:08:34 <rbowen> Indeed. 5 lines of text always trumps 5 minutes of video, but video is also valuable.
15:08:59 <number80> It's more having interactive sessions, no 1 hour long talk :)
15:09:23 <jruzicka> interactive sessions on top of good documentation sounds good ;)
15:09:32 <number80> #action see with Rich how to plan/schedule those
15:09:42 <rbowen> Excellent.
15:09:43 <number80> jruzicka: sure ;)
15:10:16 * number80 expects to see stuff on nodepool/zuul and stop doing changes without fully understanding them :)
15:10:24 <number80> pabelanger: ^
15:10:31 <jruzicka> right :D
15:10:50 <jruzicka> daily reverse engineering ;)
15:10:52 <number80> EOF from me
15:12:07 <Duck> number80: +1
15:12:12 <chandankumar> number80: thanks :-)
15:13:13 <chandankumar> Any queries related to above topic, if no then i can move ahead
15:14:02 <chandankumar> moving to next topic
15:14:08 <chandankumar> #topic rdopkg 0.44 ChangeBlog
15:14:10 <jruzicka> #link https://www.rdoproject.org/blog/2017/08/rdopkg-0.44-changeblog/
15:14:22 <jruzicka> just to raise visibility
15:14:22 <chandankumar> jruzicka: you are so fast :-)
15:14:32 <jruzicka> it is a human readable summary of changes in latest rdopkg version
15:14:45 <jruzicka> chandankumar, my #1 rule is never to block others ;)
15:15:35 <jruzicka> #info 41 commits from 7 contributors were merged over the course of 4 months since last release with average time to land of 6 days.
15:15:58 <chandankumar> awesome
15:16:21 <jruzicka> amoralej, ssbarnea, jpena, number80: thanks for making rdopkg suck less ;)
15:16:43 <amoralej> jruzicka, happy to help and make rdopkg even greater!
15:16:47 <jpena> jruzicka: I've just seen an issue with relative paths (see https://github.com/softwarefactory-project/DLRN/commit/a9c99271ba47efd2f55a7da9e2b7509f65516ad5). Is it fixed?
15:16:56 <jruzicka> It is an experimental format to make it human readable but still link to code if you're interested.
15:17:05 <jruzicka> jpena, amoralej fixed it in 0.44.2
15:17:11 <jpena> ah ok
15:17:15 <jruzicka> jpena, I hope... link me the error after meeting
15:17:32 <panda> dmsimard: 15:16:53 ERROR! Invalid callback for stdout specified: devstack whan I try to launch kolla build role
15:17:50 <jruzicka> jpena, https://github.com/softwarefactory-project/rdopkg/commit/c66d154
15:18:07 <panda> dmsimard: do I have to add something else in ENV before launching ?
15:18:18 <number80> jruzicka: ;-)
15:18:28 <jruzicka> you can look forward for nice things in next releases such as automated release, DLRN integration and Fedora packages
15:18:29 <jpena> jruzicka: nice, I'll give it a shot
15:18:32 <number80> panda: please wait we finish the meeting, it shouldn't be long
15:18:39 <panda> oh, sorry.
15:18:48 <jruzicka> jpena, that's included in 0.44.2 but regression is also possible.
15:18:51 <number80> nw
15:19:08 <jruzicka> and that's all for this topic from me
15:19:12 <PagliaccisCloud> o/ i'm late!
15:19:18 <number80> #chair PagliaccisCloud
15:19:18 <zodbot> Current chairs: Duck PagliaccisCloud amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:19:19 <openstack> Current chairs: Duck PagliaccisCloud amoralej chandankumar jpena jruzicka number80 rbowen ykarel
15:19:35 <number80> let's move to the next topic
15:19:36 <chandankumar> jruzicka: thanks for the updates :-)
15:19:40 <amoralej> i think we can unpin https://softwarefactory-project.io/r/#/c/9096/ btw
15:20:01 <jruzicka> jpena, oh right this :) https://softwarefactory-project.io/r/#/c/9096/
15:20:05 <openstackgerrit> Merged openstack/packstack stable/ocata: Bump required version of pyOpenSSL  https://review.openstack.org/486581
15:21:08 <rbowen> chandankumar: Are we moving on?
15:21:14 <chandankumar> rbowen: yup
15:21:28 <rbowen> #topic Test day delayed
15:21:28 <rbowen> No promotion for 11 days - https://dashboards.rdoproject.org/rdo-dev - so test day will be *next* Thursday/Friday, assuming we have a promotion before then.
15:21:30 <chandankumar> next is lots of announcements
15:21:49 <rbowen> I will be out all next week, so if we end up delaying again, I'll need someone to take care of communicating the change.
15:22:21 <rbowen> I'm in the process of updating the various places that reference the test day.
15:22:26 <number80> rbowen: I'll do if it happens
15:23:45 <chandankumar> rbowen: next topic is also yours i think
15:23:54 <rbowen> Ah yes
15:23:59 <rbowen> #topic lists.rdoproject.org
15:24:05 <rbowen> Duck is making lots of progress on this.
15:24:13 <rbowen> Looks like a lot of the archives have been imported.
15:24:20 <rbowen> What we still need to do is:
15:24:27 <rbowen> * Ensure that subscriber lists are copied over
15:24:34 <rbowen> * Ensure that people know where to post messages
15:24:35 <rdogerrit> Sven Anderson created config master: Add Sven Anderson as core for ec2-api package  https://review.rdoproject.org/r/8084
15:24:47 <ansiwen> number80: ^^^
15:24:50 <rbowen> * Put some kind of autoresponder on the old lists that points to the new ones.
15:25:10 <rbowen> * Not do any of that the day before I go on a week of vacation! :-D
15:25:12 <Duck> rbowen: you mised some important side-note
15:25:26 <rbowen> And here's Duck to fill in the technical details. :-)
15:25:41 <Duck> upstream said their official migration script fetching archives from an URL is CRAP
15:25:45 <Duck> https://gitlab.com/mailman/hyperkitty/issues/148#note_36562529
15:26:04 <rbowen> So we need direct access to the mbox archives, yes?
15:26:12 <sfbender> Merged DLRN master: [Doc] Install openssl-devel, libffi-devel  https://softwarefactory-project.io/r/8952
15:26:15 <Duck> so import is done, and may be satisfying, but we may also loose a few things
15:26:36 <number80> #undo
15:26:36 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x28ae46d0>
15:26:36 <openstack> Removing item from minutes: #link https://gitlab.com/mailman/hyperkitty/issues/148#note_36562529
15:26:41 <Duck> we can do that via URL too but I need more power
15:26:56 <Duck> is anyone here admin on the RDO RH MLs ?
15:27:09 <rbowen> I am admin on the list.
15:27:16 <rbowen> So is apevec and number80
15:27:17 <Duck> and could give duck@redhat.com more poser?
15:27:21 <Duck> power
15:27:23 <rbowen> Sure. I can do that.
15:27:37 <rbowen> And I'll send you the list password when we're done here.
15:27:39 <Duck> probably the admin passwd is needed
15:27:43 * number80 *nods*
15:27:43 <Duck> thnaks
15:27:48 <rdogerrit> Oliver Walsh created openstack/nova-distgit ocata-rdo: Update to 15.0.6-2  https://review.rdoproject.org/r/8085
15:27:51 <Duck> so I can try to reimport better
15:28:08 <rbowen> For the rdo-infra list ... not sure who manages that.
15:28:11 <Duck> maybe I could also reach the list settings this way
15:28:18 <Duck> and get IT out of the loop
15:28:24 <Duck> ho
15:28:26 <rbowen> So there's some tasks around that, too - in particular, ensuring that those automated messages go to the new list once it's up.
15:28:46 <rbowen> Anybody remember who owns the rdo-infra mailing list?
15:29:06 <rdogerrit> Oliver Walsh created openstack/nova-distgit newton-rdo: Update to 14.0.7-2  https://review.rdoproject.org/r/8086
15:29:10 <Duck> could you add to the tasks to search for the rdo-infra person in charge and get us the passwd?
15:29:30 <rbowen> #action Rich to send rdo-list, rdo-newsletter mailing list passwords to Duck, and add him to admin list
15:29:43 <rbowen> #action Rich to hunt down who owns rdo-infra mailing list, and get credentials passed on to Duck
15:29:52 <Duck> thanks :-)
15:30:00 <rbowen> #action Rich to write up checklist for communication around moving to new mailing lists.
15:30:09 <Duck> in the meanwhile you can have a look, familiarize with the new UI
15:30:19 <Duck> look at the new settings
15:30:22 <Duck>15:30:39 <Duck> and don't forget I'm away for DebConf RSN
15:31:00 <rbowen> Yes, and I'm out next week, too, so we really don't want to complete this until after that.
15:31:45 <rbowen> I believe that's all we have on this topic.
15:31:48 <Duck> I will also have oVirt ML migration is the same time area, so let's avoid overloads
15:31:57 <Duck> yep
15:32:14 <chandankumar> rbowen: Duck Thanks for the updates :-)
15:32:31 * Duck \_o<
15:32:37 <chandankumar> i have one question, users needs to re subscribe to new list?
15:32:55 <Duck> chandankumar: no, but they do to access their settings
15:33:00 <rbowen> The plan is to export the subscriber list from the existing lists, and import it to the new one.
15:33:27 <Duck> and you can use social auth so it should be painless
15:33:29 <rbowen> And, at least initially, all rdo-list subscribers will be copied to users@ and dev@, and encouraged to drop off of the one that they don't care about, if necessary.
15:33:34 <chandankumar> rbowen: Duck then all susbscribers will be auto subscribed to both list
15:33:36 <Duck> most people don't really care
15:33:47 <chandankumar> ack! Thanks :-)
15:33:50 <Duck> there's more than 2 lists :-)
15:34:19 <rbowen> Well, yes. but the others are all broadcast-only, and thus simpler.
15:34:20 <Duck> infra@ newsletter@ and dev@ yes, users@ I'm working on it
15:35:03 <Duck> I cannot do it right, then we may just have the same base archives on dev@ and users@ and live with it
15:35:06 <Duck> +if
15:35:28 <rbowen> That's probably fine. No harm in having duplicate archives.
15:35:28 <Duck> subcribers are dicovered with importing archives
15:35:41 <Duck> and there's no way to destroy an archive (yet)
15:35:54 <Duck> just storage :-)
15:37:04 <chandankumar> moving to next topic if no any questions related to this topic
15:37:22 <chandankumar> #topic chair for next meeting
15:37:45 <amoralej> i can take it, i haven't chair for too long
15:38:07 <chandankumar> #action amoralej to chair for next meeting
15:38:32 <chandankumar> #topic open discussions
15:38:57 <chandankumar> we still have 21 mins left, if anytopic which are missed feel free to bring in
15:39:02 <rbowen> Thanks, and welcome, to our new contributors who have joined us via EasyFix.
15:39:49 <snecklifter> action on me last week was to submit some updates to example specs
15:39:54 <snecklifter> but waiting on https://review.rdoproject.org/r/#/c/7907/
15:40:06 <amoralej> sorry, that's my fault snecklifter
15:40:08 <amoralej> :(
15:40:09 <snecklifter> so if that could be nudged along, great
15:40:11 <snecklifter> np
15:40:24 * amoralej to update that
15:40:45 <snecklifter> amoralej: you've been on PTO?
15:40:52 <snecklifter> so I think thats a good excuse :)
15:40:55 <amoralej> no, just one day
15:40:57 <amoralej> no excuse
15:40:59 <snecklifter> ha
15:41:52 <Duck> quack
15:42:14 <Duck> thanks chandankumar chairman
15:42:29 <chandankumar> rbowen: we donot know the irc nick of easyfix contributors.
15:42:49 <rbowen> No. I should have added that to the message I sent to them.
15:43:06 <rbowen> WE ave snecklifter and PagliaccisCloud for sure
15:43:16 <rbowen> The others, I'm not sure of.
15:43:34 <amoralej> just a remainder for all maintainers that we are close to pike GA and it's a good time to send any required spec update, as updating requirements
15:43:51 <chandankumar> snecklifter: PagliaccisCloud welcome aboard to RDO community, Thanks for your contribution, we are looking forward to see more contributions :-)
15:43:59 <rdogerrit> Oliver Walsh proposed openstack/nova-distgit newton-rdo: Update to 14.0.7-2  https://review.rdoproject.org/r/8086
15:44:13 <rbowen> But anybody else that is lurking and might want to contribute, you might want to know that I'm sending official RDO polo shirts to the four people that have contributed to the EasyFix effort. :-)
15:44:19 <rbowen> Those should go out tomorrow.
15:44:22 <snecklifter> Just glad to help share the load
15:45:54 <chandankumar> we still have 15 mins left, if no other topics to discuss, can we close the meeting?
15:46:19 <rdogerrit> Oliver Walsh proposed openstack/nova-distgit ocata-rdo: Update to 15.0.6-2  https://review.rdoproject.org/r/8085
15:46:51 <rbowen> +1 to adjourn.
15:47:34 <chandankumar> so ending it
15:47:39 <chandankumar> #endmeeting