15:02:00 <chandankumar> #startmeeting RDO meeting - 2017-09-13
15:02:01 <zodbot> Meeting started Wed Sep 13 15:02:00 2017 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:01 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-09-13'
15:02:02 <openstack> Meeting started Wed Sep 13 15:02:00 2017 UTC and is due to finish in 60 minutes.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:05 <openstack> The meeting name has been set to 'rdo_meeting___2017_09_13'
15:02:12 <chandankumar> #topic Roll Call
15:02:14 <number80> o/
15:02:15 <chandankumar> \o/
15:02:16 <jruzicka> o/
15:02:24 <chandankumar> #chair number80 jruzicka
15:02:24 <zodbot> Current chairs: chandankumar jruzicka number80
15:02:24 <openstack> Current chairs: chandankumar jruzicka number80
15:02:30 <apevec> o/
15:02:37 <chandankumar> #chair apevec
15:02:37 <zodbot> Current chairs: apevec chandankumar jruzicka number80
15:02:38 <openstack> Current chairs: apevec chandankumar jruzicka number80
15:02:42 <jpena> o/
15:02:49 <chandankumar> #chair jpena
15:02:49 <zodbot> Current chairs: apevec chandankumar jpena jruzicka number80
15:02:50 <openstack> Current chairs: apevec chandankumar jpena jruzicka number80
15:03:07 <chandankumar> Feel free to add your agenda here : https://etherpad.openstack.org/p/RDO-Meeting
15:03:48 <chandankumar> snecklifter: PagliaccisCloud rdo meeting time if you are around.
15:03:56 <PagliaccisCloud> i'm here
15:03:59 <snecklifter> o/
15:04:05 <chandankumar> #chair PagliaccisCloud snecklifter
15:04:05 <zodbot> Current chairs: PagliaccisCloud apevec chandankumar jpena jruzicka number80 snecklifter
15:04:06 <openstack> Current chairs: PagliaccisCloud apevec chandankumar jpena jruzicka number80 snecklifter
15:04:59 <chandankumar> So starting with first topic
15:05:17 <chandankumar> #topic dropping patches repositories
15:05:22 <chandankumar> jruzicka: go ahead
15:05:35 <number80> actually, it was from me
15:05:46 <chandankumar> number80: please go ahead
15:05:47 <number80> Well, I just noticed that they are not used anymore
15:06:05 <apevec> that's by RDO def, we don't carry patches :)
15:06:08 <number80> so either we use them, or decide to try something else
15:06:18 <apevec> but sometimes we do need a patch
15:06:32 <number80> Yeah, if we just didn't have patches, it would be perfect
15:06:36 <apevec> for blockers/security issues
15:06:46 <number80> but as we have them, we need to consolidate how we handle them
15:07:25 <number80> And also we never discussed about EOLing open reviews
15:07:45 * number80 can't use the user-specific views of gerrit since they are accumulating
15:08:00 <number80> by design, they can't be closed
15:08:20 <apevec> patches reviews for EOL branches can be abandoned?
15:08:40 <number80> I think so
15:08:53 <number80> but I wouldn't do that without checking with everyone else
15:08:57 <chandankumar> number80: https://github.com/openstack/horizon/blob/master/tools/abandon_old_reviews.sh
15:09:01 <apevec> with current SF implementation, reviews stay open as long as we need to build the RPM with the patch
15:09:06 <chandankumar> if we are talking about old reviews then
15:09:13 <number80> chandankumar: not a tooling problem, but a policy one
15:09:26 <number80> these reviews are designed to be opened
15:09:30 <number80> never merged
15:10:06 <number80> so I guess from discussion, I can elaborate two proposals
15:10:17 <number80> A: create patches branches on-demand
15:10:47 <number80> B: as part of EOL process, abandon open patches reviews for EOL branches
15:10:55 <apevec> abandoning old review could be part of EOL checklist, we had template card for that: https://trello.com/c/fV69VODx/165-rdo-release-eol
15:11:02 <number80> *nods*
15:11:13 <number80> A: +1 B: +1 (my personal take)
15:11:27 <apevec> +1 both
15:11:43 <chandankumar> +1 +1
15:12:20 <number80> PagliaccisCloud, snecklifter: even if you're new, you're allowed to express yourselves (or ask questions if you're unsure) :o)
15:12:46 <PagliaccisCloud> :D
15:13:28 <snecklifter> I thought we could pull patches into specs from upstream, what am I missing?
15:13:42 <snecklifter> lots, probably
15:14:21 <number80> snecklifter: well, flepied came with this idea of using gerrit open reviews to track downstream patches
15:14:35 <number80> Pros: easy rebase, we keep history and run CI on them
15:15:04 <number80> and we even had rdopkg support to manage them nicely (some commands were removed recently)
15:15:21 <snecklifter> Yes, have used and I like it
15:15:59 <number80> so we're just trying to see if we should keep using them, and just create repo/branches on-demand
15:16:28 <number80> and also what to do with accumulating reviews on EOL branches
15:16:29 <snecklifter> +1 to that idea, I'm all for simplification which is what this feels like to me
15:16:49 <number80> ok then
15:17:05 <number80> #agreed create patches branches on-demand
15:17:15 <number80> #agreed abandon patches open reviews for EOL branches
15:17:27 <number80> #action number80 document that where it fits ^
15:17:38 * number80 is done with that topic
15:17:44 <chandankumar> number80: thanks :-)
15:17:57 <chandankumar> Any question with this topic, if not moving ahead.
15:18:08 <snecklifter> nope
15:18:31 <chandankumar> #topic Fedora worker cleanup in RDO Trunk
15:18:42 <jpena> that's mine
15:18:42 <chandankumar> i hope it is jpena's topic :-)
15:19:12 <jpena> The Fedora Rawhide worker in RDO Trunk has been mostly unmaintained for too long, and as a result most packages are failing to build
15:19:30 <number80> that explains all the py3 reviews :)
15:19:34 <jpena> I've started working on it, trying to get it consistent asap
15:20:06 <jpena> I'm using https://review.rdoproject.org/r/#/q/topic:fedora-cleanup as a general topic for reviews related to this effort. So far I've found a few mistakes in the specs
15:20:09 <snecklifter> jpena: is this anything I can help out with?
15:20:40 <jpena> snecklifter: sure, check https://trunk-primary.rdoproject.org/f25/report.html , see if there's any failing spec you can fix
15:20:54 <snecklifter> jpena: will do, cheers
15:21:08 <jpena> besides spec issues, we have two more general problems:
15:21:11 <chandankumar> jpena: adding it to office hour for getting more help
15:21:26 <jpena> 1- We don't have openstack-macros in Fedora (should we add it?)
15:21:41 <snecklifter> Absolutely
15:22:10 <jpena> 2- eventlet 0.21.0 in Fedora is known to create problems for OpenStack: https://github.com/eventlet/eventlet/issues/401
15:23:06 <snecklifter> jpena: yeah, I was looking at that this morning, pinning to 0.20.0 as workaround
15:23:20 <jpena> I can propose openstack-macros in Fedora, but I'm happy to leave it for someone else if there's any volunteer :)
15:24:16 <snecklifter> jpena: I'll propose it tomorrow
15:24:28 <jpena> nice, thanks!
15:24:28 * snecklifter is UK-based
15:24:41 <chandankumar> #action snecklifter to propose openstack-macros for fedora
15:24:52 <apevec> jpena, I'd add openstack-macros in trunk
15:24:59 <apevec> it's openstack project
15:25:10 <apevec> so I'd undo
15:25:17 <apevec> proposing it in fedora
15:25:36 <chandankumar> #undo
15:25:36 <zodbot> Removing item from minutes: ACTION by chandankumar at 15:24:41 : snecklifter to propose openstack-macros for fedora
15:25:38 <snecklifter> I can get behind not doing it also :)
15:25:38 <openstack> Removing item from minutes: #action snecklifter to propose openstack-macros for fedora
15:25:38 <jpena> apevec: iirc, I added support for that in DLRN (because the source repo is the whole github.com/openstack/rpm-packaging)
15:25:59 <jpena> I'll check that, then
15:26:00 <apevec> jpena, yeah, we could test on it sourcing pkg directly from rpm-packaging
15:27:18 <jpena> #action jpena to check inclusion of openstack-macros in RDO Trunk
15:27:51 <jpena> that's it for me
15:28:42 <chandankumar> I think once cleanup is done, we can start porting/enabling python3 packages/
15:28:43 <chandankumar> ?
15:29:17 <number80> snecklifter: macros are specific case in Fedora, you need approval from FPC
15:29:35 <apevec> chandankumar, let's get it FTBFS-clean first
15:29:36 <snecklifter> number80: ah ok
15:29:43 <chandankumar> apevec: ack!
15:29:45 <apevec> after that we can discuss adding CI
15:30:02 <number80> Well, do not start py3 work until we know *how* we will support python3
15:30:14 <apevec> number80, in Fedora we know
15:30:27 <apevec> that's prep for next rhel
15:30:29 <number80> this is not just adding lines to spec files, it impacts build system too dependending tech
15:30:36 <apevec> for rhel7, it's different story
15:30:49 <apevec> and currently we are not doing it
15:30:51 <number80> apevec: yeah, for clients, most work is already done, I was thinking about services and other stuff
15:30:53 <apevec> on el7
15:31:28 <number80> Well, what happens if EL8 is not released before upstream drops py2 ?
15:31:39 <number80> That's the part worrying me
15:31:57 <apevec> don't worry about that, py2 will stay
15:31:59 <dmsimard> FWIW SUSE is shipping queens with py3
15:32:03 <number80> ok
15:32:10 <dmsimard> (discussed with suse yesterday in regards to rpm-packaging)
15:32:27 <chandankumar> software factory has Python35-SCL listed
15:32:28 <number80> dmsimard: SUSE has their own agenda on py3
15:32:32 <apevec> dmsimard, not all services actually work with py3, this is still work in progress
15:32:50 <dmsimard> just highlighting what they told me their plan was :)
15:32:53 <number80> RDO has to support RHEL too
15:33:05 <number80> RHEL has no py3 support as of today
15:33:33 <apevec> chandankumar, right, that works for zuul with limited set of deps,
15:33:39 <apevec> b/c you need to SCLized and rebuild them all
15:34:04 <apevec> either way, this is off topic,
15:34:12 <number80> Yeah long topic too
15:34:13 <apevec> Fedora cleanup is first step as a prep
15:34:18 <number80> *nods*
15:34:38 <chandankumar> Any questions for this topic if not moving to next topic
15:35:10 <chandankumar> #topic Using the CentOS extras Ansible
15:35:17 <chandankumar> dmsimard: please go ahead :-)
15:35:40 <dmsimard> A review caught my attention recently, we upgraded from ansible 2.3.1 to 2.3.2
15:35:47 <dmsimard> and it looked like it was *required*
15:35:56 <apevec> yes, for ceph
15:35:58 <dmsimard> so that means we won't be rolling with the ansible provided by rhel/centos extras ?
15:36:10 <apevec> ceph actually requires >= 2.3.1
15:36:23 <apevec> so we could avoid pushing 2.3.2 to release
15:36:26 <rdogerrit> rdo-trunk created openstack/manila-ui-distgit pike-rdo: Update to 2.10.2  https://review.rdoproject.org/r/9469
15:36:29 <apevec> now that 7.4 is released
15:36:59 <apevec> it was not clear when 7.4 will be released, so we pushed latest 2.3.2 we had in CBS
15:37:10 <apevec> to unblock ceph ansible
15:37:56 <dmsimard> ok, ideally we would try really hard to use the extras version :)
15:38:23 <apevec> ansible in Extras could be rebased more frequently (different update policy than baseos)
15:38:31 <apevec> so testing 2.3.2 in advance is also good
15:38:41 * Duck :-)
15:38:56 <number80> Yeah, I guess we can even provide both
15:39:00 <number80> 2.3.1 is -release
15:39:05 <number80> 2.3.2 in -testing
15:39:10 <apevec> yep
15:39:23 <number80> (it will require manual tweaking but doable)
15:39:45 <apevec> why tweaking?
15:39:56 <apevec> we just don't push 2.3.2 to openstack-release
15:40:06 <apevec> and 2.3.1 comes from centos extras
15:40:30 <apevec> it was released today http://mirror.centos.org/centos/7/extras/x86_64/Packages/ansible-2.3.1.0-3.el7.noarch.rpm
15:43:13 <dmsimard> ok
15:43:53 <chandankumar> Any questions on this topic, if not moving ahead.
15:44:15 <chandankumar> dmsimard: Thanks :-)
15:44:26 <chandankumar> #topic rdopkg is now in Fedora 25+ and EPEL 7
15:44:34 <chandankumar> jruzicka: please go ahead
15:44:42 <jruzicka> just a quick announcement
15:45:23 <jruzicka> rdopkg is now available from official Fedora 25+ and EPEL 7 repos so you can get it
15:45:34 <chandankumar> **sweet**
15:45:35 <jruzicka> by just: dnf install rdopkg
15:45:40 <snecklifter> jruzicka: so no need to use your copr repo any more? I guess we need to update the website docs
15:45:51 <snecklifter> this is good news
15:46:04 <jruzicka> yes, the copr repo is now obsolete
15:46:19 <jatanmalde> great.
15:46:23 <jruzicka> I'll use it for testing/bleeding edge builds
15:46:33 <apevec> jruzicka, which NVR is in f25 ? I still got last update from copr
15:46:39 <Duck> jruzicka: yeah, update the doc before doing this then :-)
15:46:55 <jruzicka> rdopkg docs updates are in review, I'll go through website
15:47:04 <apevec> ah so I got bleeding version :)
15:47:15 <snecklifter> me too
15:47:17 <jruzicka> #action jruzicka to update website
15:47:21 <jruzicka> dnf info rdopkg --refresh
15:47:25 <rdogerrit> rdo-trunk created openstack/manila-distgit pike-rdo: Update to 5.0.1  https://review.rdoproject.org/r/9470
15:47:44 <jruzicka> you want to disable the copr by
15:47:48 <jruzicka> dnf copr disable jruzicka/rdopkg
15:48:23 <jruzicka> Name        : rdopkg
15:48:24 <jruzicka> Arch        : noarch
15:48:24 <jruzicka> Epoch       : 0
15:48:24 <jruzicka> Version     : 0.45.0
15:48:24 <jruzicka> Release     : 4.fc25
15:48:25 <jruzicka> Size        : 69 k
15:48:26 <jruzicka> Repo        : updates
15:48:31 <jruzicka> -4 is Fedora
15:48:36 <jruzicka> -3 is last copr version
15:48:51 <jruzicka> I'll leave the Fedora version ahead for the time of transition
15:48:58 <apevec> ack
15:49:30 <jruzicka> Finally, CI scripts should also be updated not to use the copr repo.
15:49:47 <jruzicka> I assume DLRN will follow shortly after, right jpena? ;)
15:49:57 <jpena> yep, that's the plan
15:50:01 <apevec> jruzicka, iirc CI is mostly pip installing rdopkg...
15:50:31 <jruzicka> even better ;)
15:50:39 <jruzicka> well that's
15:51:18 <jruzicka> *that's it
15:51:21 <chandankumar> jruzicka: thanks :-)
15:51:32 <chandankumar> Moving to next topic
15:51:40 <chandankumar> #topic chair for next meeting
15:51:54 <chandankumar> Any volunteer up to chair for next meeting?
15:53:12 <jruzicka> allright, I'll do it.
15:53:25 <chandankumar> #action jruzicka to chair for next meeting
15:53:29 <chandankumar> jruzicka: thanks :-)
15:53:43 <chandankumar> we still have 7 mins, time to go for open discussion
15:53:50 <chandankumar> #topic Open discussion
15:53:54 <jruzicka> back to the patches branch
15:54:01 <Duck> I need dmsimard's time to work on Ansible roles :-)
15:54:04 <jruzicka> sorry for missing that, I got lost in codes
15:54:16 <jruzicka> so we're keeping the reviews?
15:54:18 <rbowen> I expect a lot of people are rather buried in stuff at the PTG, too.
15:54:37 <jruzicka> allright, I'll discuss post-meeting ;)
15:54:39 <rbowen> Also, the network here is *terrible*
15:55:41 <snecklifter> All I read on twitter is about the trains and their horns
15:55:52 <rbowen> The trains are indeed very loud.
15:56:03 <rbowen> I think one of them runs through my room.
15:57:45 <chandankumar> rbowen: i think near the interview room, there is a long dinning space.
15:58:52 <snecklifter> ok well if there is nothing else, small announcement from me
15:59:12 <snecklifter> In a blow for RDO project diversity, I have taken a job with Red Hat
15:59:20 <rbowen> !
15:59:35 <rbowen> Congratulations. And also, curse you for ruining my metrics! ;-)
15:59:36 <Duck> welcome :-)
15:59:41 <chandankumar> snecklifter: congrats :-) Welcome to Red Hat :-)
15:59:44 <snecklifter> rbowen: yes, I know, sorry
15:59:49 <rbowen> hehe
15:59:53 <jatanmalde> snecklifter, congrats :D
15:59:53 <jpena> snecklifter: I'd say "oh, no" and "oh, yes!" at the same time :)
16:00:00 <jpena> welcome ;)
16:00:08 <snecklifter> thanks all, starting in 3 weeks
16:00:24 <Duck> where will you be located?
16:00:27 <snecklifter> UK
16:01:06 <Duck> a bit far for me. if you come to other event like DevConf, FOSDEM…
16:01:10 <snecklifter> I thought nice to end the meeting on a positive note :)
16:01:15 <chandankumar> very very far far from my location :-)
16:01:25 <snecklifter> Duck: yes and I can't swim like a duck can
16:01:30 <chandankumar> times up
16:01:34 <chandankumar> #endmeeting