15:00:26 <number80> #startmeeting RDO meeting - 2017-12-06
15:00:26 <zodbot> Meeting started Wed Dec  6 15:00:26 2017 UTC.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:26 <zodbot> The meeting name has been set to 'rdo_meeting_-_2017-12-06'
15:00:27 <openstack> Meeting started Wed Dec  6 15:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'rdo_meeting___2017_12_06'
15:00:37 <number80> #topic roll call
15:00:40 <mary_grace> chandankumar: thanks! glad you liked it :)
15:01:03 <number80> Please update meeting agenda: https://etherpad.openstack.org/p/RDO-Meeting
15:01:31 <rbowen> o/
15:01:36 <chandankumar> \o
15:01:42 <number80> #chair rbowen chandankumar ykarel dmsimard
15:01:42 <zodbot> Current chairs: chandankumar dmsimard number80 rbowen ykarel
15:01:43 <ykarel> o/
15:01:44 <openstack> Current chairs: chandankumar dmsimard number80 rbowen ykarel
15:01:47 <mary_grace> o/
15:01:50 <number80> #chair mary_grace
15:01:50 <zodbot> Current chairs: chandankumar dmsimard mary_grace number80 rbowen ykarel
15:01:52 <openstack> Current chairs: chandankumar dmsimard mary_grace number80 rbowen ykarel
15:02:23 <number80> few more minutes to let people join
15:02:24 * Duck o/
15:03:55 <number80> #chair Duck
15:03:55 <zodbot> Current chairs: Duck chandankumar dmsimard mary_grace number80 rbowen ykarel
15:03:57 <openstack> Current chairs: Duck chandankumar dmsimard mary_grace number80 rbowen ykarel
15:05:25 <rdogerrit> David Moreau Simard created config master: Temporarily disable clean-floating-ips on Nodepool providers  https://review.rdoproject.org/r/10839
15:05:38 <number80> let's start
15:05:55 <number80> #topic building py3 services
15:06:41 <number80> jpena has been working recently to fix the Fedora DLRN instance so we start working on py3 packaging
15:07:05 <number80> but this does not help us as-is to build py3 services.
15:07:43 <dmsimard> I'm not paying attention very much, troubleshooting production stuff, please ping me if appropriate
15:07:48 <number80> dmsimard: ack
15:07:57 <tosky> what is the status upstream? Last I checked, even devstack/py3 is not always enabled/working
15:08:19 <tosky> (or at least I didn't find a way to deploy single services with py3)
15:08:28 <number80> tosky: that's something to discuss at next PTG but we shouldn't wait on upstream to start groundwork
15:08:36 <chandankumar> number80: is the clients and oslo libraries done?
15:08:36 <tosky> oh, sure
15:08:52 <number80> chandankumar: except tripleoclient, yes
15:09:02 <number80> jpena has been pushing some fixes along the way too
15:09:12 <chandankumar> number80: i think we can ask project maintianers to start porting the stuff
15:09:26 <number80> chandankumar: I'm getting to that point :)
15:09:45 <tosky> I mean, even if we create the packages, we should clearly mark them as "if you touch these, a kitten *may* die"
15:09:48 <number80> First, we need to take few guinea pigs to test how we want to port services packages to py3
15:10:08 <number80> I suggest that we use standalone services like swift, keystone or gnocchi
15:10:39 <tosky> I think that swift may not be the best guinea pig
15:10:55 <number80> I don't think it's worth building them under both interpreters but we need to validate how we will handle that
15:11:27 <number80> tosky: why?
15:12:09 <rdogerrit> Merged rdo-infra/ci-config master: Support different containers list for releases  https://review.rdoproject.org/r/10837
15:12:17 <number80> few ideas: 1. using renderspec to generate spec 2. abstract py2/py3 differences using macros
15:12:22 <tosky> number80: I may be mistaken, but I think it was a bit behind with py3 support
15:13:10 <number80> ah right, well, I was thinking about services with low dependencies so we don't get disturbed by building py3 dependencies first
15:13:45 <tosky> uhm, I was thinking about sahara, but it uses various clients
15:13:53 <tosky> (which should be already py3 ready)
15:14:00 <number80> so the goal is to evaluate each approach, choose one and then start porting packages
15:14:31 <number80> so we don't confuse package maintainers by telling them to do the porting without giving them proper guidelines and examples
15:14:59 <number80> Any questions? feedback?
15:15:13 <number80> (btw thanks to tosky to noticing swift py3 issue)
15:15:18 <jruzicka> well I think swift isn't the best guinea pig too
15:15:36 <jruzicka> it's conservative and slow-moving in comparison to other OS projects
15:15:38 <number80> yup, I crossed it
15:15:49 <jruzicka> I'd pick some problematic hipster kid instead :-p
15:15:58 <myoung|ruck> o/
15:16:00 <number80> jruzicka: since you know renderspec well, do you want to look at it?
15:16:12 <number80> keystone and gnocchi should be fine
15:16:25 <jruzicka> number80, well I wrote it :) looking at what exactly?
15:16:26 * number80 knows that gnocchi folks are eager to drop py2 support
15:16:51 <jruzicka> ah, I see now point 1.
15:16:53 <number80> jruzicka: if we can use to manage both py2/py3 support for services
15:17:32 <number80> well, let's discuss this next week, this is a long-term effort :)
15:17:37 <jruzicka> sure thing, renderspec integration in rdopkg is a low prio task queued for a long time, this might be the priority bump it needs to actually happen :)
15:17:47 <number80> #topic test days
15:17:47 <jruzicka> but yes, I'll do it.
15:17:51 <ykarel> number80, are we going to test it in centos or fedora? python3 is there in centos?
15:18:16 <rbowen> It's in SC, I think.
15:18:51 <number80> only in fedora, that's something I discussed earlier with Alan. Until CentOS/RHEL8, we won't be able to sustain the workload of maintaining py3 stack or use SCL
15:19:26 <number80> dmsimard: quick question, do you have status about trystack readiness for test days?
15:19:36 <ykarel> number80, ack
15:20:09 <dmsimard> number80: there's no real progress yet to speak of, I'll be talking with jpena and amoralej tomorrow to start working on it
15:20:33 <dmsimard> last I looked there wasn't any signups for the event except me and tristanC so meh
15:20:39 <rbowen> :(
15:20:46 <number80> dmsimard: ack, do you have link for signup?
15:20:58 <number80> https://etherpad.openstack.org/p/RDO-Meeting
15:21:01 <dmsimard> https://etherpad.openstack.org/p/rdo-queens-m2-cloud
15:21:11 <dmsimard> https://dmsimard.com/2017/11/29/come-try-a-real-openstack-queens-deployment/
15:21:14 <number80> damn clipboard
15:21:23 <number80> ok, I'll make some noise around it
15:21:34 <dmsimard> rbowen: can you also advertise internally ? perhaps LT can help
15:22:02 <rbowen> I've mentioned it to several difference audiences. I mentioned it on this morning's status meeting. I will also mention it several other places ASAP.
15:22:03 <number80> dmsimard: I cross-posted to internal lists rbowen's announce earlier
15:22:03 <chandankumar> dmsimard: can we include tempest also?
15:22:05 <dmsimard> I'd love to get people from the larger RDO community to participate though :/
15:22:13 <rbowen> I also mentioned it on centos-devel
15:22:14 <dmsimard> number80: ah ok
15:22:23 <rbowen> And in yesterday's newsletter.
15:22:25 <dmsimard> chandankumar: tempest isn't really something that users are going to be testing
15:22:44 <chandankumar> dmsimard: they can run after deployment.
15:24:29 <number80> Yup, this is only for cloud end-users testing
15:24:47 <number80> #info trystack setup for test days is ongoing
15:24:49 <chandankumar> ack
15:24:59 <number80> #action all spread the word about test days
15:25:19 <number80> rbowen: did you have feedback about test matrix?
15:25:37 <rbowen> There were no responses to that thread, nor edits to the page.
15:25:52 <rbowen> WHat kinds of things would we like to see people testing on this cloud?
15:26:08 <rbowen> There's the obvious "create an instance and connect to it" but what other scenarios would we want people to go through?
15:26:36 <dmsimard> I don't have anything specific in mind, whatever workload they currently run on openstack
15:26:54 <dmsimard> if nobody tries it, I'll try the hell out of it
15:27:12 <dmsimard> I hear bitcoin is worthwhile nowadays :D
15:27:16 * dmsimard just kidding ofc
15:27:30 * ykarel :)
15:27:30 <rbowen> :D
15:27:35 <number80> I wanted to add new test cases like kolla or openstack-ansible (got my neighbour to try it out on OVH)
15:28:13 <rbowen> If you can suggest things to try, please add to the "does it work" section on https://www.rdoproject.org/testday/tests/
15:28:20 <number80> ack
15:28:27 <rbowen> Or post to the list and I'll do the edits, if that's easier.
15:28:38 <number80> #action number80 add new items in "does it work"
15:29:22 <number80> I pinged our internal list of openstack power users to help us with test matrix, I hope they'll come up with ideas
15:29:38 <rbowen> That would be very helpful.
15:29:43 <number80> Anything you want to add?
15:29:54 <rbowen> Nope.
15:29:58 <number80> next topics
15:30:17 <number80> #topic Last chance to submit a talk for the CentOS Dojo at FOSDEM: https://goo.gl/forms/FVOEtVOukuCGEnsG2
15:30:35 <number80> https://goo.gl/forms/FVOEtVOukuCGEnsG2
15:30:53 <number80> rbowen: I thought I was late but I'll submit a gnocchi talk
15:30:56 <rbowen> Trying to publish a schedule for that first thing next week, so the extension of the extension of the extension of the deadline has finally arrived.
15:31:41 <rbowen> Anyone who wants to talk about OpenStack + CentOS, would be appreciated.
15:31:53 <number80> *nods*
15:32:01 <number80> I'll be there (like any FOSDEM)
15:32:11 <rbowen> And there will be beer.
15:33:01 <number80> \o/
15:33:07 <number80> anything else?
15:33:16 <rbowen> That's all there.
15:34:19 <number80> #topic Both OpenStack and CentOS will have stands at FOSDEM this year
15:34:22 <number80> rbowen: ^
15:34:23 <rbowen> And the final item is the same. If you will be at FOSDEM, there's an opportunity to work either the OpenStack table, or the table that we're sharing with CentOS. There are always interesting conversations to be had,and interesting people to meet.
15:34:45 <rbowen> I don't have details of *how* you volunteer for either. I'm still working on that. :-)
15:34:56 <rbowen> It usually takes a while for the signup sheets to show up.
15:34:57 <number80> I'll take shifts on both, maybe even simultaneously
15:35:23 <rbowen> The table map is here: https://fosdem.org/2018/stands/
15:35:38 <rbowen> I haven't looked yet, so I don't know if we're right inside the front door again. We usually are.
15:35:46 <rbowen> Where it's cold and crowded. :-D
15:36:13 <rbowen> I think we'll have RDO scarves.
15:36:17 <rbowen> That's all I've got on this topic.
15:36:41 <number80> rbowen: looks like you're up for another fosdem in the cold area
15:36:54 <rbowen> Yeah. So dress warm.
15:37:14 <number80> #info we're looking for volunteers to man the OpenStack and CentOS booth at FOSDEM
15:37:41 <number80> then we're good for the best part of the meeting
15:37:48 <number80> #topic open floor
15:37:58 <number80> Anything you want to bring before we close?
15:38:12 <chandankumar> Just a reminder, we are still looking for project ideas for easyfix as well as more engagement in easyfix initiative, if you have something feel free to bump here https://github.com/redhat-openstack/easyfix/issues
15:38:14 <number80> (and who's up to chair next meeting?)
15:38:26 <number80> #info easyfix is looking for new projects ideas
15:38:44 <number80> https://github.com/redhat-openstack/easyfix/issues
15:40:15 <chandankumar> number80: i will chair for next week
15:40:35 <number80> #action chandankumar to chair next week meeting
15:40:46 <number80> ok, anything else before I close the meeting?
15:41:55 <number80> Thanks for joining and see you next week o/
15:41:59 <number80> #endmeeting