15:00:37 <amoralej> #startmeeting RDO meeting - 2018-06-20
15:00:37 <zodbot> Meeting started Wed Jun 20 15:00:37 2018 UTC.
15:00:37 <zodbot> This meeting is logged and archived in a public location.
15:00:37 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:37 <zodbot> The meeting name has been set to 'rdo_meeting_-_2018-06-20'
15:00:38 <openstack> Meeting started Wed Jun 20 15:00:37 2018 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <amoralej> here we go!
15:00:43 <openstack> The meeting name has been set to 'rdo_meeting___2018_06_20'
15:00:48 <leanderthal> wh00t!
15:00:52 <amoralej> please, add your topics to https://etherpad.openstack.org/p/RDO-Meeting
15:00:58 <amoralej> i'm giving a couple of minutes
15:01:13 <mjturek> o/
15:01:16 <leanderthal> o/
15:01:25 <ykarel> o/
15:01:39 <jruzicka> o/
15:01:45 <PagliaccisCloud> \o
15:02:11 <amoralej> #chair mjturek leanderthal ykarel jruzicka PagliaccisCloud
15:02:11 <zodbot> Current chairs: PagliaccisCloud amoralej jruzicka leanderthal mjturek ykarel
15:02:12 <openstack> Current chairs: PagliaccisCloud amoralej jruzicka leanderthal mjturek ykarel
15:02:13 <jpena> o/
15:03:08 <amoralej> #chair jpena
15:03:08 <zodbot> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek ykarel
15:03:09 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek ykarel
15:03:20 <amoralej> ok, let's start with the first topic
15:03:39 <amoralej> #topic FYI zuul v3 migration https://lists.rdoproject.org/pipermail/dev/2018-June/008775.html
15:03:45 <number80> o/
15:03:52 <amoralej> #chair number80
15:03:52 <zodbot> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek number80 ykarel
15:03:53 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek number80 ykarel
15:04:04 <amoralej> i think this is just for awareness
15:04:38 <amoralej> pabelanger is driving the migration of projects from zuulv2 in review.r.o to new zuulv3 in softwarefactory.io
15:05:06 <pabelanger> yes, we are still working on some nodepool bits this morning
15:05:09 <pabelanger> so a little behind
15:05:35 <pabelanger> but a lot of rdo jobs have already been migrated to zuulv3 and are working
15:05:47 <amoralej> if anyone notes something abnormal in jobs, let us know
15:06:00 <amoralej> i'd recommend to double check jobs behavior in next days
15:07:16 <amoralej> so, i think we can move on
15:07:24 <amoralej> anything else wrt zuulv3 migration?
15:07:46 <amoralej> ok, let's move on
15:07:51 <amoralej> #topic CentOS Dojo @ DevConf.us CFP is open
15:07:55 <amoralej> leanderthal, ^
15:07:58 <amoralej> this is yours
15:08:09 <amoralej> #info https://wiki.centos.org/Events/Dojo/DevConfUS2018
15:08:21 <leanderthal> we've got a tight deadline on a CentOS Dojo paired with DevConfUS
15:08:45 <leanderthal> If anyone is in the Boston area, I'm super keen to help submit CFPs to it as the deadline is 25 june
15:08:56 <leanderthal> and they're pretty much deciding NOW whether or not to do it
15:09:24 <leanderthal> plus it's free! As is DevConf.US!
15:10:31 <leanderthal> any questions?
15:12:38 <amoralej> it seems there are no questions
15:12:47 <amoralej> should we move on to next topic?
15:13:11 <leanderthal> sure thing
15:13:13 <leanderthal> thx amoralej
15:13:22 <amoralej> #topic distroinfo migration is ready
15:13:25 <jruzicka> o/
15:13:34 <amoralej> #info tl;dr distroinfo is generic reimplementation of rdoinfo
15:13:46 <amoralej> #chair jruzicka
15:13:46 <zodbot> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek number80 ykarel
15:13:47 <openstack> Current chairs: PagliaccisCloud amoralej jpena jruzicka leanderthal mjturek number80 ykarel
15:13:52 <jruzicka> #link https://github.com/softwarefactory-project/distroinfo
15:13:56 <amoralej> #info distroinfo RPMs are available from Fedora 27+ and EPEL 7+
15:14:04 <amoralej> #info     rdopkg switch to distroinfo: https://softwarefactory-project.io/r/#/c/12221/
15:14:17 <amoralej> #info DLRN switch to distroinfo: https://softwarefactory-project.io/r/#/c/12271/
15:14:23 <amoralej> all yours jruzicka
15:14:29 <jruzicka> amoralej, thanks
15:14:49 <jruzicka> so to my surprise the first python-distroinfo release seems to work fine
15:15:05 <amoralej> :)
15:15:11 <jruzicka> as in I didn't expect there would be no packaging issue requiring re-release ;)
15:15:36 <jruzicka> yet jpena reports success with DLRN and number80 is testing if I'm not mistaken?
15:15:52 <jruzicka> so let's get these patches merged
15:15:58 <jpena> yep, there's an under-review commit for DLRN that uses it, so it works fine
15:16:04 <amoralej> jruzicka, is this change backwards compatible from rdoinfo cli pov?
15:16:05 <number80> jruzicka: yes
15:16:23 <jpena> but for python scripts importing rdopkg.* stuff, there are changes
15:16:30 <jruzicka> amoralej, jpena informed me that we need you to fix the rdo-infra/releng scripts ;)
15:16:54 <jpena> see https://softwarefactory-project.io/r/12221, at least there's some script under rdo-infra/releng that imports rdopkg.actionmods.rdoinfo
15:17:12 <jpena> and that will be gone, so we have to fix it before releasing a new rdopkg version
15:17:19 <amoralej> yes
15:17:28 <amoralej> and i imported utils iirc
15:17:42 <amoralej> i need to test that
15:17:45 <jruzicka> amoralej, it was a rather intrusive refactor, I took a code from rdopkg and rdoinfo parser and put it in one place with sane interface so that resulted in some changes to rdopkg modules
15:17:55 <number80> Remember that we haven't had a promotion for > 2 weeks, so I'd prefer that we limit change to the platform
15:18:16 <amoralej> ykarel, how far are we from getting a promotion in master?
15:19:13 <jruzicka> amoralej, let's talk about specific usages of rdopkg.actionmods.rdoinfo and find a proper replacement.
15:19:23 <jruzicka> (post meeting)
15:19:28 <amoralej> yeah, ok
15:19:54 <amoralej> jruzicka, i guess distroinfo is in pypi also
15:20:08 <amoralej> will pip install rdopkg keep working?
15:20:15 <amoralej> i guess so
15:20:15 <jruzicka> amoralej, yes and if you only query rdoinfo, chances are rdopkg req can be dropped in favor of much lighter distroinfo.
15:20:31 <amoralej> ok
15:20:36 <jruzicka> amoralej, unless I fail horribly, it will keep working, yes ;)
15:20:42 <amoralej> :)
15:21:08 <amoralej> will we remove rdoinfo python module from rdoinfo repo?
15:21:11 <jruzicka> sorry for the disruptive change but it is neccessary to support multiple *info instances without getting crazy
15:21:32 <jruzicka> amoralej, I'm all in favor of nuking it once it's safe
15:22:00 <amoralej> there are some scripts and code there used to gate changes in yaml files
15:22:05 <rdogerrit> pabelanger created rdo-jobs master: Add remaining projects to zuulv3 jobs  https://review.rdoproject.org/r/14352
15:22:47 <jruzicka> better validation for for rdoinfo is still on TODO, but that's another topic.
15:23:33 <rdogerrit> pabelanger proposed rdo-jobs master: Add remaining projects to zuulv3 jobs  https://review.rdoproject.org/r/14352
15:23:55 <jruzicka> I think that's it.
15:25:08 <amoralej> ok
15:25:20 <amoralej> no more topics in the agenda
15:25:26 <amoralej> so, before moving to open floor
15:25:34 <amoralej> who wants to chair next week?
15:25:44 <jpena> I can take it
15:26:17 <amoralej> #action jpena will chair next meeting
15:26:26 <amoralej> #topic open floor
15:26:37 <leanderthal> thx jpena
15:26:56 <PagliaccisCloud> is it too early to start planning openstack birthday celebrations?
15:27:24 <leanderthal> NO
15:27:35 <PagliaccisCloud> :D
15:27:45 <leanderthal> PagliaccisCloud, as a matter of fact, OSAS is sponsoring a birthday celebration at openstack days san jose next month
15:28:07 <leanderthal> do we want to do a virtual birthday party? or a blog post where we show how we're celebrating?
15:28:16 <leanderthal> or did you have something specific in mind, PagliaccisCloud ?
15:28:26 <PagliaccisCloud> why_not_both.gif
15:28:33 <leanderthal> #YESSSSS
15:28:45 <leanderthal> PagliaccisCloud, will you spearhead it? i can help.
15:29:01 <PagliaccisCloud> but seriously, my boss wants to do another company-wide celebration & livestream it july 12th
15:29:19 <leanderthal> PagliaccisCloud, okay, yes, definitely.
15:29:39 <PagliaccisCloud> it would be ossim if we could get project reps to join in. i'll talk to our media guys about it
15:29:56 <leanderthal> i'm a thousand percent in.
15:29:58 <jruzicka> :)
15:30:21 <PagliaccisCloud> yiss  ٩( ᐛ )و
15:31:02 * jruzicka is impressed by ٩( ᐛ )و
15:31:05 <leanderthal> #info RDO to celebrate openstack birthday
15:31:52 <leanderthal> #action PagliaccisCloud is doing a company wide celebration / livestreak 12 july and will work with leanderthal to coordinate
15:32:27 <PagliaccisCloud> i'll start the email thread now leanderthal :D
15:32:32 <leanderthal> perfect
15:32:41 <leanderthal> i love cake
15:35:44 <amoralej> anything else for open floor?
15:35:55 <amoralej> otherwise i'll close it and give you some time back
15:36:20 <amoralej> ok, i'll close it
15:36:28 <amoralej> thanks for joining
15:36:33 <amoralej> see you next week
15:36:43 <amoralej> #endmeeting