15:04:11 <jpena> #startmeeting RDO meeting - 2018-08-08
15:04:11 <zodbot> Meeting started Wed Aug  8 15:04:11 2018 UTC.
15:04:11 <zodbot> This meeting is logged and archived in a public location.
15:04:11 <zodbot> The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:11 <zodbot> The meeting name has been set to 'rdo_meeting_-_2018-08-08'
15:04:18 <jpena> rbowen: can you give voice to the openstack bot?
15:04:18 <mjturek> o/
15:04:45 <jpena> #chair PagliaccisCloud mjturek
15:04:45 <zodbot> Current chairs: PagliaccisCloud jpena mjturek
15:04:46 <baha> o/
15:04:46 <PagliaccisCloud> \o
15:04:46 <amoralej> o/
15:04:46 <jpena> remember to add last-minute items to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
15:04:48 <jpena> #chair baha amoralej
15:04:48 <zodbot> Current chairs: PagliaccisCloud amoralej baha jpena mjturek
15:06:18 <chandankumar> \o
15:07:05 <jpena> #chair chandankumar
15:07:05 <zodbot> Current chairs: PagliaccisCloud amoralej baha chandankumar jpena mjturek
15:07:59 <jpena> let's start with the agenda
15:08:05 <jpena> #topic Request for publishing of centos-release-openstack-queens to altarch/cloud/ppc64le/
15:08:16 <jpena> baha, mjturek: the stage is yours ^^
15:08:50 <baha> Right! So I think the topic pretty much covers this one =) We've been trying to build Triple O containers on ppc64le, and we're blocked on the centos-release-openstack-queens package not being published
15:09:09 <baha> As far as I'm aware the RDO community maintains that package, so I was hoping we could get it published
15:09:32 <mjturek> I think the last build of it was done by amoralej fwiw
15:09:43 <amoralej> i'm not sure about where do we need to push that tbh
15:09:52 <amoralej> it's in extras repo iirc
15:10:08 <amoralej> i need to check if the content is fine
15:10:08 <jpena> apevec: do you know? ^^
15:10:10 <amoralej> for altarch
15:10:18 <amoralej> with the contentdir stuff
15:10:23 <mjturek> that is correct, I said cloud, but it is indeed in the extras repo for x86
15:10:43 <amoralej> and then push to extras, i guess, for altarch
15:11:01 <amoralej> #action amoralej to check rdo queens release rpm status for altarch
15:11:10 <baha> I don't think it uses contentdir yet actually, but I can push a patch up for it later today
15:11:32 <amoralej> we manage that via gerrit reviews too
15:11:34 <amoralej> yeah
15:11:46 <mjturek> baha that would be awesome, thanks!
15:13:17 <jpena> is that all for this topic?
15:13:25 <baha> Should be!
15:13:39 <baha> Thank you amoralej
15:14:10 <jpena> #topic Status of Rocky release
15:14:31 <amoralej> Rocky GA is getting closer
15:14:53 <amoralej> #info https://releases.openstack.org/rocky/schedule.html
15:15:16 <amoralej> so we are working in all the tasks to get ready to release as soon as possible after upstream GA
15:15:36 <amoralej> which will be around 30 august
15:15:57 <amoralej> we've already created a new DLRN builder following rocky branches instead of master
15:16:13 <amoralej> which will be published in http:/trunk.rdoproject.org/centos7-rocky
15:16:43 <amoralej> and we will create branch rocky-rdo in remaining distgits in next days
15:17:02 <amoralej> so, for maintainers, please send any update that you need for rocky asap
15:17:28 <amoralej> #action maintainers to send required updates for rocky to distgits asap
15:18:02 <amoralej> as in previous release, i think release criteria will be weirdo jobs passing with cloudsig repos
15:18:14 <amoralej> for GA
15:18:48 <amoralej> #info status of tasks for rocky in https://trello.com/c/eYGgs0d2/668-rocky-release-preparation
15:19:17 <amoralej> and that's it from my side
15:19:27 <amoralej> let me know if you have any question about rocky
15:20:19 <jpena> next topic, then
15:20:25 <jpena> #topic next week's chair
15:20:51 <jpena> If I remember correctly, leanderthal offered to chair the meeting next week. However, if any of you is interested, raise your hand now
15:21:20 <amoralej> yes
15:21:25 <amoralej> he did
15:21:44 <apevec> she
15:22:11 * apevec reads back what he missed (doublebooked w/ other meeting)
15:22:38 <jpena> ok, no other volunteer
15:22:38 <amoralej> :)
15:22:47 <jpena> #action leanderthal to chair the next meeting
15:22:55 <jpena> #topic open floor
15:23:01 <amoralej> apevec, we discussed about queens rpm release for altarch
15:23:06 <amoralej> i'll ask you after the meeting
15:23:07 <jpena> Now it's the time to bring anything else for the discussion
15:23:35 <apevec> amoralej, we have it in rdo-infra
15:23:44 <apevec> but no build automation
15:24:20 <amoralej> yeah, but i'm not sure how to get it published in altarch extras
15:24:21 <apevec> https://review.rdoproject.org/r/#/q/project:rdo-infra/centos-release-openstack
15:24:35 <amoralej> it's only in x86_64 extras
15:24:40 <apevec> amoralej, do you have the build in CBS?
15:24:49 <amoralej> i need to check if last build is fine
15:24:57 <amoralej> if it has contentdir variable
15:25:00 <jpena> amoralej: http://cbs.centos.org/koji/buildinfo?buildID=21944
15:25:56 <apevec> amoralej, jpena - ah yes we need to make it back noarch
15:26:16 <apevec> making it arch was a workaround we tried before contentdir was introduced
15:26:22 <amoralej> yeap
15:26:29 <apevec> that's why it is published x86_64 only
15:26:40 <amoralej> ok
15:26:42 <apevec> send the review and rebuild
15:26:53 <amoralej> ok
15:27:00 <apevec> then as noarch it should be properly published
15:27:17 <amoralej> we can't tag in extras, right?
15:27:21 <apevec> you still need to ping centos-devel to get it published after tagging
15:27:24 <amoralej> do i need to create a bug?
15:27:28 <apevec> it's not automatic
15:27:30 <amoralej> to get it tagged?
15:27:40 <amoralej> ok
15:27:45 <apevec> I think I was able to tag
15:28:06 <amoralej> ok
15:30:06 <apevec> amoralej, actually you did for queens :)  Tue Feb 27 11:30:29 2018: centos-release-openstack-queens-1-1.el7.centos tagged into core7-extras-common-release by amoralej [still active]
15:30:26 <amoralej> oh :D
15:30:34 <amoralej> i didn't even remember
15:30:54 <amoralej> ok, i'll take care
15:31:28 <amoralej> one more topic for open floor
15:31:36 <amoralej> apevec, number80 please vote on https://review.rdoproject.org/r/#/c/15274/
15:31:42 <number80> sure
15:32:08 <apevec> +100
15:32:26 <number80> you get then to give the +W
15:32:29 <amoralej> merging :)
15:32:50 <amoralej> #info ykarel is now RDO provenpackager. Well done!!
15:33:18 <rdogerrit> Merged config master: Add ykarel as provenpackager  https://review.rdoproject.org/r/15274
15:33:27 <amoralej> here it is
15:33:55 <amoralej> one last point
15:34:04 <rdogerrit> rdo-trunk created openstack/networking-ansible-distgit rpm-master: python-networking-ansible: failed to build b0adb6e  https://review.rdoproject.org/r/15301
15:34:25 <amoralej> we are doing a prototype for adoption of python3 in specs in https://review.rdoproject.org/r/#/c/15247/
15:34:39 <amoralej> anyone interested on the topic can provide feedback
15:34:52 <amoralej> note that pattern is to build python2 or python3 only
15:35:04 <amoralej> not python2 AND python3 as we do for clients and libs
15:35:55 <amoralej> note there are still some open questions about the topic, so it's still open to discussion
15:36:00 <amoralej> that's it from me
15:37:26 <jpena> so, if there's nothing else to discuss, we can enjoy 20 minutes extra
15:38:42 <jpena> going once, going twice...
15:39:51 <jpena> #endmeeting