15:01:23 <number80> #startmeeting RDO meeting - 2018-10-24
15:01:23 <zodbot> Meeting started Wed Oct 24 15:01:23 2018 UTC.
15:01:23 <zodbot> This meeting is logged and archived in a public location.
15:01:23 <zodbot> The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:23 <zodbot> The meeting name has been set to 'rdo_meeting_-_2018-10-24'
15:01:23 <openstack> Meeting started Wed Oct 24 15:01:23 2018 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:27 <openstack> The meeting name has been set to 'rdo_meeting___2018_10_24'
15:01:31 <number80> #topic roll call
15:01:37 <rdogerrit> Alfredo Moralejo proposed rdoinfo master: Add oslo-upgradecheck to deps repo temporarily  https://review.rdoproject.org/r/17089
15:01:38 <number80> agenda is here: https://etherpad.openstack.org/p/RDO-Meeting
15:01:48 <amoralej> o/
15:01:49 <PagliaccisCloud> o/
15:02:13 <hitchover> o/
15:02:24 <jpena> o/
15:02:42 <number80> #chair amoralej PagliaccisCloud hitchover jpena
15:02:42 <zodbot> Current chairs: PagliaccisCloud amoralej hitchover jpena number80
15:02:43 <openstack> Current chairs: PagliaccisCloud amoralej hitchover jpena number80
15:04:15 <chandankumar> \o/
15:11:46 <number80> Let's start
15:11:49 <number80> #chair chandankumar
15:11:49 <zodbot> Current chairs: PagliaccisCloud amoralej chandankumar hitchover jpena number80
15:11:50 <openstack> Current chairs: PagliaccisCloud amoralej chandankumar hitchover jpena number80
15:12:03 <number80> #topic reserve rdo-* namespaces on gitlab
15:12:14 <number80> apevec: can you explain rationale?
15:14:14 <number80> jpena: ?
15:14:36 <chandankumar> number80: let me lead this topic
15:14:39 <jpena> I just know what apevec mentioned before the meeting
15:14:39 <number80> ok
15:15:24 <chandankumar> number80: since gitlab is new in market, someday we want to use gitlab services for mirroring the RDo stuff on gitlab
15:15:33 <number80> #info considering to move gerrit replication from github to gitlab
15:15:49 <chandankumar> that's why reserving the namespace on gitlab make sense
15:16:04 <number80> IMHO, reserving namespace in popular services is a good thing
15:16:34 <number80> If that's all, I suggest that we vote: +1 if you agree, -1 if you disagree, +0 if you have no opinion :)
15:16:38 <number80> +1
15:16:45 <jpena> +1 to reserving the namespace
15:16:57 <hitchover> 1
15:17:00 <hitchover> +
15:17:03 <amoralej> +1 to reserving
15:17:05 <jpena> also, there should be no special issue in mirroring our repos there, according to https://softwarefactory-project.io/docs/operator/gerrit_replication_operator.html
15:17:22 <number80> ack, this good thing
15:17:26 <amoralej> jpena can we have 1 to N replication ?
15:17:26 <chandankumar> number80: the same goes for software factory also
15:18:08 <jpena> amoralej: hmm, I haven't tested it, we'd have to investigate
15:18:39 <amoralej> because we don't want to stop replication to github, right?
15:18:49 <chandankumar> multiple places replication will also going to help, if somehting goes down we should provide fallback mechanias
15:19:06 <amoralej> at least, yet
15:19:16 <number80> chandankumar: well, I guess we need to have some experimenting before deciding on either switching completely to gitlab or have 1:N replication
15:19:42 <number80> reserving namespace implies we allow such experimentations to happen
15:19:44 <chandankumar> number80: first step would be reserving the namespace on gitlab and also considering bitbucker
15:19:54 <number80> chandankumar: good thinking
15:20:10 <number80> is anyone opposed to add bitbucket?
15:20:32 <chandankumar> number80: may be Duck or misc can help here
15:21:04 <chandankumar> since we are discussing this topic let's think about other community project we support
15:21:11 <number80> Duck is our main liaison with OSAS infra tream so he's welcome to provide his input
15:21:13 <chandankumar> may be OSAS can help on that
15:21:34 <number80> Well, for now, we should be fine with this
15:21:55 <number80> #agree Allow reserving rdo-* namespaces on both gitlab and bitbucket
15:22:31 <number80> (For newcomers, OSAS is community management team at Red Hat, and they've been providing us support on many topics)
15:22:36 <chandankumar> number80: we need someone to take the AI
15:22:48 <hitchover> ack
15:23:01 <number80> Yup, who wants it?
15:23:16 <number80> we can also defer that to apevec since he's not here :)
15:23:27 * jpena nods
15:23:46 <amoralej> :)
15:23:50 <number80> #action apevec reserve rdo-* namespaces on gitlab and bitbucket
15:24:48 <number80> #action number80 mail apevec and Duck about gitlab namespaces
15:25:08 <number80> So I guess we can move to the next topic
15:25:19 <number80> #topic Booth volunteers for OpenStack Summit Berlin
15:25:40 <number80> Since Rain is at OSS Summit, I'll handle that
15:26:08 <number80> So we're looking for volunteers to staff the community pod of the Red Hat booth
15:26:37 <PagliaccisCloud> add an asterisk next to your name if you'd like to do a demo!
15:27:07 <number80> Yes
15:27:08 <chandankumar> PagliaccisCloud: what about migrating jenkins job to zuul infra would be cool demo
15:27:12 <number80> Here's the link
15:27:14 <number80> https://etherpad.openstack.org/p/berlin-summit-community-pod
15:27:14 <chandankumar> with depending on feature
15:27:33 <chandankumar> PagliaccisCloud: I will be not there, but people will love it and increase adoption
15:27:40 <amoralej> i think demos for summit are more focused to openstack users
15:27:43 <PagliaccisCloud> chandankumar, yes!! that'd be awesome!
15:27:45 <number80> Anyone who will do 3 or more shifts gets an exclusive RDO hoodie
15:27:54 <number80> *exclusive*
15:27:55 <PagliaccisCloud> aw... :(
15:28:12 <number80> PagliaccisCloud: if you do demo, you can try to negotiate with Rain :)
15:28:34 <chandankumar> or tripleo standalone is another hot topic
15:28:35 <hitchover> who else will be at the booth?
15:28:42 <PagliaccisCloud> I've got one ready to go. openshift on openstack!
15:28:58 <amoralej> that's cool
15:29:07 <amoralej> i will not attend Summit
15:29:34 <PagliaccisCloud> i'll be there but there's no way i can put together a zuul demo in time, with everything else going on :/
15:29:36 <PagliaccisCloud> maybe next time
15:29:39 <amoralej> is the etherpad working for you?, i can't see it
15:29:42 <chandankumar> PagliaccisCloud: please make sure we have docs/public reference of the shift on stack deployment because last time people hitted with that who are consuming it
15:29:54 <hitchover> amoralej: not working for me
15:30:01 <chandankumar> i mean real usecase
15:30:08 <hitchover> amoralej: now works
15:30:08 <ykarel> o/
15:30:21 <amoralej> yeah, it came back
15:30:24 <number80> Good, let's move on
15:30:28 <chandankumar> that was from devconf.in 2018
15:30:32 <number80> #topic open floor
15:30:42 <number80> Anyone has a topic to bring?
15:30:46 <PagliaccisCloud> ok i'll put one together. thanks for the suggestion chandankumar. I hadn't thought about including one
15:30:51 <rdogerrit> Adam Kimball proposed rdo-infra/ci-config master: Add cico flavor specification to cico-node-get-to-ansible.sh  https://review.rdoproject.org/r/17004
15:30:54 <amoralej> number80, i added a last minute topic
15:30:59 <chandankumar> number80: I have one boring topic to bring
15:31:06 <amoralej> i can take it in open floor
15:31:08 <amoralej> no problem
15:31:10 <number80> ah right
15:31:16 <amoralej> it's just an update on python3 conversion
15:31:18 <number80> #topic python3 enabled status
15:31:41 <amoralej> so, in the last week there has been some progress
15:31:58 <amoralej> wrt packaging, there are a bunch of tempest plugins converted
15:32:25 <amoralej> and we've started converting clients to single subpackage
15:32:39 <amoralej> that means in fedora wi will not have python2 subpackages any more
15:32:47 <chandankumar> https://lists.rdoproject.org/pipermail/dev/2018-October/008952.html -> call for help on tempest plugins
15:32:49 <amoralej> we are about to merge the conversion for openstackclient
15:33:05 <amoralej> i think ykarel has taken care of some of them
15:33:17 <amoralej> tosky did it for sahara one, iirc
15:33:26 <chandankumar> vkmc: is working on manila
15:33:39 <tosky> tempest plugin for sahara, yep
15:33:49 <vkmc> o/
15:33:50 <chandankumar> we also pinged few people they will start working on that
15:33:51 <vkmc> covering manila
15:33:54 <amoralej> status is in https://review.rdoproject.org/etherpad/p/py3_conversion_status
15:34:01 <tosky> oh, forgot to update
15:34:03 <number80> Good job everyne!
15:34:12 <amoralej> i'll also add the list of clients
15:34:35 <rdogerrit> Adam Kimball created rdo-infra/ci-config master: Add CICO_FLAVOR variable to Triple O Upstream job  https://review.rdoproject.org/r/17090
15:34:46 <ykarel> amoralej, will do neutronclient if no one else started, need for  https://review.openstack.org/#/c/609596
15:34:56 <amoralej> and i'm not sure if i already mentioned in other meeting
15:35:26 <chandankumar> ykarel: check with slaweq he might help
15:35:27 <amoralej> we have a promotion pipeline for puppet running in https://ci.centos.org/view/rdo/view/weirdo-pipelines/view/weirdo-promote-test-puppet-fedora/
15:35:33 <amoralej> ykarel, ack
15:35:33 <chandankumar> regarding neutron
15:35:35 <tosky> amoralej: what is the part about "adding to rdoinfo"? I didn't do it for sahara-tests
15:35:52 <ykarel> amoralej, u discussed with slaweq regarding neutron projects conversion?
15:36:00 <amoralej> yes i did
15:36:03 <number80> #info new promotion pipeline running for puppet (fedora)
15:36:12 <amoralej> tosky, right, that's missing
15:36:25 <amoralej> you need to add stein-py3-uc tag
15:36:40 <ykarel> amoralej, do he or his team planning to convert those in coming days?
15:36:50 <ykarel> if yes we can wait
15:36:51 <amoralej> from networking side, i know they are aware of it, just probably lack of time
15:36:52 <chandankumar> amoralej: i think lots of packages got converted to py3 this week, we need to add it in rdoinfo
15:37:09 <tosky> amoralej: given the complication of merging things to rdoinfo (merge conflicts) wouldn't it make sense to do it in batches
15:37:10 <tosky> ?
15:37:21 <amoralej> yeah, we can add all in a single batch
15:37:34 <ykarel> yes all tempest plugin in one go
15:37:43 <amoralej> ykarel, from networking side
15:37:55 <amoralej> i'd just would do what is blocking us
15:38:01 <amoralej> we can wait for the rest
15:38:07 <amoralej> i'll remind them
15:38:20 <amoralej> they already did the neutron tempest plugin iirc
15:38:24 <chandankumar> amoralej: since all tempest plugin in one ago, can we a new attribute in rdoinfo like team which consist of a set of projects
15:38:26 <ykarel> amoralej, okk agreed, then i will do neutronclient and wait for others
15:38:29 <ykarel> amoralej, yes that's done
15:38:58 <amoralej> chandankumar, mmm
15:39:08 <chandankumar> having a since point of contact for bunch of project in a team through which we can poke them for conversion
15:39:23 <chandankumar> just an idea
15:39:31 <amoralej> yeah, i'm thinking
15:39:36 <amoralej> but not sure i follow
15:39:50 <amoralej> so you want to create an attribute in packates?
15:39:54 <chandankumar> amoralej: just like we have stuff in openstack governance
15:40:06 <amoralej> something like existing confs ?
15:40:19 <amoralej> chandankumar, i'll back to you after the meeting to discuss
15:40:28 <amoralej> i'm preparing some ideas for rdoinfo improvement
15:40:36 <number80> Yep, let's close this topic
15:40:38 <amoralej> and this could be one to add
15:40:43 <chandankumar> amoralej: yes, like we have grups for client/lib/tempest plugins
15:40:46 <amoralej> yeah, this was it
15:41:04 <chandankumar> amoralej: https://github.com/openstack/governance/blob/master/reference/projects.yaml#L63
15:41:24 <chandankumar> team followed by projects having a single point of contact as PTL or maintainer
15:41:29 <number80> please let's have those design discussion after we close the meeting :)
15:41:44 <number80> chandankumar: I think you had a topic?
15:41:46 <amoralej> yes, we will discuss later
15:41:53 <chandankumar> number80: yes
15:42:02 <chandankumar> number80: it is about easyfix project
15:42:13 <number80> #topic easyfix project
15:42:16 <number80> go ahead
15:42:39 <chandankumar> So here is the thing, we have RDO openstack tripleo all working together
15:43:00 <chandankumar> each of them are working hard to get contributions through different programs
15:43:06 <chandankumar> for example
15:43:13 <chandankumar> openstack - first contact sig
15:43:17 <chandankumar> rdo - easyfix
15:43:26 <chandankumar> tripleo - community meeting
15:43:48 <chandankumar> what about we can combine all the efforts in a single one which will benefit all
15:44:04 <chandankumar> we also inclide centos and fedora since we rely on that
15:44:21 <chandankumar> contributors always come and get confused where to start
15:44:35 <chandankumar> writing docs needs hardware contributing code is much easier
15:44:51 <chandankumar> we have written tools in order to make the contribution easier
15:45:04 <chandankumar> but we always failed to attract the contributor
15:45:46 <chandankumar> my question is how we can work toegther to bring more people to the community as people always moves towards shiny things like k8s ir machine learning
15:45:55 <chandankumar> ?
15:46:09 <PagliaccisCloud> teach people how to incorporate those shiny things into openstack?
15:46:11 <chandankumar> since we are going to summit, I think we can bring this topic
15:46:27 <chandankumar> PagliaccisCloud: all those shiny things we are already consuming
15:46:42 <PagliaccisCloud> or how openstack makes those shiny things better? i've got a lightning talk on that
15:47:29 <chandankumar> when any oen contributes to any project they always look for something
15:47:38 <PagliaccisCloud> does anyone know which projects have the most atcs? what are they doing to attract people?
15:47:40 <chandankumar> like if I contribute I can do this or get a job or soemthing
15:47:57 <number80> PagliaccisCloud: we have OpenStack Upstream Training in that aspect (/me won't comment current status)
15:48:32 <chandankumar> I donot know how to address this topic but we are also starving from the contribution
15:48:38 <PagliaccisCloud> good point. most of the would-be contributors i've talked to have been looking for resume fillers
15:49:09 <PagliaccisCloud> & others just need experience. hm...
15:49:32 <number80> Well, I guess that we need to see how we can collaborate with the Foundation
15:49:48 <number80> chandankumar: are you willing to start a discussion on the mailing-lists?
15:49:57 <chandankumar> number80: sure I can add an AI for that
15:50:03 <number80> *nods*
15:50:21 <PagliaccisCloud> upstream institute always has their 1st time contributor workshop - is RDO involved at all?
15:50:30 <PagliaccisCloud> can we/you squeeze in during this summit?
15:51:02 <chandankumar> PagliaccisCloud: it is always openstack specific
15:51:05 <number80> PagliaccisCloud: well, we have various contributors here who are mentors, but we can contact them to do that
15:51:08 <amoralej> I think it's also good to think where/when have we been more successful with contributors
15:51:29 <number80> But I fear we won't have enough representation in Berlin Summit for that to happen
15:51:38 <PagliaccisCloud> what about red hat summit?
15:51:57 <chandankumar> amoralej: one thing last time we kicked easyfix we almost cleared the tech debts in spec file
15:52:05 <chandankumar> it was kind of beneficial for us
15:52:10 <amoralej> yeah
15:52:19 <amoralej> that worked fine
15:52:20 <number80> PagliaccisCloud: well, we'd have to talk with Rain, RH Summit is notoriously hard to get in for RH employees :)
15:52:34 <PagliaccisCloud> if i submit a first time contributor workshop, would any of you guys be willing to partner with me?
15:52:39 <PagliaccisCloud> for RHS*
15:52:56 <chandankumar> during pycon india, people suggested me to use this https://gitcoin.co/ for open source project contribution
15:53:01 <PagliaccisCloud> workshops need at least two presenters
15:53:07 <number80> PagliaccisCloud: sure, but take contact with Rain first, maybe Rich Bowen too
15:53:15 <PagliaccisCloud> ok, i'll reach out to them
15:53:32 <number80> PagliaccisCloud: you can copy me or anyone who is more motivated to go at RH Summit
15:53:39 <amoralej> PagliaccisCloud, looks like a good idea
15:53:46 * number80 is not too keen to go in the US recently
15:53:56 <amoralej> i haven't seen in previous summits
15:53:59 <PagliaccisCloud> number80, lol me either & i live here :D
15:54:24 <amoralej> and could be interesting to do some practical perspective about how a community work
15:54:27 <number80> PagliaccisCloud: I suspect Rain can co-present with you but I'd rather not decide in her stead
15:54:38 <number80> And she's used to do such workshops
15:54:39 <chandankumar> we are working on awesome stuff on which most of the world software runs, we need to think on how to attaract people because in job market it is also veyr hard to get skilled people working on openstack
15:54:59 <number80> +2
15:55:12 <chandankumar> the sitaution with openstack these days is like early years of Linux kernel
15:55:43 <chandankumar> that's it from my side
15:55:49 <number80> I guess we have now to close the topic
15:55:57 <number80> please add actions PagliaccisCloud and chandankumar :)
15:56:20 <number80> And who would want to chair next week  meeting
15:56:23 <PagliaccisCloud> ok
15:56:52 <PagliaccisCloud> #action PagliaccisCloud will start emails with Rain & Rich on possible 1st time contributor workshop at upcoming Red Hat Summit
15:56:55 <chandankumar> #action chandankumar to kick discusssion on merging efforts taken by tripleo rdo and openstack community to attract contributors
15:56:55 * ykarel would be not be available next week
15:57:33 * chandankumar also not sure as Diwali / Winter is coming in india :-)
15:57:59 <number80> Thanks
15:58:08 <number80> well, I can do it again next week
15:58:20 <number80> #info number80 again chairing next week
15:58:47 <number80> Thanks for attending, and see you next week (and happy Diwali for our indian friends!)
15:58:52 <number80> #endmeeting