15:00:56 <jpena> #startmeeting RDO meeting - 2019-03-06
15:00:56 <zodbot> Meeting started Wed Mar  6 15:00:56 2019 UTC.
15:00:56 <zodbot> This meeting is logged and archived in a public location.
15:00:56 <zodbot> The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:56 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-03-06'
15:00:58 <openstack> Meeting started Wed Mar  6 15:00:56 2019 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:01 <openstack> The meeting name has been set to 'rdo_meeting___2019_03_06'
15:01:10 <jpena> #topic roll call
15:01:20 <amoralej> o/
15:01:21 <jpena> remember to add any last-minute topic to the agenda: https://etherpad.openstack.org/p/RDO-Meeting
15:01:25 <jpena> #chair amoralej ykarel
15:01:25 <zodbot> Current chairs: amoralej jpena ykarel
15:01:25 <openstack> Current chairs: amoralej jpena ykarel
15:01:26 <ykarel> o/
15:01:30 <mjturek> o/
15:01:37 <PagliaccisCloud> o/
15:01:45 <jpena> #chair mjturek PagliaccisCloud
15:01:45 <zodbot> Current chairs: PagliaccisCloud amoralej jpena mjturek ykarel
15:01:46 <openstack> Current chairs: PagliaccisCloud amoralej jpena mjturek ykarel
15:01:49 <baha> o/
15:02:31 <jpena> #chair baha
15:02:31 <zodbot> Current chairs: PagliaccisCloud amoralej baha jpena mjturek ykarel
15:02:31 <openstack> Current chairs: PagliaccisCloud amoralej baha jpena mjturek ykarel
15:04:37 <jpena> let's start with the agenda
15:04:43 <jpena> #topic Status of Stein release
15:04:45 <rdogerrit> Alfredo Moralejo created rdo-infra/ci-config master: Move weirdo jobs to ci aggretate temporarily  https://review.rdoproject.org/r/19138
15:04:52 <jpena> amoralej: ^^
15:04:53 <rdogerrit> Merged openstack/ovsdbapp-distgit rpm-master: Move req python[*]-fixtures to -test subrpm  https://review.rdoproject.org/r/19136
15:05:16 <amoralej> it's just to share the status and plans for Stein GA preparation tasks
15:05:40 <amoralej> jpena has already created new DLRN builders following stable/stein branches
15:05:52 <amoralej> both for centos7 and fedora-stabilized
15:06:05 <amoralej> bootstrap is finished
15:06:10 <amoralej> and both are consistent
15:06:30 <amoralej> currently are available in http://trunk.rdoproject.org/centos7-stein-bootstrap
15:06:46 <amoralej> and http://trunk.rdoproject.org/fedora28-stein-bootstrap
15:07:06 <amoralej> tomorrow we'll switch centos7-stein and fedora28-stein links to the new builders
15:07:31 <amoralej> #info DLRN builders for CentOS7 and Fedora28 chasing stable/stein branches are bootstrapped
15:08:13 <amoralej> #info URLs http://trunk.rdoproject.org/centos7-stein and http://trunk.rdoproject.org/fedora28-stein will be switched to new builders tomorrow
15:08:34 <amoralej> any user that wants to use master branches must use centos7-master
15:08:52 <amoralej> apart from that, we are already starting requirements updates for stein
15:09:36 <amoralej> #info requirements adjustements for stein ongoing in https://review.rdoproject.org/r/#/q/topic:stein-branching
15:09:49 <amoralej> we should start doint it for libraries
15:09:57 <amoralej> and clients at the end of this week
15:10:14 <amoralej> and we will start branching distgits and building libraris early next week
15:10:35 <amoralej> #info we will start branching distgits and building libraris early next week
15:10:53 <amoralej> #action maintainers send required adjustments for distgits for stein
15:10:57 <ykarel> amoralej, do you know when stable/stein branches created upstream, i see only few created till now
15:11:01 <amoralej> i think that's it
15:11:24 <amoralej> ykarel, for libraries and clients, it's not a big problem to have the branches created because they are pinned
15:11:40 <amoralej> for others, it should be in rc1
15:12:16 <ykarel> amoralej, yup, was unsure about the timing, so asked
15:12:20 <amoralej> we are also finishing deps rebases for stain
15:12:25 <amoralej> yeah, it should be soon
15:12:28 <weshay|rover> 0/
15:12:42 <ykarel> ack
15:13:03 <amoralej> i think that's it from me
15:13:08 <ykarel> #link status for release at https://review.rdoproject.org/etherpad/p/stein-release-preparation
15:13:19 <jpena> ok, let's move on then
15:13:20 <amoralej> thanks ykarel
15:13:22 <jschlueter> tempest is one of few that still has dep on os-testr and not yet flipped to stestr?
15:13:44 <jpena> #topic open floor
15:13:50 <weshay|rover> you guys are ready for CI to start building ci jobs for stein it seems, right?
15:13:53 <ykarel> tempest should be switched i think
15:13:55 <weshay|rover> I see repos w/ links :)
15:13:59 <amoralej> weshay|rover, almost
15:14:01 <amoralej> yes
15:14:05 <weshay|rover> amoralej++
15:14:10 <weshay|rover> one other qq
15:14:12 <amoralej> we are consistent, we just need to switch links
15:14:25 <amoralej> we expect to do it tomorrow, i'll send a mail to the ML
15:14:28 <weshay|rover> Pike, does rdo need more builds of Pike due to the extended release?
15:14:34 * Duck o/
15:14:43 <weshay|rover> there are issues w/ ceph that will require a bit of work to promote another build
15:14:52 <weshay|rover> amoralej k.. thanks
15:15:07 <amoralej> weshay|rover, you mean pike with ceph is broken?
15:15:22 <weshay|rover> on unpromoted builds yes
15:15:52 <amoralej> according to https://releases.openstack.org/ pike is still maintained
15:15:55 <weshay|rover> so there is a significant cost to not EOL pike atm
15:16:21 <amoralej> so i'd like to get pike dlrn builder running
15:16:24 <ykarel> promoted builds should also be affected i think
15:16:40 <amoralej> what introduced the problem? update in ceph?
15:16:50 <weshay|rover> fultonj can you comment
15:17:16 <weshay|rover> amoralej lp 1817688
15:17:17 <openstack> Launchpad bug 1817688 in tripleo "job that test ceph in periodic pipeline for stable branches are getting the wrong configuration" [Critical,Fix released] https://launchpad.net/bugs/1817688 - Assigned to Gabriele Cerami (gcerami)
15:17:23 <fultonj> yes
15:17:38 <fultonj> tripleo ci can't fully switch on versions
15:17:51 <amoralej> oh, that i remember now
15:18:12 <fultonj> we switched ceph from filestore to bluestore for all versions which support it
15:18:22 <fultonj> pike doesn't because pike is aligned with jewel
15:18:39 <amoralej> there is no easy wat to switch back in pike?
15:18:41 <rdogerrit> Sagi Shnaidman proposed rdo-infra/ansible-role-tripleo-ci-reproducer master: Run centos jobs on vexxhost  https://review.rdoproject.org/r/19134
15:18:48 <fultonj> easy no
15:19:21 <amoralej> weshay|rover, so you are proposing to stop promoting pike, iiuc
15:19:35 <fultonj> tripleo ci can get an option to switch on version at a cost
15:19:49 <fultonj> is value(cost) > keeping pike
15:19:52 <fultonj> that's the question?
15:20:18 <weshay|rover> amoralej pretty much yes
15:20:54 <amoralej> well, it's almost moving to extended maintenance
15:21:01 <amoralej> i'd keep dlrn builders running
15:21:08 <amoralej> so that user can consume package updates
15:21:41 <amoralej> even if it's for non-ceph or even non-tripleo environments
15:21:50 <fultonj> option: keep builder but stop CI'ing ceph jobs on it
15:22:12 <weshay|rover> I suppose we could remove ooo from pike criteria
15:22:30 <fultonj> weshay|rover: perhaps not all ooo but just ooo w/ ceph?
15:22:32 <amoralej> or maybe ooo+ceph
15:22:35 <fultonj> for pike only
15:22:36 <amoralej> would that work?
15:22:40 <amoralej> for pike
15:22:49 <weshay|rover> I think it's a viable option
15:23:50 <fultonj> who would remove the ooo+ceph from pike?
15:24:06 <fultonj> is that a weshay|rover thing or an amoralej thing?
15:24:37 <weshay|rover> fultonj we should look at that together
15:24:51 <ykarel> fultonj, so iiuc tasks in https://review.openstack.org/#/c/637196/6/roles/ceph-loop-device/tasks/main.yml caused it
15:25:03 <ykarel> and specifically using ceph_loop_device
15:25:13 <fultonj> ykarel: yeah i know
15:25:33 <fultonj> see line 40 it doesnt' work
15:25:36 <ykarel> so using different loop_device will not solve it
15:25:55 <ykarel> yup i know that, release is master in periodic jobs
15:26:02 <amoralej> i think we could update periodic pipeline and promoter to just remove ceph jobs
15:26:15 <fultonj> amoralej: ++
15:26:41 <fultonj> different loop_device ?
15:26:49 <fultonj> that's horrible and ugly but it might work
15:27:16 <ykarel> hmm that what i got from error it's used somewhere
15:27:31 <ykarel> so using different might be a workaround
15:27:53 <ykarel> but ok to remove jobs and keep dlrn running
15:28:36 <amoralej> +1 to remove the job, even removing the full promotion is not a big problem imo
15:29:07 <fultonj> ykarel++ good idea
15:29:12 <fultonj> i'll try the workaround
15:29:15 <fultonj> next step me
15:29:20 <fultonj> i'll update this group with results
15:29:42 <fultonj> if it doesnt' work let's go to plan b
15:29:52 <fultonj> remove jobs and keep dlrn running
15:29:53 <fultonj> ok?
15:30:00 <fultonj> weshay|rover: amoralej ykarel ?
15:30:06 <ykarel> +1 for me
15:30:12 <gfidente> +1 fwiw
15:30:25 <weshay|rover> cool, fultonj I'll sync w/ u
15:31:06 <jpena> any action to record?
15:31:40 <fultonj> #ACTION fultonj to try second loop devices for https://review.openstack.org/#/c/637196/ and pike and report if it fixes pike job xor we remove ooo+ceph tests for pike only
15:32:10 <fultonj> i'd like to talk about https://review.rdoproject.org/r/#/c/18721/ at the approipriate time
15:32:14 <ykarel> fultonj, you can test failing pike job like https://review.rdoproject.org/r/#/c/19017 with depends on on tripleo-ci patch just in case u are not aware
15:32:15 <fultonj> as anothe topic
15:32:26 <jpena> #agreed keep RDO Trunk pike but remove ceph from pike promotion criteria
15:33:00 <jpena> fultonj: the previous topic is done, feel free to start with ansible
15:33:51 <fultonj> #TOPIC ansible 2.7 in rdo for train https://review.rdoproject.org/r/#/c/18721/
15:34:05 <jpena> #topic  ansible 2.7 in rdo for train https://review.rdoproject.org/r/#/c/18721/
15:34:11 <jpena> it's lowercase :D
15:34:14 <fultonj> thanks jpena
15:34:38 <amoralej> any update on nautilus release?
15:34:39 <fultonj> we're blocked on needing newer clients
15:34:45 <fultonj> nautilus clients
15:34:50 <gfidente> yeah I can't get a build to pass in centos/cbs
15:34:56 <gfidente> have to retry
15:35:21 <fultonj> can we get help w/ why 1. https://cbs.centos.org/koji/getfile?taskID=710313&name=build.log&offset=-4000 fails?
15:35:25 <fultonj> ktdreyer: ^ :)
15:37:08 <fultonj> that's the status update. https://review.rdoproject.org/r/#/c/18721 is blocked on getting clients on failure ^
15:41:27 <fultonj> so should we move on?
15:41:43 <jpena> yes, let's continue
15:41:48 <jpena> #topic chair for next meeting
15:42:00 <jpena> do we have any volunteer to chair next week's meeting?
15:43:17 <mjturek> jpena: I can run
15:43:24 <jpena> thanks mjturek!
15:43:31 <jpena> #action mjturek to chair the next meeting
15:44:00 <mjturek> np
15:44:10 <jpena> ok, so unless we have any other topic to bring, let's end the meeting and put those extra 15 minutes to good use
15:44:15 <rdogerrit> Merged openstack/oslo-concurrency-distgit rpm-master: remove Req on python3-fixtures from main package  https://review.rdoproject.org/r/19133
15:44:19 <mjturek> oh I do!
15:44:23 <mjturek> baha and I are looking for the proper way to get the IP of the jenkins slave running the job for ci.centos.org through ansible. We need it to properly rsync the logs to the logserver. Anyone have any insight here?
15:45:22 <jpena> mjturek: do you need to get it from the cico node, or from the slave itself?
15:45:53 <mjturek> the slave itself!
15:47:51 <jpena> there must be an ansible fact you can use, let me check
15:48:57 <mjturek> jpena: maybe this ansible_default_ipv4.address?
15:49:12 <jpena> mjturek: yep, that's what I was thinking about
15:49:40 <mjturek> cool!
15:49:57 <mjturek> and I think it would just need to run on localhost to properly resolve right?
15:50:25 <jpena> yes
15:50:40 <mjturek> cool! I think we're good then, thanks jpena
15:50:58 <jpena> so this is everyone's last chance of raising a topic!
15:51:50 <rdogerrit> Merged openstack/tripleo-heat-templates-distgit rpm-master: Updates on directories  https://review.rdoproject.org/r/19132
15:53:04 <jpena> 3, 2, 1...
15:53:10 <jpena> gone!
15:53:13 <jpena> #endmeeting