15:01:53 <jpena> #startmeeting RDO meeting - 2019-08-21
15:01:53 <zodbot> Meeting started Wed Aug 21 15:01:53 2019 UTC.
15:01:53 <zodbot> This meeting is logged and archived in a public location.
15:01:53 <zodbot> The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:53 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-08-21'
15:01:53 <openstack> Meeting started Wed Aug 21 15:01:53 2019 UTC and is due to finish in 60 minutes.  The chair is jpena. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:56 <openstack> The meeting name has been set to 'rdo_meeting___2019_08_21'
15:02:08 <jpena> Please add any last-minute topic to the agenda at https://etherpad.openstack.org/p/RDO-Meeting
15:02:10 <jcapitao> jpena: o/
15:02:12 <jpena> #topic roll call
15:02:16 <jpena> #chair jcapitao
15:02:16 <zodbot> Current chairs: jcapitao jpena
15:02:17 <openstack> Current chairs: jcapitao jpena
15:02:18 <zbr> o/
15:02:27 <jpena> #chair zbr
15:02:27 <zodbot> Current chairs: jcapitao jpena zbr
15:02:29 <openstack> Current chairs: jcapitao jpena zbr
15:02:42 <ykarel> o/
15:02:54 <jpena> #chair ykarel
15:02:54 <zodbot> Current chairs: jcapitao jpena ykarel zbr
15:02:55 <openstack> Current chairs: jcapitao jpena ykarel zbr
15:03:34 <amoralej> o/
15:03:48 <jpena> #chair amoralej
15:03:48 <zodbot> Current chairs: amoralej jcapitao jpena ykarel zbr
15:03:49 <openstack> Current chairs: amoralej jcapitao jpena ykarel zbr
15:05:29 <jpena> so.. there's not a lot in the agenda :)
15:05:32 <jpena> #topic open floor
15:05:38 <jpena> Anything to be discussed?
15:07:35 <amoralej> just one update about centos8
15:07:39 <amoralej> according to https://wiki.centos.org/About/Building_8
15:07:50 <amoralej> it's very close to be ready
15:08:38 <jpena> #info CentOS 8 is coming soon: https://wiki.centos.org/About/Building_8
15:08:44 <ykarel> nice, but no ETA available for release there
15:08:53 <amoralej> nop
15:09:19 <amoralej> ah, and about 7.7
15:09:36 <amoralej> i've requested to remove ocata and pike
15:10:01 <amoralej> as it's not supported anymore
15:10:02 <ykarel> amoralej, remove buildsys-tags?
15:10:05 <amoralej> no
15:10:06 <amoralej> i mean
15:10:09 <amoralej> removing the repos
15:10:22 <amoralej> when a new minor release is created in centos
15:10:43 <amoralej> it's the time when repos can be removed
15:10:53 <ykarel> ack
15:11:00 <amoralej> from http://mirror.centos.org/centos/7/cloud/x86_64/
15:11:01 <PagliaccisCloud> \o
15:11:08 <jpena> #chair PagliaccisCloud
15:11:08 <zodbot> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel zbr
15:11:10 <openstack> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel zbr
15:11:28 <amoralej> as, actualy /7 is a link to the last minor
15:11:40 <amoralej> now is http://mirror.centos.org/centos/7.6.1810/
15:11:56 <amoralej> when 7.7 is released, there is a new directory and content is copied
15:11:58 <amoralej> from sigs
15:12:25 <amoralej> so i requested to remove EOL releases
15:12:32 <ykarel> ack
15:12:50 <ykarel> amoralej, do you know when packages get available in cr repo
15:13:15 <ykarel> i remember it's before new update is released
15:13:23 <amoralej> yes
15:13:24 <ykarel> http://mirror.centos.org/centos/7/cr/x86_64/Packages/
15:13:31 <amoralej> they send a mail to centos-devel
15:13:45 <amoralej> i'd say one week before or so
15:13:49 <ykarel> ohhk
15:15:01 <ykarel> amoralej, and regarding, CentOS8, once it's released, we need to request train centos8 tags, right
15:15:10 <ykarel> i see there is new koji instance https://koji.mbox.centos.org/koji/tags
15:15:17 <amoralej> #info CloudSIG repo for ocata and pike will be removed with CentOS 7.7 GA
15:15:37 <amoralej> ykarel, yes, that's the one used for CentOS8
15:15:51 <amoralej> not sure if there will be the same for CBS or a new one
15:16:01 <amoralej> but i think they will move from existing one
15:16:07 <amoralej> we need to stay tuned
15:16:35 <ykarel> yup
15:17:05 <amoralej> one last thing, fedora is bootstraping f32 on python3.8
15:17:31 <amoralej> we may need to fix things and enable bootstrap macros for some packages
15:17:53 <amoralej> i did yesterday for oslotest, but need to keep an eye on it
15:18:30 <ykarel> amoralej, where are u tracking all this, u said u creating etherpad yesterday
15:19:02 <amoralej> dunno, the problem is that i don't find a way to list other that checking my mail
15:19:17 <ykarel> ohhk np
15:20:33 <amoralej> they are creating ftbfs in bz https://bugzilla.redhat.com/show_bug.cgi?id=1743899
15:20:34 <openstack> bugzilla.redhat.com bug 1743899 in python-oslo-utils "python-oslo-utils fails to build with Python 3.8" [High,New] - Assigned to apevec
15:21:23 <amoralej> they are opening them for real issues that are blocking
15:21:26 <amoralej> which is good
15:21:51 <amoralej> and blocking https://bugzilla.redhat.com/show_bug.cgi?id=1686977
15:21:53 <openstack> bugzilla.redhat.com bug 1686977 in Changes Tracking "Python 3.8" [Unspecified,Modified] - Assigned to mhroncok
15:22:11 <amoralej> so we may look for bz blocking that and list by package
15:22:14 <amoralej> i'll check
15:22:27 <ykarel> ack
15:23:35 <jcapitao> you want to proactively update the package before having a bz ticket ?
15:23:42 <ykarel> hmm too many failures https://koji.fedoraproject.org/koji/builds?prefix=p&userID=churchyard&order=-build_id&state=3
15:24:56 <amoralej> we can start fixing the ones with bz
15:25:42 <ykarel> we can also check all packages and there f32 builds https://src.fedoraproject.org/group/openstack-sig
15:25:55 <ykarel> and try build in order
15:28:43 <amoralej> https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&bug_status=NEW&bug_status=ASSIGNED&f1=blocked&f2=assigned_to&list_id=10432013&o1=substring&o2=anywords&query_format=advanced&v1=1686977&v2=apevec%20jpena%20amoralej%20ykarel%20hguemar
15:28:47 <amoralej> ykarel, ^
15:28:51 <amoralej> may be good
15:28:58 <amoralej> in fact you have one :)
15:29:11 <amoralej> need to start by fixing oslo-utils
15:29:16 <amoralej> that will probably unblock others
15:30:05 <ykarel> hmm i filed issue upstream for the one i had, need to followup
15:30:12 <ykarel> that's not openstack one though
15:30:38 <amoralej> ups https://bugs.python.org/issue37218
15:30:58 <amoralej> probably needs fix upstream too
15:31:51 <ykarel> yes, the one i saw was also python3.8 issue, related to ast
15:32:30 <jpena> amoralej: that definitely needs an upstream fix
15:32:39 <amoralej> if it's only affecting tests we may be able to trick
15:33:26 <amoralej> let me expend some time on it
15:33:30 <ykarel> yes only tests should be affected
15:34:18 <ykarel> getting upstream fixes, will also need tag released and so on, else we need patches
15:34:36 <jpena> if we get the upstream fix, we can carry a .patch for a while
15:34:58 <ykarel> yes
15:34:59 <amoralej> yes
15:35:09 <amoralej> we'll need to fix patch in distgit
15:35:36 <amoralej> in fact merging a patch in a stable branch for a python version which is not supported is weird
15:35:46 <amoralej> let's send it to master and put the .patch
15:36:19 <ykarel> ack
15:36:32 <jpena> amoralej: well, it's a deprecated parameter since 3.4, maybe it would be accepted
15:36:34 <jpena> but anyway
15:36:46 <amoralej> that's also true
15:36:59 <amoralej> and convincing
15:39:32 <jpena> anything else to discuss? Else we can get ~20 minutes back
15:41:54 <jpena> going once, going twice...
15:42:06 <jpena> oh, I forgot!
15:42:15 <jpena> any volunteer to chair the next meeting?
15:42:27 <ykarel> I can take it
15:42:37 <jpena> #action ykarel to chair the next meeting
15:42:39 <jpena> thanks ykarel
15:42:45 <jpena> ok, let's close it
15:42:48 <jpena> #endmeeting