15:01:42 <amoralej> #startmeeting RDO meeting - 2019-09-25
15:01:42 <zodbot> Meeting started Wed Sep 25 15:01:42 2019 UTC.
15:01:42 <zodbot> This meeting is logged and archived in a public location.
15:01:42 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:42 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-09-25'
15:01:43 <openstack> Meeting started Wed Sep 25 15:01:42 2019 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:46 <openstack> The meeting name has been set to 'rdo_meeting___2019_09_25'
15:01:51 <amoralej> #chair ykarel jcapitao
15:01:51 <zodbot> Current chairs: amoralej jcapitao ykarel
15:01:53 <openstack> Current chairs: amoralej jcapitao ykarel
15:02:06 <amoralej> still have time to add your topics to https://etherpad.openstack.org/p/RDO-Meeting
15:03:43 <jpena> o/
15:04:45 <amoralej> #chair jpena
15:04:45 <zodbot> Current chairs: amoralej jcapitao jpena ykarel
15:04:45 <openstack> Current chairs: amoralej jcapitao jpena ykarel
15:05:44 <weshay> 0/
15:06:17 <amoralej> #chair weshay
15:06:17 <zodbot> Current chairs: amoralej jcapitao jpena weshay ykarel
15:06:19 <openstack> Current chairs: amoralej jcapitao jpena weshay ykarel
15:07:10 <amoralej> let's start with the first topic
15:07:24 <amoralej> #topic Train branching status
15:07:36 <amoralej> #info RC1 week going on upstream, stable/train being created, reqcheck started in RDO for these projects
15:07:45 <amoralej> #link https://review.rdoproject.org/r/#/q/topic:train-branching
15:07:48 <amoralej> ykarel, ^
15:07:51 <ykarel> o/
15:08:08 <ykarel> Yes so upstream RC this week, and projects cutting stable/train
15:08:22 <ykarel> on RDO side we started requirement sync with https://review.rdoproject.org/r/#/q/topic:train-branching
15:08:32 <ykarel> reviews appreciated for ^^
15:09:11 <ykarel> and may be rlandy chandankumar  can share any news about promotion pipeline
15:09:23 <ykarel> as they are working on preparing those
15:10:02 <ykarel> #link https://review.rdoproject.org/r/#/q/topic:train-jobs
15:10:14 <ykarel> jobs are added with reviews ^^
15:11:34 <ykarel> that's it from me, we can move if no  queries
15:11:55 <ykarel> job status is clear from those reviews, it's still WIP
15:12:12 <amoralej> chandankumar, rlandy any ETA for promotion pipeline on train repo?
15:14:05 <amoralej> seems, they are not available
15:14:12 <amoralej> let's move on
15:14:14 <amoralej> to next topic
15:14:23 <ykarel> yes we can followup offline
15:14:35 <amoralej> #topic CentOS8 is available
15:14:44 <amoralej> \o/
15:14:48 <jpena> |o/
15:14:53 <amoralej> let's celebrate and thank centos team!
15:15:00 <jcapitao> \o/
15:15:09 <EmilienM> woot woot
15:15:19 <amoralej> #link https://wiki.centos.org/Manuals/ReleaseNotes/CentOS8.1905
15:15:37 <ykarel> \o/
15:15:54 <rlandy> amoralej: sorry - re: promotion pipeline ... there are still a few jobs to add
15:15:58 <amoralej> #info currently repos for centos8 are available, not cloud or container images
15:16:10 <amoralej> rlandy, ack
15:16:12 <rlandy> and then we need to merge the weekend pipeline review
15:16:20 <rlandy> before we add train pipeline
15:16:28 <amoralej> train promotion depends on moving to weekend?
15:16:31 <amoralej> oh
15:16:34 <rlandy> to latest-release pipeline
15:16:47 <rlandy> otherwise we will have a ton of jibs running concurrently
15:16:49 <amoralej> ok, we can follow up after the meeting
15:17:00 <amoralej> i'd like to get a promotion in queens first
15:17:04 <amoralej> ok
15:17:11 <rlandy> k - let's talk after the meeting
15:17:26 <amoralej> dib team is also working to add support for centos8 already
15:17:46 <amoralej> so we may be able to add centos8 images to zuul
15:17:48 <amoralej> also
15:18:08 <amoralej> CentOS Streams has been announce
15:18:17 <amoralej> for the ones that didn't hear about
15:19:02 <amoralej> #info new CentOS Streams has been announced https://lists.centos.org/pipermail/centos-announce/2019-September/023449.html
15:19:25 <amoralej> so far, the plan is to initially release Train on CentOS 7
15:19:39 <amoralej> as it has arrived too late for GA
15:20:02 <amoralej> and later add support for it
15:20:23 <jpena> can we add that somewhere to https://review.rdoproject.org/etherpad/p/moving-rdo-to-centos8
15:20:25 <jpena> ?
15:20:31 <amoralej> #info the plan for RDO and CentOS8 is in https://review.rdoproject.org/etherpad/p/moving-rdo-to-centos8
15:20:46 <amoralej> please review
15:20:51 <jpena> I see the pad was written when we were young and naive, and thought centos 8 would be there on time
15:20:57 <amoralej> jpena, i've reviewed the etherpad today
15:21:01 <amoralej> :)
15:21:12 <amoralej> i thought it was more or less clear
15:21:15 <amoralej> maybe it's not
15:21:25 <amoralej> "Have a full RDO Trunk Train repo for CentOS8 in addition to CentOS7 post-GA"
15:21:39 <amoralej> I'll be more explicit
15:21:42 <jpena> I was reading the steps
15:21:55 <jpena> they mention master using train-uc tags and similar
15:22:02 <ykarel> yup let's clean the info if it's outdated
15:22:03 <amoralej> ah, yeah
15:22:10 <amoralej> i focused on revieweing the first part
15:22:12 <amoralej> goals
15:22:22 <amoralej> and initial steps
15:22:29 <amoralej> i'll keep fixing after the meeting
15:23:09 <amoralej> yeah, some adjustments are needed
15:23:10 <amoralej> ok
15:23:26 <amoralej> also, need to discuss how we can leverage CentOS Streams
15:24:09 <amoralej> it looks great to test new CentOS/RHEL content before it actually lands in RHEL and CentOS8
15:24:24 <amoralej> which has been an issue in the past
15:24:49 <amoralej> anyway there are still a bunch of details to discover about Streams
15:24:51 <ykarel> yes that would really help
15:25:08 <amoralej> we still have time to discuss
15:25:25 <amoralej> so far, we'll start using CentOS8 as we've been using CentOS7
15:25:51 <amoralej> at some point we'll see if we can add streams only for periodic validation or even to move master to it
15:25:54 <amoralej> we'll see
15:26:45 <amoralej> so far, there is not community build system for CentOS8 yet, so we can not start building dependencies
15:27:09 <amoralej> still working with centos to get the infra ready for it
15:27:23 <ykarel> hmm also seems there is no ETA for it yet
15:27:26 <amoralej> #info there is not community build system for CentOS8 yet, so we can not start building dependencies
15:27:49 <amoralej> ykarel, no, there is not, in fact it's not clear how it will be deployed
15:27:59 <jcapitao> is it not the same as centos7 ?
15:28:02 <amoralej> we'll keep updating status in weekly meetings and reports
15:28:05 <ykarel> hmm i saw discussion on #centos-devel, they need to plan yet
15:28:13 <amoralej> jcapitao, not the same as for centos7
15:28:27 <amoralej> there is mail thread in centos-devel ML too
15:28:56 <ykarel> there was https://koji.mbox.centos.org/koji/builds for bootstrapping
15:29:02 <ykarel> but they are considering migration
15:29:20 <amoralej> #link https://lists.centos.org/pipermail/centos-devel/2019-September/017800.html
15:29:56 <amoralej> one of the questions is if SIGs need to *build* modules or not initially
15:30:45 <ykarel> would be better if SIGs choose common approach
15:31:01 <ykarel> atleast which are dependent on each other
15:31:07 <amoralej> i think most or all sigs were thinking in not providing modules
15:31:07 <amoralej> but
15:31:14 <amoralej> virtsig may need it
15:31:33 <amoralej> to override base virtualization packages provided in virt module in base
15:31:52 <amoralej> but afaik it's not clear how the advanced virtualization is going to be rebuilt
15:32:48 <chandankumar> amoralej: it is work in progress
15:33:05 <chandankumar> amoralej: we will get the pipeline up but not sure it will work
15:33:15 <amoralej> ok, thanks chandankumar
15:33:38 <amoralej> well, first thing is te get pipeline up, then i guess need to keep working to make it work :)
15:33:50 <amoralej> i think that's it about centos8
15:33:59 <amoralej> am i missing something you want to add?
15:35:17 <amoralej> #topic Plan for fedora28 DLRN builder and repo
15:35:45 <amoralej> so, as part of moving to centos8, we'll remove fedora28 repos and dlrn builder
15:36:25 <amoralej> it's becoming hard to keep working as fedora removed support for it and even retired f28 buildroots from copr
15:36:27 <chandankumar> amoralej: we are working on adding RHEL8 and centos7 pipeline
15:36:50 <chandankumar> since centos8 dlrn builder is not available so we have not started working
15:36:53 <amoralej> so anytime we need to update a dependency we need to do it manually
15:37:00 <amoralej> in fedora28
15:37:08 <amoralej> so i'd like to get rid of it
15:38:07 <rdogerrit> wes hayutin proposed rdo-infra/ci-config master: Update jobs-exploration  https://review.rdoproject.org/r/22578
15:38:19 <rdogerrit> User marios proposed rdo-infra/ci-config master: WIP DNM create + push container manifest --arch ppc64le amd64  https://review.rdoproject.org/r/22002
15:38:37 <jpena> personally, I'd prefer to keep it in life support until we have a centos8 builder. We're also using the dependencies part for the rpm-packaging project, and it still gives us valuable info about packaging.
15:38:39 <amoralej> and i have some doubts we can keep it working until then
15:38:42 <ykarel> yup let's clean once we have centos8 ready
15:38:54 <amoralej> centos8 still will take some time
15:39:07 <amoralej> we'll do our best to keep fedora28 working until then
15:39:11 <ykarel> or rhel8? if possible
15:39:13 <amoralej> but don't want to invest too much
15:39:26 <amoralej> as it's only used to gate changes in distgits
15:39:39 <jpena> rhel8 is its own mess, dependency packages create a similar amount of issues
15:39:40 <amoralej> and in upstream rpm-packaging jobs, iirc
15:39:41 <ykarel> it should be possible, but if it doesn't take much effort
15:39:54 <chandankumar> amoralej: ykarel is it possible to reuse rhel8 based standalone or fs01 job for distgit to keep up?
15:40:06 <chandankumar> as a third party
15:40:08 <ykarel> :( so best would be centos8 than
15:40:21 <amoralej> chandankumar, not really, we just need to do dlrn rpmbuilds jobs
15:40:24 <jpena> if we want to gate package builds on a system with python3, we still depend on fedora
15:40:35 <chandankumar> ok
15:40:35 <amoralej> ykarel, do we still run fedora jobs in puppet changes?
15:40:43 <amoralej> upstream
15:40:57 <amoralej> is there any point in keep the puppet promotion for fedora?
15:41:26 <ykarel> amoralej, yes
15:41:29 <ykarel> as a third party
15:42:05 <amoralej> ok
15:42:15 <amoralej> let's keep it while it's working then
15:42:23 <amoralej> with best effort commitment only
15:42:32 <ykarel> yup can be cleaned up at same time we do for DLRN
15:42:35 <amoralej> currently we have a couple of issues
15:42:47 <amoralej> with deps that i need to rebuild
15:42:53 <ykarel> cachetools, pbr?
15:42:56 <amoralej> or maybe we can add conditionals for fedora
15:42:58 <amoralej> networkx
15:43:04 <amoralej> cachetools was fine
15:43:06 <amoralej> it's updated
15:43:39 <amoralej> rebuild with mock in f28 didn't work
15:43:44 <amoralej> i need to check again
15:44:10 <ykarel> okk, if it's get hard to update we can go with conditional
15:44:14 <ykarel> and cleanup later
15:44:26 <amoralej> yeah, it's last resort
15:44:27 <ykarel> as we already have plan to move away from pyver macros
15:44:37 <ykarel> once we are full py3
15:45:04 <amoralej> should happen in ussuri
15:45:13 <ykarel> yes
15:45:29 <amoralej> ussuri should be centos8/py3 only
15:45:51 <amoralej> while in train we'll need to support both for the whole life
15:47:19 <amoralej> #info we'll do best effort to keep fedora28 deps repo and dlrn builder clean for CI only until moving to centos8
15:47:40 <amoralej> next topic
15:47:51 <amoralej> #topic swift deps py2->py3 Status
15:47:58 <amoralej> jcapitao, all yours
15:48:17 <jcapitao> so, swift deps are being converted from py2 to py3
15:48:41 <jcapitao> #link https://review.rdoproject.org/r/#/q/topic:py3-enable
15:49:12 <jcapitao> #link https://review.rdoproject.org/etherpad/p/py3_conversion_status
15:49:21 <amoralej> jcapitao, is merge order clear?
15:49:28 <jcapitao> I'm following the list of packages between 207-220
15:49:30 <amoralej> to avoid issues with missing deps in other packages?
15:49:44 <jcapitao> yeah I still need to create the deps tree in order to have the proper order of merging
15:50:06 <amoralej> libraries are pinned, so there should not be rebuilds
15:50:09 <amoralej> it should be fine
15:50:15 <amoralej> but still good to merge ordered
15:50:37 <amoralej> or keep reviews on hold and merge all at the same time
15:51:27 <amoralej> jcapitao, you meant the list of packages in https://review.rdoproject.org/etherpad/p/py3_conversion_status 238-269, right?
15:51:57 <ykarel> amoralej, no rebuilds?
15:52:05 <jcapitao> amoralej: yeah, sry
15:52:09 <amoralej> ykarel, yes
15:52:10 <ykarel> once it merges, it will rebuild
15:52:10 <amoralej> i mean
15:52:32 <amoralej> yes but those ones are *removing* python2, so those will not fail because of missing python2 deps
15:52:47 <amoralej> the actual problem is for packages still having py2 and py3
15:52:54 <amoralej> that try to rebuild
15:53:02 <amoralej> and needs py2 packages already removed
15:53:11 <amoralej> not sure if i'm explaining it clear
15:53:39 <ykarel> yes got it
15:53:41 <amoralej> as libraries are pinned, only would be rebuilt for other changes in distgits
15:54:00 <amoralej> which is unlikely at this point, but yes, may happen
15:54:35 <amoralej> ok, so jcapitao let's keep sending reviews for py2->py3
15:54:42 <amoralej> once we have reqchecks done
15:54:55 <ykarel> amoralej, master-head might fail then, right if changes are committed furing the transition, right?
15:55:02 <amoralej> yes correct
15:55:13 <ykarel> ok makes sense
15:55:13 <amoralej> but who cares of master-head :)
15:55:19 <amoralej> just kidding
15:55:25 <amoralej> note it'd only fail in fedora
15:55:37 <amoralej> in centos7 everything is py2 anyway
15:55:38 <ykarel> yes
15:55:42 <amoralej> there is fedora-master-head?
15:55:46 <amoralej> i forgot
15:55:50 <amoralej> jpena, ^
15:55:54 <ykarel> nope it's not there
15:56:01 <amoralej> ack, even better, then
15:56:01 <jpena> amoralej: it's never existed
15:56:11 <amoralej> that's what i thought
15:56:18 <amoralej> ok
15:56:41 <amoralej> also, we need to cherry pick changes to train-rdo after merging in rpm-master
15:57:11 <jcapitao> why ?
15:57:31 <amoralej> because we want to get rid of those py2 packages in train
15:57:42 <amoralej> swift is not branched yet
15:57:53 <amoralej> so swift will be py3 in train
15:58:02 <amoralej> so no need to carry python2 deps
15:58:18 <amoralej> and, as libraries and clients where already branched
15:58:18 <jcapitao> ok got it
15:58:22 <amoralej> we need to cherry-pick
15:58:39 <amoralej> ok, let's give a couple of minutes at least for open floor
15:58:41 <ykarel> with this centos8-train would also be py3 only
15:58:43 <amoralej> we are gettingout of time
15:58:51 <amoralej> yes
15:58:56 <amoralej> that's the goal
15:59:08 <amoralej> do you see any problem on that?
15:59:14 <amoralej> am i missing something?
15:59:32 <ykarel> i was trying to share to goal only, to make it more clear
15:59:37 <amoralej> ok
15:59:54 <amoralej> #info the goal is to make centos8-train python3 only
16:00:04 <amoralej> let's keep it in mtg minutes :)
16:00:13 <amoralej> #topic open  floor
16:00:29 <amoralej> anyone has some topic to bring?
16:00:49 <rdogerrit> Merged rdo-infra/ci-config master: Update jobs-exploration  https://review.rdoproject.org/r/22578
16:01:05 <amoralej> who will chair next week?
16:01:08 <amoralej> volunteers?
16:01:18 <jcapitao> o/
16:01:39 <amoralej> #action jcapitao to chair next meeting
16:01:49 <amoralej> thanks jcapitao
16:02:12 <amoralej> ok, i'm closing the meeting
16:02:16 <amoralej> thanks all for joining!
16:02:38 <ykarel> we have holiday here next wednesday
16:02:42 <amoralej> #endmeeting