14:02:31 <ykarel> #startmeeting RDO meeting - 2020-02-26
14:02:31 <zodbot> Meeting started Wed Feb 26 14:02:31 2020 UTC.
14:02:31 <zodbot> This meeting is logged and archived in a public location.
14:02:31 <zodbot> The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:31 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-02-26'
14:02:32 <openstack> Meeting started Wed Feb 26 14:02:31 2020 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:35 <openstack> The meeting name has been set to 'rdo_meeting___2020_02_26'
14:02:52 <ykarel> add last minute topic to agenda https://etherpad.openstack.org/p/RDO-Meeting
14:02:58 <ykarel> #topic roll call
14:02:59 <jcapitao> o/
14:03:34 <ykarel> #chair jcapitao
14:03:34 <zodbot> Current chairs: jcapitao ykarel
14:03:35 <openstack> Current chairs: jcapitao ykarel
14:04:11 <jpena> o/
14:04:43 <ykarel> #chair jpena
14:04:43 <zodbot> Current chairs: jcapitao jpena ykarel
14:04:44 <openstack> Current chairs: jcapitao jpena ykarel
14:04:56 <fultonj> o/
14:05:00 <amoralej> o/
14:05:56 <ykarel> #chair fultonj amoralej
14:05:56 <zodbot> Current chairs: amoralej fultonj jcapitao jpena ykarel
14:05:57 <openstack> Current chairs: amoralej fultonj jcapitao jpena ykarel
14:06:16 <ykarel> Ok let's start with topics
14:06:26 <ykarel> #topic CentOS 8 updates:
14:06:33 <ykarel> amoralej, ^^
14:06:45 <amoralej> ok, let's start
14:07:15 <amoralej> #info CBS buildsys-tags for ussuri on centos8 is merged
14:07:37 <amoralej> cbs builds are now properlly tagged in ussuri-testing and ussuri-el8-build
14:08:06 <amoralej> next step is synchronize them in trunk.r.o i'm waiting for https://review.rdoproject.org/r/#/c/25373/
14:08:06 <rh-jelabarre> o/
14:08:15 <ykarel> #chair rh-jelabarre
14:08:15 <zodbot> Current chairs: amoralej fultonj jcapitao jpena rh-jelabarre ykarel
14:08:16 <openstack> Current chairs: amoralej fultonj jcapitao jpena rh-jelabarre ykarel
14:08:21 <leanderthal> o/
14:08:43 <ykarel> #chair leanderthal
14:08:43 <zodbot> Current chairs: amoralej fultonj jcapitao jpena leanderthal rh-jelabarre ykarel
14:08:43 <openstack> Current chairs: amoralej fultonj jcapitao jpena leanderthal rh-jelabarre ykarel
14:09:11 <amoralej> #info Moving back to ansible 2.8 in CentOS8 - http://lists.openstack.org/pipermail/openstack-discuss/2020-February/012820.html
14:09:23 <amoralej> so ceph-ansible is not compatible with ansible 2.9
14:09:38 <amoralej> so we will move back to 2.8 in CentOS8
14:09:53 <amoralej> and move to 2.9 when everyone is ready
14:09:58 <jpena> is there any chance to make ceph-ansible compatible with both?
14:10:11 <fultonj> jpena: not much
14:10:17 <fultonj> They have limited testing capability and only want to support one version of ansible; that's why they have a task to fail if it's not the supported version.
14:10:41 <fultonj> jpena: they plan to support 2.9 when they move to octopus
14:11:00 <fultonj> ceph-ansible5 --> 2.9 + octopus
14:11:08 <fultonj> ceph-ansible4 --> 2.8 + nautilus
14:11:14 <fultonj> i hope to move to octopus with victoria
14:11:27 <fultonj> more info in #link https://bugzilla.redhat.com/show_bug.cgi?id=1807085
14:11:28 <openstack> bugzilla.redhat.com bug 1807085 in Ceph-Ansible "ceph-ansible 4.0.x does not work with ansible 2.9" [High,New] - Assigned to gabrioux
14:11:53 <fultonj> jpena: they're looking into moving from 2.8 to 2.9 by way of that bug
14:12:21 <fultonj> i kind of like this proposal
14:12:26 <fultonj> keep ceph-ansible 4.x at 2.8 and keep stein/train/ussuri at 2.8 (we are at U m3). We then move to 2.9 with Victoria/17.
14:12:54 <amoralej> fultonj, maybe we (openstackland) may help them to gate ceph-ansible with differnt versions of os and ansible
14:13:02 <amoralej> if it's mainly a ci problem
14:13:06 <ykarel> also there was a new issue detected today in non ceph jobs which is likely related to ansible-2.9, so moving to 2.8 would be another reason for now
14:13:13 <amoralej> from softwarefactory zuul
14:13:35 <ykarel> related change https://review.opendev.org/#/c/709959/
14:13:44 <ykarel> though that can be fixed, but found with 2.9
14:14:01 <ykarel> amoralej, so what version we targetting for c8 now
14:14:07 <ykarel> 2.8.8 or something else?
14:14:18 <amoralej> ykarel, yes, i'd like to use 2.8.8
14:14:25 <amoralej> but need to double check
14:14:25 <ykarel> i see that is available in cbs
14:14:35 <amoralej> yes, i plan to test the existing build
14:14:45 <amoralej> upstream spec does not support 2.8 on centos8
14:14:49 <ykarel> okk i guess we can test that in ci too to see if it unblocks all scenarios
14:14:52 <ykarel> chandankumar, ^^
14:14:58 <fultonj> amoralej: which upstream spec?
14:14:59 <ykarel> https://cbs.centos.org/koji/buildinfo?buildID=28541
14:15:02 <amoralej> so i'll use that one which i think comes from epel
14:15:08 <amoralej> fultonj, the one in ceph repo
14:15:24 <amoralej> sorry
14:15:26 <amoralej> in ansible repo
14:15:28 <amoralej> :)
14:15:37 <ykarel> :)
14:15:43 <amoralej> fultonj, https://github.com/ansible/ansible/blob/stable-2.8/packaging/rpm/ansible.spec
14:15:54 * fultonj loves links (they clarify things)
14:15:59 <fultonj> #link https://github.com/ansible/ansible/blob/stable-2.8/packaging/rpm/ansible.spec
14:16:13 <amoralej> i think the cbs one is rebuilt from epel which maintains separated spec
14:16:14 <ykarel> #link https://cbs.centos.org/koji/buildinfo?buildID=28541
14:16:32 * fultonj trying to catch up
14:17:08 <fultonj> amoralej: so it takes extra effort to get ansible 2.8 working on cent8 ?
14:17:16 <amoralej> fultonj, probably not
14:17:31 <amoralej> it's just that we will do in a different way this time
14:17:45 <amoralej> usually, we use that spec to rebuild ansible in RDO
14:18:21 <amoralej> this time, i think we will reuse the one built by gfidente in storage sig https://cbs.centos.org/koji/buildinfo?buildID=28541
14:18:33 <fultonj> thanks amoralej for trying the 2.8 option in cent8 for now
14:18:48 <rdogerrit> Merged rdoinfo master: Update pykmip to new build  https://review.rdoproject.org/r/25373
14:19:08 <amoralej> fultonj, in fact it will be less work, althoug a bit inconsistent with what we've done in other cases
14:19:23 <amoralej> but should be fine
14:19:45 <amoralej> ok, so i think that's it wrt ansible
14:19:48 <ykarel> +1
14:20:13 <amoralej> #info Unpinning ussuri-uc
14:20:21 <amoralej> #link https://lists.rdoproject.org/pipermail/dev/2020-February/009279.html
14:20:41 <amoralej> so, i'd like to unpin all py2 related pins in ussuri-uc asap
14:21:03 <amoralej> currently we need to get one more promotion in c7 to ship mistra-extras in promoted repo
14:21:15 <amoralej> so we need to keep it consistent a bit more
14:21:40 <amoralej> once we have one more promotion, i'll propose in the ML thread to unpin
14:23:36 <amoralej> #info once we have one more promotion, i'll propose in the ML thread to unpin
14:23:38 * jpena can't wait for that to happen
14:23:39 <ykarel> proposed pin for glance today https://review.rdoproject.org/r/#/c/25378/
14:23:48 <ykarel> needed to get consistent
14:24:16 <ykarel> there is one more FTBFS in octavia-tempest-plugin, need to check what's wrong there
14:24:19 <amoralej> mmm
14:24:37 <amoralej> so, cyclic between two files in the same module?
14:24:56 <ykarel> yes
14:25:06 <ykarel> same package
14:25:55 <amoralej> ok
14:26:16 <amoralej> so there is something different to load in py2 and py3
14:26:46 <ykarel> hmm looks like
14:27:25 <amoralej> let's ask glance team before merging the pin
14:27:32 <amoralej> i think last successful build should be fine
14:27:34 <amoralej> for them
14:27:39 <amoralej> but let's ask
14:28:24 <ykarel> okk
14:30:20 <ykarel> anything else on this, or let's move to next topic
14:30:44 <amoralej> yep
14:31:02 <ykarel> ack
14:31:03 <ykarel> #info Currently building train pkgs https://review.rdoproject.org/r/#/q/topic:train-centos8
14:31:11 <ykarel> jcapitao, anything to add ^^
14:31:55 <jcapitao> i hope to finish it by end of the week
14:31:59 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace fetch_jobs  https://review.rdoproject.org/r/24699
14:32:00 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace get_latest_hashes  https://review.rdoproject.org/r/24694
14:32:00 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace tag_qcow_images  https://review.rdoproject.org/r/24714
14:32:01 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace check named hashes function  https://review.rdoproject.org/r/24715
14:32:01 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace tag_containers  https://review.rdoproject.org/r/24716
14:32:02 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Modularize Promoter: replace promote_link  https://review.rdoproject.org/r/24721
14:32:02 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: [WIP] Implement promotion for integration pipeline  https://review.rdoproject.org/r/24774
14:33:05 <ykarel> jcapitao, okk nice
14:33:36 <ykarel> #topic chair for next week
14:33:44 <ykarel> any volunteer
14:34:27 <jcapitao> i can take it
14:34:48 <ykarel> Thanks jcapitao
14:34:55 <ykarel> #action jcapitao to chair next week
14:35:04 <ykarel> #topic open floor
14:35:10 <ykarel> feel free to bring any topic now
14:37:14 <rdogerrit> Yatin Karel proposed openstack/octavia-tempest-plugin-distgit rpm-master: Rename httpd to test_server  https://review.rdoproject.org/r/25367
14:40:24 <ykarel> If nothing else we can close early and everyone gets 20 minutes back
14:42:21 <rdogerrit> Alfredo Moralejo created rdoinfo master: Move CentOS8 to use ansible-2.8.8 instead of 2.9  https://review.rdoproject.org/r/25379
14:42:55 <ykarel> Ok let's close than
14:42:59 <amoralej> fultonj, ^
14:42:59 <ykarel> Thanks everyone
14:43:02 <ykarel> #endmeeting