14:00:35 <jcapitao> #startmeeting RDO meeting - 2020-04-01
14:00:35 <zodbot> Meeting started Wed Apr  1 14:00:35 2020 UTC.
14:00:35 <zodbot> This meeting is logged and archived in a public location.
14:00:35 <zodbot> The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:35 <zodbot> The meeting name has been set to 'rdo_meeting_-_2020-04-01'
14:00:36 <openstack> Meeting started Wed Apr  1 14:00:35 2020 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <openstack> The meeting name has been set to 'rdo_meeting___2020_04_01'
14:01:00 <jcapitao> still time to add last minute topic to agenda https://etherpad.openstack.org/p/RDO-Meeting
14:01:03 <PagliaccisCloud> O/
14:01:06 <amoralej> o/
14:01:12 <jcapitao> #topic roll call
14:01:14 <jpena> o/
14:01:27 <jcapitao> #chair PagliaccisCloud amoralej jpena
14:01:27 <zodbot> Current chairs: PagliaccisCloud amoralej jcapitao jpena
14:01:27 <openstack> Current chairs: PagliaccisCloud amoralej jcapitao jpena
14:02:06 <ykarel> o/
14:02:36 <jcapitao> #chair ykarel
14:02:36 <zodbot> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel
14:02:37 <openstack> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel
14:05:43 <jcapitao> let's start whith first topic
14:05:51 <jcapitao> #topic Rocky moving to Extended Maintenance
14:06:15 <jcapitao> ^ amoralej
14:06:57 <amoralej> #info most projects are already in Extended Maintenance in Rocky upstream branch
14:07:05 <amoralej> #link https://review.opendev.org/#/q/topic:rocky-em
14:07:25 <rdogerrit> Grzegorz Grasza created rdoinfo master: Add the train tag to ansible-tripleo-ipa  https://review.rdoproject.org/r/26202
14:07:36 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: Adapt provision playbook for centos 8  https://review.rdoproject.org/r/26022
14:07:49 <amoralej> In RDO terms that means that we consider CloudSIG repos for Rocky as EOL
14:08:13 <amoralej> #info CloudSIG Rocky will be EOL soon
14:08:59 <amoralej> #info RDO Trunk rocky will be alive and following stable/rocky branches
14:09:31 <amoralej> that means rocky is still available for tripleo ci or others using rdo trunk
14:09:33 <amoralej> that's it
14:10:58 <jcapitao> ok thx
14:11:07 <jcapitao> next topic
14:11:15 <jcapitao> #topic rdopkg reqcheck
14:11:22 <ykarel> amoralej, so removing auto updates for rocky, right?
14:11:27 <ykarel> buildsys etc
14:11:40 <amoralej> ykarel, there will be no more releases
14:11:48 <amoralej> so, let's wait for all the reviews to be closed
14:11:53 <amoralej> and we can get rid of it
14:11:54 <amoralej> yes
14:12:00 <ykarel> ykarel, i meant remove rocky check from our bots
14:12:06 <amoralej> yes
14:12:07 <ykarel> but ok to keep also
14:12:21 <amoralej> but let's keep it until next week or so
14:12:25 <ykarel> ok for me
14:12:30 <amoralej> to make sure we build any latecomer
14:12:38 <ykarel> agreed
14:13:42 <jcapitao> ok so, i've created the global override file for reqcheck
14:13:55 <jcapitao> #link https://review.rdoproject.org/r/#/c/26165/
14:15:07 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: Adapt provision playbook for centos 8  https://review.rdoproject.org/r/26022
14:15:32 <jcapitao> i put all the further steps in the commit message
14:15:40 <amoralej> jcapitao, so that file is simulating more packages in the requirements.txt?
14:15:52 <rdogerrit> Merged rdoinfo master: Rebuild latest python-etcd3gw from fedora  https://review.rdoproject.org/r/26186
14:16:04 <amoralej> what means "all:"
14:16:58 <jcapitao> well, not all, but the next step i suggest
14:17:26 <rdogerrit> Merged rdo-jobs master: Tox-delegated: override default playbook  https://review.rdoproject.org/r/26030
14:17:35 <jcapitao> this file contains all the modules which are not synced
14:17:47 <jcapitao> tagged as MISSING or MISMATCH
14:18:53 * jcapitao looking for a review to explain the 'all:'
14:19:39 <jcapitao> amoralej: https://softwarefactory-project.io/r/#/c/17372/
14:19:50 <ykarel> i guess that all: is common for all packages?
14:20:02 <jcapitao> yep that's it
14:20:47 <amoralej> but that means we are adding python-yaml and python-pbr as dependency for all packages?
14:21:05 <amoralej> that's what i don't get
14:21:22 <amoralej> yaml should be explicit in requirements.txt
14:21:27 <amoralej> not sure why we need to override that
14:22:10 <jcapitao> no, it means, that those packages (python-yaml & python-pbr) will be ignored from reqcheck operations
14:22:27 <ykarel> hmm me too confused on usage of that file, may be after we do reqcheck for ussuri it will contain more real examples
14:22:41 * jcapitao need to write a doc
14:23:14 <amoralej> yeah, syntax is not clear to me
14:24:06 <amoralej> i guess we can add, remove or modify caps for deps in requirements.txt for each package?
14:25:03 <rdogerrit> John Eckersberg created rdoinfo master: Rebase python-etcd3gw to 0.2.5 in train/el7 and ussuri/el8 testing  https://review.rdoproject.org/r/26203
14:25:51 <jcapitao> yes, that's the point, the dep in requirements.txt is overridden by the one specified in reqcheck-override-file.yml
14:26:11 <jcapitao> i will write a doc with common example
14:26:33 <jcapitao> but you're right items in "all:" list should not be used
14:26:47 <amoralej> i think i got it
14:27:14 <amoralej> so a package with no version in the overrides means it's ignored from requirements.txt
14:27:24 <jcapitao> i put python-yaml because of the multiple name YAML got in py2/py3 pkgs
14:27:36 <amoralej> with version means is added or replaces existing cap in requirements.txt
14:27:40 <jcapitao> exactly
14:27:51 <amoralej> but if a project actually depends on pyyaml
14:28:07 <amoralej> and has yaml in requirements.txt we can't ignore it
14:28:09 <amoralej> right?
14:28:17 <rdogerrit> Gabriele Cerami created rdo-infra/ci-config master: [WIP] Promoter: change integration job to use centos8  https://review.rdoproject.org/r/26204
14:28:34 <amoralej> also, pbr is runtime requirement is many packages
14:28:41 <amoralej> for the --version functionality
14:29:44 <jcapitao> you're right
14:29:57 <amoralej> ok, got it
14:31:14 <jcapitao> but i will write a doc
14:31:20 <jcapitao> to be more clear
14:31:32 <amoralej> ok
14:32:07 <amoralej> to build that file
14:32:51 <amoralej> ok, i'll review and will come to you later
14:33:12 <ykarel> i got it version: in that file is current version is spec, and that mis matches with requirement.txt
14:33:13 <amoralej> i think some (probably many) of the overrides means actual issues in spec files that we need to fix
14:33:35 <ykarel> and assume with next reqcheck for ussuri that file will get shorten
14:33:40 <ykarel> and contains only real issues
14:33:51 <amoralej> exactly
14:33:57 <amoralej> but the process should be
14:34:01 <amoralej> first run reqcheck
14:34:07 <amoralej> to get specs right
14:34:14 <amoralej> and then create the file with exceptions
14:34:14 <jcapitao> yeah, that was my interrogation, whether we fix it now or fix it during ussuri release
14:34:17 <ykarel> yes
14:34:19 <amoralej> otherwise we will over-override
14:34:31 <amoralej> and that will lead to miss required updates from the job
14:34:40 <amoralej> mmm
14:34:54 <amoralej> let me check how far is the latest release of clients and libs in ussuri
14:35:10 <ykarel> it's going on this week
14:35:14 <ykarel> for libs
14:35:36 <ykarel> Mar 30 - April 03 - Final release for non-client libraries
14:35:57 <amoralej> next week is requirements freeze
14:36:02 <amoralej> so that's probably a good time
14:36:06 <amoralej> so start doing reqchecks
14:36:13 <amoralej> and then create the overrides
14:36:13 <ykarel> yeap
14:36:35 <amoralej> other option would be to create a very minimal overrides with cases that we know are exceptions
14:36:46 <amoralej> to start getting value from the job asap
14:37:20 <ykarel> both together can work
14:37:36 <amoralej> yep
14:37:45 <jcapitao> +1
14:38:31 <jcapitao> so we start reqcheck non-client libs next week ?
14:39:06 <amoralej> yes
14:39:27 <amoralej> in fact that's other topic for meeting, ussuri GA is coming fast :)
14:39:28 <amoralej> wow
14:40:30 <jcapitao> ok let's talk about it
14:40:45 <jcapitao> #topic Ussuri GA is coming
14:41:24 <jcapitao> one month left
14:42:09 <amoralej> so next week is deps freeze
14:42:25 <amoralej> and RC1 is on 20
14:42:33 <amoralej> so i think it's time to start thinking on it
14:43:04 <amoralej> from other SIGs perspective, i think the only missing part is rabbitmq which i'm working on
14:43:09 <amoralej> wrt RDO builds
14:43:25 <amoralej> we need to start the usual process for new builds
14:43:42 <amoralej> #info next week is deps freeze
14:43:52 <amoralej> #info RC1 is on April 20th week
14:44:12 <ykarel> amoralej, ususal process for new builds?
14:44:24 <amoralej> for new releases i meant
14:44:25 <ykarel> u mean auto deps update as per u-c?
14:44:38 <amoralej> trello card, etherpad, reqchecks, ci changes, etc...
14:44:45 <ykarel> yeap okk
14:44:45 <amoralej> usual stuff :)
14:44:50 <jcapitao> okk
14:44:51 <ykarel> ok got it :)
14:45:15 <amoralej> #action amoralej to create new trello card for Ussuri release
14:45:16 <ykarel> jcapitao, would you like to start this time ?
14:46:01 <jcapitao> to start the new release procedure ?
14:46:11 <ykarel> jcapitao, yeap
14:46:25 <ykarel> trello/etherpad is the first step
14:46:34 <jcapitao> i'd be glad to
14:46:37 <ykarel> maily we reuse previous release ones and edit it for next release
14:47:38 <jcapitao> ack, i'll catch you off-meeting
14:47:39 <amoralej> #undo
14:47:39 <zodbot> Removing item from minutes: ACTION by amoralej at 14:45:15 : amoralej to create new trello card for Ussuri release
14:47:40 <openstack> Removing item from minutes: #action amoralej to create new trello card for Ussuri release
14:47:48 <amoralej> #action jcapitao to create new trello card for Ussuri release
14:47:57 <amoralej> jcapitao, for you ^:)
14:48:52 <jcapitao> ohh feeling pressure :D
14:48:56 <amoralej> :)
14:49:12 <amoralej> the tasks are mainly the same is from train
14:49:23 <amoralej> we need to review if there is any divergence related to c8
14:49:53 <jcapitao> ok
14:50:30 <amoralej> but let's start cloning from train
14:50:36 <amoralej> and then we will refine
14:51:42 <jcapitao> yeah
14:51:57 <jcapitao> we can move to next topic
14:52:10 <jcapitao> #topic chair for next week
14:52:19 <ykarel> i can take it
14:52:47 <jcapitao> #action ykarel to chair next week
14:52:49 <jcapitao> thx ykarel
14:52:58 <jcapitao> #topic open floor
14:53:29 <tobias-urdin> i'm in the middle of upgrade testing, could use some reviews on my changes :)
14:53:34 <tobias-urdin> https://review.rdoproject.org/r/#/q/owner:%22Tobias+Urdin+%253Ctobias.urdin%2540gmail.com%253E%22+is:open
14:54:19 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter: Adapt provision playbook for centos 8  https://review.rdoproject.org/r/26022
14:54:19 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: [WIP] Promoter: change integration job to use centos8  https://review.rdoproject.org/r/26204
14:54:49 <amoralej> sure tobias-urdin
14:55:00 <amoralej> thx for all your upgrades cleanups
14:55:20 <amoralej> i'll review
15:01:03 <jcapitao> ok let's close the meeting if nothing to add
15:01:27 <jcapitao> #endmeeting